Latest News: (loading..)
VJ

Easy Populate & Products Attributes

9,069 posts in this topic

A question about EP if I may.

 

I'm currently manually loading a store with potentially hundreds of products, with what feels like endless attributes. I've read that EP doesn't handle attributes well, and as such has put me off using/trying it out, is this still the case? as I'm looking for an easier way to load approx 500 more products with attributes. Is EP the way to go or should I stick to plugging away manually (ie one product at a time and all its associated attributes).

 

Many thanks.

 

edit: I should say i'm using 2.3.1 and have a few addons installed also.

 

EP handles attributes fine you just need to set up the headings correctly.

 

I have just set up a store store where the products have upto 20 odd options with some options having between 2 and 10 values to select from.

 

Try downloading an EP export file and use that as a template.

 

HTH

 

G

Edited by geoffreywalton

Share this post


Link to post
Share on other sites

The only changes I made to the error listed is I wrote "This lists my Product's Title" and "This lists my Product's Model #" so people would know what was in the quotes.

 

If you change the error message how do you expect anyone to debug your problem?

 

G

Share this post


Link to post
Share on other sites

If you change the error message how do you expect anyone to debug your problem?

 

G

 

Again, the only thing I changed was the actual product title and model #. The message is the same besides those values. It affects every single item so it isn't like it is one specific product title or model #

Edited by ggrant3

Share this post


Link to post
Share on other sites

OK, your call.

 

Good luck.

 

Cheers

 

G

Share this post


Link to post
Share on other sites

Hi all

 

I have had my own website for a couple of years now - I have recently changed to OSC 2.3.1 and EP v2.76i and have also recently had to change all my model name to my suppliers' codes for easier updating - in this process I have changed my model name length for 12 to 20, but in the last 2 updates, I see it keeps adding duplicate products - supplier code is "CA-SATALT90-1B" - I have just downloaded a complete stock file from my website and all codes longer than 12 have been shortened to 12, maning that everytime I update, it adds "new product" when the product is already there! I now have 4 or 5 of the same items on my site!

 

How do I fix this error?

 

Thx

Russel

Share this post


Link to post
Share on other sites

Hi all

 

I have had my own website for a couple of years now - I have recently changed to OSC 2.3.1 and EP v2.76i and have also recently had to change all my model name to my suppliers' codes for easier updating - in this process I have changed my model name length for 12 to 20, but in the last 2 updates, I see it keeps adding duplicate products - supplier code is "CA-SATALT90-1B" - I have just downloaded a complete stock file from my website and all codes longer than 12 have been shortened to 12, maning that everytime I update, it adds "new product" when the product is already there! I now have 4 or 5 of the same items on my site!

 

How do I fix this error?

 

Thx

Russel

Share this post


Link to post
Share on other sites

Hi again

 

Strangely enough - it is updating the pricing correctly on each item?

 

Russel

Share this post


Link to post
Share on other sites

hi there, i have no idea what i did but followed instuctions to the best of my ability.

Now problem is that after installing easypopulate when i click on catalog--> product attributes in the backend of OSC then i come out to the EP documentation.

What file did i stuff up to do this? :)

Share this post


Link to post
Share on other sites

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/xxxxx/public_html/test_store/admin/easypopulate.php on line 1082

 

Anybody know what this error points to in a 2.3.1 shop?

Share this post


Link to post
Share on other sites

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/xxxxx/public_html/test_store/admin/easypopulate.php on line 1082

 

Anybody know what this error points to in a 2.3.1 shop?

 

Which version of easy populate are you using?

Share this post


Link to post
Share on other sites

EP_v2_77a_for_2.3_1

 

BUT, it has instructions for 2.2 in the download

Share this post


Link to post
Share on other sites

Hi

I have just installed EP_v2_77a_22RC2a by Roaddoctor (4 March 2012 package) on a MS2.2 store with about 3500 products.

 

I can download something simple such as a Model/Category file but When I click Create & Download I eventually (after about a minute) get an 500 Internal Server Error. What is the problem?

 

 

Thanks,

Ben

Share this post


Link to post
Share on other sites

My host has now told me that the script does not have the correct log in details:

 

Apache-Error: [file "mod_auth_basic.c"] [line 264] [level 3] user admin not found: /test/admin/easypopulate.php, referer: http://www.mysite.co.uk/test/admin/categories.php?selected_box=catalog
Apache-Error: [file "core.c"] [line 3714] [level 3] File does not exist: /home/account/public_html/401.shtml, referer: http://www.mysite.co.uk/test/admin/categories.php?selected_box=catalog

Edited by Benjjj6

Share this post


Link to post
Share on other sites

Does anyone have a solution for running this script on a store with lots of products? Currently I can not even download the .csv as the server times out after 60 seconds.

 

I know we can split the file for uploading, but what about downloading?

Share this post


Link to post
Share on other sites

When uploading a .csv do all columns need to be in the file? ie. Are all the columns necessary?

 

And, Does EasyPopulate support the updating of attributes? I am not sure how to get that to work?

Edited by Benjjj6

Share this post


Link to post
Share on other sites

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/xxxxx/public_html/test_store/admin/easypopulate.php on line 1082

 

Anybody know what this error points to in a 2.3.1 shop?

 

Anybody?

Share this post


Link to post
Share on other sites

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /home/xxxxx/public_html/test_store/admin/easypopulate.php on line 1082

 

Anybody know what this error points to in a 2.3.1 shop?

 

It indicates an error in the code around lines 1080 to 1083 in easypopulate.php.

 

If we could be shown 10 lines before and after that line, might be able to help more.

 

HTH

 

G

Edited by geoffreywalton

Share this post


Link to post
Share on other sites

how do i get EP to extract the SKU and Model fields for my products?

 

SKU is not a standard field, open easypopulate.php and follow the instructions on how to add new fields in the product file.

 

Then use the Export EP or Froogle Products File and down load a cutom file.

 

HTH

 

G

Share this post


Link to post
Share on other sites

When uploading a .csv do all columns need to be in the file? ie. Are all the columns necessary?

 

And, Does EasyPopulate support the updating of attributes? I am not sure how to get that to work?

 

You can upload using files that only contain the columns you need but read the documentation for the mandatory fields certainly the model no and EOREOR are 2 you need.

 

HTH

 

G

Share this post


Link to post
Share on other sites

Does anyone have a solution for running this script on a store with lots of products? Currently I can not even download the .csv as the server times out after 60 seconds.

 

I know we can split the file for uploading, but what about downloading?

 

Either set the maximum execution time in php.ini to a higher value or make a custom feed and filter on manufacturer of category.

 

HTH

 

G

 

PS Attributes can be loaded using EP but it took me ages workiing out how to do it, download a sample file of products that have attributes and then use that as a template to upload/amend products with attributes.

Share this post


Link to post
Share on other sites

Either set the maximum execution time in php.ini to a higher value or make a custom feed and filter on manufacturer of category.

 

HTH

 

G

 

PS Attributes can be loaded using EP but it took me ages workiing out how to do it, download a sample file of products that have attributes and then use that as a template to upload/amend products with attributes.

 

Thank you for your help Geoffrey, I really appreciate it.

Share this post


Link to post
Share on other sites

It indicates an error in the code around lines 1080 to 1083 in easypopulate.php.

 

If we could be shown 10 lines before and after that line, might be able to help more.

 

HTH

 

G

 

}

//*******************************
//*******************************
// S T A R T
// PAGE DELIVERY
//*******************************
//*******************************
require(DIR_WS_INCLUDES . 'template_top.php');
?>
<td class="pageHeading" valign="top"><?phpecho "Easy Populate ".EP_CURRENT_VERSION." - Default Language : " . EP_DEFAULT_LANGUAGE_NAME . '(' . EP_DEFAULT_LANGUAGE_ID .')' ;?>
<script type="text/javascript"><!--
 function switchForm( field ) {
var d = document;
var frm = field.form;
var tbl = d.getElementById('customtable');

if(d.getElementById)

 

^ Lines 1070-1090

Edited by zeus_r6

Share this post


Link to post
Share on other sites

Hi there,

 

sorry to sound like a dunce here but does anyone know if the latest version of Easy Populate works with v2.2 rc2 as it seems to be playing a few tricks with my products.

 

 

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now