Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

and read the documentation that comes with it.

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Just uploaded EP files, and now following rest of the installation instructions. I don't understand how the line in STEP #3 fits in the file:

 

STEP #3 - Add a link in the Admin Panel. Edit file "/catalog/admin/incudes/boxes/catalog.php"

 

Find this code (Around Line 25):

'' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '' .

 

Directly AFTER add this:

'Easy Populate'

.

 

The relevant lines in the my catalog.php looks like this:

  array(
	'code' => FILENAME_PRODUCTS_ATTRIBUTES,
	'title' => BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES,
	'link' => tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES)
  ),

 

Do I simply do this?

  array(
	'code' => FILENAME_PRODUCTS_ATTRIBUTES,
	'title' => BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES,
'Easy Populate' .
	'link' => tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES)
  ),

 

I don't think it fits into the array pattern or whatever it's called.

Edited by oxwivi

Share this post


Link to post
Share on other sites

If you are installing a contribution no around 500, you are installing the wrong version, look for the 2.3.1 version

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

If you are installing a contribution no around 500, you are installing the wrong version, look for the 2.3.1 version

 

Ah! The original addon page was updated recently (and showed up at top of the search), so I assumed it's compatible with 2.3.1. Good thing I only uploaded the files and not modify anything.

Share this post


Link to post
Share on other sites
STEP #3 - Add a link in the Admin Panel. Edit file "/catalog/admin/incudes/boxes/catalog.php"

Find this code (Around Line 25):

array(
	'code' => FILENAME_PRODUCTS_ATTRIBUTES,
	'title' => BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES,
	'link' => tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES)
  ),

Directly AFTER add this:

  array(
	'code' => 'easypopulate.php',
	'title' => 'Easy Populate',
	'link' => tep_href_link('easypopulate.php')
  ),

 

Do I need to indent the array I'm adding?

Edited by oxwivi

Share this post


Link to post
Share on other sites

Hi

 

You need to start reading the install documentation and just doing what it says. It has proably worked for thousands of others and if you need to do anything apart from what they say the instructions would have been changed by now. You don't want to get a rep as a help vulture.

 

If you keep back up copies then you can restore and try again.

 

If it doesn't work then post.

 

If you want to learn about php / css / html / mysql try w3schools.com


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

I'm doing everything according to the docs. And in the example given (as quoted in my last post), the indentation of the existing lines and the lines I am to add was different, hence the confusion. But examining the file to edit, I understood how it should be.

 

Thanks for the pointers.

Share this post


Link to post
Share on other sites

How do I add more than one image to a product? The exported file contains no reference to the 'larger image' added to a product using the regular way.

 

The only references to more images to add in the documentation is the Additional Images Contribution, something for osC 2.2 I believe. Can we make it work for the now-built in ability to show more images per product?

Share this post


Link to post
Share on other sites

Setting large images support in easypopulate.php to true doesn't make any difference either:

 

//**** Large Images osc 2.3.1 Supportg ****
define ('EP_PRODUCTS_IMAGES', true);  // default is false
define ('EP_PRODUCTS_IMAGES_MAX', 6);  // default is 6, maximum number of columns

 

I still get only one column dedicated to the thumbnail, with no mention of other images anywhere.

 

By the way, why do we need to define category image for every product? Kinda stupid. Empty cell for no changes would be great.

Edited by oxwivi

Share this post


Link to post
Share on other sites
and read the documentation that comes with it.

 

Cheers

 

G

 

Did just that but could not see anywhere it states about uploading the file and it not working.

 

Doug

Share this post


Link to post
Share on other sites

Hello,

 

I am setting up a new store and am having the following error

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in ....easypopulate.php on line 1082

 

This occurs when I click on the easy populate link in version 2.3.1

 

Any suggestions?

 

I'm also getting the same error. I have not changed the easypopulate.php file - it is exactly how it was when uploaded. Not sure what I need to change?

 

Many thanks.

Share this post


Link to post
Share on other sites

I created some product attriubutes, and corresponding columns appeared on the exported CSV. But how do I use them?

Share this post


Link to post
Share on other sites

I ma having two issues and i need your help.

First problem: Does easy populate cooperates with utf8 cause when i am downloading also the description then i am getting ?!!???!?!?!?&&&& in the field of description. In thew greek file.

Second: in Big numbers like 300.000,00 euro with vat the easy populate shoes as a price 2.234.234.544 for ex . It tryes to give you the price without the vat but it understands the 223.423,4544 as a 2.234.234.544. Now if i will send this price i am sure that i am going to destroy the real price so does anyone knows something?


One amateur made the Arc, 5.000 pro made the Titanic...

Share this post


Link to post
Share on other sites

2.77 but read the instructions and back up your store

 

Thank you I read the instructions through and the install went great and everything appears to work good even with the add more fields cont.

Share this post


Link to post
Share on other sites

I created some product attriubutes, and corresponding columns appeared on the exported CSV. But how do I use them?

 

Set up some products with attributes and export the file.

 

Then you can emulate this on ne products.

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

This is what i get for description

 

Ξονοφασικοί Inverters του ΞΏΞ―ΞΊΞΏΟ… SOLAREDGE, ΞΉΟƒΟαηλινής Ο€Οοέλευσης, ΞΌΞµ τους οποίους επιτυγχάνεται Ξ±Οξηση της Ξ±Ο€Οδοσης του Ξ¦/Ξ’ πάΟΞΊΞΏΟ… έως 25%.<br> ΞΞΉ Inverters συνοδεΟονται Ξ±Ο€Ο ΞΊΞ±Ο„Ξ¬Ξ»Ξ»Ξ·Ξ»ΞΏ Ξ±ΟΞΉΞΈΞΌΟ ΟƒΟ…ΟƒΞΊΞµΟ…ΟΞ½ Βελτιστοποίησης (Optimizer Monitoring) της SOLAREDGE (Power Box - Add on).<br> <br> ΔυνατΟτητα επέκτασης της ΞµΞ³Ξ³Οησης Ξ³ΞΉΞ± Ολους τους Ο„Οπους Inverter της Solarerdge στα 20 έτη.<br>

 

Any help please?


One amateur made the Arc, 5.000 pro made the Titanic...

Share this post


Link to post
Share on other sites

Also while I have your attention, I have a separate issue with the product images being fullsize on the product page. I have read in previous threads that this can be resolved using Easy Populate but on looking at the suggested contribution in the Support documentation http://addons.oscommerce.com/info/1032 I realise its only for 2.2. Is there a version for 2.3.1 or even another way to get my main images to resize?

 

Or can it still be used?

 

Please advise.

 

Could I ask if anyone can help? thanks.


Debbie Harrison

 

Share this post


Link to post
Share on other sites

I am aware we can upload to the larger file image field, but we have about 1100-1500 images on the catalogue. please could anyone help? :sweating:


Debbie Harrison

 

Share this post


Link to post
Share on other sites

This is what i get for description

 

Ξονοφασικοί Inverters του ΞΏΞ―ΞΊΞΏΟ… SOLAREDGE, ΞΉΟƒΟαηλινής Ο€Οοέλευσης, ΞΌΞµ τους οποίους επιτυγχάνεται Ξ±Οξηση της Ξ±Ο€Οδοσης του Ξ¦/Ξ’ πάΟΞΊΞΏΟ… έως 25%.<br> ΞΞΉ Inverters συνοδεΟονται Ξ±Ο€Ο ΞΊΞ±Ο„Ξ¬Ξ»Ξ»Ξ·Ξ»ΞΏ Ξ±ΟΞΉΞΈΞΌΟ ΟƒΟ…ΟƒΞΊΞµΟ…ΟΞ½ Βελτιστοποίησης (Optimizer Monitoring) της SOLAREDGE (Power Box - Add on).<br> <br> ΔυνατΟτητα επέκτασης της ΞµΞ³Ξ³Οησης Ξ³ΞΉΞ± Ολους τους Ο„Οπους Inverter της Solarerdge στα 20 έτη.<br>

 

Any help please?

 

Does anyone knows something?


One amateur made the Arc, 5.000 pro made the Titanic...

Share this post


Link to post
Share on other sites

I installed the newest version of this contribution (2.77a for osc2.3.1), and everything looks fine. However, whenever I upload my csv file to the backend (after I have created and downloaded it & then edited the file), it removes all of the html tags that I had in the .csv file, so now in my product description i don't have any breaks. Does anyone else have this problem?

Share this post


Link to post
Share on other sites

Hi there,

 

I have installed oscommerce in the form of the wp-online-store plugin for wordpress. The store works but this contribution does not. I have fiddled around to see what he problem is and it is this: all the links from the easyconribute page (even the documentation) goes to www.mysite.com/wp-admin/ (for example it tries to find the backup.php, the EPDocumentation and even easypopulate.php itself in mysite.com/wp-admin/ . It should look for www.mysite.com/wp-content/plugins/wp-online-store/admin/ because that's where these files are!

My php knowledge is very little but I already tried:

-adjust the "define('DIR_WS_ADMIN'," in admin/includes to the correct path, but then the whole store did not work anymore

-adjust every href in easypopulate.php to the right path but with no result (clicking on a "download .csv" link gave a blank page).

 

Any help is appreciated

 

Settings & Info

 

EP vers: 2.77a-2.3.1

osCommerce Online Merchant v2.3

OS: Array

HTTP:

DB:

PHP: Array (Zend: )

 

Temp Directory:

/Library/Server/Web/Data/Sites/Default/wp-content/plugins/wp-online-store/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

Unlimited Images: false

HTC: false

SPPC: false

Extra Fields: true

PDF Upload: false

Quick Backup Enabled: true

Share this post


Link to post
Share on other sites

Hi

 

I am thinking of using this product, but when I read the instructions it mentions

 

This is based on the Excel Upload 1.51 from dynamok.

 

Does this mean the Excel Upload needs to be installed first?

 

many thanks in advance

Share this post


Link to post
Share on other sites

Rob

 

No they have used the initial work and enhanced it

 

Cheers

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×