Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

I love EasyPopulate. Just Love it. I have 11,000 items and counting but I do not use the attributes. It would be lovely if it could allow for Specials to be incorporated and make the manipulation of that field easier from the spreadsheets. Is it not possible for that field to be used somehow or because it is a different database file it is not able to be used? I have tried investigating it on my own but it is over my head. SB

Share this post


Link to post
Share on other sites

I love EasyPopulate. Just Love it. I have 11,000 items and counting but I do not use the attributes. It would be lovely if it could allow for Specials to be incorporated and make the manipulation of that field easier from the spreadsheets. Is it not possible for that field to be used somehow or because it is a different database file it is not able to be used? I have tried investigating it on my own but it is over my head. SB

Share this post


Link to post
Share on other sites

I'm sorry I did not mean specials, I meant featured.

 

I'm sorry there are not any featured products contributions supported in the latest versions.

Share this post


Link to post
Share on other sites

Maybe I'm missing something - but from what I can tell I have downloaded the latest version - it was uploaded March 27 2010 (there is no newer file on this page: http://addons.oscommerce.com/info/500)

 

The file with just one product is here: www.mountainmeadowherbs.com/temp/test.csv

 

The support instructions tell me my first step for requesting help should be this:

1. Edit easypopulate.php and ensure EP_SHOW_EP_SETTINGS is set to true, then copy the settings & server info that are displayed on the EP main page into your post.

 

However, I cannot find EP_SHOW_EP_SETTINGS in the easypopulate.php file anywhere. (I'm looking at admin/easypopulate.php - is that the correct file?) I cannot even find the word "settings" in the file. So I was figuring the support instructions were out-of-date in comparison to the files. Am I missing something here too?

 

Sorry - I'm just confused about what version you are referring to when you tell me I don't have the latest version. I don't see anything more recent on the download page - LOL

 

A link to your file would help. See the support section of the latest version I uploaded for details.

Edited by TracyS

~Tracy
 

Share this post


Link to post
Share on other sites

Maybe I'm missing something - but from what I can tell I have downloaded the latest version - it was uploaded March 27 2010 (there is no newer file on this page: http://addons.oscommerce.com/info/500)

 

The file with just one product is here: www.mountainmeadowherbs.com/temp/test.csv

 

The support instructions tell me my first step for requesting help should be this:

1. Edit easypopulate.php and ensure EP_SHOW_EP_SETTINGS is set to true, then copy the settings & server info that are displayed on the EP main page into your post.

 

However, I cannot find EP_SHOW_EP_SETTINGS in the easypopulate.php file anywhere. (I'm looking at admin/easypopulate.php - is that the correct file?) I cannot even find the word "settings" in the file. So I was figuring the support instructions were out-of-date in comparison to the files. Am I missing something here too?

 

Sorry - I'm just confused about what version you are referring to when you tell me I don't have the latest version. I don't see anything more recent on the download page - LOL

 

 

As I mentioned in the post at the top of the page, the latest version is 2.76i. If you would like me to help further, you need to download that version which I uploaded (2.76i). I didn't upload the March version.

 

Please use that version & those instructions. If you are not seeing EP_SHOW_EP_SETTINGS or a section of settings at the top of the script, you are using a version I can't support. Please verify you are using that version and have read through all the docs for good measure.

 

And of course once you do, you should note the category column headings in that version are different from those that you have used in your test file. And you have a v_attribute_options_id_1 column which is useless by itself.

Share this post


Link to post
Share on other sites

Have been using this fore som time now, but have to change it a little.

 

Need to add two fields. field1 and field2. Have added them to products tabel in mysql.

 

Have a lot of fields i never use, as products_weight and products_quantity. Can i in a easy way change them to field1 and field2 ?

 

thanks.

Share this post


Link to post
Share on other sites

was easy, onlye replace all products_weight with products_field1 in easypopulate.php and easypopulate_functions.php.

Share this post


Link to post
Share on other sites

was easy, onlye replace all products_weight with products_field1 in easypopulate.php and easypopulate_functions.php.

 

if you are using one of my latest version, you went WAY out of your way to accomplish that. Reading the docs and the settings at the top of the script would have saved you lots of time. crying.gif

Share this post


Link to post
Share on other sites

I am getting a Server 500 error. :(

 

I installed EasyPopulate 2.76i with 1 extra field (product_retail_price) and the headers plugin (HTC?) enabled. My database is 297 products. I am unable to create & download the initial csv file. The browser sits for about a minute and then throws a Server 500 error.

 

The support for my webhost says, and I quote, "It appears that the application runs out of memory while generating the CSV file.

We are forwarding your ticket to our system administrators. They will check if the memory limit can be raised for your account."

 

Is there anything else I can do? I remember seeing a setting about a 30-second server timeout, but I am not sure how to use it. Would that help?

Share this post


Link to post
Share on other sites

I am getting a Server 500 error. :(

 

...

I remember seeing a setting about a 30-second server timeout, but I am not sure how to use it. Would that help?

 

I removed the // in front of the 330 setting, but it did not help. Still 500 error.

 

 

Here are my settings:

 

Settings & Info

 

EP vers: 2.76i-MS2

osCommerce 2.2-MS2

OS:

HTTP: Apache

DB: MySQL 4.0.27-icd1-log

PHP: 5.2.12 (Zend: 2.2.0)

 

Temp Directory:

/home/dreaming/www/coyoteas/catalog/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 3

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: true

SPPC: false

Extra Fields: false

PDF Upload: false

 

 

^ one thing does bother me about the above. The SQL database I'm using is 5.0, so seeing a 4.0 next to SQL makes me uneasy.

Share this post


Link to post
Share on other sites

if you are using one of my latest version, you went WAY out of your way to accomplish that. Reading the docs and the settings at the top of the script would have saved you lots of time. crying.gif

 

dont think it had saved me a lot of time, used notepad++ and replace, so was very easy done and worked on first try.

 

Thanks for answer anyway, now i know what to do if i need to change some more fields.

Share this post


Link to post
Share on other sites

*sighs and rubs face*

 

I still need some help, please.

 

My hosting company, I C D Soft, says that they allow 120 seconds maximum for a script to execute. It is taking longer than that to download the initial CSV out of EasyPopulate... probably because my database is so large. They will not help me. So, please if anyone has any ideas, I would very, very much appreciate it! Thank you.

 

1.) Is there anything I can do, to nab a csv formatted version of my database that will work with Easy Populate? I can get one using MySQL, but I'm not sure how to format it so Easy Populate can read it.

 

and

 

2.) Does anyone have suggestions for a *reliable* hosting company that can run OSCommerce?

 

 

Thank you,

Kyr

Share this post


Link to post
Share on other sites

Ya know, when they are both named version 2_76i - it might be helpful if you tell people to download the August 2009 version rather than the latest version, as the downloads page shows the March 2010 on top which typically signifies it is the most recent version and the file is also version 2_76i - very confusing for someone who has not used this contribution before. :blush:

 

I will download the August version and run a quick file comparison to see if I can find the differences. Is this version setup to handle the price groups with separate pricing per customer?

 

As I mentioned in the post at the top of the page, the latest version is 2.76i. If you would like me to help further, you need to download that version which I uploaded (2.76i). I didn't upload the March version.

 

Please use that version & those instructions. If you are not seeing EP_SHOW_EP_SETTINGS or a section of settings at the top of the script, you are using a version I can't support. Please verify you are using that version and have read through all the docs for good measure.

 

And of course once you do, you should note the category column headings in that version are different from those that you have used in your test file. And you have a v_attribute_options_id_1 column which is useless by itself.


~Tracy
 

Share this post


Link to post
Share on other sites

I removed the // in front of the 330 setting, but it did not help. Still 500 error.

 

 

Here are my settings:

 

Settings & Info

 

EP vers: 2.76i-MS2

osCommerce 2.2-MS2

OS:

HTTP: Apache

DB: MySQL 4.0.27-icd1-log

PHP: 5.2.12 (Zend: 2.2.0)

 

Temp Directory:

/home/dreaming/www/coyoteas/catalog/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 3

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: true

SPPC: false

Extra Fields: false

PDF Upload: false

 

 

^ one thing does bother me about the above. The SQL database I'm using is 5.0, so seeing a 4.0 next to SQL makes me uneasy.

if you are running out of memory, then you want to do is discuss the Step #6 in the install instructions (my latest version) with your host to ensure you are withing policy to change those settings. 500 errors are hard to diagnose since they are so vague. My gut is telling me it is something else like file permissions, or mod_security settings, or something else.

Share this post


Link to post
Share on other sites

dont think it had saved me a lot of time, used notepad++ and replace, so was very easy done and worked on first try.

 

Thanks for answer anyway, now i know what to do if i need to change some more fields.

 

Not sure why this settings section wouldn't save you time. It was designed to do just that:

 

// ******************************************************************

// BEGIN Define Custom Fields for your products database

// ******************************************************************

// The following setup will allow you to define any additional

// field into the "products" and "products_description" tables

// in your shop. If you have installed a custom contribution

// that adds fields to these tables you may simply and easily add

// them to the EasyPopulate system.

 

custom product fields in an instant, really.

Share this post


Link to post
Share on other sites

*sighs and rubs face*

 

I still need some help, please.

 

My hosting company, I C D Soft, says that they allow 120 seconds maximum for a script to execute. It is taking longer than that to download the initial CSV out of EasyPopulate... probably because my database is so large. They will not help me. So, please if anyone has any ideas, I would very, very much appreciate it! Thank you.

 

1.) Is there anything I can do, to nab a csv formatted version of my database that will work with Easy Populate? I can get one using MySQL, but I'm not sure how to format it so Easy Populate can read it.

 

and

 

2.) Does anyone have suggestions for a *reliable* hosting company that can run OSCommerce?

 

 

Thank you,

Kyr

sorry to hear about your troubles, yes, hosts can be a pain when they don't want to help. If you can't make the settings described in step 6 of the install, then move hosts, interview them before about how well they can assist with osCommerce shops. Some will some just don't care about the "little guy".

 

the best thing I can suggest is to make sure your host has a database server on your web server and not a remote database server. That will kill the site's performance and ability to run EP.

Share this post


Link to post
Share on other sites

Hi iam trying to install the Easypopulate contribution.. but have problems with Step 3

which states:

 

STEP #3 - Add a link in the Admin Panel. Edit file "/catalog/admin/incudes/boxes/catalog.php"

 

Find this code (Around Line 25):

 

'' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '' .

 

Directly AFTER add this:

'Easy Populate' .

 

 

The line they are indicating is this...

 

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

 

I Can't see the 2 '' after the word attribute...

 

Please can someone advise as to where to add this 'Easy Populate' . text

 

Thanks in advance...

Share this post


Link to post
Share on other sites

Ya know, when they are both named version 2_76i - it might be helpful if you tell people to download the August 2009 version rather than the latest version, as the downloads page shows the March 2010 on top which typically signifies it is the most recent version and the file is also version 2_76i - very confusing for someone who has not used this contribution before. :blush:

 

I will download the August version and run a quick file comparison to see if I can find the differences. Is this version setup to handle the price groups with separate pricing per customer?

 

 

 

the latest version (march 2010) has EP_SHOW_EP_SETTINGS on line 36 of easypopulate.php. you are not looking hard enough for it.

 

I can't help the version numbers. It's usually pretty clear to folks that they should increase the version numbers when they upload a new one.

 

if you are looking for support for SPPC, I can't say it will work. Support in this package was for a version that was out many years ago.

Share this post


Link to post
Share on other sites

I would like to have both Model-number and EAN/Barcode-number in my products.

 

Is it possible to update Easypopulate so it also can handle EAN number?

Share this post


Link to post
Share on other sites

I would like to have both Model-number and EAN/Barcode-number in my products.

 

Is it possible to update Easypopulate so it also can handle EAN number?

please see the instructions for adding fields to the code in the top settings section of easypopulate.php script. if you have further specific questions about that part, please post again.

Share this post


Link to post
Share on other sites

Is there any chance at all that someone is working on getting this great contribution to work with the images contribution "Simple Multiple Images (Unlimited) with Fancy Popups" ?

 

Or perhaps someone has already got them to work together?

 

Thank you

 

Michael

Share this post


Link to post
Share on other sites

Three additional images contributions actually.

 

Additional Images 2.x

More Pics 6 1.3 or previous

UltraPics Pics 2.0.x

 

Hi, thanks for the advice here and I have had a quick look at all the options mentioned. However since this post was written in December 2009 there have been a few updates to the UltraPics contribution.

 

Can I use any version, the latest version or a specific version of UltraPics to be compatible with Easy Populate?

 

Thank you

 

Michael

Share this post


Link to post
Share on other sites

Hi, thanks for the advice here and I have had a quick look at all the options mentioned. However since this post was written in December 2009 there have been a few updates to the UltraPics contribution.

 

Can I use any version, the latest version or a specific version of UltraPics to be compatible with Easy Populate?

 

Thank you

 

Michael

sorry, I don't know the answer to that. The question to Ultrapics forum would be; is there any database changes since then?

 

Note: Ultrapics of that year was limited to 6 additional pics. Additional Images is unlimited.

Edited by surfalot

Share this post


Link to post
Share on other sites

sorry, I don't know the answer to that. The question to Ultrapics forum would be; is there any database changes since then?

 

Note: Ultrapics of that year was limited to 6 additional pics. Additional Images is unlimited.

 

Thanks foir the quick reply.

 

I will look at AI then but I can't see me wanting more than 6 images anyway, probably 3 at most. Its the style and format of the popup image that most concerns me not how many images I can have.

 

I loved the style of the contribution simple multi images but unfortunately this did not work with easy populate contribution.

 

Thanks anyway for your help, its much appreciated.

 

Michael

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×