Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

I noticed after entering product descriptions through the admin catalog in osCommerce there were <p> tags around it.

 

But if I try to add H1 tags it doesn't work.

 

Can it be done in EZ Populate?

 

thanks,

ed

 

any html can be included with the product description.

Share this post


Link to post
Share on other sites

I have also had a file added called extra_info_pages/bground1.gif-fix.by.php containing.

 

000huyasse

 

not sure what you are referring to.

Share this post


Link to post
Share on other sites

Hi, I am about to install this contribution and have been reading through the Documentation and Installation file.

 

Firstly I have downloaded the latest files dated 27 Mar 2010 by mickthehat. Although this is titled "additional instructions", am I right to think that this is the full package with extra things added within it?

 

Also in the download folder there are 2 Documentation and Installation files with one of them having update at the end. I have looked at both files and they seem to be the same, I can not see any differences between the files so can I use any of them to do the installation or should I use the one that says Documentation and Installation update?

 

Finally, near the end of the Documentation and Installation files there are instructions for users who have installed other contributions such as Extra Fields Contribution. I have noted that one of the contributions mentioned is Additional Images Contribution. Now I do not have that installed but I do have Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5. installed. Would these instruction apply to this contribution or not?

 

Thanks for any help

 

Michael

sorry, not sure what mickthehat updated in that version. It appears by the description the docs were updated. Most folks haven't had trouble with the version I uploaded.

 

The support for other contributions are quite specific to those contributions. I would not expect them to work with other contributions.

Share this post


Link to post
Share on other sites

sorry, not sure what mickthehat updated in that version. It appears by the description the docs were updated. Most folks haven't had trouble with the version I uploaded.

 

The support for other contributions are quite specific to those contributions. I would not expect them to work with other contributions.

 

Thanks, I will use your version then.

 

Michael

Share this post


Link to post
Share on other sites

Hi,

 

Sorry have posted as a stand alone question but came across this thread so sorry for newbie duplication - mods - can you delete dupe posting please as necessary?

 

Anyway:

 

Can you please point me on how to extend the product model_id variant from the default 25 characters to 75 when importing a .csv file (first column) for new items as I have a number of variants in excess of the 25 range that I need to keep seperate.

 

I have read I have to amend the EP mainpage file.php and also products model table but am not sure where to find these or indeed whether they are the correct ones I should be changing.

 

Many thanks in advance

 

Del

Share this post


Link to post
Share on other sites

Hi,

 

Sorry have posted as a stand alone question but came across this thread so sorry for newbie duplication - mods - can you delete dupe posting please as necessary?

 

Anyway:

 

Can you please point me on how to extend the product model_id variant from the default 25 characters to 75 when importing a .csv file (first column) for new items as I have a number of variants in excess of the 25 range that I need to keep seperate.

 

I have read I have to amend the EP mainpage file.php and also products model table but am not sure where to find these or indeed whether they are the correct ones I should be changing.

 

Many thanks in advance

 

Del

 

the default is 12 chars. you have to change the setting in easypopulate.php and change the field length in the products database table using something like phpMyAdmin usually supplied by your host.

Share this post


Link to post
Share on other sites

the default is 12 chars. you have to change the setting in easypopulate.php and change the field length in the products database table using something like phpMyAdmin usually supplied by your host.

 

Thanks - does changing the range affect anything or am likely to see any issues from changing this?

 

Is this variable in EP.php file I change?

 

if (strlen($v_products_model) > $modelsize ){

echo "<font color='red'>" . strlen($v_products_model) . $v_products_model . "... ERROR! - Too many characters in the model number.<br>

12 is the maximum on a standard OSC install.<br>

Your maximum product_model length is set to $modelsize<br>

You can either shorten your model numbers or increase the size of the field in the database.</font>";

 

Sorry I do also have myphpadmin - which field/area do I find the area in question - I have never used this part before?

Edited by Delboy2424

Share this post


Link to post
Share on other sites

Thanks - does changing the range affect anything or am likely to see any issues from changing this?

 

Is this variable in EP.php file I change?

 

I can't think of any problems this would cause.

 

there is a setting at the top of the code page in the settings.

Share this post


Link to post
Share on other sites

I can't think of any problems this would cause.

 

there is a setting at the top of the code page in the settings.

 

 

Sorry for sounding "dence" - is this the .php file named easypopulate.php - the only reference to variable of 12 is the section I posted which lists a number of configuration guidelines throughout, am not sure where I should be looking for

....a setting at the top of the code page in the settings

 

Thanks

 

Del

Share this post


Link to post
Share on other sites

Sorry for sounding "dence" - is this the .php file named easypopulate.php - the only reference to variable of 12 is the section I posted which lists a number of configuration guidelines throughout, am not sure where I should be looking for

....a setting at the top of the code page in the settings

 

Thanks

 

Del

 

you're looking for this section of the settings

 

//**** Size of products_model in products table ****
// set this to the size of your model number field in the db. We check to make 
// sure all models are no longer than this value. this prevents the database from 
// getting fubared. Just making this number bigger won't help your database! They must match!
// If you increase the Model Number size, you must increase the size of the field
// in the database. Use a SQL tool like phpMyAdmin (see your host) and change the
// "products_model" field of the "products" table in your osCommerce Database.
define ('EP_MODEL_NUMBER_SIZE', 12); // default is 12

Share this post


Link to post
Share on other sites

Many thanks - all sorted, now another issue....

 

 

I have created a new attributes input .csv file (2mb) but on upload EP only seems to upload a small percentage of my products but does not report an error that the file upload is incomplete?

 

Is this a timeout issue - how do I ensure EP is picking all the product attributes?

 

It is saved as a tab delimited excel file - I do not have the option to split files and EP version is 3.0

 

Thanks in advance,

 

Del

Edited by Delboy2424

Share this post


Link to post
Share on other sites

Have also just tried FTP to server and loading from there in the admin/temp file - same issue.

 

Any ideas anyone please?

Share this post


Link to post
Share on other sites

Have also just tried FTP to server and loading from there in the admin/temp file - same issue.

 

Any ideas anyone please?

 

I can't help you with 3.0. which is why you didn't see that setting in the file I suspect.

 

But there is a pretty good detail in the latest version's installation instructions that should help with timeouts.

Share this post


Link to post
Share on other sites

But there is a pretty good detail in the latest version's installation instructions that should help with timeouts.

 

 

Thanks again for your help...

 

Would you suggest that this is as I thought then, a timing out issue?

 

Where would I find the instructions you refer to, this came on a pre-bundled site so am still finding my way around the detail on here - Is it as simple as downloading the zip folder from here?

 

Also given my site is hosted on a shared server, would this cause any issues with timings or so much as in, being able to amend them?

 

Many thanks once again,

 

Del

Share this post


Link to post
Share on other sites

If this has been asked already I apologize - I've not been having any luck finding my situation via Google so figured I'd finally break down and ask.

 

I have installed Easy Populate with the easypopulate.php file for SPPC. All seems to be ok, until I click to download my file. No matter if I choose "Download Complete tab-delimited .txt file to edit" or "Create Complete tab-delimited .txt file in temp dir" - It doesn't do anything. I don't get any errors, it just refreshes the page and does nothing.

 

I am not sure what I need to change in the settings of the easypopulate.php file to correct this. I am currently attempting this on a test server, and I don't use the "Catalog" folder. So my domain is root/MMHTest/index.php (this would be the home page that the customer sees, root/MMHTest/admin/ is where the admin files are). So, what should I put here:

 

$tempdir = "temp/";
$tempdir2 = "temp/";

 

I've tried "temp/" , "/temp/" , "/MMHTest/temp/" and "MMHTest/temp/" and it doesn't seem to make any difference.

 

I'm not sure if I'm looking in the right place or not, but figured for the "save the file in temp dir" this would most likely be where to look. Not sure on the download file to edit option though.

 

Any ideas would be greatly appreciated. Thank you.


~Tracy
 

Share this post


Link to post
Share on other sites

Strangely enough - after installing these same files (nothing changed other than the froogle paths) on the live server, it worked just fine :thumbsup:

 

I have no idea why it is having issues on the test server, but hey - at least it's working on the live server- YAY

 

Now that I have downloaded my first excel file of the database, I have a new question. I did download the easypopulate.php for SPPC, but I don't see the product prices for different groups on the spreadsheet. Am I missing something in the configuration of easypopulate.php to pull the various group prices?

 

 

If this has been asked already I apologize - I've not been having any luck finding my situation via Google so figured I'd finally break down and ask.


~Tracy
 

Share this post


Link to post
Share on other sites

PS- I've found the various prices in the Model/Price/Qty download, but not in the "complete" file? Is there a way I can incorporate it into the complete file?

 

Strangely enough - after installing these same files (nothing changed other than the froogle paths) on the live server, it worked just fine :thumbsup:

 

I have no idea why it is having issues on the test server, but hey - at least it's working on the live server- YAY

 

Now that I have downloaded my first excel file of the database, I have a new question. I did download the easypopulate.php for SPPC, but I don't see the product prices for different groups on the spreadsheet. Am I missing something in the configuration of easypopulate.php to pull the various group prices?


~Tracy
 

Share this post


Link to post
Share on other sites

another question: do you have to have all of the fields in the excel file, even if they aren't used, in order to upload the changes?

 

For example, I have a few hundred products that I just need to add a price for customer group 2. I downloaded the Model/Price/Qty csv and modified it to only contain the products I need to edit. I also removed the columns for additional price groups that I do not have (they would just be empty as I only have groups 0, 1 & 2 and it is group 2 I am setting).

 

I have trimmed this initial file down to only 3 rows, the header row and two product rows.

 

I then upload my file via "Upload EP File" and click "Insert into DB" button and I get the following message at the top:

 

File uploaded.

Temporary filename: /tmp/phpElK1ss

User filename: test1.csv

Size: 226

 

I go check on the item via admin/catalog and look to see if the new price has been added to the product - and it has not. Nothing has changed with the product :huh:

 

Am I doing something wrong? My csv file looks like this (not sure if it will come out right on here, but I'll try):

 

v_products_model	v_products_price	v_products_quantity    v_customer_price_1	v_customer_group_id_1	v_customer_price_2	v_customer_group_id_2	EOREOR
AE4002	14.27	1000	9.97	1	7.14	2	EOREOR
AE4004	24.97	1000	17.05	1	12.49	2	EOREOR

Edited by TracyS

~Tracy
 

Share this post


Link to post
Share on other sites

Thanks again for your help...

 

Would you suggest that this is as I thought then, a timing out issue?

 

Where would I find the instructions you refer to, this came on a pre-bundled site so am still finding my way around the detail on here - Is it as simple as downloading the zip folder from here?

 

Also given my site is hosted on a shared server, would this cause any issues with timings or so much as in, being able to amend them?

 

Many thanks once again,

 

Del

You should make sure you are not hosted on a plan with a remote SQL server. That is always trouble with osC.

 

I don't know what osCommerce flavor you have, but 3.0 easypop was never adopted well here and it's author asked folks to use something else. So replacing what you have could be trouble if your shop is not osCommerce RCx.

 

there isn't any reason to replace your EP version. just download the latest version uploaded by me (2.76i) and look at step 6 of the html docs included. search the contributions section for easypopulate.

Share this post


Link to post
Share on other sites

another question: do you have to have all of the fields in the excel file, even if they aren't used, in order to upload the changes?

 

For example, I have a few hundred products that I just need to add a price for customer group 2. I downloaded the Model/Price/Qty csv and modified it to only contain the products I need to edit. I also removed the columns for additional price groups that I do not have (they would just be empty as I only have groups 0, 1 & 2 and it is group 2 I am setting).

 

I have trimmed this initial file down to only 3 rows, the header row and two product rows.

 

I then upload my file via "Upload EP File" and click "Insert into DB" button and I get the following message at the top:

 

File uploaded.

Temporary filename: /tmp/phpElK1ss

User filename: test1.csv

Size: 226

 

I go check on the item via admin/catalog and look to see if the new price has been added to the product - and it has not. Nothing has changed with the product :huh:

 

Am I doing something wrong? My csv file looks like this (not sure if it will come out right on here, but I'll try):

 

v_products_model	v_products_price	v_products_quantity v_customer_price_1	v_customer_group_id_1	v_customer_price_2	v_customer_group_id_2	EOREOR
AE4002	14.27	1000	9.97	1	7.14	2	EOREOR
AE4004	24.97	1000	17.05	1	12.49	2	EOREOR

what's the OS on your computer? what are you using to edit the file?

since this is an older version, I probably won't be able to help much.

The latest version (2.76i) has much better docs and far more bug fixes, BUT I'm not 100% sure it supports the latest version of SPPC. If my latest version doesn't support it, I believe the version you tried won't either.

Share this post


Link to post
Share on other sites

Sorry for the delay, I had forgotten to click the "enable notification of replies" button when I posted :blush:

 

My OS is XP, I use Office 2007 Excel to modify the file, save it as a csv file. I tried again today, keeping all of the additional customer group columns in the spreadsheet (just blank) and the file splitter worked perfectly (so I know it's reading the file correctly) and I then uploaded the split files using the "Import from Temp Dir" section - but no changes occurred.

 

Which thing is an older version? I downloaded EP_v2_76i_MS2_1 and easypopulate_sppc_hide_products_for_cg_v1.

 

What should I have installed? I can download and WinMerge to find the differences in the files if need be.

 

I'm thinking it may have to do with how the database stores the pricing for the separate customer groups vs how the easypopulate file is trying to save them - but then again, since it is pulling the pricing information correctly for each group - you would think it would also be writing it correctly? :huh:

 

I will have to try and upload a basic product just to test and see if that works correctly (without looking at separate group pricing) and then maybe we can better troubleshoot. :thumbsup:

 

Thanks in advance for your help.

 

what's the OS on your computer? what are you using to edit the file?

since this is an older version, I probably won't be able to help much.

The latest version (2.76i) has much better docs and far more bug fixes, BUT I'm not 100% sure it supports the latest version of SPPC. If my latest version doesn't support it, I believe the version you tried won't either.


~Tracy
 

Share this post


Link to post
Share on other sites

Ok - I created a test file with one product and uploaded it. I get this message at the top of easypopulate:

 

Easy Populate 2.74-MS2 - Default Language : English(1)

 

File uploaded.

Temporary filename: /tmp/php1KSsQL

User filename: test.csv

Size: 672

 

But I have no product created. Could it also have to do with running Master Products? I don't see a way to designate if the product is a master or a slave, but I would think it would just upload as a slave by default - hmmm <_<

 

Anyway - I checked both client side and via admin and it did not create the new product.

 

With all of the customizations on our site I might just have to learn to write SQL and create a query file to run via phpMyAdmin for bulk updates - LOL

 

what's the OS on your computer? what are you using to edit the file?

since this is an older version, I probably won't be able to help much.

The latest version (2.76i) has much better docs and far more bug fixes, BUT I'm not 100% sure it supports the latest version of SPPC. If my latest version doesn't support it, I believe the version you tried won't either.


~Tracy
 

Share this post


Link to post
Share on other sites

Ok - I created a test file with one product and uploaded it. I get this message at the top of easypopulate:

 

Easy Populate 2.74-MS2 - Default Language : English(1)

 

File uploaded.

Temporary filename: /tmp/php1KSsQL

User filename: test.csv

Size: 672

 

But I have no product created. Could it also have to do with running Master Products? I don't see a way to designate if the product is a master or a slave, but I would think it would just upload as a slave by default - hmmm <_<

 

Anyway - I checked both client side and via admin and it did not create the new product.

 

With all of the customizations on our site I might just have to learn to write SQL and create a query file to run via phpMyAdmin for bulk updates - LOL

 

 

A link to your file would help. See the support section of the latest version I uploaded for details.

Share this post


Link to post
Share on other sites

Yes, this is something I would like to work on. I'm sure it'd make things easier to maintain, especially with these new attribute fields, getting added.

 

Thanks so much for all your feedback and comments :).

 

VJ

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×