Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Hello.

I am trying to install EP using the instructions, but there is something wrong with the code in step 3..

I am using oscommerce 2.2.rc2a

 

STEP #3 - Add a link in the Admin Panel. Edit file "/catalog/admin/incudes/boxes/catalog.php"

Find this code (Around Line 25):

'' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '' .

Directly AFTER add this:

 

'Easy Populate' .

 

----

The problem is that my code is like:

 

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

 

'<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .

 

I don't know what "directly after" means, because anywhere I put 'Easy Populate' . , it doesnt create a seperate link in admin panel :(

 

Help pls!

Afterwards, it should be:

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' .

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '" class="menuBoxContentLink">Easy Populate</a><br>' .

'<a href="' . tep_href_link(FILENAME_MANUFACTURERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_MANUFACTURERS . '</a><br>' .


For a new install or if your store isn't mobile-friendly, get the community-supported responsive osCommerce (2.3.4.1 CE).

here: https://github.com/gburton/Responsive-osCommerce/releases

Working on generalising bespoke solutions for Quickbooks integration, Easify integration and pay4later (DEKO) integration at 2.3.x

Share this post


Link to post
Share on other sites

Hi, wondered if anyone can help.

 

I am importing a largish file of around 15MB and basically it stops, it wont let me split it, I have been able to upload 3,000 products which is about 1/5 of the files contents.

 

Is there any server/ file settings I can use to help load it for splitting or upload it all?

 

Thanks

step 6 of the install instructions. If you didn't understand the process there when installing, please let me know where you got stuck.

Share this post


Link to post
Share on other sites

It doesn't mean in the package, it means in your store. If there's no catalog.php file in your osCommerce installation then admin won't work. If you were looking in the store, my guess would be you looked in catalog/includes instead of catalog/admin/includes

 

hope this helps

 

Thank you for your answer JohnAtYM, I was already looking in the shop. But it's the file which is simply not here.

Share this post


Link to post
Share on other sites

Thank you for your answer JohnAtYM, I was already looking in the shop. But it's the file which is simply not here.

osCommerce version? has to be there or your admin will error-out

Share this post


Link to post
Share on other sites

Hi everyone. :blink:

 

Newbie to posting so apologies in advance if i stuff this up.

 

I run a heavily modded shop and have loaded up easy poulate and made the relevant changes to the PHP config (at least i think i've done them correctly). The issue we are having is we can export the CSV file no probs and instead of the " it places the # & 34 which is all well and good, however when we upload it changes the inverted comma into an inverted comma and a ' so for example an html reference comes out like this '"http:// rather than just "http:// (i.e. it is adding the ' symbol before any inverted commas throughout the html code. this includes in font codes as well and not just html references, so all inverted commas throught the code).

 

We do run a wysiwyg add on for the product description window (v 1.7 by maxidvd) so unsure if this is an issue?

 

I have looked through the forum and can't find an answer (hopefully i haven't missed it and again appologies if i have).

 

Hopefully my post makes sense. Any advice would be greatly appreciated as i'm pulling my hair out.

Share this post


Link to post
Share on other sites

Hi everyone. :blink:

 

Newbie to posting so apologies in advance if i stuff this up.

 

I run a heavily modded shop and have loaded up easy poulate and made the relevant changes to the PHP config (at least i think i've done them correctly). The issue we are having is we can export the CSV file no probs and instead of the " it places the # & 34 which is all well and good, however when we upload it changes the inverted comma into an inverted comma and a ' so for example an html reference comes out like this '"http:// rather than just "http:// (i.e. it is adding the ' symbol before any inverted commas throughout the html code. this includes in font codes as well and not just html references, so all inverted commas throught the code).

 

We do run a wysiwyg add on for the product description window (v 1.7 by maxidvd) so unsure if this is an issue?

 

I have looked through the forum and can't find an answer (hopefully i haven't missed it and again appologies if i have).

 

Hopefully my post makes sense. Any advice would be greatly appreciated as i'm pulling my hair out.

 

please see the support section of the docs for the complete list of items needed help you further.

Share this post


Link to post
Share on other sites
EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.32.8-grsec-2.1.14-modsign-xeon-64

HTTP: Apache

DB: MySQL 5.1.39-log

PHP: 5.2.13 (Zend: 2.2.0)

 

Temp Directory:

/home/univbooks/shop.gamesboro.net/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: false

SPPC: false

Extra Fields: false

PDF Upload: false

 

My csv is empty except for the headers. I am not sure what I am doing wrong, but there is definitely two test products in the store.

 

I'd post the file, but I don't see the point, since it's just an empty file with headers.

Share this post


Link to post
Share on other sites

My csv is empty except for the headers. I am not sure what I am doing wrong, but there is definitely two test products in the store.

 

I'd post the file, but I don't see the point, since it's just an empty file with headers.

 

Nevermind, I fixed it.

 

For future reference, it needs to be added to the FAQ that in order for products to appear in the exported CSV, they need to be in categories. All products must be in categories, or they will not show!!!

Share this post


Link to post
Share on other sites

Hi,

 

the htc contribution is switched on but I dont see any code for the htc categories in the file, I do see the products htc information.

 

and I dont have the option to use htc for the ctegories, what code do i need to add to the easy pop file to get htc to work?


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Hi

does anybody know why my Froogle Products export file is enquoting titles and descriptions and omitting the html please?

 

- Title is coming out in quotes:

"Zzino vs. Accelerator: Waterproof 12"""

 

...should be...

 

Zzino vs. Accelerator: Waterproof 12"

 

- Description is coming out in quotes, html formatting tags have been omitted:

"Zzino vs. Accelerator: Waterproof12""Re-load Records REL 972103Belgium 1997-00-00Waterproof (Original Mix)Waterproof (Mould Impression Remix)Waterproof (Space DJz Remix)Item condition: Near Mint (NM or M-)Sleeve condition: Very Good Plus (VG+)"

 

...should be...

 

Zzino vs. Accelerator: Waterproof[bR]12"[bR]Re-load Records REL 972103[bR]Belgium 1997-00-00[bR]Waterproof (Original Mix)[bR]Waterproof (Mould Impression Remix)[bR]Waterproof (Space DJz Remix)[bR]Item condition: Near Mint (NM or M-)[bR]Sleeve condition: Very Good Plus (VG+)

 

Any help appreciated, apologies if this has already been covered...

Share this post


Link to post
Share on other sites

Hi

does anybody know why my Froogle Products export file is enquoting titles and descriptions and omitting the html please?

 

- Title is coming out in quotes:

"Zzino vs. Accelerator: Waterproof 12"""

 

...should be...

 

Zzino vs. Accelerator: Waterproof 12"

 

- Description is coming out in quotes, html formatting tags have been omitted:

"Zzino vs. Accelerator: Waterproof12""Re-load Records REL 972103Belgium 1997-00-00Waterproof (Original Mix)Waterproof (Mould Impression Remix)Waterproof (Space DJz Remix)Item condition: Near Mint (NM or M-)Sleeve condition: Very Good Plus (VG+)"

 

...should be...

 

Zzino vs. Accelerator: Waterproof[bR]12"[bR]Re-load Records REL 972103[bR]Belgium 1997-00-00[bR]Waterproof (Original Mix)[bR]Waterproof (Mould Impression Remix)[bR]Waterproof (Space DJz Remix)[bR]Item condition: Near Mint (NM or M-)[bR]Sleeve condition: Very Good Plus (VG+)

 

Any help appreciated, apologies if this has already been covered...

the froogle part is quite out of date. please use a contribution specifically for product feeds for full compatibility with latest Googlebase standards.

Share this post


Link to post
Share on other sites

I have my site hosted at dropshippingwholesalers.com as www.dreamdolldesigns.com. They decided to eliminate the catalog directory so everything starts at public_html as the root.

 

My osCommerce version is v2.2 RC2a.

 

Easy Populate seems to be included (sort of) ... it is listed under My Configuration under ADMIN but I don't see anything under Catalog to use it (if I am reading the documentation correctly).

 

Should I just walk through the full install instructions to see if anything was missed or has anyone had any experience with this that would help?

 

r/

ed

Share this post


Link to post
Share on other sites

I have my site hosted at dropshippingwholesalers.com as www.dreamdolldesigns.com. They decided to eliminate the catalog directory so everything starts at public_html as the root.

 

My osCommerce version is v2.2 RC2a.

 

Easy Populate seems to be included (sort of) ... it is listed under My Configuration under ADMIN but I don't see anything under Catalog to use it (if I am reading the documentation correctly).

 

Should I just walk through the full install instructions to see if anything was missed or has anyone had any experience with this that would help?

 

r/

ed

I would. the install is pretty easy.

Share this post


Link to post
Share on other sites

I would. the install is pretty easy.

 

 

Is step #3 correct? it says to add:

 

'Easy Populate' .

 

But there is no link info?

Share this post


Link to post
Share on other sites

Is step #3 correct? it says to add:

 

'Easy Populate' .

 

But there is no link info?

 

step 3 says:

STEP #3 - Add a link in the Admin Panel. Edit file "/catalog/admin/incudes/boxes/catalog.php"

 

Find this code (Around Line 25):

 

'<a href="' . tep_href_link(FILENAME_PRODUCTS_ATTRIBUTES, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_CATALOG_CATEGORIES_PRODUCTS_ATTRIBUTES . '</a><br>' . 

 

Directly AFTER add this:

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '" class="menuBoxContentLink">Easy Populate</a><br>' . 

Edited by surfalot

Share this post


Link to post
Share on other sites

This is a life saver!!! Thanks VJ!!!!

 

it's really more of a community project as VJ hasn't been involved in over 6 years.

Share this post


Link to post
Share on other sites

Dear

 

I am working on the” Easy Populate” is very convenient,but now

I have a problem need to help.

It Troubled me for a long time,I try it again and again,but faild

I hope you can help me ,thank you very much

 

I add two contribution to my web

1.Products Short Description

the website http://addons.oscommerce.com/info/3123

 

2. Quantity Price Breaks Per Product

http://addons.oscommerce.com/info/1242

 

I can’t add the field “Short Description”and”Price Breaks”to the csv files

Can you help me ,I’m a new leaner about “PHP”,how can I do?

Thank you very much

 

 

my admin interface

001.jpg

 

 

002.jpg

 

 

 

who can help me,i need this help

Edited by baiyangshuo

Share this post


Link to post
Share on other sites

I am using EasyPopulate, and I need a solution for two things:

 


  1.  
  2. An ability to incorporate short term "instant" rebates, and their expiration dates. These will be deducted at the time of check out.
  3. An ability to incorporate and manage manufacturer "mail in" rebates, and their expiration dates. These discounts will not be deducted at the time of check out, but I would like to show an adjusted "After Mail In Rebate" price on the product page, so that customers can see how the rebate will afect them. I would also like to report the "After Mail In Rebate Price" to Froogle.

 

Thanks!!

Share this post


Link to post
Share on other sites

I am using EasyPopulate, and I need a solution for two things:

 


  1.  
  2. An ability to incorporate short term "instant" rebates, and their expiration dates. These will be deducted at the time of check out.
  3. An ability to incorporate and manage manufacturer "mail in" rebates, and their expiration dates. These discounts will not be deducted at the time of check out, but I would like to show an adjusted "After Mail In Rebate" price on the product page, so that customers can see how the rebate will afect them. I would also like to report the "After Mail In Rebate Price" to Froogle.

 

Thanks!!

 

Wow! Easy populate has nothing to do with any of that. You need to search the contributions for something like that and if not found, hire a programmer. Once your set-up can do that, you can modify Easy Populate to easily export, edit and import those fields. Understand that this is a tall order. Configuring Easy Populate to manage it later is simple.

 

Walter

 

(Don't mean to step on your toes Surfalot, but you're very helpful and don't need this)


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites

who can help me,i need this help

 

Reverse engineer. Look at easypopulate.php decide which block you want to use to download them. Find a line that downloads a field. Copy and paste that line. Now that section downloads that field twice. Check the name of the field in your database, alter the pasted line to that name. Don't forget the v_ and table name the same way as it is in the line you copied, in other words, use the same method. I think reading the comments on the actual easypopulate.php helped me the first time i did it. After you do it, if it doesn't work, but you have demonstrated the willingness to try, and made a mistake, then people will help you, either someone smart, or me!

 

Walter


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites

I noticed after entering product descriptions through the admin catalog in osCommerce there were <p> tags around it.

 

But if I try to add H1 tags it doesn't work.

 

Can it be done in EZ Populate?

 

thanks,

ed

Share this post


Link to post
Share on other sites

I have also had a file added called extra_info_pages/bground1.gif-fix.by.php containing.

 

000huyasse

Share this post


Link to post
Share on other sites

Hi, I am about to install this contribution and have been reading through the Documentation and Installation file.

 

Firstly I have downloaded the latest files dated 27 Mar 2010 by mickthehat. Although this is titled "additional instructions", am I right to think that this is the full package with extra things added within it?

 

Also in the download folder there are 2 Documentation and Installation files with one of them having update at the end. I have looked at both files and they seem to be the same, I can not see any differences between the files so can I use any of them to do the installation or should I use the one that says Documentation and Installation update?

 

Finally, near the end of the Documentation and Installation files there are instructions for users who have installed other contributions such as Extra Fields Contribution. I have noted that one of the contributions mentioned is Additional Images Contribution. Now I do not have that installed but I do have Simple Multiple Images (Unlimited) with Fancy Popups V1.3.5. installed. Would these instruction apply to this contribution or not?

 

Thanks for any help

 

Michael

Edited by offie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×