Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

I uploaded a php.ini containing this on my system and it split your file just fine:

 

max_execution_time = 180 ;
post_max_size = 20M ;
upload_max_filesize = 20M ;
memory_limit = 24M ;

 

Thanks for the support Surfalot,

I gonna contact my webhosting company to see if they will let me do it.

Share this post


Link to post
Share on other sites

Hello everybody,

I add a field on table Products_Attributes (called options_weight)

 

How to change EP that can handle this field?

thank you so much

 

I just had a similar request that was answered in the custom fields area. See my reply http://forums.oscommerce.com/topic/162244-easy-populate-products-attributes/page__view__findpost__p__1467358

 

Good Luck

Cary

Share this post


Link to post
Share on other sites

Sorry Guys - I had a mini holiday but am back now

 

@surfalot - the products show up in my admin, but not on my site at all,except in the Random listing on any page and if you click on them then, the single product is listed - can I just upgrade to v2.76i and use my old CSV files? Maybe it is the newer PHP and MySql that is causing this error?

 

Check my site - http://russalpc.co.za and click any of the categories - most of them list a couple of sub-categories, and then should list the items in that sub-category, but do not.The couple of categories that should go straight to products(I think there are only 2 - Games and Thermal paste),also do not display any products when clicked on.

Edited by russalpcs

Share this post


Link to post
Share on other sites

Hello I have a question. how do I use easy populate to bulk list with special price. I am using v_products_specials_price in my cvs file and it dose not show any changes to my price after uploading my cvs file.

 

Thanks

 

Lexxie

Share this post


Link to post
Share on other sites

ehagglebids & russalpcs, please see the "how to ask for help" section of the docs in the latest version for the information I need to help you. And while you're there, please read the rest of the docs for anything that may be helpful to you. :)

Share this post


Link to post
Share on other sites

Hello newbie here, i m not sure if other newbies have experienced the same problem but this is kind of weird:

 

OS: Mac OS X 10.6

CSV editor: OpenOffice 3.1.1

EP vers: EP_v2_76i_MS2

osCommerce Online Merchant v2.2 RC2a

HTTP: Apache 2.2.14

DB: MySQL 5.0.88

PHP: 5.2.11

My SQL: 5.0.87

 

This is the CSV file i downloaded and modified:

www.cloudywool.com/test.csv

 

And after I imported with EP, not only there's absolute no changes were made to my products,

all product images has turned into one same image, that's the only change happened and it's not desired.

site language english/mandarin, and i have two identical store set up to compare:

www.cloudywool.com (original)

www.pacsonic.com (made change)

 

Since I used a customized template for my store, so i tried installing original osCommerce Online Merchant v2.2 RC2a on another domain i have and tested EP, yet same thing happened.

 

STEP #1 - Upload the three files to your osCommerce Store Directory

STEP #2 - Setup the "temp" folder

STEP #3 - Add a link in the Admin Panel. Edit file

 

I did follow the install instruction step by step, wonder what i did wrong please help.

Thx

Share this post


Link to post
Share on other sites

Hello newbie here, i m not sure if other newbies have experienced the same problem but this is kind of weird:

 

OS: Mac OS X 10.6

 

why yes, lots of newbies have experienced this. :) It's pretty common for folks that overlook this in the docs:

Easy Populate uses the product_model field (model number) to identify the record to update. It won't work without the model number. Each row should have a unique model number. i.e. you can't give all your products a product_model of "test".

 

also make sure you have read the section specifically for Mac users.

Share this post


Link to post
Share on other sites

why yes, lots of newbies have experienced this. :) It's pretty common for folks that overlook this in the docs:

Easy Populate uses the product_model field (model number) to identify the record to update. It won't work without the model number. Each row should have a unique model number. i.e. you can't give all your products a product_model of "test".

 

also make sure you have read the section specifically for Mac users.

 

Thx for the quick response, it all make sense now.

I fixed the model area and EP started working like a charm :)

Share this post


Link to post
Share on other sites

Hi..

 

I would like to add another field in my Database to my products that is name will be "supplier code" (25 chars) , that would hold my supplier "item numbers" and to modify Easypopulate to download/upload also the "supplier code"

Is it complicated todo ??

Could someone help me to do that?

 

Best Regards & happy new year, :D

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites

Hi..

 

I would like to add another field in my Database to my products that is name will be "supplier code" (25 chars) , that would hold my supplier "item numbers" and to modify Easypopulate to download/upload also the "supplier code"

Is it complicated todo ??

Could someone help me to do that?

 

Best Regards & happy new year, :D

Nathali

 

Hi,

 

To modify the Easypopulate code I read in the manual.. it should be something like that:

$custom_fields[TABLE_PRODUCTS] = array( 'Supplier_model_number' => 'Supplier_model' );

 

But what should be the SQL command to enter that supplier model number field(25char) to the database?

 

Any help please??

 

Thanks,

 

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites

Hi,

 

To modify the Easypopulate code I read in the manual.. it should be something like that:

$custom_fields[TABLE_PRODUCTS] = array( 'Supplier_model_number' => 'Supplier_model' );

 

But what should be the SQL command to enter that supplier model number field(25char) to the database?

 

Any help please??

 

Thanks,

 

Nathali

 

It should be easy with PHPMyAdmin, your hosting company would normally offer you this. Failing that, this might help:

http://surf11.com/entry/97/change-size-of-varchar-column-with-mysql

Share this post


Link to post
Share on other sites

*Duplicate Database Entry Issue*

 

Hello all,

 

I have an installation of Easy Populate that normally runs fine for small updates. However, when a sizeable number of changes are uploaded at once, instead of the product being updated, a duplicate is created within the database. This breaks the relationship on products_to_categories and not only is a duplicate entry left on the database, but both it and the original disappear entirely from OSCommerce.

 

Can anyone help?

 

Thanks,

 

R.

Share this post


Link to post
Share on other sites

Hi!

 

I've downloaded the latest version EP 2.76i and noticed there is a configuration setting for use of QTPro (attributes stock). I've added some stock values for an item in admin and then exported the file. However, stock values are not exported even though EP_PRODUCTS_ATTRIBUTES_STOCK is set to true. The columns in the CSV file are there, but they are empty.

 

I know someone made a contribution called "EP 2.76 & Qtpro" in 2007. I checked in that easy_populate.php and it's quite different from 2.76i.

 

Is the stock code in 2.76i some kind of incomplete code or just remains of an older EP version? It would of course be great if stock could be updated using EP.

Share this post


Link to post
Share on other sites

*Duplicate Database Entry Issue*

 

Hello all,

 

I have an installation of Easy Populate that normally runs fine for small updates. However, when a sizeable number of changes are uploaded at once, instead of the product being updated, a duplicate is created within the database. This breaks the relationship on products_to_categories and not only is a duplicate entry left on the database, but both it and the original disappear entirely from OSCommerce.

 

Can anyone help?

 

Thanks,

 

R.

the only way a duplicate model number can appear is if the model number changes. If you would like further help, please see the how to ask for help section of the docs accompanying the latest version.

Share this post


Link to post
Share on other sites

Sorry if this has been asked but I have made a custom field called product_SUPPCODE. How can I edit easypopulate to import biased on the supp code rather than the model number.

 

Thanks

Share this post


Link to post
Share on other sites

Hi!

 

I've downloaded the latest version EP 2.76i and noticed there is a configuration setting for use of QTPro (attributes stock). I've added some stock values for an item in admin and then exported the file. However, stock values are not exported even though EP_PRODUCTS_ATTRIBUTES_STOCK is set to true. The columns in the CSV file are there, but they are empty.

 

I know someone made a contribution called "EP 2.76 & Qtpro" in 2007. I checked in that easy_populate.php and it's quite different from 2.76i.

 

Is the stock code in 2.76i some kind of incomplete code or just remains of an older EP version? It would of course be great if stock could be updated using EP.

the only thing I can tell you about the 2.76i version and QTPro is that it is untested by myself and very old code.

Share this post


Link to post
Share on other sites

Sorry if this has been asked but I have made a custom field called product_SUPPCODE. How can I edit easypopulate to import biased on the supp code rather than the model number.

 

Thanks

 

search and replace maybe?

Share this post


Link to post
Share on other sites

To Surfalot:

Easy populate is perhaps the greatest thing since sliced bread, especially after I learned how to use the Excel concatenate feature to make really nice descriptions. I am currently on 2.76h - MS2 & I see that you are now at 2.76i so I will upgrade soon. But before I do, I wanted to mention that many of us use the "cieto Featured Products" & consequently I have a "Products Short Description:" just before the "Products Description:" block when I am entering a new product. Do you have plans to give us the option to upload this ("Products Short Description:") so we do not have to manually add this field for every new record? It would really be appreciated and save TONS of time!

Thanks

jestep


Joseph E. "Joe" Stephenson
jestep@alphanautical.com

Share this post


Link to post
Share on other sites

Do you have plans to give us the option to upload this ("Products Short Description:") so we do not have to manually add this field for every new record?

 

nope, sure don't. But if you read through the settings at the top of the easypopulate.php file (as you were begged to by the install directions), you will probably be quite surprised at how easy it is to add additional fields to the products and products_description tables. :thumbsup:

Edited by surfalot

Share this post


Link to post
Share on other sites

I have installed "Separate Pricing Per Customer" and "Easy Populate & Products Attributes", and I would like to update each product price for the groups I have added on Separate Pricing Per Customer.

 

Can this be done? :blink:

 

Gilberto

Share this post


Link to post
Share on other sites

I have a suggestion here. after really messing up my DB. I now realize something and have a question. Why is easy populate connected to the modifiable model when the Product_ID would be unique and automatic so it could not over lap other products.

Share this post


Link to post
Share on other sites

I have a suggestion here. after really messing up my DB. I now realize something and have a question. Why is easy populate connected to the modifiable model when the Product_ID would be unique and automatic so it could not over lap other products.

mainly because our suppliers and distributors don't know our shop's products IDs. The only way to match our supplier data sheets with the shop's products is to use some COMMON identifier, like the model number.

 

Backup warnings were everywhere, hope you made one. crying.gif

Share this post


Link to post
Share on other sites

I have installed "Separate Pricing Per Customer" and "Easy Populate & Products Attributes", and I would like to update each product price for the groups I have added on Separate Pricing Per Customer.

 

Can this be done? :blink:

 

Gilberto

The support for SPPC was created for an older version of SPPC. I don't know if it works with the current version. You can enable it and try it. *ALWAYS BACKUP*

Share this post


Link to post
Share on other sites

Everything seems to be working fine UNTIL I set UltraPics Pics to "true"...then, I get this error when trying to upload/download files:

 

1054 - Unknown column 'p.products_image_med' in 'field list'

SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_image_med as v_products_image_med, p.products_image_lrg as v_products_image_lrg, p.products_image_sm_1 as v_products_image_sm_1, p.products_image_xl_1 as v_products_image_xl_1, p.products_image_sm_2 as v_products_image_sm_2, p.products_image_xl_2 as v_products_image_xl_2, p.products_image_sm_3 as v_products_image_sm_3, p.products_image_xl_3 as v_products_image_xl_3, p.products_image_sm_4 as v_products_image_sm_4, p.products_image_xl_4 as v_products_image_xl_4, p.products_image_sm_5 as v_products_image_sm_5, p.products_image_xl_5 as v_products_image_xl_5, p.products_image_sm_6 as v_products_image_sm_6,p.products_image_xl_6 as v_products_image_xl_6, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_available as v_date_avail, p.products_date_added as v_date_added, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id, p.products_status as v_status FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND ptoc.categories_id = subc.categories_id

[TEP STOP]

 

Been trying to figure out the answer but can't find it anywhere...any help will be greatly appreciated!

Share this post


Link to post
Share on other sites

Everything seems to be working fine UNTIL I set UltraPics Pics to "true"...then, I get this error when trying to upload/download files:

 

1054 - Unknown column 'p.products_image_med' in 'field list'

SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_image_med as v_products_image_med, p.products_image_lrg as v_products_image_lrg, p.products_image_sm_1 as v_products_image_sm_1, p.products_image_xl_1 as v_products_image_xl_1, p.products_image_sm_2 as v_products_image_sm_2, p.products_image_xl_2 as v_products_image_xl_2, p.products_image_sm_3 as v_products_image_sm_3, p.products_image_xl_3 as v_products_image_xl_3, p.products_image_sm_4 as v_products_image_sm_4, p.products_image_xl_4 as v_products_image_xl_4, p.products_image_sm_5 as v_products_image_sm_5, p.products_image_xl_5 as v_products_image_xl_5, p.products_image_sm_6 as v_products_image_sm_6,p.products_image_xl_6 as v_products_image_xl_6, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_available as v_date_avail, p.products_date_added as v_date_added, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id, p.products_status as v_status FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND ptoc.categories_id = subc.categories_id

[TEP STOP]

 

Been trying to figure out the answer but can't find it anywhere...any help will be greatly appreciated!

this may sound like a silly question but, have you install the ultrapics contribution? The error is saying it wasn't fully installed in the database at the moment.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×