Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Thanks for answering. Can you please recommend exactly which one I need to download as there is so many versions. Also did you manage to get UltraPic resize images?

 

Cheers.

 

I installed the contribution very long time ago (Year 2006), and didn't bother to update so not sure which is the latest stable version now. Sorry...

 

I think I have installed another contribution that automatically create thumbnails images...not sure which contri now...


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

Hi Team

 

Be kind, i'm a newbie here. SO far I have installed EP 2.76i and it works like a treat, I now import thousands of products directly from my supplier.

 

I have a contribution installed for stock status that gets displayed next to the price.

 

If I add a product manually its comes out like this : http://www.mtechcomputers.com.au/product_info.php?cPath=586&products_id=20510

 

If I import I only get the price shown, customer will not know if its in stock or not.

 

When I import the datafeed I would like to set another field so its toggles the "Products_Availability" contrubtion which is based on stock levels when importing , I've logged in phpadmin and I have this:

 

Its listed as "products_availability" I then click that and get "products_availability_id" and a few other things under neath it.

 

I've worked out that to set "Out of Stock" I would use a '1', and In Stock has a value of '2'

 

 

Any help would be great to add an extra filed when importing eg, "v_products_availability_id"

 

If its too hard I'm willing to pay a few bucks to get it done, $$$

 

cheers

Arthur

Share this post


Link to post
Share on other sites

Hey Todd,

 

I was wondering if you could clear up some issues and questions I have regarding Easy Populate?

 

Some contributions I've added that might effect Easy Populate:

Basically all I am looking for is a sort of off-line version of the admin panels categories new product page.

 

I need to insert all the information (copied from a Word document) then link the two images (thumbnail & large).

After inserting a list of products, upload the information and images.

I'm not lucky enough to get a database or spreadsheet containing all the info from my suppliers, so I'm stuck with manually inserting one product at a time.

 

I've gotten used to doing hundreds of products this way right in the admin panel, but I'm stuck with dialup (promissed high-speed maybe come spring) and spending hours tying up my phoneline isn't exceptable during the day.

 

Can Easy Populate take care of my needs?

Or do I need to import a database/spreadsheet file?

 

Forgot, if Easy Populate will work for me, which version do you recommend (using osC MS2 2.2 updated)

 

TIA wink.gif

Edited by jhande

- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

Hi Jim,

 

EP supports two types of additional image contributions:

 

More Pics

UltraPics Pics

 

If yours are not one of those, then you can't get extra images listed, but will still be able to have the original one big one small images as default in OSC in EP.

 

I am new to EP, start using it just recently and I find it to be very helpful if you have similar products (different colours or size). If your products are all different, then you will need to spend time in coding and describing as well, but of course it really helps if you have slow line.


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

Any help would be great to add an extra filed when importing eg, "v_products_availability_id"

 

If its too hard I'm willing to pay a few bucks to get it done, $$$

 

cheers

Arthur

 

Hi Arthur,

 

My OSC has an extra field of product_cost, and what I did is to check out those lines that mentioned product_price and copy and modify it to product cost.

 

Works well in my case. :)


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

Hi Jim,

 

EP supports two types of additional image contributions:

 

More Pics

UltraPics Pics

 

If yours are not one of those, then you can't get extra images listed, but will still be able to have the original one big one small images as default in OSC in EP.

 

I am new to EP, start using it just recently and I find it to be very helpful if you have similar products (different colours or size). If your products are all different, then you will need to spend time in coding and describing as well, but of course it really helps if you have slow line.

 

Hi King,

 

Thanks for the reply wink.gif

 

Actually my "Big Image" contribution utilizes 'products_bimage'.

 

I thought I noticed mention of that in easypopulate.php line 478

if (EP_UNKNOWN_ADD_IMAGES_SUPPORT == true) { 
 $default_these[] = 'v_products_mimage';
 $default_these[] = 'v_products_bimage';
 $default_these[] = 'v_products_subimage1';

 

So I wasn't sure if that would work or need a bit of editing.

 

I thought the Image Directories contribution might pose more of a problem due to my images NOT being in the image folder.

Instead their directory structure is like this:

images\Images\Manufacturer\Thumb

images\Images\Manufacturer\Large

 

I quess I could always try inserting my products one by one on my localhost running under XAMPP and then export/import that database to save online time??


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

Hi Jim,

 

EP supports two types of additional image contributions:

 

More Pics

UltraPics Pics

 

If yours are not one of those, then you can't get extra images listed, but will still be able to have the original one big one small images as default in OSC in EP.

 

I am new to EP, start using it just recently and I find it to be very helpful if you have similar products (different colours or size). If your products are all different, then you will need to spend time in coding and describing as well, but of course it really helps if you have slow line.

Three additional images contributions actually.

 

Additional Images 2.x

More Pics 6 1.3 or previous

UltraPics Pics 2.0.x

Share this post


Link to post
Share on other sites

Hi Arthur,

 

My OSC has an extra field of product_cost, and what I did is to check out those lines that mentioned product_price and copy and modify it to product cost.

 

Works well in my case. :)

 

The latest EP has a built in feature that allows easy instant configuration of additional fields to the products and products_description tables. But only those tables.

 

Arthur is looking to add code for a new table so it won't be that easy. It will require building unique lookups, import matching, inserts and updates. Unfortunately there's no simple good advice in this case, I haven't seen any tutorials, you just have to know your PHP & SQL to pull it off.

Share this post


Link to post
Share on other sites

Hey Todd,

 

I was wondering if you could clear up some issues and questions I have regarding Easy Populate?

 

Some contributions I've added that might effect Easy Populate:

Basically all I am looking for is a sort of off-line version of the admin panels categories new product page.

 

I need to insert all the information (copied from a Word document) then link the two images (thumbnail & large).

After inserting a list of products, upload the information and images.

I'm not lucky enough to get a database or spreadsheet containing all the info from my suppliers, so I'm stuck with manually inserting one product at a time.

 

I've gotten used to doing hundreds of products this way right in the admin panel, but I'm stuck with dialup (promissed high-speed maybe come spring) and spending hours tying up my phoneline isn't exceptable during the day.

 

Can Easy Populate take care of my needs?

Or do I need to import a database/spreadsheet file?

 

Forgot, if Easy Populate will work for me, which version do you recommend (using osC MS2 2.2 updated)

 

TIA wink.gif

> Modified version of Big Images 1.25 (replaces the pop-up images)

EP won't import the big image name for you, base image should be fine.

 

> Header Tags SEO (not sure which version anymore)

Partial support, supports the product fields

 

> Image Subdirectories 2.0

shouldn't matter

 

> More Category Boxes (not sure of version)

don't know

 

> Product Short Description (not sure of version - this one or this one)

should be able to add the nec. field in the products_description table setup in EP

 

 

> Optional Related Products 4

no support

 

> Modified version of Show Sold Out Items 1.1

no support

 

> Probably no effect - Ultimate SEO URLs 2.1d Original Updated

no affect

 

I have not heard of any off-line version to assist in product entry, but that doesn't mean it doesn't exist, try google.

 

I think most folks work smaller sections at a time. ready 20 products in a spreadsheet, copying in the stray data before uploading.

Share this post


Link to post
Share on other sites

Hi King,

 

Thanks for the reply wink.gif

 

Actually my "Big Image" contribution utilizes 'products_bimage'.

 

I thought I noticed mention of that in easypopulate.php line 478

if (EP_UNKNOWN_ADD_IMAGES_SUPPORT == true) { 
$default_these[] = 'v_products_mimage';
$default_these[] = 'v_products_bimage';
$default_these[] = 'v_products_subimage1';

 

So I wasn't sure if that would work or need a bit of editing.

 

I thought the Image Directories contribution might pose more of a problem due to my images NOT being in the image folder.

Instead their directory structure is like this:

images\Images\Manufacturer\Thumb

images\Images\Manufacturer\Large

 

I quess I could always try inserting my products one by one on my localhost running under XAMPP and then export/import that database to save online time??

there was an "unknown images" contribution in the versions previous to 2.76i. in 2.76i it was replaced by an known "ultra pics". If you look back to version 2.76h you might find the one you need. You'll have to understand how the big image changes you database to confirm that code is right. always backup.

Share this post


Link to post
Share on other sites

Thank you Todd for clarifying and enlightening me. thumbsup.gif

 

I was hoping to skip the step of inserting from a Word document into a spreadsheet or database.

 

I'll play around with (learn more) Microsoft Office Pro and an earlier version of EP to see what I can come up with.

 

Again, thank you for your help, it is much appreciated.


- :: Jim :: -

- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

Share this post


Link to post
Share on other sites

Hi, I have a problem with easy populate 2.76,

 

I installed easy populate exactly to the instructions, made sure I CHMOD the correct files but when try loading easypopulate.php, the page is just loading a blank page.

 

Anyone know whats going on? I cat find any help with this problem.

 

Any help would be much appreciated.

Share this post


Link to post
Share on other sites

Hi, I have a problem with easy populate 2.76,

 

I installed easy populate exactly to the instructions, made sure I CHMOD the correct files but when try loading easypopulate.php, the page is just loading a blank page.

 

Anyone know whats going on? I cat find any help with this problem.

 

Any help would be much appreciated.

the first step would be to download the latest v2.76i.

Next read the entire docs as these docs ask. Pay particularly close attention to install step #6.

If you are still stuck, re-read the Support section and the how to ask for help section of that and post again.

Share this post


Link to post
Share on other sites

the first step would be to download the latest v2.76i.

Next read the entire docs as these docs ask. Pay particularly close attention to install step #6.

If you are still stuck, re-read the Support section and the how to ask for help section of that and post again.

 

We followed the instructions and we are still getting the same problem, unfortunetly this is the first time we have used oscommerce so its a little tricky.

 

Have you got any links to a guide to fix it simply?

Share this post


Link to post
Share on other sites

Hi,

 

I've taken over working on an existing osC store where Easy Populate was already in use. I added the products short description module but I can't get it working with easy populate

 

Version is Easy Populate 2.76c-MS2

When I try to upload I get error 1054 - Unknown column 'products_info' in 'field list'

 

In my text file I have a column v_products_info_1

 

Should I have PRODUCT_LIST_INFO or PRODUCT_LIST_SHORTDESC??? I've tried both

 

Can anyone tell me what I'm doing wrong?

Share this post


Link to post
Share on other sites

Hi all

 

You may have seen my recent post regarding easy populate and not being able to import files. Today I had a breakthrough with it. It was acting like it uploaded, and was putting the file into the temp directory, but it wasnt updating the data inside the site.

 

We discovered that the type of csv file and the version of excel that is used matters. It appears that different versions of excel create different types of csv files. Once we made tab-delimited files and used those, the problem went away. We think that it may have something to do with one version of excel putting extra characters in that other versions of excel dont.

 

Hope this helps somebody.

 

cheers

Glenn

Edited by r2160

Share this post


Link to post
Share on other sites

After reading about 100 pages on this thread we cant find any solution to the next problem, we ended up paying someone to install Easy Populate, however we can export the CSV, we then take teh csv it to Excel and Openoffice etc.. just change the name of a product save it back as it should be and try to import it to test it, the screen kind of refreshes and goes back, no message or anything, and the product update did not work.

 

We have looked all night for the result for this and we are well and truly stumped!

 

Does anyone have any ideas?

Edited by superleeds

Share this post


Link to post
Share on other sites

HI superleeds

 

Have a look at my previous post. It sounds like you are having the same issue that I was. We found it was the csv file that turned out to be the issue. Try saving as a tab delimited file and see if that works.

 

cheers

Glenn

Share this post


Link to post
Share on other sites

HI superleeds

 

Have a look at my previous post. It sounds like you are having the same issue that I was. We found it was the csv file that turned out to be the issue. Try saving as a tab delimited file and see if that works.

 

cheers

Glenn

 

Glenn,

 

Yes it was because we didnt have a model number in the csv file, it suddenly starting working just fine when we applied a model number to a product.

 

However we now have another problem, during testing we had a load of products we didnt need so we deleted every single product from the store and then used the CSV to import, it seemed to work but none of the images work, even though the path is correct and i FTP'd all the images to the images folder, it gives a 404 error i cant paste the url in the browser even though the files are there.

 

when i go to the osc admin and upload from computer its fine, but we have a lot of products so really need the image linking to work, it was working fine before, just not now after i deleted all the pics.

 

Cheers if anyone can help

 

Paul

Share this post


Link to post
Share on other sites

Glenn,

 

Yes it was because we didnt have a model number in the csv file, it suddenly starting working just fine when we applied a model number to a product.

 

However we now have another problem, during testing we had a load of products we didnt need so we deleted every single product from the store and then used the CSV to import, it seemed to work but none of the images work, even though the path is correct and i FTP'd all the images to the images folder, it gives a 404 error i cant paste the url in the browser even though the files are there.

 

when i go to the osc admin and upload from computer its fine, but we have a lot of products so really need the image linking to work, it was working fine before, just not now after i deleted all the pics.

 

Cheers if anyone can help

 

Paul

 

fixed it, for some reason i uploaded images to the /admin/images rather than to /images/ what an idiot!!

Share this post


Link to post
Share on other sites

Hi,

 

I've taken over working on an existing osC store where Easy Populate was already in use. I added the products short description module but I can't get it working with easy populate

 

Version is Easy Populate 2.76c-MS2

When I try to upload I get error 1054 - Unknown column 'products_info' in 'field list'

 

In my text file I have a column v_products_info_1

 

Should I have PRODUCT_LIST_INFO or PRODUCT_LIST_SHORTDESC??? I've tried both

 

Can anyone tell me what I'm doing wrong?

 

I'm not familiar with that column name. maybe your version was modified for additional fields. If that is the case, only the author with know the correct column header for that data or if that is valid at all.

 

version 2.76i has much better tolerances for import data and some other advantages. If you upgrade, backup your old easy populate files just in case you need to go back. I might assume that column you are refering to is in one of the products or products_description tables so you should be able to add the column quickly with the newer version's configuration section.

 

don't forget to read the documentation in that download, and the "how to ask for help" section at the bottom (cause I'll know if you didn't like superleeds above) <_<.

Share this post


Link to post
Share on other sites

I've been using EP for a couple weeks on my first site and things work great. I use the split to upload more than 300 files and everything just works perfectly. But now I'm at an issue that I can't seem to find a solution for in the docs or in this support forum. I've been trying to download the entire products file in a csv using the quicklinks on the EP admin section of my site. It just seems to hang on the link to the php "easypopulate.php?download=stream&dltype=full" and nothing happens. I'm able to use the model/price/qty quicklink without issue. I've checked the memory allocation using a getinfo.php file in my root directory and it says 96M so I don't think memory is the issue. Any guidance or suggestions?

 

 

EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.28.5-grsec-sg2

HTTP: Apache/1.3.41 (Unix)

DB: MySQL 5.0.77mm0.1-log

PHP: 5.2.9 (Zend: 2.2.0)

 

Thanks,

Cary

Edited by JoeySchmoe

Share this post


Link to post
Share on other sites

I've been using EP for a couple weeks on my first site and things work great. I use the split to upload more than 300 files and everything just works perfectly. But now I'm at an issue that I can't seem to find a solution for in the docs or in this support forum. I've been trying to download the entire products file in a csv using the quicklinks on the EP admin section of my site. It just seems to hang on the link to the php "easypopulate.php?download=stream&dltype=full" and nothing happens. I'm able to use the model/price/qty quicklink without issue. I've checked the memory allocation using a getinfo.php file in my root directory and it says 96M so I don't think memory is the issue. Any guidance or suggestions?

 

 

EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.28.5-grsec-sg2

HTTP: Apache/1.3.41 (Unix)

DB: MySQL 5.0.77mm0.1-log

PHP: 5.2.9 (Zend: 2.2.0)

 

Thanks,

Cary

 

how many products in the store? how long have you waited?

depending on the number of products and options, a complete download may take a very long time.

If you use the on the fly download it should start streaming the file quicker.

Share this post


Link to post
Share on other sites

how many products in the store? how long have you waited?

depending on the number of products and options, a complete download may take a very long time.

If you use the on the fly download it should start streaming the file quicker.

 

 

Nice! I hadn't even messed with this detailed feature. I like it better than the complete download since I can focus on specific categories. Thanks for your prompt and insightful response!

 

Merry Christmas,

Cary

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×