Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

J.M.

 

There are others on this forum far better able to answer your question than me but I think you need to use the "update" option when you upload your file.

 

Norman

Share this post


Link to post
Share on other sites

J.M.

 

There are others on this forum far better able to answer your question than me but I think you need to use the "update" option when you upload your file.

 

Norman

 

 

Thanks, Norman. I suspect you're right. Ah well, lesson learned. I just have to reassign the attributes and make sure I only UPDATE the database from now on!

 

J.M. Snyder

Share this post


Link to post
Share on other sites

Hi there,

 

I'm new to OSCommerce and am trying to create an e-book storefront. I uploaded the products with EasyPopulate and spent the better part of three weeks entering in the download links as product attributes through the admin panel. Then yesterday I needed to update prices for the books, so I downloaded the CSV file from EasyPopulate, made the changes, and reuploaded it.

 

Now all the attributes are gone. They are still listed in the table in the MySql database (I can see them in phpAdmin) but I don't want to sit there and reattach them all in the Products Attributes screen. Is there a simpler way to get them back?

 

Any help will be much appreciated!

 

J.M. Snyder

 

oh no, that doesn't sound good. please do backup before doing anything in EP. always, always, and yes, always. crying.gif If you have phpMyAdmin (see your host), it would be preferred over the osCommerce backup.

 

The automatic default function is to update. That selector was added to allow you to upload and ONLY update, or ONLY add new, or both (normal).

 

If you ensure there are no option/attribute columns in the import/upload, you should avoid this issue in the future. If those columns are present in the upload, I could see how that would happen. EP doens't understand the downloadable product attributes and the code for options is old and a little reckless in how it works.

 

For prices, all you need is the model number column and the price column to accomplish a price update, as long as the price modifiers in the options are not used. nothing else on the product will change.

 

can you please PM or post a link to the file that caused the problem?

Share this post


Link to post
Share on other sites

I recently installed A MAP add on and EP is no longer working. I cannot export to file. I figured this add on would give me problems since it adds a column for the MAP (manufacturers advertised price). Will using the extra fields add on help me fix this conflict or is there another work around?

Share this post


Link to post
Share on other sites

I recently installed A MAP add on and EP is no longer working. I cannot export to file. I figured this add on would give me problems since it adds a column for the MAP (manufacturers advertised price). Will using the extra fields add on help me fix this conflict or is there another work around?

 

adding fields to the shop should not cause EP to fail. did you change EP at all?

 

Extra fields won't help unless you need to add more fields beyond what you have now.

Share this post


Link to post
Share on other sites

Hi,

 

I use Easypopulate 2.76g I would like to add another "value" to my database.

This value will be additional "model number" to the product model number. The additional "model number" will be my supplier's "model number".

 

I would like to use easypopulate to update this additional "model number" and also to collect it when I use "download" option. It should come at column B in the excel sheet after the first "model number".

 

Actually the second "model number" does not need serious modification on easypopulate, since it is a static value.

 

Is there any patch for it ? please advise if you find something.. it will make my life much easier.. :)

 

Best Regards!

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites

Hi,

 

I use Easypopulate 2.76g I would like to add another "value" to my database.

This value will be additional "model number" to the product model number. The additional "model number" will be my supplier's "model number".

 

I would like to use easypopulate to update this additional "model number" and also to collect it when I use "download" option. It should come at column B in the excel sheet after the first "model number".

 

Actually the second "model number" does not need serious modification on easypopulate, since it is a static value.

 

Is there any patch for it ? please advise if you find something.. it will make my life much easier.. :)

 

Best Regards!

Nathali

if you are adding a field to the products table, you should be looking at the setting at the top of the easypopulate.php script. Versoin g introduced a nice easy way to add fields for the products & products_description tables. There are details and an example of how to quickly add additional fields. as far as the position of the column in the export goes, you may have to hack the code a little or move the column after in excel.

 

also be sure to read through the manual once, which in turn, asks you to read through those settings once. :thumbsup:

Share this post


Link to post
Share on other sites

if you are adding a field to the products table, you should be looking at the setting at the top of the easypopulate.php script. Versoin g introduced a nice easy way to add fields for the products & products_description tables. There are details and an example of how to quickly add additional fields. as far as the position of the column in the export goes, you may have to hack the code a little or move the column after in excel.

 

also be sure to read through the manual once, which in turn, asks you to read through those settings once. :thumbsup:

 

Thanks for your reply Surfalot. I read it and saw your example how to add additional field.

But still there are some more modifications in Easypopulate.php file as you said yourself, and also adding another "model number" to the database table. It's too complicated for me as I am not a programmer.. :(

Anyway, I appreciate your advise on the matter.

 

Thanks again & best regards,

 

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites

Thanks for your reply Surfalot. I read it and saw your example how to add additional field.

But still there are some more modifications in Easypopulate.php file as you said yourself, and also adding another "model number" to the database table. It's too complicated for me as I am not a programmer.. :(

Anyway, I appreciate your advise on the matter.

 

Thanks again & best regards,

 

Nathali

 

you don't need to be a programmer.

 

so you've managed to add a field to the products table and make some mods to include this new model number on your shop, but can't make a small change in the easypopulate.php file to include it there? I may be able to help you with it

Share this post


Link to post
Share on other sites

Quick question -

I have quite a few items with blank descriptions. This is my own fault. I didn't put a description into the file before I uploaded. Anyway, here's what I wanted to do, but it didn't work. I downloaded the Model/Price/Quantity file, added a column with the header v_products_description_1, filled in a test description for a couple of items and uploaded. The description does not get updated for some reason. If I use the same file, but change the price for example, that updates. Is there a way to get this to work? I can't download the complete inventory file because I have about 16,000 items in inventory. If someone could help me out with some advice, I would really appreciate it. Thanks! :)


Laurel

Share this post


Link to post
Share on other sites

Quick question -

I have quite a few items with blank descriptions. This is my own fault. I didn't put a description into the file before I uploaded. Anyway, here's what I wanted to do, but it didn't work. I downloaded the Model/Price/Quantity file, added a column with the header v_products_description_1, filled in a test description for a couple of items and uploaded. The description does not get updated for some reason. If I use the same file, but change the price for example, that updates. Is there a way to get this to work? I can't download the complete inventory file because I have about 16,000 items in inventory. If someone could help me out with some advice, I would really appreciate it. Thanks! :)

if you are using one of the 2.76x versions, there is a section of suggested information to offer with your post. it would be real helpful.

Share this post


Link to post
Share on other sites

Hi,

 

I changed servers a while back and carried on with some mods, now I am retesting the website and have a few issues.

 

Easypopulate works, however I am unable to upload a file and process it using the browse import system in easy populate.

 

I can import the data if I upload the csv file into the temp directory and select the file from there.

 

Having looked at a few mods lately on the new server, I suspect that its a server setting issue that does not allow access to files in the shop.

 

I am searching for similar file permission issues but havent found any yet.

 

Can anyone help.

 

Thanks


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Hi,

 

I changed servers a while back and carried on with some mods, now I am retesting the website and have a few issues.

 

Easypopulate works, however I am unable to upload a file and process it using the browse import system in easy populate.

 

I can import the data if I upload the csv file into the temp directory and select the file from there.

 

Having looked at a few mods lately on the new server, I suspect that its a server setting issue that does not allow access to files in the shop.

 

I am searching for similar file permission issues but havent found any yet.

 

Can anyone help.

 

Thanks

I'm assuming you are not getting an error since you didn't post one. the settings and configuration info would be helpful as requested by the Support's "how to ask for help" section of the docs.

 

As per step 2 in the installation instructions, you should have chmod the temp folder 777. You should look at step 6 of the installation documentation in the latest v2.76i.

Share this post


Link to post
Share on other sites

if you are using one of the 2.76x versions, there is a section of suggested information to offer with your post. it would be real helpful.

How to ask for help

 

Please gather information we need to help you:

 

1. Edit easypopulate.php and ensure EP_SHOW_EP_SETTINGS is set to true, then copy the settings & server info that are displayed on the EP main page into your post.

 

My easypopulate.php does not contain EP_SHOW_EP_SETTINGS, so I'm not sure what this means.

 

2. Include the type of operating system and software you are using to edit the datafile.

(Windows, MAC, Linux) / (Excel, Open Office, etc.)

 

I'm on a Mac and I use Taco HTML Edit for the PHP files and Excel for the TXT files

 

3. Copy of any error message you are receiving or description of problem if no error.

 

No error messages

 

4. If it is a upload problem, post a link to a sample of any upload file you are trying.

If it is a download problem, post a link to the file EP is producing.

** Please avoid posting the sample data since the forum may modify it:

This is easy to do. Simply FTP all or a portion of your import file to the root of your shop's hosting space (remember, no spaces in the file name. Then post a link to the file like this: http://www.myshop.com/shop/mycsv.csv. After someone has responded, you can remove it.

 

http://laurelsstitchery.com/10-27-2009-test-file.txt

 

Let me know if you have any suggestions.

Edited by laurelsstitchery

Laurel

Share this post


Link to post
Share on other sites

what version are you using?

 

This is from the top of the easypopulate.php file:

// Current EP Version

$curver = '2.76-MS2';

 

/*

$Id: easypopulate.php,v 2.75 2005/04/05 AL Exp $

*/

 

I'm pretty sure it's 2.76b, but I can't find confirmation of that anywhere. For what it's worth, I'm open to updating to the most current version, but I wanted to avoid that if possible since the version I have works for everything but this one thing.

Edited by laurelsstitchery

Laurel

Share this post


Link to post
Share on other sites

This is from the top of the easypopulate.php file:

// Current EP Version

$curver = '2.76-MS2';

 

/*

$Id: easypopulate.php,v 2.75 2005/04/05 AL Exp $

*/

 

I'm pretty sure it's 2.76b, but I can't find confirmation of that anywhere. For what it's worth, I'm open to updating to the most current version, but I wanted to avoid that if possible since the version I have works for everything but this one thing.

 

Ok I went ahead and updated to version 2.76i. The upload doesn't work at all now. I used the example file included in the package and edited it to try to upload a test item and it didn't upload anything at all. Here are my EP settings:

Settings & Info

 

EP vers: 2.76i-MS2

osCommerce 2.2-MS2

OS: Linux 2.6.29.6-aufs2-grsec-v1.4-i686-opt

HTTP: Apache

DB: MySQL 5.0.67-userstats-log

PHP: 4.4.9 (Zend: 1.3.0)

 

Temp Directory:

/home/moosedog/laurelsstitchery.com/catalog/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: dash

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: false

SPPC: false

Extra Fields: false

PDF Upload: false


Laurel

Share this post


Link to post
Share on other sites

This is from the top of the easypopulate.php file:

// Current EP Version

$curver = '2.76-MS2';

 

/*

$Id: easypopulate.php,v 2.75 2005/04/05 AL Exp $

*/

 

I'm pretty sure it's 2.76b, but I can't find confirmation of that anywhere. For what it's worth, I'm open to updating to the most current version, but I wanted to avoid that if possible since the version I have works for everything but this one thing.

 

Ok I went ahead and updated to version 2.76i. The upload doesn't work at all now. I used the example file included in the package and edited it to try to upload a test item and it didn't upload anything at all. Here are my EP settings:

Settings & Info

 

EP vers: 2.76i-MS2

osCommerce 2.2-MS2

OS: Linux 2.6.29.6-aufs2-grsec-v1.4-i686-opt

HTTP: Apache

DB: MySQL 5.0.67-userstats-log

PHP: 4.4.9 (Zend: 1.3.0)

 

Temp Directory:

/home/moosedog/laurelsstitchery.com/catalog/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: dash

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: false

SPPC: false

Extra Fields: false

PDF Upload: false


Laurel

Share this post


Link to post
Share on other sites

I'm not sure why field separator is showing to be "dash". I want it to be "tab". Here's what I have in that section of easypopulate.php:

// **** Field Separator ****

// change this if you can't use the default of tabs

// Tab is the default, comma and semicolon are commonly supported by various progs

// Remember, if your descriptions contain this character, you will confuse EP!

// if EP_EXCEL_SAFE_OUTPUT if false (below) you must make EP_PRESERVE_TABS_CR_LF false also.

$ep_separator = "\t"; // tab is default

//$ep_separator = ','; // comma

//$ep_separator = ';'; // semi-colon

//$ep_separator = '~'; // tilde

//$ep_separator = '*'; // splat

 

Is this the correct code?

 

Edited to add: I went into easypopulate.php and commented out the tab line and uncommented the comma line. Uploaded the file and the file separator changed to comma. I went back and reversed the process, but it didn't change to tab, it remained comma. I don't know what I'm doing wrong and I'm getting frustrated with my ignorance.

 

Edited again to add my easy populate file: http://laurelsstitchery.com/catalog/temp/10-29-2009-test-file.txt

or http://laurelsstitchery.com/catalog/temp/10-29-2009-test-file.csv

They're both there.

Edited by laurelsstitchery

Laurel

Share this post


Link to post
Share on other sites

I'm not sure why field separator is showing to be "dash". I want it to be "tab". Here's what I have in that section of easypopulate.php:

// **** Field Separator ****

// change this if you can't use the default of tabs

// Tab is the default, comma and semicolon are commonly supported by various progs

// Remember, if your descriptions contain this character, you will confuse EP!

// if EP_EXCEL_SAFE_OUTPUT if false (below) you must make EP_PRESERVE_TABS_CR_LF false also.

$ep_separator = "\t"; // tab is default

//$ep_separator = ','; // comma

//$ep_separator = ';'; // semi-colon

//$ep_separator = '~'; // tilde

//$ep_separator = '*'; // splat

 

Is this the correct code?

 

Edited to add: I went into easypopulate.php and commented out the tab line and uncommented the comma line. Uploaded the file and the file separator changed to comma. I went back and reversed the process, but it didn't change to tab, it remained comma. I don't know what I'm doing wrong and I'm getting frustrated with my ignorance.

 

Edited again to add my easy populate file: http://laurelsstitch...9-test-file.txt

or http://laurelsstitch...9-test-file.csv

They're both there.

 

the dash being recognized as the separator issue is related to using a Mac. You should look at the instructions in the documentation that is for Mac users to fix why EP is not recognizing the correct line-feeds in your import files.

 

if you want to use tab, you have to set EP_EXCEL_SAFE_OUTPUT to false since that overrides the separator setting to be a comma for the US. The EP_EXCEL_SAFE_OUTPUT uses strict CSV file format that tries to solve all the problems with odd characters in your data that have been problems for some in the past. If you use Excel or Open Office to save your files as directed in the documentation, the strict CSV format will be used.

 

hope that helps.

Share this post


Link to post
Share on other sites

the dash being recognized as the separator issue is related to using a Mac. You should look at the instructions in the documentation that is for Mac users to fix why EP is not recognizing the correct line-feeds in your import files.

 

if you want to use tab, you have to set EP_EXCEL_SAFE_OUTPUT to false since that overrides the separator setting to be a comma for the US. The EP_EXCEL_SAFE_OUTPUT uses strict CSV file format that tries to solve all the problems with odd characters in your data that have been problems for some in the past. If you use Excel or Open Office to save your files as directed in the documentation, the strict CSV format will be used.

 

hope that helps.

 

Well that's weird. I had tried saving the file like it says in the instructions a couple of times and it still didn't work. I just tried it again and it did work. Probably operator error! :) Thanks for your patience and your help!!!!!!!!!!!!!! :) :thumbsup:


Laurel

Share this post


Link to post
Share on other sites

adding fields to the shop should not cause EP to fail. did you change EP at all?

 

Extra fields won't help unless you need to add more fields beyond what you have now.

 

no, the ep files were not changed.

Edited by baruke

Share this post


Link to post
Share on other sites

Is there a way to move products from one category to another? I accidentally put 600 over products into a wrong category, and it is too time-consuming to move one by one in admin. :(


Best regards,

Koh Kho King

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×