Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Hi! Easy Populate is such an excellent contribution! Thanks for this super-time-saver!

 

Can someone suggest if this is, first of all, possible to do with Easy Populate, and secondly, offer suggestions on how to import products that have different size attributes via EP?

 

What I thought to try, that failed, was to create Option Name Size, and list within it Option Values of sizes 4-18, S, M, L, XL, S/M, and M/L.

Then, applying all these sizes to one product to see how it came out in the downloaded .csv file. Now, I am trying to use those headings and data to configure a list of products with different size attributes. I first attempted uploading a .CSV with only one product (avail. in sizes 6-12). No product attributes show for this product in Admin. No drop down on the Product Page on my website either.

 

It also seems like I read something that said I should NOT have created Product Attributes within Admin. But I cannot find it again, nor confirm it in the EP documentation.

 

EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a

OS:

HTTP: Apache

DB: MySQL 5.0.81-community

PHP: 5.2.10 (Zend: 2.2.0)

 

Temp Directory:

/home/firelily/public_html/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 25

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: false

SPPC: false

Extra Fields: false

PDF Upload: false

 

Example

Shoe 1 comes in sizes 6-12

Shoe 2 comes in sizes 5-14

Shoe 4 comes in sizes S, M, L and XL

Shoe 5 comes in sizes S/M, or M/L

 

You volunteers are awesome! I appreciate your time and assistance!

Share this post


Link to post
Share on other sites
Hi! Easy Populate is such an excellent contribution! Thanks for this super-time-saver!

 

Can someone suggest if this is, first of all, possible to do with Easy Populate, and secondly, offer suggestions on how to import products that have different size attributes via EP?

 

The best advice I can give is to create a complete product in the osC admin with all the attributes you require. Then export. Examine the export for the format to use on the rest of your products.

 

All the attributes will be filled in for each product. an attribute is designated to a product by adding a non-blank entry in the v_attribute_values_price_x_x column.

 

hope that helps.

Share this post


Link to post
Share on other sites

You may disregard or delete my previous post. :blush:

 

The funny thing about posting on this forum is, about the time I've posted something, I'm usually getting close to a solution. I kept trying different things and found a work-around! Yeah! Now, I do believe that I understand the way the Attributes are set up.

 

I'm still curious if there is a way to implement different sets of Attributes within a single .CSV file? If you have any ideas or suggestions, i'm still open to them, and i'm also more than happy to help you set up Attributes for your store. At least, I'll do what I can.

 

Blessings to the creators of the osC code and time-saving add-ons!

Share this post


Link to post
Share on other sites
The best advice I can give is to create a complete product in the osC admin with all the attributes you require. Then export. Examine the export for the format to use on the rest of your products.

All the attributes will be filled in for each product. an attribute is designated to a product by adding a non-blank entry in the v_attribute_values_price_x_x column.

hope that helps.

Thank you!! Does this mean I can use all 22 size attributes within my spreadsheet, and cancel the unwanted Sizes by leaving the price column completely blank? See bold below. Just want to make sure I understand what you are saying. A very big thanks for the help! ie.

 

Attribute #6 - Size 11

v_attribute_values_id_1_6 is 6

v_attribute_values_name_1_6_1 is 11 "shoe size"

v_attribute_values_price_1_6 set to 0 will set this attribute with catalog price.

 

Attribute #7 - Size 12

v_attribute_values_id_1_7 is 7

v_attribute_values_name_1_7_1 is 12 "shoe size"

v_attribute_values_price_1_7 set to a blank entry will void this particular attribute on an individual product basis?

 

Thanks again, only 2,000 products to go !

Share this post


Link to post
Share on other sites
Thank you!! Does this mean I can use all 22 size attributes within my spreadsheet, and cancel the unwanted Sizes by leaving the price column completely blank? See bold below. Just want to make sure I understand what you are saying. A very big thanks for the help! ie.

 

Attribute #6 - Size 11

v_attribute_values_id_1_6 is 6

v_attribute_values_name_1_6_1 is 11 "shoe size"

v_attribute_values_price_1_6 set to 0 will set this attribute with catalog price.

 

Attribute #7 - Size 12

v_attribute_values_id_1_7 is 7

v_attribute_values_name_1_7_1 is 12 "shoe size"

v_attribute_values_price_1_7 set to a blank entry will void this particular attribute on an individual product basis?

 

Thanks again, only 2,000 products to go !

that sounds right to me.

Share this post


Link to post
Share on other sites

Hello

 

After installing this i am having a problem

 

Fatal error: Class 'productListingOSCBox' not found in /demo/includes/modules/product_listing.php on line 404

 

So any help in this

Share this post


Link to post
Share on other sites
Hello

 

After installing this i am having a problem

 

Fatal error: Class 'productListingOSCBox' not found in /demo/includes/modules/product_listing.php on line 404

 

So any help in this

if you received that error after installing this contribution, then you are changing the wrong files. The only suggestion is the do some searching related to any other changes you may have made, or restoring the changed files and trying the install again.

Share this post


Link to post
Share on other sites

This is a great contribution. However, I have been testing for while now and have a just noticed that I have the following issue which I can’t seem to resolve.

 

From a clean database, I populate a few categories with a few products, check the live site and everything is fine. I then extract these to a csv and then reload them. After this process I have the following issue.

 

When I check from within the ADMIN panel I can see the product description and picture. When I view the home page I can see the product picture and the start of the description however when I click on one the products to take me to the detail then I do not see the picture or description anymore, it just states this product was added to our catalog on …

 

Any ideas?

Share this post


Link to post
Share on other sites
This is a great contribution. However, I have been testing for while now and have a just noticed that I have the following issue which I can’t seem to resolve.

 

From a clean database, I populate a few categories with a few products, check the live site and everything is fine. I then extract these to a csv and then reload them. After this process I have the following issue.

 

When I check from within the ADMIN panel I can see the product description and picture. When I view the home page I can see the product picture and the start of the description however when I click on one the products to take me to the detail then I do not see the picture or description anymore, it just states this product was added to our catalog on …

 

Any ideas?

sure, I have a great idea. :) Try reading the Support section of the documentation that comes with v2.76f-i to see if there is any additional information that would be helpful.

Share this post


Link to post
Share on other sites
Is possible to get "Vendors Price(Base)" and "Vendors Item Number" as an entry of the .CSV file if you have MVS add-on?

 

Absolutely! the instructions for adding additional product fields such as the vendor price and item number, are clear on the easypopulate.php page. You just gotta read the section on adding additional fields. It involves adding a field in your database and also on your easypopulate.php file - easy stuff.

 

kenz

Share this post


Link to post
Share on other sites
did you create the current attributes using the standard osCommerce attribute manager? or an attribute contribution? is there just one language installed? English language ID #1?

 

I tried to come up with a scenario where that would happen, but couldn't.

 

The only suggestion is to empty the attributes tables and create a few test attributes from scratch and trying again. **Please backup before anything like this**

 

Hi surfalot,

Whenever you get a sec, can you please post how you helped dowser fixed his issue. I got the exact same problem.

 

thanks!

kenz

Share this post


Link to post
Share on other sites
Hi surfalot,

Whenever you get a sec, can you please post how you helped dowser fixed his issue. I got the exact same problem.

 

thanks!

kenz

 

his problem was bad data in his attributes tables. We don't know how it happened. Maybe deleting some supporting option or attribute definitions after assigning them to the product.

 

I would recommend deleting the option, attribute, and product assignments and starting over to make sure it was defined and assigned correctly.

 

try it with just one product to make sure that is your issue. Create all new option, attribute, and product assignments scratch. if that works, you know the problem.

Share this post


Link to post
Share on other sites
Absolutely! the instructions for adding additional product fields such as the vendor price and item number, are clear on the easypopulate.php page. You just gotta read the section on adding additional fields. It involves adding a field in your database and also on your easypopulate.php file - easy stuff.

 

kenz

 

that info is only for the products table and the products_description table. it won't work for the MVS support.

Share this post


Link to post
Share on other sites
QUOTE (kenz @ Sep 22 2009, 05:24 PM) *

Absolutely! the instructions for adding additional product fields such as the vendor price and item number, are clear on the easypopulate.php page. You just gotta read the section on adding additional fields. It involves adding a field in your database and also on your easypopulate.php file - easy stuff.

 

kenz

 

 

that info is only for the products table and the products_description table. it won't work for the MVS support.

 

 

So how will MVS work? I really needed this right now.

 

Dossier de surendettement

Share this post


Link to post
Share on other sites
So how will MVS work? I really needed this right now.

After thoroughly reading the docs you will find a plea to please read though all the settings at the top of the script, there you will find a setting that enables the MVS support.

 

Then in the docs you will find a section about import file format that talks about the column label for the vendor name.

 

hope that helps

Share this post


Link to post
Share on other sites
sure, I have a great idea. :) Try reading the Support section of the documentation that comes with v2.76f-i to see if there is any additional information that would be helpful.

 

At the risk of being flamed for my admitted ignorance I have a somewhat similar problem. I think I have read the support section of the documentation several times and am still not finding the answer that I want. I have spent three days reading nearly every post on this forum and do not find anyone with exactly the same problem. So, here is my problem. If I create a couple of products, create product attributes for them and keep everything simple it all works great. I can create and download the csv file and it looks good. I can upload the csv file and it looks good. But, if I add HTML to the v_products_description_1 field and upload the new csv file it scrambles things and puts stuff in all manner of weird places. The documentation says that the columns Excel messes with are the model numbers if they contain dashes and the dates. In my case it is the descriptions. I do have some apostrophes in there but they are all backslashed and that is not where it splits the data to other fields.

 

If I just put a couple words of plain text in the description field and easy populate the product into my site I can edit the product and insert the HTML description from the admin and everything is OK. I just can not EP the HTML part. Is that because Excel is doing something I am not aware of or is EP not handling it?

 

Thanks for your help.

 

Norman

Share this post


Link to post
Share on other sites
At the risk of being flamed for my admitted ignorance I have a somewhat similar problem. I think I have read the support section of the documentation several times and am still not finding the answer that I want. I have spent three days reading nearly every post on this forum and do not find anyone with exactly the same problem. So, here is my problem. If I create a couple of products, create product attributes for them and keep everything simple it all works great. I can create and download the csv file and it looks good. I can upload the csv file and it looks good. But, if I add HTML to the v_products_description_1 field and upload the new csv file it scrambles things and puts stuff in all manner of weird places. The documentation says that the columns Excel messes with are the model numbers if they contain dashes and the dates. In my case it is the descriptions. I do have some apostrophes in there but they are all backslashed and that is not where it splits the data to other fields.

 

If I just put a couple words of plain text in the description field and easy populate the product into my site I can edit the product and insert the HTML description from the admin and everything is OK. I just can not EP the HTML part. Is that because Excel is doing something I am not aware of or is EP not handling it?

 

Thanks for your help.

 

Norman

EP should handle any HTML you have for the descriptions as long as the CSV file formatted is correct. If you follow the directions in using excel or open office, that should format it for you correctly.

 

The support section only suggests reading a few of the last pages in the forum. Mainly because only the last few will be applicable to the latest version. It also suggests offering a sample of the upload you are trying, the version you are using, the type of spreadsheet software, your operating system, etc. Mainly because it all matters in trying to help you. If you read it, why not follow the steps and offer the info so that I don't have to ask for it? <_< As I said in the support section, you are not saving anyone any time by avoiding it.

Share this post


Link to post
Share on other sites
EP should handle any HTML you have for the descriptions as long as the CSV file formatted is correct. If you follow the directions in using excel or open office, that should format it for you correctly.

 

The support section only suggests reading a few of the last pages in the forum. Mainly because only the last few will be applicable to the latest version. It also suggests offering a sample of the upload you are trying, the version you are using, the type of spreadsheet software, your operating system, etc. Mainly because it all matters in trying to help you. If you read it, why not follow the steps and offer the info so that I don't have to ask for it? <_< As I said in the support section, you are not saving anyone any time by avoiding it.

 

 

How to ask for help

 

Please gather information we need to help you:

 

1. Edit easypopulate.php and ensure EP_SHOW_EP_SETTINGS is set to true, then copy the settings & server info that are displayed on the EP main page into your post.

 

Settings & Info

 

EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.9-42.0.3.EL.wh1smp

HTTP: Apache/2.0.52 (Red Hat)

DB: MySQL 5.1.37

PHP: 5.2.9 (Zend: 2.2.0)

 

Temp Directory:

/var/www/html/vandornfamily/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: false

SPPC: false

Extra Fields: false

PDF Upload: false

 

Please see the manual in this contribution's package for help in changing these settings.

 

2. # Include the type of operating system and software you are using to edit the datafile.

(Windows, MAC, Linux) / (Excel, Open Office, etc.)

 

Windows XP Pro / Problem is same with Excel and Open office

 

3. # Copy of any error message you are receiving or description of problem if no error.

 

No error message. Description of problem: I created two products with some attributes in admin and then used Easy Populate to create and download csv file with the intent of adding the rest of my products and attributes and uploading. I discovered that if I use HTML in the product description either by entering it in admin or putting it in my csv file it gets truncated and parts of it get moved to other fields upon upload via easy populate. This happens even if I enter the HTML in admin, create and download the csv file and immediately upload it back to the site without opening the file. The behavior is much like what is described in the easy populate manual in the section "My products are going in duplicate categories instead of the one I specify, what now?" except that it is happening in the description field not the category name field.

 

4. If it is a upload problem, post a link to a sample of any upload file you are trying.

If it is a download problem, post a link to the file EP is producing.

 

csv without any products

csv with product but no HTML

csv with HTML inserted through Admin

csv with HTML after uploading

 

First file (1.csv) created without products to show the structure.

Second file (2.csv) created with two products and a couple of attributes but only text in the description field. Everything added through Admin. File uploads fine.

Third file (3.csv) created after adding HTML through admin. All appears to me to be ok in this file. But if I upload through easy populate I get a new category named "2009-09-25 16:24:10" with subcategory named "Personalized CDs" with one product "Tyro English" as well as my original "Personalized CDs" category. The Tyro English product is now pretty jacked up. I will leave the site this way until I hear from somebody or a couple of days if I do not hear.

Fourth file (4.csv) created after uploading the previous (3.csv) file through easy populate.

 

I am sure that this is my shortcoming not yours or Easy Populates. I am a one man shop retailer not a programmer but am trying to learn as time permits. If you can find the time to look at what is going on I humbly seek your help.

 

Norman

Share this post


Link to post
Share on other sites
How to ask for help

 

Please gather information we need to help you:

 

1. Edit easypopulate.php and ensure EP_SHOW_EP_SETTINGS is set to true, then copy the settings & server info that are displayed on the EP main page into your post.

 

Settings & Info

 

EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.9-42.0.3.EL.wh1smp

HTTP: Apache/2.0.52 (Red Hat)

DB: MySQL 5.1.37

PHP: 5.2.9 (Zend: 2.2.0)

 

Temp Directory:

/var/www/html/vandornfamily/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: false

SPPC: false

Extra Fields: false

PDF Upload: false

 

Please see the manual in this contribution's package for help in changing these settings.

 

2. # Include the type of operating system and software you are using to edit the datafile.

(Windows, MAC, Linux) / (Excel, Open Office, etc.)

 

Windows XP Pro / Problem is same with Excel and Open office

 

3. # Copy of any error message you are receiving or description of problem if no error.

 

No error message. Description of problem: I created two products with some attributes in admin and then used Easy Populate to create and download csv file with the intent of adding the rest of my products and attributes and uploading. I discovered that if I use HTML in the product description either by entering it in admin or putting it in my csv file it gets truncated and parts of it get moved to other fields upon upload via easy populate. This happens even if I enter the HTML in admin, create and download the csv file and immediately upload it back to the site without opening the file. The behavior is much like what is described in the easy populate manual in the section "My products are going in duplicate categories instead of the one I specify, what now?" except that it is happening in the description field not the category name field.

 

4. If it is a upload problem, post a link to a sample of any upload file you are trying.

If it is a download problem, post a link to the file EP is producing.

 

csv without any products

csv with product but no HTML

csv with HTML inserted through Admin

csv with HTML after uploading

 

First file (1.csv) created without products to show the structure.

Second file (2.csv) created with two products and a couple of attributes but only text in the description field. Everything added through Admin. File uploads fine.

Third file (3.csv) created after adding HTML through admin. All appears to me to be ok in this file. But if I upload through easy populate I get a new category named "2009-09-25 16:24:10" with subcategory named "Personalized CDs" with one product "Tyro English" as well as my original "Personalized CDs" category. The Tyro English product is now pretty jacked up. I will leave the site this way until I hear from somebody or a couple of days if I do not hear.

Fourth file (4.csv) created after uploading the previous (3.csv) file through easy populate.

 

I am sure that this is my shortcoming not yours or Easy Populates. I am a one man shop retailer not a programmer but am trying to learn as time permits. If you can find the time to look at what is going on I humbly seek your help.

 

Norman

 

Don't waste your time replying to the above unless you want to tell me I am an idiot. *.csv = comma delimited and I had a comma in my HTML description. When I take the comma out - no more problem just bad grammar. But, if you want to teach me something, explain why a comma inside HTML causes this reaction but a comma in a plain text description does not.

 

Thanks,

 

Norman

Share this post


Link to post
Share on other sites

HI my Names Richard, I've recently taken a job designing a site around oscommerce as this is the program my boss wants to use and he gave me this update program for it in excell made by my predecessor. Now I've used excel before but never to this degree, and we're having problems, we sell games and all our old retro stuff is updating fine and are newer consoles 360, ps3 all the ones I've had to add etc update new stock but not pre-owned can any one here help? I can send you the update prog and sample database.

 

Thanks in advance,

 

Rich

Share this post


Link to post
Share on other sites

Maximum Attributes/Easy Populate

 

My question pertains to the maximum number of attributes/options EP will handle. I have only a few products on my site but each has 4000-6,000 available options. In some other versions of osCommerce I was able to EP as many as 5440 (MS Excel 2007 column limit). With EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a I seem to be bumping into a wall around 356. If a add number 357 and try to upload it gives the following error: File uploaded.

Temporary filename: /var/tmp/php4sStOy

User filename: names3.txt

Size: 46395

25ttribute_options_name_2_1... ERROR! - Too many characters in the model number.

12 is the maximum on a standard OSC install.

Your maximum product_model length is set to 12.

You can either shorten your model numbers or increase the size of the

"products_model" field of the "products" table in the database.

Then change the setting at the top of the easypopulate.php file.

 

I do not think it has anything to do with the product_model length since none of my product model numbers are longer than 9 and with less than 357 attributes it works great.

 

Reading the easypopulate.php configuration section there are a couple of settings dealing with attributes and one of them talks about the number of columns limit in Excel being 256 but Excel 2007 has a limit of over 15000 columns so that setting does not seem to apply. Besides they deal with not downloading any or certain attributes. I am more concerned with uploading a lot of attributes.

 

any suggestions?

 

Windows XP professional

MS Excel 2007

 

Settings & Info

 

EP vers: 2.76i-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.9-42.0.3.EL.wh1smp

HTTP: Apache/2.0.52 (Red Hat)

DB: MySQL 5.1.37

PHP: 5.2.9 (Zend: 2.2.0)

 

Temp Directory:

/var/www/html/vandornfamily/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

 

Other Support:

MVS Support: false

Additional Images: false

More Pics: false

UltraPics Pics: false

HTC: false

SPPC: false

Extra Fields: false

PDF Upload: false

 

Thanks,

 

Norman

Share this post


Link to post
Share on other sites
4. If it is a upload problem, post a link to a sample of any upload file you are trying.

If it is a download problem, post a link to the file EP is producing.

 

csv without any products

csv with product but no HTML

csv with HTML inserted through Admin

csv with HTML after uploading

we're getting close, but your files are secured with a password so I can't read them. commas should not be a problem in a properly formatted CSV.

 

question... are you using the excel "Save As..." and selecting CSV (MS-DOS) as the file type?

Edited by surfalot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×