Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Wow, I just started adding this contribution and ran into a few glitches.

 

For 1. It did not like the code to add this to the Admin panel under Catalog, it would make all the other categories disappear in catalog. No biggie, no needed for now.

 

2. I did run the excel.php manually from the browser, it only lets me upload at this time, no way to Export.

and i get this line at the bottom

Fatal error: Call to undefined function: tep_get_uploaded_file() in /home/content/s/t/r/stroker398/html/catalog/admin/excel.php on line 489

I assume because i have not uploaded anything yet.

 

3. Since there are 392 pages I have not had a chance to read many of them yet and the instructions are average at best. I am wondering if I upload a single product does it just add to the current product (i.e. append it to the database) or do I need to export the current list and add to it? I do not want to wipe out the work that has been done.

 

4. Any recommendations as to which is the best version for multiple pictures?

 

Thanks, I will be out of town so I wanted to get this up so I can finish when I return.

 

 

 

Easy populate doesnt have a file excel.php as far as I am aware, theres another mod that has excel.php Excel Import 1.51 as far as I can tell.

 

the links in the admin should not have dissappeared, my guess is you accidentaly deleted them?

 

Easy populate 2.76g is what I am using and its pretty damn good, it has a lot of built in functions for other mods which you can just switch on when you have them.


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Sorry part of the confusion is people uploading only partial and not complete contributions without labeling it as such!


The Site can be viewed at www.performanceautopartsonline.com

 

The site is live (despite these minor glitches) please respect that and do not sign up etc...

 

maybe a contribution one day when I get this site the way I want it.

 

I don't make spelling mistakes! I have dyslecsic fingers.

Share this post


Link to post
Share on other sites

Hi, I installed easypopulate 2.76h successfully and followed the instruction to the dot. The problem I am having after I do this is:

 

When I click on the "Quick Links" > "Download COMPLETE .csv file to edit" it gives me this error:

 

1054 - Unknown column 'products_options_name' in 'field list'

 

select products_options_name from products_options where products_options_id = '1' and language_id = '1'

 

[TEP STOP]

 

but when I click on the "Export EP or Froogle Products File" and try to export a "COMPLETE" download, it creates a file for me and when I open it in excel, there are no products eventhough I have many products in my store, except it has one line that says:

 

<font color="#000000"><b>1054 - Unknown column 'products_options_name' in 'field list'<br><br>select products_options_name from products_options where products_options_id = '1' and language_id = '1'<br><br><small><font color="#ff0000">[TEP STOP]</font></small><br><br></b></font>

 

I believe this to be a problem with my attributes because when I do a custom download and check everything except the "attributes" box it downloads my store perfectly with all the products, the moment I check the "attributes" box it gives me the same error

<font color="#000000"><b>1054 - Unknown column 'products_options_name' in 'field list'<br><br>select products_options_name from products_options where products_options_id = '1' and language_id = '1'<br><br><small><font color="#ff0000">[TEP STOP]</font></small><br><br></b></font>

 

Can someone please help. Thank you

Share this post


Link to post
Share on other sites

I need help. I have Easy Populate 2.76g-MS2 and i wont export and import easy populate. Can any help me

 

thanks

 

Simon

Share this post


Link to post
Share on other sites
Hi, I installed easypopulate 2.76h successfully and followed the instruction to the dot. The problem I am having after I do this is:

 

When I click on the "Quick Links" > "Download COMPLETE .csv file to edit" it gives me this error:

 

but when I click on the "Export EP or Froogle Products File" and try to export a "COMPLETE" download, it creates a file for me and when I open it in excel, there are no products eventhough I have many products in my store, except it has one line that says:

 

I would suspect creloaded is not using the same attributes setup that the standard osCommerce is. I can only support this version on osCommerce.

Share this post


Link to post
Share on other sites
I need help. I have Easy Populate 2.76g-MS2 and i wont export and import easy populate. Can any help me

 

thanks

 

Simon

The docs in that version has a section called "how to ask for help". please take a look, offer the information that helps me help you.

Share this post


Link to post
Share on other sites

Do you happen to know where I can find the installation guide for "PDF File Upload and Display". - claimed to be a part of easy populate now.

 

thanks

Share this post


Link to post
Share on other sites
Do you happen to know where I can find the installation guide for "PDF File Upload and Display". - claimed to be a part of easy populate now.

 

thanks

 

josequituc put the name and link on the page you downloaded the EP script from.

Share this post


Link to post
Share on other sites
josequituc put the name and link on the page you downloaded the EP script from.

 

Thank you for point that out. For some reason I thought the link was broken. Thanks

Share this post


Link to post
Share on other sites

Welcome,

 

 

Easy Populate 2.76h-MS2

 

I have a question how to add the easypopulate several products with the same model number (with the same v_products_model) Now how do I add a few products with the same model number (v_products_model) me to overwrite and thus is a product of the same model number (v_products_model). Advisor, manually adding the products of the same product model number, you can easily add and how much you want easypopulate I do not know how to add multiple products with the same model number at the same time with different names to eShop

Share this post


Link to post
Share on other sites

can more clearly

 

wishes to change to update the products after products_id and not products_model

 

 

how to do??

Share this post


Link to post
Share on other sites

i can't even import the sample file... :(

 

i have imported the csv file that i just "saved as". in which i delete all the the rows except row 1 to 3...

and the result is that i got the following message :

 

Easy Populate 2.76h-MS2 - Default Language : english(1)

Filename: try1.csv

1054 - Unknown column 'p.products_subimage1' in 'field list'

 

SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_subimage1 as v_products_subimage1,p.products_subimage2 as v_products_subimage2,p.products_subimage3 as v_products_subimage3,p.products_subimage4 as v_products_subimage4,p.products_subimage5 as v_products_subimage5,p.products_subimage6 as v_products_subimage6, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_available as v_date_avail, p.products_date_added as v_date_added, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id, p.products_status as v_status_current FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_model = 'MG200MMS' AND p.products_id = ptoc.products_id AND ptoc.categories_id = subc.categories_id LIMIT 1

 

[TEP STOP]

 

please help!!!!!!!

thank you very much :(

Share this post


Link to post
Share on other sites
Welcome,

 

 

Easy Populate 2.76h-MS2

 

I have a question how to add the easypopulate several products with the same model number (with the same v_products_model) Now how do I add a few products with the same model number (v_products_model) me to overwrite and thus is a product of the same model number (v_products_model). Advisor, manually adding the products of the same product model number, you can easily add and how much you want easypopulate I do not know how to add multiple products with the same model number at the same time with different names to eShop

 

at current, EP 2.76 will not allow you to do that. The code looks up the existing product based on the model number. There is an version that was modified for Master Product (? I think) that is based on the product id. That might help you.

Share this post


Link to post
Share on other sites
i can't even import the sample file... :(

 

i have imported the csv file that i just "saved as". in which i delete all the the rows except row 1 to 3...

and the result is that i got the following message :

 

 

 

please help!!!!!!!

thank you very much :(

 

you should take a look at the "how to ask for help" section of the docs if you are using any of the v2.76d-h versions of EP. when you help me help you, everyone is happy! B)

Share this post


Link to post
Share on other sites
at current, EP 2.76 will not allow you to do that. The code looks up the existing product based on the model number. There is an version that was modified for Master Product (? I think) that is based on the product id. That might help you.

 

I need that version based on the product id. where is it?

Share this post


Link to post
Share on other sites

how about the "Configuration Variables"??

i cant find it in the "/catalog/admin/easypopulate.php"

 

and whatever i clicked under "Create then Download Files"

it gives me the same result:

 

1054 - Unknown column 'p.products_subimage1' in 'field list'

 

SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_subimage1 as v_products_subimage1, p.products_subimage2 as v_products_subimage2, p.products_subimage3 as v_products_subimage3, p.products_subimage4 as v_products_subimage4, p.products_subimage5 as v_products_subimage5, p.products_subimage6 as v_products_subimage6, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_available as v_date_avail, p.products_date_added as v_date_added, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id, p.products_status as v_status FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND ptoc.categories_id = subc.categories_id

 

 

um... i also found that the following is stated in the easypopulate.php

Settings & Info

 

EP vers: 2.76h-MS2

osCommerce Online Merchant v2.2 RC2a

OS:

HTTP: Apache/2

DB: MySQL 5.0.81-community

PHP: 5.2.10 (Zend: 2.2.0)

 

so i have to do step 4 and 5??

 

i know that i may be annoying, sorry about that :( :( :( :( :( :(

Share this post


Link to post
Share on other sites

I hope I am posting this in the right place! If not, let me know......

 

I am running osCommerce v2.2 RC2 with Easy Populate 2.76c-MS2. In easypopulate.php it says to set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php $tempdir = "/catalog/temp/"; $tempdir2 = "/catalog/temp/";

 

What it doesn't say is how to do this.

 

Is it......

 

DOCUMENT_ROOT = $DOCUMENT_ROOT;

or

define('DOCUMENT_ROOT', $DOCUMENT_ROOT);

or

set(DOCUMENT_ROOT, $DOCUMENT_ROOT);

 

and where do I change $tempdir = "/catalog/temp/"; $tempdir2 = "/catalog/temp/"; ? Does this go in the DOCUMENT_ROOT line somewhere?

 

Also, I don't have a line in /catalog/admin/includes/configure.php that says "DOCUMENT_ROOT". I have a line that says define('DIR_FS_DOCUMENT_ROOT', '/........'); so do I add another line for DOCUMENT_ROOT or alter this line?

 

I created a catalog/temp dir in admin and set the permissions to 777 like it said and I copied easypopulate.php and easypopulate functions into admin/ and added a link to the Admin by editing file admin/includes/boxes/catalog.php and Easy Populate shows up in the menu but when I try to download a file nothing happens. A message flashes on the screen for a split second but it’s too fast to read. Also, nothing shows up in the temp dir which I assume is where the txt file is supposed to be downloaded to. I couldn't find anything in the forums or documentation that explains how to do this. Can someone tell me how to set this DOCUMENT_ROOT command or tell me where I can find documentation on this? Thanks!

Share this post


Link to post
Share on other sites
I hope I am posting this in the right place! If not, let me know......

 

I am running osCommerce v2.2 RC2 with Easy Populate 2.76c-MS2. In easypopulate.php it says to set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php $tempdir = "/catalog/temp/"; $tempdir2 = "/catalog/temp/";

you'll have a lot of trouble with that version and osC RC2. You should try v2.76h that I uploaded. Better install docs, comments on the settings. and the most fixes available.

Share this post


Link to post
Share on other sites
how about the "Configuration Variables"??

i cant find it in the "/catalog/admin/easypopulate.php"

 

and whatever i clicked under "Create then Download Files"

it gives me the same result:

 

so i have to do step 4 and 5??

"and whatever i clicked under" ? I'm not psychic, so you will need to be a bit more specific. You'll find things work better if you click deliberately, describe what you have changed in the settings, and describe what you are doing with detail.

 

The manual asked you to post the settings displayed on the main page of easy populate within the admin.

Share this post


Link to post
Share on other sites
you'll have a lot of trouble with that version and osC RC2. You should try v2.76h that I uploaded. Better install docs, comments on the settings. and the most fixes available.

 

Thanks! I'll try the other version.

Share this post


Link to post
Share on other sites

Is there a reason Easy Populate would just stop working? I was using it fine last week, splitting big imports and everything. Now I can't even reload a csv file of one item.

Share this post


Link to post
Share on other sites
Is there a reason Easy Populate would just stop working? I was using it fine last week, splitting big imports and everything. Now I can't even reload a csv file of one item.

 

one reason would be a server update at your web host causing some kind of issue. If there is no error, you might try to get their assistance in finding one.

Share this post


Link to post
Share on other sites

I am using Easy Populate 2.76h-MS2 and when updating existing products if there is a price drop for an product attribute (from 0 to -1 cost for example) it doesn't get update.

 

step 1: I upload a product with some attributes

step 2: I download the complete csv

step 3: I edit one of the options to a -1 value (not caring about tax or whatever)

step 4: I upload the file

 

After step 4 the negative value hasn't been applied, but any other changes have.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×