Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Have you seen the example file included in the easy populate package? Or looked at the "How to use Easy Populate" section of the docs that walks you through creating your own sample file to reference? Or the "EasyPopulate File Format" and "Description of Column Headers" sections of the docs that describes the format of the file?

 

the images go in the catalog/images/ folder the same as with the standard shop's product edit page.

 

Yes, but my descriptions are fairly long with all the HTML code, so when I put it into the product description part, for some reason it distorts the whole line, and the product I was editing goes away, leaving one long line going down of my description. Am I doing something wrong?

Share this post


Link to post
Share on other sites
Yes, but my descriptions are fairly long with all the HTML code, so when I put it into the product description part, for some reason it distorts the whole line, and the product I was editing goes away, leaving one long line going down of my description. Am I doing something wrong?

 

I can't edit the post above, but on top of that, my HTML parts are actually shown how they would be on the site, and not in the HTML format. It's pretty much like a fairly long list going down, and then a long line of the description above it.

Share this post


Link to post
Share on other sites
Thanks again. I think I found another weird issue. When I try to export using the following url, it exports only inactive products. Any idea why?

 

easypopulate.php?download=tempfile&dltype=custom&epcust_status_filter=active&epcust_name=show&epcust_description=show&epcust_image=show&epcust_category=show&epcust_price=show&epcust_quantity=show&epcust_status=show

What, you didn't double check my work dissecting the form? :blush:

epcust_status_filter need to be a 1 or 0 rather then active or inactive.

Share this post


Link to post
Share on other sites
Yes, but my descriptions are fairly long with all the HTML code, so when I put it into the product description part, for some reason it distorts the whole line, and the product I was editing goes away, leaving one long line going down of my description. Am I doing something wrong?

I wish I was, but I'm not psychic. If you can't provide a sample of your import, there isn't much I can do to help other then to suggest you lookup proper formatting for standard CSV files and marry that with the info provided in the docs.

Share this post


Link to post
Share on other sites
if you read the how to ask for help section of the docs, you would know what else to post. :rolleyes:

you can pm me the link to the CSV.

 

The first version I got (or the package I got) didnt come with a docs section. I have the EP_v2_76f_r1_MS2 now.

I may have some other issues I may wish to PM you on at a later time. So far seems to be working.

Share this post


Link to post
Share on other sites
The first version I got (or the package I got) didnt come with a docs section. I have the EP_v2_76f_r1_MS2 now.

I may have some other issues I may wish to PM you on at a later time. So far seems to be working.

 

v2.76h that I uploaded has the easiest to read and best organized and most up-to-date docs.

Share this post


Link to post
Share on other sites
I wish I was, but I'm not psychic. If you can't provide a sample of your import, there isn't much I can do to help other then to suggest you lookup proper formatting for standard CSV files and marry that with the info provided in the docs.

 

Sorry, I fixed the excel issue, but even still I inputted all the data, but only the product info shows when I click the item in my store. No price, manufacturer, pic, more info link, etc is shown at all. I have this all in the excel file, do you know why this may be happening?

Share this post


Link to post
Share on other sites
Sorry, I fixed the excel issue, but even still I inputted all the data, but only the product info shows when I click the item in my store. No price, manufacturer, pic, more info link, etc is shown at all. I have this all in the excel file, do you know why this may be happening?

um, see the post you just replied to. :huh:

Share this post


Link to post
Share on other sites

Can anyone help with this problem (I know it has been briefly discussed but there was no answer)

 

say I have XXXX in category AAAA I download in easypopulate and then realise XXXX needs to be in category BBBB

 

Now if I alter the line in the spreadsheet to BBBB and upload it then will have XXXX in both AAAA and the newly generated BBBB

 

I know this is because easypopulate works from v_products_model but is there a way to make easypopulate use the product_id as the control field? by doing this altering a product from one category to another would not cause duplicates to be created and it would also not affect SEO urls that have already been indexed by Google.

Edited by ShaGGy

Share this post


Link to post
Share on other sites

There is no way to move a product to another category using one line, as you know the default function is to add to a new category.

 

if you need to move a product from category to category you need to duplicate the line in your import, change the category on the first line, then make the status "Delete" on the second. The product id won't be changed as long as you add it to the second category first, then delete it from the original category second.

 

using the products id as the hook wouldn't solve that problem, EP will still add it to the second category. EP allows you to add the product to multiple categories by default. This is the same as the Copy to -> Link product function in the admin. It copies the product to the new category and uses the same product_id in both. Of course if you are adding the path to the seo urls, the url of both will be different. If you don't use the path in the url, the url for each product will be the same.

 

you can preserve the product id if you need to clear the products and start over or duplicate a shop exactly including the products_id. Use the custom fields feature for the products table and setup the products_id as one of the custom fields. Then export

Share this post


Link to post
Share on other sites

Thanks Surfalot,

 

I did have a look at the SQl and noticed (like you say) that the product id's stay unique to the item, would it be possible to alter easypopulate to 'move' rather than 'add' ?

 

The reason I would like to be able to do this is because my suppliers give me a database and the cats are mostly different from my own and he likes to use 'And' where I use '&' plus he only has main cats and one sub cat where i break the products down into 3 or 4 sub cats, so when updating the spread sheet I some times miss his cats and end up with a mess.

 

A friend of mine has helped me build a access form that uses my cats in drop down boxes to help keep things tidier in the future but I think if it is possible to do a 'move' via easypopulate it would be a good feature form stores with big inventories?

Share this post


Link to post
Share on other sites
i have the UPC codes installed...can EP download them too?

thanks

 

if you read through the settings at the top of the easypopulate.php file (as the docs asked you to do :P ), you will find a section dedicated to custom fields for the products and products_description table.

Share this post


Link to post
Share on other sites

Hi everyone,

 

i have duplication problems with my categories and subcategories? does anyone know a block of code in Easy Populate that help prevent duplication? thanks

Share this post


Link to post
Share on other sites

if you read through the settings at the top of the easypopulate.php file (as the docs asked you to do tongue.gif ), you will find a section dedicated to custom fields for the products and products_description table.

 

And it's easy to understand. Nice job Surfalot.


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites
Hi everyone,

 

i have duplication problems with my categories and subcategories? does anyone know a block of code in Easy Populate that help prevent duplication? thanks

 

Actually, the category duplication is addressed in the troubleshooting of the docs you were asked to read.... :D

Share this post


Link to post
Share on other sites

I am struggling to get Easy Populate to even show up in the tools.

 

I set this tool up in Zen Cart and had no trouble but I can't get it to even show up in tools?

 

I have checked everything three times and I am sure I am missing something minor.

 

Any one have any ideas?

Share this post


Link to post
Share on other sites

It's not in tools, it's in Catalog.


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites
It's not in tools, it's in Catalog.

Open up your internet browser and go to your osCommerce Store Admin Panel

Go to osCommerce Tools -> Ez Populate

 

Nothing there....dont see it under catalog either.

 

Thanks

Share this post


Link to post
Share on other sites

I don't know., I have osCommerce and Easy Populate

 

It sounds like you have zen cart and Ez Populate

 

Maybe you're in the wrong forum?

 

Catalog

Categories/Products

Products Attributes

Easy Populate

Manufacturers

Reviews

Specials

Products Expected


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites

No, I am using osCommerce now.

 

Previously I had Zencart and had no trouble installing ez populate there.

 

Just weird because I see to have everything right.

Share this post


Link to post
Share on other sites

Hello,

 

Need some help with 2.76g-MS2. When I activate SPPC and download the file to edit a, add into SPPC fields and upload, I get the following error,

 

1136 - Column count doesn't match value count at row 1

 

INSERT INTO products_groups VALUES ( 1, 7, 34 )

 

But, if I upload the file with SPPC fields blank it uploads fine?

 

Thanks JR

 

EP vers: 2.76g-MS2

osCommerce Online Merchant v2.2 RC1

OS: Linux 2.6.20.1

HTTP: Apache/2.2.4 (Fedora)

DB: MySQL 5.0.27

PHP: 5.1.6 (Zend: 2.1.0)

 

Temp Directory:

/home/virtual/site1.com/var/www/html/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: tab

Excel safe output: false

Preserve tab/cr/lf: false

Category depth: 3

Enable attributes: false

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: true

Extra Fields: false

Share this post


Link to post
Share on other sites
No, I am using osCommerce now.

 

Previously I had Zencart and had no trouble installing ez populate there.

 

Just weird because I see to have everything right.

 

 

EZ Populate and Easy Populate seem to be 2 different things.

When I googled EZ populate, it only returned Zen results.

Is it possible you put a Zen add on into OSc and it doesn't like that?


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites

Hi,

 

been looking through this thread and trying to find out how to add the msrp field to the easypopulate 2.76h.

 

I am guess I can use the extra field mod or something specific for msrp, however I cant find references on how to do any of these and or the best ones to follow given my current setup.

 

If someone can point me to the correct contributions or provide a guide for the installation I will give it a go.

 

Thanks

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites
I am guess I can use the extra field mod or something specific for msrp, however I cant find references on how to do any of these and or the best ones to follow given my current setup.

have you looked at the instructions in the easypopulate.php file? there should be enough info to get started in the comments there.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×