Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Imported the file and most of it is correct.

One subcategorie holds 10 products and when checking the shop

there is 10 subcategories with exactly the same name holding 1 product each!

This happend to about 4-5 subcategories.

 

rereading the troubleshooting section of the docs would be appropriate at this juncture.

Share this post


Link to post
Share on other sites
rereading the troubleshooting section of the docs would be appropriate at this juncture.

 

Thank you for the idea, did this again and found a section that covered this matter,

strange did not see this first time... :blush:

 

But after counting I see that I don´t use 32 letters in catagori name, I have now changed to 64 caracters in database.

And in fact, the catagorie that made the problem was one of the shortest...

Is it not correct to us "space" in catagorie names?

 

Had duplicate problem with subcatagorie "FISKESET"

Have more subcatagories that works fine like "FISKESET i LÅDA", "FISKESET TELESKOPSPÖ"

BUT, if I change the subcatagorie "FISKESET" to "FISKESET NORMAL" it works!

Share this post


Link to post
Share on other sites

the next thing I would do is check to make sure that each of those duplicate categories are, in fact, EXACT duplicates. That is, no extra spaces before or after the names, no special characters, etc.

 

If that doesn't help, then I would suggest rereading the "how to ask for help" section and offer a full set of info for me to look at. If there is anything sensitive, proprietary, or private in any of those required info, you can PM it to me.

 

another thought is the UTF chars in the names. That is probably the problem. You want to reread the section on "non-roman" character sets. If you don't have it, get Open Office and use that to edit your CSV file. MS Office mangles UTF chars on export. If you look at your MS Excel export file in windows notepad, you will probably see that your category names are not what you expected.

Edited by surfalot

Share this post


Link to post
Share on other sites
the next thing I would do is check to make sure that each of those duplicate categories are, in fact, EXACT duplicates. That is, no extra spaces before or after the names, no special characters, etc.

 

If that doesn't help, then I would suggest rereading the "how to ask for help" section and offer a full set of info for me to look at. If there is anything sensitive, proprietary, or private in any of those required info, you can PM it to me.

 

another thought is the UTF chars in the names. That is probably the problem. You want to reread the section on "non-roman" character sets. If you don't have it, get Open Office and use that to edit your CSV file. MS Office mangles UTF chars on export. If you look at your MS Excel export file in windows notepad, you will probably see that your category names are not what you expected.

 

Thank you for your help,

Use Swedish signs and also MS Excel to edit the CSV file, and there is no problem with the output.

But finally I saw that there was space added after some of the catagory name when it came from my distributer.

The name is exactly the same but with two spaces added after.

And this was the cause of the problem, difficult to see when 3500 articles was imported.

Could this not be checked when imported by EP?

Anyway, now it works perfect, can import all 3500 without splitting the file.

Thank you again for helping users in need....

Share this post


Link to post
Share on other sites

Is there anyone out there with a better grasp of creating Easypopulate compatible tables (and more patience), that fancies taking a look at the Excel data I'm working with?

 

The wholesalers CD contains 21132 products, of which I initially need to use 3574 of them for our store. I'm just struggling to get my head around translating the table headers defined by the supplier into the table headers needed by EP.

 

Excel and databases aren't my thing if I'm honest, and I've spent the last 4 hours trying to find out how to add a ".jpg" extension to all the product names to link into the images folder - still no idea so I'm tired and grumpy now :angry:

 

If anyone can advise or fancies taking a look then PM me - At this point I'll even consider paying for it to be setup!

 

Lee

 

(Not sure if I can get away with this request here, so mods feel free to move/ delete if necessary.)

Share this post


Link to post
Share on other sites

:rolleyes:

 

Scrub that request - tried again now that I've had a sleep and it all makes sense!

 

Lessson learned, when you get tired and grumpy - walk away and come back to it later. My problem was the CD I was working from contained 2 databases of products, and I was trying to work with the wrong one, doh!

 

Lee

Share this post


Link to post
Share on other sites

Does Easy Populate work with QPBPP (Quantity Price Breaks) ?

 

If not ... can some one point in the right direction ...

 

Thanks ... Dan

Share this post


Link to post
Share on other sites
Does Easy Populate work with QPBPP (Quantity Price Breaks) ?

 

If not ... can some one point in the right direction ...

 

Thanks ... Dan

not in the latest, most up-to-date, version. you may want to look around the downloads for some modified version that supports it. Most likely it will be an old version for an old version of QPBPP.

Share this post


Link to post
Share on other sites

Hi again. I haven't heard from anyone regarding the additional feature request on EP, so I thought I would post one more time just to be sure. :)

 

I was basically wanting to see if anyone would like to add in the following:

 

- I have EP working and can download; change the excel file and upload it correctly.

 

Here's my catch -> I have digital downloads for my products. When I upload the excel file, it drops/erases my Filename attribute.

 

- I was going to see if anyone knows how to add an attribute to the excel file for it. I'm not looking for it to 'automatically' upload the digital files, I just want to be sure the name (ex: test.zip) is placed as the Filename option in the attributes.

 

My email address is walkerbg at msn.com. I would be happy to talk with you and see if it's workable. ($50-100)

 

Thank you!

Share this post


Link to post
Share on other sites

hello everybody,

 

My site is up and running and i have EP installed within it. It works great, i split, upload and i am done. What my question and problem is........

 

 

when i use EP it install's. when i update, and i no longer have "that" product anymore, EP can not get rid of it. I have to go in manually and delete it. Thats no big deal but with 15000 products that could be a huge problem.

 

I downloaded and installed EP in dec, of 08. so what i am asking is, is their a new EP that will delete a product that you no longer have within you Excel sheet? Or is their any way of deleting a product any other way rather then one by one. i read in the start of the post VJ said

 

Hello,

 

I've added a code patch, that now enables removal of product attributes linked to a product. You can download the new code here.

 

but this was 6 years ago,

 

any help would be great!!!

thanks a bunch.

 

will

Share this post


Link to post
Share on other sites

yes, and yes.

yes, VJ's comments from 6 years ago really don't apply to the current version.

yes, you can delete products, but EP will not delete products that "are not in your spreadsheet any longer".

Either you can make a spreadsheet of the discontinued products and upload them with "Delete" as the status, or you can clear your product database before uploading the new set. That is the best EP can offer.

 

Catalog management can be done as a "not in spreadsheet, then delete" manner, as a mater of fact, I've done it. But not the way EP works.

Share this post


Link to post
Share on other sites
yes, and yes.

yes, VJ's comments from 6 years ago really don't apply to the current version.

yes, you can delete products, but EP will not delete products that "are not in your spreadsheet any longer".

Either you can make a spreadsheet of the discontinued products and upload them with "Delete" as the status, or you can clear your product database before uploading the new set. That is the best EP can offer.

 

Catalog management can be done as a "not in spreadsheet, then delete" manner, as a mater of fact, I've done it. But not the way EP works.

 

 

deleteing the whole catalog was the way i was doing it. The only problem with that is that you loose all the "reviews" and the "best sellers". Its no big deal, not really informaton that will destroy the site.

 

BUT what where you talking about making a spreadsheet of the discontunued product with a "Delete" as the status? Is this a completely new spreadsheet that i upload after i upload my updates? I might be intrested in that, can you explan alittle bit more?

 

thanks

 

will

Share this post


Link to post
Share on other sites
deleteing the whole catalog was the way i was doing it. The only problem with that is that you loose all the "reviews" and the "best sellers". Its no big deal, not really informaton that will destroy the site.

 

BUT what where you talking about making a spreadsheet of the discontunued product with a "Delete" as the status? Is this a completely new spreadsheet that i upload after i upload my updates? I might be intrested in that, can you explan alittle bit more?

 

thanks

 

will

if you read the docs, you'll find information about the Status column. One option for the status is Delete. That will remove the product from the one category listed on that row. If in multiple categories, you'll need a remove for all of them. This will also remove the images from the server. You don't need a separate spreadsheet for the delete, it can be mixed in the periodic updates.

Share this post


Link to post
Share on other sites
if you read the docs, you'll find information about the Status column. One option for the status is Delete. That will remove the product from the one category listed on that row. If in multiple categories, you'll need a remove for all of them. This will also remove the images from the server. You don't need a separate spreadsheet for the delete, it can be mixed in the periodic updates.

 

 

allright, that could still be extreamly time consuming. Going throu each one and finding them, labeling them deleted, and then uploading them. Thanks for the information, i guess i just need to look into the problem in a different way, that is to try to fix it.

 

thanks again

 

will

Share this post


Link to post
Share on other sites
allright, that could still be extreamly time consuming. Going throu each one and finding them, labeling them deleted, and then uploading them. Thanks for the information, i guess i just need to look into the problem in a different way, that is to try to fix it.

 

thanks again

 

will

 

The main problem is, as I have seen it, that you can't determine products that don't exist in a large spreadsheet by processing each line one at a time as EP does. It is a function that need to build a new table in the database of the newest imported items, then make some queries after the update has take place to determine what was missing. That's how it has be solved in the past. It's easy to know what is in the new spreadsheet, as apposed to what is not there.

Share this post


Link to post
Share on other sites

Hi everybody!

 

I'm bothering you now, because i have a problem!

 

My EP is not splitting my files!!!

 

I have just one big file, ca. 6.000 products, and when I do the "large store" procedure,

EP just splitt it into 1 file!: EP_spli1.csv,

 

And naturally it has the same size, and is the same fime, but renamed.

 

What can it be? What am I missing!?

 

TODD: I swear I read the doc's but can't find the solution this time!

 

Appreciate everybody's time!!!

 

Oscar

 

BTW: I have Easy Populate 2.76h-MS2 - Default Language : espanol(3)

Share this post


Link to post
Share on other sites
Hi everybody!

 

I'm bothering you now, because i have a problem!

 

My EP is not splitting my files!!!

 

I have just one big file, ca. 6.000 products, and when I do the "large store" procedure,

EP just splitt it into 1 file!: EP_spli1.csv,

 

And naturally it has the same size, and is the same fime, but renamed.

 

What can it be? What am I missing!?

 

TODD: I swear I read the doc's but can't find the solution this time!

 

Appreciate everybody's time!!!

 

Oscar

 

BTW: I have Easy Populate 2.76h-MS2 - Default Language : espanol(3)

Share this post


Link to post
Share on other sites

Hi,

I am a real newbie and really dumb. I tried to download Easy Populate 2.76h-MS2 (with attributes) and all i get is File Not Found. How do i get this on my website. I need this for datafeed for clixgalore. Can anyone take me through how to do this or is there instructions.

Share this post


Link to post
Share on other sites

Hi,

 

I'm just going through the installation of Easy Populate.

 

Where is:

 

/catalog/admin/boxes/catalog.php

 

I don't have a directory called boxes?

Share this post


Link to post
Share on other sites

I've posted this message a couple of times before realising I was putting it in the wrong place.

I hope someone can help with my problem.

 

I have just installed the latest versions of Apache, PHP, phpMyAdmin, osCommerce, SPPC add-on and Easy Populate.

I've now tried importing the .csv file exported with Easy Populate from an older osCommerce and EP instance into this setup.

The full file imported after I fixed the values in the v_product_tax_id column.

Trouble is the new data does not appear in the website. After checking the database with phpMyAdmin I found that I have two sets of tables. One starts with osc_.

The table "products" contains the sample data and the "osc_products" contains the imported data. Can some one tell my why this is happening and suggest a fix?

Share this post


Link to post
Share on other sites
Hi,

 

I'm just going through the installation of Easy Populate.

 

Where is:

 

/catalog/admin/boxes/catalog.php

 

I don't have a directory called boxes?

 

Try /catalog/admin/includes/boxes/catalog.php

Share this post


Link to post
Share on other sites
Trouble is the new data does not appear in the website. After checking the database with phpMyAdmin I found that I have two sets of tables. One starts with osc_.

The table "products" contains the sample data and the "osc_products" contains the imported data. Can some one tell my why this is happening and suggest a fix?

 

I found where the osc_ tables came from. I also imported a database backup which must have created them.

 

I've just created a new database and run the SPPC script on it then imported my original EP download file. It runs and shows that it is adding new products and finishes without error but when I go into the website or phpMyAdmin I can't see the records anywhere.

 

What have I done wrong?

Share this post


Link to post
Share on other sites

Please ignore my previous requests for help with imported data not appearing in the database.

After comparison of complete downloads of both the new and old databases I think I can massage the old file by changing some column names and adding others.

will post any gotchas I find here in case they are of help to others.

Share this post


Link to post
Share on other sites

Hi, I have installed EP v2.76h on OSC rca2.2 and it seems to run ok. I can install products into the ep system with excel csv files and everything uploads and shows ok except the images. I have trawled and searched through the forum but cannot find a complete or near complete answer to my dilemma.

 

In the categories/products section against each product description it has this message: IMAGE DOES NOT EXIST

http://imagestore.xpressplatforms.com/AMW/...00000080111.jpg

 

Obviously the image file name itself is different because I am using different images but for some reason or other it is not picking up the images from the relevant http page even though the images are there.

 

My second problem is that when I now update changes within the products themselves and submit them in admin I get this return:

 

Warning: Invalid argument supplied for foreach() in /customers/computerbob.info/computerbob.info/httpd.www/catalog/admin/includes/reset_meta_cache.php on line 36

 

Warning: Cannot modify header information - headers already sent by (output started at /customers/computerbob.info/computerbob.info/httpd.www/catalog/admin/includes/reset_meta_cache.php:36) in /customers/computerbob.info/computerbob.info/httpd.www/catalog/admin/includes/functions/general.php on line 94

 

Does any one out there know what the problems might be. Thank you in advance for any help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×