Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

can't think of anything off the top of my head. It's always worked for me. I may have some additional thoughts if you post the information ask for by the "how to ask for help" section of the docs. (You can block out the path to your web folder if you like).

Share this post


Link to post
Share on other sites

I would very much apprecite it if any one has used this contribution with conjunction with sexshop365 could give me a shout.

 

Apart from having a nightmare after breaking this contirb, I am having severe difficulties in converting the data from the dropshipper in a timely manner


Complete Newbie On The Learn - Not A Programmer

But Learning As I Go

Share this post


Link to post
Share on other sites

I probably missed something stupid but could use some help. I have a fairly clean install of the latest osC2.2 and EP (installed both in the last few days). I can download the data file but do not get any content, only the headers. Can anyone point me in the right direction?

Share this post


Link to post
Share on other sites
I probably missed something stupid but could use some help. I have a fairly clean install of the latest osC2.2 and EP (installed both in the last few days). I can download the data file but do not get any content, only the headers. Can anyone point me in the right direction?

 

 

Ok, so uploads seem to work but the download function still does not. with the download function I get headers for each column but no data.

 

Settings & Info

 

EP vers: 2.76h-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.18-92.1.22.el5

HTTP: Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8b mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

DB: MySQL 5.0.67-community

PHP: 5.2.9 (Zend: 2.2.0)

 

Temp Directory:

/home/xxxxxxxx/public_html/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

Share this post


Link to post
Share on other sites
I probably missed something stupid but could use some help. I have a fairly clean install of the latest osC2.2 and EP (installed both in the last few days). I can download the data file but do not get any content, only the headers. Can anyone point me in the right direction?

 

can't think of anything off the top of my head, but if you would like help I would suggest you read through the docs (presuming you are using one of the latest 2.76e+ versions). When you reach the section called "how to ask for help", follow the instructions to post ALL the information requested.

Share this post


Link to post
Share on other sites
Ok, so uploads seem to work but the download function still does not.

EP vers: 2.76h-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.18-92.1.22.el5

HTTP: Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8b mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

DB: MySQL 5.0.67-community

PHP: 5.2.9 (Zend: 2.2.0)

 

that answers a few questions. how many products? what are you clicking on to download? Is there an error in the last line of the download?

Share this post


Link to post
Share on other sites
that answers a few questions. how many products? what are you clicking on to download? Is there an error in the last line of the download?

 

2 products as a test. tried all the options both download and temp storage location. I get no errors file that is generated just has headers. It is as if the SQL is returning 0 rows.

Share this post


Link to post
Share on other sites

I have updated my installation:-

 

 

my settings:-

EP vers: 2.76h-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.18-92.el5

HTTP: Apache/2.2.10 (Unix) mod_ssl/2.2.10 OpenSSL/0.9.8b mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

DB: MySQL 5.0.67-community

PHP: 5.2.5 (Zend: 2.2.0)

 

Temp Directory:

/home/simplydr/public_html/shop3/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: true

SPPC: false

Extra Fields: false

 

 

My problem is down loading and uploading of attributes, I can download all the attributes, however these are displayed one after the other and are exactly the same for all the products, so basically not downloading the attributes that are specific to a product.

 

On upload, the attributes are being uploaded but not being assigned to products, I have ajax attribute manager installed, when I check the available attributes after an upload they are there, to assign to a product, but they are not assigned at the time of the upload.

 

Any help would be gratefully recieved.

 

Thanks

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites
My problem is down loading and uploading of attributes, I can download all the attributes, however these are displayed one after the other and are exactly the same for all the products, so basically not downloading the attributes that are specific to a product.

 

On upload, the attributes are being uploaded but not being assigned to products, I have ajax attribute manager installed, when I check the available attributes after an upload they are there, to assign to a product, but they are not assigned at the time of the upload.

so the only thing you are gauging EP as working is to look at the attributes manager? That's probably what the problem is. Check the catalog side of the shop for the attributes.

 

EP isn't perfect. The intro reading in the docs says the attributes are not handled well. It does work, but it doesn't work well. Meaning, the way it works makes it 1) makes it difficult to work with in the spreadsheet since, as you say, they are displayed on after the other. All products have all attributes available in the spreadsheet. That is the way it works. And 2) it doesn't create all the table entries in the database, just the ones important to the cart side of the store. It leaves the admin side attribute management without some entries. It's not broken, just the way it works doens't allow for everything to be created correctly for the admin.

 

Sorry, this is not an attributes manager. If you read the docs intro, you'll know what it was designed for and what it is meant to be.

Edited by surfalot

Share this post


Link to post
Share on other sites
2 products as a test. tried all the options both download and temp storage location. I get no errors file that is generated just has headers. It is as if the SQL is returning 0 rows.

 

OK, so you have 2 test products in the shop right now, and that is all. Are those products inside of categories, or just placed in the root of the shop? If I'm remembering correctly, EP will not catch products that have not been placed within at least one category.

Share this post


Link to post
Share on other sites
so the only thing you are gauging EP as working is to look at the attributes manager? That's probably what the problem is. Check the catalog side of the shop for the attributes.

 

EP isn't perfect. The intro reading in the docs says the attributes are not handled well. It does work, but it doesn't work well. Meaning, the way it works makes it 1) makes it difficult to work with in the spreadsheet since, as you say, they are displayed on after the other. All products have all attributes available in the spreadsheet. That is the way it works. And 2) it doesn't create all the table entries in the database, just the ones important to the cart side of the store. It leaves the admin side attribute management without some entries. It's not broken, just the way it works doens't allow for everything to be created correctly for the admin.

 

Sorry, this is not an attributes manager. If you read the docs intro, you'll know what it was designed for and what it is meant to be.

 

The attributes are available in admin only, they are not available cart side, ie. no drop down menu.

 

So if I understand it correctly to get the attributes to upload and be assigned to products I would need more code to fill in the blanks?

 

Okay I am not a coder, but given there are a few tables that link the attributes, options, option values etc to products. Is it not possbile to, or is there a solution to upload the relevant tables one by one to the database.

 

For example, I can download csv files directly from my database in phpmyadmin and change them add to and upload them back and my products would be assigned with the attributes I need. It be better to work from the shop admin rather than the control panel admin.

 

I am guessing that it works the way it does as it would take too long to link large database tables together and sort them in a meaningful way.

 

Thanks

 

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

I think you misread me. EP doesn't need any additional code to maintain attributes with products. There is a reference in one table that makes one feature of the attributes admin faulty.

 

the reason it doesn't seem to work on your shop is still a mystery. If you are unwilling or unable to provide the information requested in the "how to ask for help" section of the manual, there isn't anything more I can help you with.

Share this post


Link to post
Share on other sites
I think you misread me. EP doesn't need any additional code to maintain attributes with products. There is a reference in one table that makes one feature of the attributes admin faulty.

 

the reason it doesn't seem to work on your shop is still a mystery. If you are unwilling or unable to provide the information requested in the "how to ask for help" section of the manual, there isn't anything more I can help you with.

 

I am sorry I havent provided the information you require but I have read the section and I dont know what it is you need as far as I can tell I have given you everything or I have misunderstood the request help document.

 

I can tell you the modules installed, I can tell you what is happening I can provide sample files, but wouldnt know how to load them up to here for you to read. If I new what database tables or file codes you need I could get these also.

 

If you would be so kind to tell me what information you need I will glady collect it all for you and put on the forum.

 

I appreciate how difficult it is with pieces of the jigsaw missing.

 

 

Thanks for your patience

 

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Items #2 & #4

 

 

2. Include the type of operating system and software you are using to edit the datafile.

(Windows, MAC, Linux) / (Excel, Open Office, etc.)

 

4. If it is a upload problem, post a link to a sample of any upload file you are trying.

** Please avoid posting the sample data since the forum may modify it:

This is easy to do. Simply FTP all or a portion of your import file to the root of your shop's hosting space (remember, no spaces in the file name. Then post a link to the file like this: http://www.myshop.com/shop/mycsv.csv. After someone has responded, you can remove it.

 

is there something in #4 you don't understand how to proceed with?

Share this post


Link to post
Share on other sites

Wow, got it to work.

 

think my problem was assigning numbers to the attribute ids option ids etc, either I have tried a number and it wqas in use or didnt get the number in the right place.

 

been through and triple checked the file before uploading and it worked.

 

Thanks for your help, I guess I now have an idea whats what and should be able to get it going smoothly.

 

Feel a right numpty but it works and probably always has just me not knowing what I am doing.

 

Thanks

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Have just move my "old" shop to a new server. Everything works fine except EP. Are not able to import anything to the shop.

Get this message when I try to import a split file:

 

User filename: EP_Split1.txt

 

Warning: explode() [function.explode]: Empty delimiter. in /home/userA/a13021xx/public_html/doman.se/admin/easypopulate.php on line 690

 

Warning: Invalid argument supplied for foreach() in /home/userA/a13021xx/public_html/doman.se/admin/easypopulate.php on line 693

 

Warning: explode() [function.explode]: Empty delimiter. in /home/userA/a1302199/public_html/doman.se/admin/easypopulate.php on line 1208

 

Warning: array_walk() [function.array-walk]: The argument should be an array in /home/userA/a1302199/public_html/doman.se/admin/easypopulate.php on line 2165

 

 

No products_model field in record. This line was not imported.

 

 

 

This message is repeated several times and then nothing happens, have tried more old exported ep files and non of the works.

 

Any ideas??

Share this post


Link to post
Share on other sites

try the latest v2.76h. You are probably experiencing incompatibility problems with php5/mysql5 in the version you have.

Share this post


Link to post
Share on other sites

Hi,

 

I read through the docs and it looks like the Filename option and download don't entirely work?

 

I was just checking to see if anyone had an idea how I could do the following.

 

I have EP working and can download; change the excel file and upload it correctly.

 

Here's my catch -> I have digital downloads for my products. When I upload the excel file, it drops/erases my Filename attribute.

 

I was going to see if anyone knows how to add an attribute to the excel file for it. I'm not looking for it to 'automatically' upload the digital files, I just want to be sure the name (ex: test.zip) is placed as the Filename option.

 

If you need more information from me, just let me know.

Thanks in advance.

Share this post


Link to post
Share on other sites

that's correct, as it says in the intro, the download attributes have not been implemented. there are some older versions of EP that have integration with some odd download manager contributions available, look around the contribution page.

Share this post


Link to post
Share on other sites

I am using easy populate

when a customer places an order, I can not see the detail of the attributes that they order?

how can I look this infomation up or where is it stored in the system?

 

thank you

Share this post


Link to post
Share on other sites
I am using easy populate

when a customer places an order, I can not see the detail of the attributes that they order?

how can I look this infomation up or where is it stored in the system?

If you can see the attributes on the order page, then EP should be doing the job correctly. And if so, you should be checking your cart for problems. the data is in a combination of these tables:

products_attributes

products_options

products_options_values

products_options_values_to_products_options

Share this post


Link to post
Share on other sites

I read somewher that EasyPopulate can only import 300 records ata time?? Is this true?

 

We currently sell over 50,000 different products. I currently have them stored in another system where the data is in a MySQL table.

 

It looks like products are entered in a few tables (PRODUCTS, PRODUCT DESCRIPTION, ??others) to create 1 record

 

Please advise the best way to move this data into the catalog

 

Thanks ... Dan.m

Share this post


Link to post
Share on other sites

That may or may not be true. Depends on your web host environment. Your host needs to be osCommerce friendly. And that is, really osCommerce friendly, not just claim they are. Localhost database with minimal restrictions is a must.

Share this post


Link to post
Share on other sites

Upgraded EP to latest version and are now able to upload and download.

BUT, something strange happens:

 

Imported the file and most of it is correct.

One subcategorie holds 10 products and when checking the shop

there is 10 subcategories with exactly the same name holding 1 product each!

This happend to about 4-5 subcategories.

 

Example:

COMPUTERS

HARDWARE

FAN

FAN

FAN

FAN

FAN

Anyone have any ideas?

Share this post


Link to post
Share on other sites

Thank you for confirming the Filename attribute.

 

(Not sure I can post this here, but...) If there is anyone that would like to earn an extra $50+ for adding that feature in, I would be more than happy to talk with you. If it's a bigger job than I am thinking, we can discuss different pricing.

 

walkerbg at msn.com

 

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×