Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Easy Populate not splitting csv Files has anyone seen this? Will you please contact me if you have or is there someone who is willing to help and et paid? Thanks alexbezianis @ Hotmail.com

Share this post


Link to post
Share on other sites

Hey guys,

I have a quite strange problem with updating my database.

I have about 100 products in each 8 categories and I am uploading 1 category at a time.

The problem is when I import .csv file, it lists every product as 'updated' but in the store, it's only the last product in the csv that is added.

In one category I already had 32 products, so now if I add products in that, it remains just 32 by adding only the first 32 products,

In another where I already had 2 products, it remains 2 by replacing the old ones (or only alphabetically first 2 are added)

 

Any solution????

Share this post


Link to post
Share on other sites

Ok I have found my issues, but I have one more.

 

I Currently have 2 stores up one using another E-Commerce Package. What I want to do is basically link my images from my one store to my newest store. But when I add the web URL into the Images section of the CSV file and update the products I am getting no images. When I right click on the Image Holder for the properties I am getting this.

 

http://www.mynewsite.com/images/http://www...images/blahblah.

 

How can I do away with the first URL in this problem?

 

Thanks much in advance.

Share this post


Link to post
Share on other sites
HI Everyone,

 

New here and am seeking some help with Easy Populate. I am currently switching from Magento to OSCommerce as the addons are so much better and have heard that OSCommerce isn't as hard on the servers as Magento.

 

Anyways. I had a shop with over 3500 products and I have the export of all products from my old site in CSV format. I tried to upload the CSV file and it worked great, all products where uploaded. However my BIG BIG issue is it didn't create any sub-categories For instance Holidays is a Primary Cat, and it put all 400+ items into the Main Cat of Holidays instead of creating each Sub Cat and then placing the items in each specific Sub Cat. I have the Headers as such in my CSV:

 

v_categories_name_1_1

v_categories_name_1_2

v_categories_name_1_3

 

Here is my system Specs from the EP Page:

 

 

Any help on this would be greatly appreciated.

 

the primary category should go under "v_categories_name_1_1"

 

the sub category should go under "v_categories_name_2_1"

 

any category under the sub categories go under "v_categories_name_3_1" and so on

 

this is how my easy populate works and it is the same version as yours.

Share this post


Link to post
Share on other sites

Hi Adam,

 

Thanks for your reply. After tons more of searching I came across another thread similar and tried it and it worked. But have come across another issue with the images, LOL.

 

Thanks again very much appreciated. ;)

Share this post


Link to post
Share on other sites
Ok I have found my issues, but I have one more.

 

I Currently have 2 stores up one using another E-Commerce Package. What I want to do is basically link my images from my one store to my newest store. But when I add the web URL into the Images section of the CSV file and update the products I am getting no images. When I right click on the Image Holder for the properties I am getting this.

 

http://www.mynewsite.com/images/http://www...images/blahblah.

 

How can I do away with the first URL in this problem?

 

Thanks much in advance.

 

you need to put the images from your other site into the images folder on your new site.

 

then try just putting blahblah.jpg or blahblah.gif or whatever the correct extention is. just go into the images folder and find the exact name of the image and put it into your spreadsheet.

Share this post


Link to post
Share on other sites
Does anyone know what instructions I should give to my suppliers as they arn't sure how to get the required file that I need for easypopulate.

the file format is described in the docs of any of the versions v2.76d+

Share this post


Link to post
Share on other sites
you need to put the images from your other site into the images folder on your new site.

 

then try just putting blahblah.jpg or blahblah.gif or whatever the correct extention is. just go into the images folder and find the exact name of the image and put it into your spreadsheet.

 

 

Ok sounds good. THought maybe I could hyperlink them.

 

Now you say go into the spreadsheet and add the image names. I am not very spreadsheet savvy to say the least as I don't work with them all that often, but is there a quick and dirty way to modify 3600 items with just the image names without having to modify each line individually, LOL?

 

I have the following in the Images section now http:/www.myothersite.com/images/0000.jpg and so on.

 

Thanks much in advance.

Share this post


Link to post
Share on other sites
Hey guys,

I have a quite strange problem with updating my database.

I have about 100 products in each 8 categories and I am uploading 1 category at a time.

The problem is when I import .csv file, it lists every product as 'updated' but in the store, it's only the last product in the csv that is added.

In one category I already had 32 products, so now if I add products in that, it remains just 32 by adding only the first 32 products,

In another where I already had 2 products, it remains 2 by replacing the old ones (or only alphabetically first 2 are added)

 

Any solution????

I would highly recommend looking at the "how to ask for help" section of the v2.76h docs. If you are unable to provide that level of information, there isn't much anyone can do to resolve your issue based the the description alone.

Share this post


Link to post
Share on other sites
Ok I have found my issues, but I have one more.

 

I Currently have 2 stores up one using another E-Commerce Package. What I want to do is basically link my images from my one store to my newest store. But when I add the web URL into the Images section of the CSV file and update the products I am getting no images. When I right click on the Image Holder for the properties I am getting this.

 

http://www.mynewsite.com/images/http://www...images/blahblah.

 

How can I do away with the first URL in this problem?

 

Thanks much in advance.

 

it doesn't work that way. Its not a problem with EP, it is how the shop handles the image file names. This issue has been discussed in the recent past if you want lookup the reasons.

Share this post


Link to post
Share on other sites
Hi Adam,

 

Thanks for your reply. After tons more of searching I came across another thread similar and tried it and it worked. But have come across another issue with the images, LOL.

 

Thanks again very much appreciated. ;)

 

It shouldn't have taken tons of searching. All the information you needed about how to format the categories in EP are included in the docs. Please give them a read as the install instructions begged you to do.

Share this post


Link to post
Share on other sites
Ok sounds good. THought maybe I could hyperlink them.

 

Now you say go into the spreadsheet and add the image names. I am not very spreadsheet savvy to say the least as I don't work with them all that often, but is there a quick and dirty way to modify 3600 items with just the image names without having to modify each line individually, LOL?

 

I have the following in the Images section now http:/www.myothersite.com/images/0000.jpg and so on.

 

Thanks much in advance.

you might give the search and replace a try. search for "http:/www.myothersite.com/" replace with nothing.

Share this post


Link to post
Share on other sites

after looking through the code, i have found that easy populate does not work with the newer versions of the SPPC contribution. SPPC used to keep all the database information in the products_groups table, but there have been database changes in the new versions of SPPC. now SPPC keeps information in a couple of different tables. it doesn't use the products_groups table anymore. i hope someone fixes this in future versions of easy populate.

Share this post


Link to post
Share on other sites
after looking through the code, i have found that easy populate does not work with the newer versions of the SPPC contribution. SPPC used to keep all the database information in the products_groups table, but there have been database changes in the new versions of SPPC. now SPPC keeps information in a couple of different tables. it doesn't use the products_groups table anymore. i hope someone fixes this in future versions of easy populate.

the only way that will be fixed is when someone that is familiar with that version of SPPC takes the initiative to do so. As for myself, I'm only offering support here, so don't wait for me. :) So dive-in and donate the result for all!

Edited by surfalot

Share this post


Link to post
Share on other sites

Hello,

 

i installed the add-on as supposed. But when i want to create an EP-file to download nothing happens. What maybe wrong??

 

Greets

 

Imi

Share this post


Link to post
Share on other sites

The docs has a 90% list of know things that could go wrong. To list them all here would be a waste of time. I would suggest reading through the docs, when you reach the bottom, you will see a "how to ask for help" guide with information required to look into your issue. (v2.76h)

Share this post


Link to post
Share on other sites

(Sorry for providing insufficient info earlier, here's it)

 

Hey guys,

I have a quite strange problem with updating my database.

I have about 100 products in each 8 categories and I am uploading 1 category at a time.

The problem is when I import .csv file, it lists every product as 'updated' but in the store, it's only the last product in the csv that is added.

In one category I already had 32 products, so now if I add products in that, it remains just 32 by adding only the first 32 products,

In another category where I already had 2 products, it remains 2 by replacing the old ones (or only alphabetically first 2 are added).

So can't update anymore products, pls help!

 

I am using WinXP and MS Excel '07 to edit .csv

-----------------------------------------------

Settings and Info:

EP vers: 2.76h-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.28

HTTP: Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

DB: MySQL 5.1.30

PHP: 5.2.9 (Zend: 2.2.0)

 

Temp Directory:

/home/chandrik/public_html/catalog/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

-----------------------------------------------

Files : I tried this csv file http://www.chandrikamasala.com/catalog/temp/EP-misc.csv

also delimited txt file http://www.chandrikamasala.com/catalog/temp/EP-misc.txt

-----------------------------------------------

Any solution????

Share this post


Link to post
Share on other sites

you would want to re-read the section in the docs called: Requirements / Points to note BEFORE Installing

3rd bullet point.

 

then you may want to re-read the section called: Description of Columns

first bullet point.

Share this post


Link to post
Share on other sites

Hi

 

I have a field in the products_description table called short_desc_1 and while it appears that easypopulate is uploading all the fields when I ask it to this field is not appearing in the database

 

Here are a few lines of the updating of products in the database, the field I am having problems with is the 5th one in, everything else is fine.

 

| 636 | Active | Vinca mino | Lesser Per | | A mat-form | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Shrubs | | | | | | | | | | | | | | --none-- Updated

| 308 | Active | Vinca mino | Lesser Per | | A mat-form | | 0.20000000 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Shrubs | | | | | | | | | | | | | | --none-- Updated

| 309 | Active | Viola rivi | A dense sp | | A dense sp | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Perennials | | | | | | | | | | | | | | --none-- Updated

| 821 | Active | Viola soro | Northern W | | A stemless | | 3.95000004 | 1 | 0 | 30/11/1999 | 03/01/2010 | | Perennials | | | | | | | | | | | | | | --none-- Updated

 

Here is the Settings and Info

 

Settings & Info

 

EP vers: 2.76g-MS2

osCommerce Online Merchant v2.2 RC2a

OS:

HTTP: Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7d

DB: MySQL 4.1.19-standard-log

PHP: 4.4.1 (Zend: 1.3.0)

 

Temp Directory:

/home/c/h/charlesellis/public_html/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

Any advice would be greatly appreciated as I want to add more custom fields that I can then incorporate into the product_info.php page

 

Thanks

 

Mark Warren

Share this post


Link to post
Share on other sites

You should be looking at the docs and the settings for how to add fields to the products_description table. I think I documented it pretty well. You did read through all the settings like the docs begged you to, right? :)

Share this post


Link to post
Share on other sites
You should be looking at the docs and the settings for how to add fields to the products_description table. I think I documented it pretty well. You did read through all the settings like the docs begged you to, right? :)

 

I'm sure I did here is the following part of easypopulate.php that refers to the custom fields:-

 

$custom_fields[TABLE_PRODUCTS] = array(); // this line is used if you have no custom fields to import/export

$custom_fields[TABLE_PRODUCTS_DESCRIPTION] = array( 'short_desc_1' => 'Short Description'); // this line is used if you have no custom fields to import/export

 

I tried commenting out the first line but it threw up an error that is linked to this line:

 

foreach ($custom_fields[TABLE_PRODUCTS] as $key => $name) {

 

The error being:

Warning: Invalid argument supplied for foreach() in /home/c/h/charlesellis/public_html/admin/easypopulate.php on line 472 and each product throws out 2 error warnings about that line in the code at line 2213 and line2751.

 

I did read through the document at the beginning of the easypopulate file to make sure I had everything else right.

 

Can I supply any more info that might point to where I am going wrong.

 

Thanks

 

Mark

Share this post


Link to post
Share on other sites

Ooooh, then that should have been your first post, that is, demonstrating you understood the stuff and that you where making an effort. :)

 

so the field in the products_description table is: "short_desc_1" ?

Share this post


Link to post
Share on other sites

Hello,

 

<spam link removed>

 

and anyways, im wondering if anyone has had any php uploading problems with files over 5 megs?

 

i have a large database

 

thanks!

 

-drex

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites
That is correct

 

so then the column header for the field in your import is "v_short_desc_1_1" for english, correct?

 

if that is correct, then find the "how to ask for help" section of the docs and find the item you were missing in your first post and let me take a look at your import file.

Edited by surfalot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×