Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Can someone please help me? I've searched through Google and Yahoo! for days now trying to fix this. For some reason, when I upload my products through Easy Populate the descriptions are getting truncated after about 220 characters. Has anyone experienced this problem before? Does anyone now how to fix it??

Share this post


Link to post
Share on other sites
Can someone please help me? I've searched through Google and Yahoo! for days now trying to fix this. For some reason, when I upload my products through Easy Populate the descriptions are getting truncated after about 220 characters. Has anyone experienced this problem before? Does anyone now how to fix it??

easypopulate wouldn't be doing it. Since I don't know what version you are using, how you are using it, and what data you are trying, my only guess at this point would be that the description field in your database is doing it.

Share this post


Link to post
Share on other sites
easypopulate wouldn't be doing it. Since I don't know what version you are using, how you are using it, and what data you are trying, my only guess at this point would be that the description field in your database is doing it.

 

When I type a description in the Admin panel I can make the description as long as I want without any characters getting truncated. Only when I upload through EP is when my description gets truncated after about 220 characters. I looked at the description field in the database and it does not have a var limit set. What could be causing these characters to be truncated?

Share this post


Link to post
Share on other sites
When I type a description in the Admin panel I can make the description as long as I want without any characters getting truncated. Only when I upload through EP is when my description gets truncated after about 220 characters. I looked at the description field in the database and it does not have a var limit set. What could be causing these characters to be truncated?

 

Since I don't know what version you are using, how you are using it, and what data you are trying, my only guess at this point would be....

 

If you want to fill in the blanks, I could probably help further. If you are using one of the versions of EP that I have uploaded, there is a guide in each of the docs that describes all the information required to look into EP issues. It's at the bottom of the docs, called "how to ask for help"

Share this post


Link to post
Share on other sites
When I type a description in the Admin panel I can make the description as long as I want without any characters getting truncated. Only when I upload through EP is when my description gets truncated after about 220 characters. I looked at the description field in the database and it does not have a var limit set. What could be causing these characters to be truncated?

 

If you are copying and pasting the description from one excel file to your EP file, make sure that you copy the entire description because I had the same problem and that’s what I found. Some times it would only copy the first few lines, the rest would be left off. When you click on the cell that contains the description, it should show the description in the formula bar in excel. Copy from the formula bar and not the cell. Make sure your description file is .csv and not an excel worksheet.

 

Good Luck, Rickey

Edited by rickeyl

Share this post


Link to post
Share on other sites
If you are copying and pasting the description from one excel file to your EP file, make sure that you copy the entire description because I had the same problem and that’s what I found. Some times it would only copy the first few lines, the rest would be left off. When you click on the cell that contains the description, it should show the description in the formula bar in excel. Copy from the formula bar and not the cell. Make sure your description file is .csv and not an excel worksheet.

 

Good Luck, Rickey

 

Thank you for your response. Yes, the description fields in Excel show the entire description. I save the file as a .csv file and upload it through EP, but the descriptions are getting truncated in the database. I still can't figure out why the descriptions are getting truncated after about 220 characters...

Share this post


Link to post
Share on other sites
Thank you for your response. Yes, the description fields in Excel show the entire description. I save the file as a .csv file and upload it through EP, but the descriptions are getting truncated in the database. I still can't figure out why the descriptions are getting truncated after about 220 characters...

 

 

In your database, is the product_description table feild "type" set to text?

Check your database using PHPMyAdmin

Share this post


Link to post
Share on other sites
In your database, is the product_description table feild "type" set to text?

Check your database using PHPMyAdmin

 

Your product discription table should look like this:

 

 

CREATE TABLE IF NOT EXISTS `products_description` (
 `products_id` int(11) NOT NULL auto_increment,
 `language_id` int(11) NOT NULL default '1',
 `products_name` varchar(150) NOT NULL default '',
 `products_description` text,
 `products_url` varchar(255) default NULL,
 `products_viewed` int(5) default '0',
 `products_seo_url` varchar(100) NOT NULL default '',
 `products_head_title_tag` varchar(80) default NULL,
 `products_head_desc_tag` longtext,
 `products_head_keywords_tag` longtext,
 PRIMARY KEY  (`products_id`,`language_id`),
 KEY `products_name` (`products_name`)
) ENGINE=MyISAM  DEFAULT CHARSET=latin1 AUTO_INCREMENT=5634 ;

Share this post


Link to post
Share on other sites

Hello Everyone, and 'Thank You' in advance for any help on this matter. (Apologies if posted incorrectly)

 

From the OSC Administration > Catalog panel I've used the EP 'Download Model/Cost/Qty tab-delimited .txt file to edit' and have made cost & quantity changes to many products in the file, several of which had a zero (0) quantity. After making price and quantity changes then using 'Upload EP File' the data seems to upload fine however those products with a new quantity don't update the existing product models quantity but instead become a duplicate record (only having the 3 fields uploaded, 'v_products_model, v_products_price, v_products_quantity) in the database and so do not update the actual existing products models, such to say that the price & quantity of the products that are viewed in the cart are not updated. Downloading the EP file again shows duplicate 'v_products_model' entries, one a full entry with all fields and still a zero quantity (the viewed product), and the newly added entry of the same model number with the correct price and quantity.

 

How should I be updating just the price and quantity of the products. I'm not using the 'Download COMPLETE tab-delimited .txt file to edit' to make product changes. What am I doing wrong? Any Ideas are much appreciated.

 

I've searched for solutions but to no avail.

Many Thanks

JK

Share this post


Link to post
Share on other sites

Suspect you need to specify the category and sub categories on each part so it overwrites the existing record rather than creating a new one.

 

Try uploading a header line plus 1 product line from the complete file where you change the qty and cost.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Hello Everyone, and 'Thank You' in advance for any help on this matter. (Apologies if posted incorrectly)

 

From the OSC Administration > Catalog panel I've used the EP 'Download Model/Cost/Qty tab-delimited .txt file to edit' and have made cost & quantity changes to many products in the file, several of which had a zero (0) quantity. After making price and quantity changes then using 'Upload EP File' the data seems to upload fine however those products with a new quantity don't update the existing product models quantity but instead become a duplicate record (only having the 3 fields uploaded, 'v_products_model, v_products_price, v_products_quantity) in the database and so do not update the actual existing products models, such to say that the price & quantity of the products that are viewed in the cart are not updated. Downloading the EP file again shows duplicate 'v_products_model' entries, one a full entry with all fields and still a zero quantity (the viewed product), and the newly added entry of the same model number with the correct price and quantity.

 

How should I be updating just the price and quantity of the products. I'm not using the 'Download COMPLETE tab-delimited .txt file to edit' to make product changes. What am I doing wrong? Any Ideas are much appreciated.

 

I've searched for solutions but to no avail.

Many Thanks

JK

 

What I always do is download a complete .csv file for the catagory I need to update. I make the neccessary changes. I SAVE the file AGAIN so the changes are there. I go back to Admin/easypopulate.php and browse to the file I just edited. Once selected I go to the drop down box and select "Update Only" then click on insert into Database

Share this post


Link to post
Share on other sites
In your database, is the product_description table feild "type" set to text?

Check your database using PHPMyAdmin

Yes, it is set to text. And again, when I type the description through the admin panel it doesn't get truncated. It is only being truncated when uploaded through EP. Is there something I could have done wrong while installing EP? Also, I use a template that I got from Template Monster. Could that be causing the problem?

Share this post


Link to post
Share on other sites
Yes, it is set to text. And again, when I type the description through the admin panel it doesn't get truncated. It is only being truncated when uploaded through EP. Is there something I could have done wrong while installing EP? Also, I use a template that I got from Template Monster. Could that be causing the problem?

 

Since I don't know what version you are using, how you are using it, and what data you are trying, my only guess at this point would be....

 

If you want to fill in the blanks, I could probably help further. If you are using one of the versions of EP that I have uploaded, there is a guide in each of the docs that describes all the information required to look into EP issues. It's at the bottom of the docs, called "how to ask for help"

 

If you don't wish to help us help you, then you are destine to simply help yourself. Questions without offering any information about how you are using it (or even what version you are using) will most likely result in broad guesses that rarely offer any real solutions. ;)

Edited by surfalot

Share this post


Link to post
Share on other sites
Suspect you need to specify the category and sub categories

 

FYI, ep versions that I have uploaded matches the model number only.

Share this post


Link to post
Share on other sites
Hello,

 

Does anyone have EP working with SPPC Attributes contribution for groups?

 

Thank JR

 

I realize that this is an old post…

 

I saw it last night paging through for a solution. I recall seeing a few that were similar.

I realize this will bore most of you and probably even muster a chuckle. That’s OK ;)

 

That said, yes. I copied over a heavily modded store for SPPC and patched everything back afterwards- including Easy Populate (EP). All went well with just a few ‘head scratchers’. Why this method? Well, the sum of all other mods was less than the single mod for SPPC ;)~ Was it worth it? Absolutely! Great stuff…

 

A couple of helpers for noobs (like me):

1) ‘v_customer_group_id_N‘ means just that- it’s a number. The proper number is revealed in the ‘customers_group_id’ table. Here are some of mine from the .csv header…

v_products_price v_customer_group_id_1 v_customer_price_1 v_customer_group_id_2 v_customer_price_2 v_customer_group_id_3 v_customer_price_3

 

Where

v_products_price= the default price for ungrouped customers

v_customer_group_id_1= Cost, and v_customer_price_1= a coressponding amount

v_customer_group_id_2= Retail, and v_customer_price_2= a corresponding amount

v_customer_group_id_3= Sponsored, and v_customer_price_3= a corresponding amount

 

 

2) My groups (customers_group_id table) began at 0 (zero) and incremented up from there. The EP code indicated incrementing from (1).

I simply re-numbered my ‘groups’ in the ‘customers_group_id’ table

 

Yeah, yeah- I cheated and will probably go back and tweak the scripts properly… I may call up the id number and show it in the admin panel along with the front end tags as well (Cost (1), Retail (2), (Sponsored (3), etc…). just to avoid user issues once deployed.

 

Well, whether you got a chuckle or a little help, that’s my $.02 worth.

 

Greg

 

PS:

By listing mods across the top and file changes down the left in the spreadsheet flavor of your choice, managing mods on top of mods on top mods is quick and easy. Well, a little quicker and a little easier anyway…

Share this post


Link to post
Share on other sites
I realize that this is an old post…

 

I saw it last night paging through for a solution. I recall seeing a few that were similar.

I realize this will bore most of you and probably even muster a chuckle. That’s OK ;)

 

That said, yes. I copied over a heavily modded store for SPPC and patched everything back afterwards- including Easy Populate (EP). All went well with just a few ‘head scratchers’. Why this method? Well, the sum of all other mods was less than the single mod for SPPC ;)~ Was it worth it? Absolutely! Great stuff…

 

A couple of helpers for noobs (like me):

1) ‘v_customer_group_id_N‘ means just that- it’s a number. The proper number is revealed in the ‘customers_group_id’ table. Here are some of mine from the .csv header…

v_products_price v_customer_group_id_1 v_customer_price_1 v_customer_group_id_2 v_customer_price_2 v_customer_group_id_3 v_customer_price_3

 

Where

v_products_price= the default price for ungrouped customers

v_customer_group_id_1= Cost, and v_customer_price_1= a coressponding amount

v_customer_group_id_2= Retail, and v_customer_price_2= a corresponding amount

v_customer_group_id_3= Sponsored, and v_customer_price_3= a corresponding amount

 

 

2) My groups (customers_group_id table) began at 0 (zero) and incremented up from there. The EP code indicated incrementing from (1).

I simply re-numbered my ‘groups’ in the ‘customers_group_id’ table

 

Yeah, yeah- I cheated and will probably go back and tweak the scripts properly… I may call up the id number and show it in the admin panel along with the front end tags as well (Cost (1), Retail (2), (Sponsored (3), etc…). just to avoid user issues once deployed.

 

Well, whether you got a chuckle or a little help, that’s my $.02 worth.

 

Greg

 

PS:

By listing mods across the top and file changes down the left in the spreadsheet flavor of your choice, managing mods on top of mods on top mods is quick and easy. Well, a little quicker and a little easier anyway…

 

 

After thought:

If you follow my crazy logic and have some reason to include the ability to see 'Cost', it is probably best to ensure that the 'Cost' option is not your first id#- that makes it the default assignment when you edit a customer. In my case, 'Retail' is now #1.

Share this post


Link to post
Share on other sites

RE #2, it starts at zero because the original retail price default to the zero group in the SPPC versions I worked with.

 

All the rest didn't make sense to me, unless you are talking about a large number of mods to EP itself. SPPC is integrated in EP v2.76d-h, all that is required to activate it is to make the setting "true" in the EP settings.

Edited by surfalot

Share this post


Link to post
Share on other sites
RE #2, it starts at zero because the original retail price default to the zero group in the SPPC versions I worked with.

 

All the rest didn't make sense to me, unless you are talking about a large number of mods to EP itself. SPPC is integrated in EP v2.76d-h, all that is required to activate it is to make the setting "true" in the EP settings.

 

 

Hi Todd,

The zero thing was a none issue really- even for a noob. Just thought I would share with those that might be having trouble with it. Of course, it assumes that one followed the instructions and read everything provided and that all else is well... It did have me hung up for a moment, but again, just noob info for noob problem.

 

As for my 'mod' comment, I might have been more clear this way:

 

"That said, yes. I copied over a heavily modded store for SPPC (including EP) and just patched everything else back afterwards."

 

Sorry for the confusion...

 

Greg

Share this post


Link to post
Share on other sites

Hello, the only small problem I have been trying to import a file with about 200 products or so and every single one is for the same category but every time I upload it, only the first 15 or so go into the right category and the rest aren't placed in one at all.

Share this post


Link to post
Share on other sites

If you are using one of the versions of EP that I have uploaded, there is a guide in each of the docs that describes all the information required to look into EP issues. It's at the bottom of the docs, called "how to ask for help"

Share this post


Link to post
Share on other sites

Hi,

 

I've been trying to figure this out for sometime. I want to add some extra product attribute fields to my easypopulate.php file. I'm using easy populate with the sppc (Separate Prices Per Customer) contribution. I modified my product attribute table to include option sort order and option weight.

 

Easy Populate is working great. I can easily update all the standard fields using a csv file, but then I have to manually search for these extra product attribute fields in the admin area to update their values. The store has over 700 products, and I'm adding 10-20 products at a time, so this is a real pain to do.

 

Below are the headings from my product attribute tables in the admin area:

 

ID Product Name Option Name Option Value Sort Order Value Price Prefix Weight to add Hidden Action

 

The fields that I want to include in the easypopulate.php file are:

1. Sort Order

2. Weight to add

 

Is it possible to include these fields in the easypopulate.php file and if so, where do I start? I read in the documentation about how to add extra product fields, but there is nothing about adding extra product attribute fields. Any help would be appreciated.

 

Thanks,

Walt

Share this post


Link to post
Share on other sites

Hello, the only small problem I have been trying to import a file with about 200 products or so and every single one is for the same category but every time I upload it, only the first 15 or so go into the right category and the rest aren't placed in one at all.

 

 

 

Settings & Info

 

EP vers: 2.76h-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.9-78.0.8.ELsmp

HTTP: Apache

DB: MySQL 4.1.22

PHP: 4.3.9 (Zend: 1.3.0)

 

Temp Directory:

/home/e-smith/files/ibays/Primary/html/Catalog/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: true

Extra Fields: false

 

 

File I am trying to upload: http://concept.bz/Catalog/temp/ file:EP2009Feb17-2008.csv

 

I use Dreamweaver CS4 and Excel for Mac

Share this post


Link to post
Share on other sites
Hello, the only small problem I have been trying to import a file with about 200 products or so and every single one is for the same category but every time I upload it, only the first 15 or so go into the right category and the rest aren't placed in one at all

Are you sure about that file? I only see one product in it. The other file in the folder has a common problem. That is you have not added EOREOR as the last field of each row.

 

Be sure to read the special instructions for Mac users in the docs.

Share this post


Link to post
Share on other sites
Perfect, adding the eoreor thing must of done the trick. Thanks for the help. What is the use of adding the EOREOR?

 

different platforms (linux, Win, Mac) use different end-of-line characters (or combinations of characters) and in some situations the product descriptions will also contain an end of line char. So the only way to be absolutely sure when the end of the row is reached is to use some indicator like that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×