Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

I am unclear on whether or not Easy Populate will support a Master Products store. I have searched the forums, especially this thread and I can't find a definitive answer.

 

The best I could come up with is using the custom field capability available in this version of EP to add in the fields that are added to the product and product description tables by MP.

 

Will this do it? If so can someone give me a complete list of the new fields.

 

If not can someone tell me what to do to use EP with MP?

 

I'm using:

OSC v2.2rc2a

Master Products v1.2

Easy Populate v2.76g

 

Thanks for the help.

 

Joel

Share this post


Link to post
Share on other sites
I am unclear on whether or not Easy Populate will support a Master Products store. I have searched the forums, especially this thread and I can't find a definitive answer.

 

The best I could come up with is using the custom field capability available in this version of EP to add in the fields that are added to the product and product description tables by MP.

 

Will this do it? If so can someone give me a complete list of the new fields.

 

If not can someone tell me what to do to use EP with MP?

 

I'm using:

OSC v2.2rc2a

Master Products v1.2

Easy Populate v2.76g

 

Thanks for the help.

 

Joel

 

 

I assume that a Master Product store simply adds fields to the products and products_descriptions tables that don't exist in a vanilla OSC installation. If that's the case then EP will support that. Our products table is highly modified and all I did was add the extra fields to the EP extra fields section. I have not had very good luck with adding product_description fields with large stores, but it seems to work well with small stores. If the Master Products store has other table changes that you want easypopulate to fill then it will not do that unless you make some major modifications.

Edited by rs2k

Share this post


Link to post
Share on other sites
I do not see an easypopulate 2.76-MS2 available. Are you sure it's not something like 2.76g-MS2?

 

 

I checked again here is the place says

 

 

// Current EP Version

$curver = '2.76-MS2';

 

/*

 

Do I need to paste some portion of the codes for your review?

 

Thanks

Share this post


Link to post
Share on other sites
I assume that a Master Product store simply adds fields to the products and products_descriptions tables that don't exist in a vanilla OSC installation. If that's the case then EP will support that. Our products table is highly modified and all I did was add the extra fields to the EP extra fields section. I have not had very good luck with adding product_description fields with large stores, but it seems to work well with small stores. If the Master Products store has other table changes that you want easypopulate to fill then it will not do that unless you make some major modifications.

 

From looking at the sql that came with MP the only table changes are the addition of 3 fields to the products table.

 

I used this code in the EP extra fields section for that table (easypopulate.php) and had success on the export (easy part). We'll see how it goes on the import when I get a chance.

 

$custom_fields[TABLE_PRODUCTS] = array( 'products_master' => 'MASTER', 'products_master_status' => 'MASTER_STATUS', 'products_listing_status' => 'LISTING_STATUS' );

 

Thanks for the help.

 

Joel

Share this post


Link to post
Share on other sites
I checked again here is the place says

 

 

// Current EP Version

$curver = '2.76-MS2';

 

/*

 

Do I need to paste some portion of the codes for your review?

 

Thanks

 

 

If you have not made any more modifications to 2.76-MS2 I would recommend installing 2.76g-MS2 by surfalot. The header names are slightly different with 2.76g-MS2, but it supports 7 category levels. It also supports adding extra fields to the products and products_description tables.

Share this post


Link to post
Share on other sites

it actually supports an unlimited number of category levels, configurable in the settings.

Share this post


Link to post
Share on other sites

Hi i receive a feed from my supplier and for the image they give me a call function. Is there a way easy populate can use this call function to populate the image?

 

Here are a few examples:

 

http://afc.retail.sprint3.com/package/webS...ageCode=21.2647

http://afc.retail.sprint3.com/package/webS...mageCode=21.819

http://afc.retail.sprint3.com/package/webS...mageCode=21.809

http://afc.retail.sprint3.com/package/webS...ageCode=21.1754

 

Thanks

Share this post


Link to post
Share on other sites
Hi i receive a feed from my supplier and for the image they give me a call function. Is there a way easy populate can use this call function to populate the image?

 

Here are a few examples:

 

http://afc.retail.sprint3.com/package/webS...ageCode=21.2647

http://afc.retail.sprint3.com/package/webS...mageCode=21.819

http://afc.retail.sprint3.com/package/webS...mageCode=21.809

http://afc.retail.sprint3.com/package/webS...ageCode=21.1754

 

Thanks

 

What you really need to do is download all of those images to your server and then put the image locations into the easy populate file. You could have someone create a script to do all of that for you or even modify EP to do it on the fly, but it would take some custom programming to make it work. I did not find any contribution that does what you ask.

Share this post


Link to post
Share on other sites

Hi,

I had this working fine and did a successful upload after populating the sheet, but now when downloading to my computer add more info, my columns are not showing up at all. I'm sure this is something simple, any ideas? (Have opened in both tab and comma, no difference). I've used this before and had no problems, so I'm stumped.

 

Thanks,

Violet

Share this post


Link to post
Share on other sites

I am currently using EP I have had very good luck using this contribution, I am looking to add a blank text input box. This is so customers can add custom text to their items. please let me know if this possible

Share this post


Link to post
Share on other sites

Wrong thread to post in but try searching the contributions for bilder and be prepared to translate the install instructions from German.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
I had this working fine and did a successful upload after populating the sheet, but now when downloading to my computer add more info, my columns are not showing up at all. I'm sure this is something simple, any ideas? (Have opened in both tab and comma, no difference). I've used this before and had no problems, so I'm stumped.

have you opened it in a text editor?

As always for any contribution support, it would really be helpful if you gave some details about the version of the contribution you are using and the version of the osCommerce you are using. In my EP contributions there is a detailed explanation in the docs about what items to post when asking for help.

Share this post


Link to post
Share on other sites

I've opened it in both Open Office 2.2 Calc as well as the latest MS Excel. It was working fine before and I am certainly not blaming the mod, just curious if it's in the way I'm opening the file, or a setting in the spreadsheet program that I'm forgetting.... it was working great when I originally populated it. I have searched both these forums and Google for the missing columns problem. I have tried both setting the 'replace quotes' to true and false.

 

Here are the settings:

Settings & Info

EP vers: 2.76g-MS2

osCommerce 2.2-MS2

OS: Linux 2.4.22-1.2199.nptl

HTTP: Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

DB: MySQL 4.1.22-standard

PHP: 5.2.5 (Zend: 2.2.0)

 

Temp Directory:

/home/lenore2/public_html/cart/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: true

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: true

Category depth: 7

Enable attributes: false

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

have you opened it in a text editor?

As always for any contribution support, it would really be helpful if you gave some details about the version of the contribution you are using and the version of the osCommerce you are using. In my EP contributions there is a detailed explanation in the docs about what items to post when asking for help.

 

Thanks,

Violet

Share this post


Link to post
Share on other sites
What you really need to do is download all of those images to your server and then put the image locations into the easy populate file. You could have someone create a script to do all of that for you or even modify EP to do it on the fly, but it would take some custom programming to make it work. I did not find any contribution that does what you ask.

 

Thanks Ill have to sort something out.

Share this post


Link to post
Share on other sites
I've opened it in both Open Office 2.2 Calc as well as the latest MS Excel.

 

have you opened it in a text editor? like Notepad or Wordpad (windoz)?

Share this post


Link to post
Share on other sites

I hadn't, but just tried.. and the first few lines look like this:

"v_products_model","v_products_name_1","v_products_description_1","v_products_url_1","v_products_image","v_products_price","v_products_quantity","v_products_weight","v_date_avail","v_date_added","v_categories_image_1","v_categories_name_1_1","v_categories_image_2","v_categories_name_2_1","v_categories_image_3","v_categories_name_3_1","v_categories_image_4","v_categories_name_4_1","v_categories_image_5","v_categories_name_5_1","v_categories_image_6","v_categories_name_6_1","v_categories_image_7","v_categories_name_7_1","v_manufacturers_name","v_tax_class_title","v_status","EOREOR"
"JL-062-132","JL-062 - Colour 132","Size: 4-3/8 ", weight: 1/2 oz.",,"JL-062-132.jpg",8,1,0.5,"0000-00-00 00:00:00",08/01/08 12:42 AM,"JL-062-132.jpg","Crank Bait","JL-062-132.jpg","Alpha Diver",,,,,,,,,,,"Strike Pro","Taxable Goods","Active","EOREOR"
"JL-062-302","JL-062 - Colour 302","Size: 4-3/8 ", weight: 1/2 oz.",,"JL-062-302.jpg",8,1,0.5,"0000-00-00 00:00:00",08/05/08 10:48 PM,"JL-062-132.jpg","Crank Bait","JL-062-132.jpg","Alpha Diver",,,,,,,,,,,"Strike Pro","Taxable Goods","Active","EOREOR"
"JL-062-206","JL-062 - Colour 206","Size: 4-3/8 ", weight: 1/2 oz.",,"JL-062-206.jpg",8,1,0.5,"0000-00-00 00:00:00",08/05/08 10:49 PM,"JL-062-132.jpg","Crank Bait","JL-062-132.jpg","Alpha Diver",,,,,,,,,,,"Strike Pro","Taxable Goods","Active","EOREOR"
"JL-062-205","JL-062 - Colour 205","Size: 4-3/8 ", weight: 1/2 oz.",,"JL-062-205.jpg",8,1,0.5,"0000-00-00 00:00:00",08/05/08 10:49 PM,"JL-062-132.jpg","Crank Bait","JL-062-132.jpg","Alpha Diver",,,,,,,,,,,"Strike Pro","Taxable Goods","Active","EOREOR"

 

have you opened it in a text editor? like Notepad or Wordpad (windoz)?

Share this post


Link to post
Share on other sites
I hadn't, but just tried.. and the first few lines look like this:

 

On the surface it looks good to me. Maybe I don't understand what "but now when downloading to my computer add more info, my columns are not showing up at all" means.

Share this post


Link to post
Share on other sites

Hi im just wondering if anyone has modified there code to delete all the products in the catalog then run EP?

So what i would like is the user would select there file to upload then click 'insert into db' and it would run a quick query that deletes all the products in the catalog. I have made a custom field that is either 1 or 0, so if custom field = 0 then delete from db else do nothing, then run EP upload.

 

Mainly i would just like to know where to put this in the easypopulate.php file? I can probably do the coding myself but anyone has any better ideas help is much appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

One of my contributions/add-ons clears down products file or clears it down ready ready for production after testing.

 

Enjoy


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Mainly i would just like to know where to put this in the easypopulate.php file? I can probably do the coding myself but anyone has any better ideas help is much appreciated.

there is a comment that looks like this:

//*******************************
//*******************************
// UPLOAD AND INSERT FILE
//*******************************
//*******************************

place your code after the IF statement that follows.

Share this post


Link to post
Share on other sites

I have installed the most recent version of OSC and Easy Populate and Products Attributes. I have also installed Actual Attributes Price v1.5.

 

Everything appears to be working as intended but I want to allow customers to choose a case or half a case of product, see and receive a volume price.

 

When I use EP to populate the database it adds the price of the attribute to the product price. It inserts the + sign and adds the 2 prices together. I want to show both prices but charge only the attribute price.

 

This does not happen when I use the products attributes interface as I have removed the column that permits the use of the + or - . I can use this interface to remove the plus signs created by EP and get the correct prices to display etc. but I have more than 6000 products with at least one attribute each.

 

Does anyone know how I can stop the + from being inserted in EP without losing the attribute information in the process?

Share this post


Link to post
Share on other sites

I don't think you tried searching before posting. ;)

Put: Actual Attributes Price into the search field at the lower left of this page. Scroll to the bottom.

 

the line numbers may have changed, but the code didn't. So it should be easy enough to search for. Let me know if you can't find it.

Edited by surfalot

Share this post


Link to post
Share on other sites

Hey everyone.

 

I love the contribution.

 

I just have one question.

 

Currently, the products in my store do not have a model number assigned to them.

 

Is there any quick way that I can assign them a model number without having to manually edit each item?

 

Thanks a lot.

Share this post


Link to post
Share on other sites
Hey everyone.

 

I love the contribution.

 

I just have one question.

 

Currently, the products in my store do not have a model number assigned to them.

 

Is there any quick way that I can assign them a model number without having to manually edit each item?

 

Thanks a lot.

(ALWAYS BACKUP BEFORE USING)

(ALWAYS THOROUGHLY VERIFY AFTER THAT EVERYTHING WENT WELL)

 

you can probably do it a couple ways.

1) export, then use Excel to add a number sequence down the model column. Then clear the products tables in the db and then re-import.

2) add products_id to the configuration item that allows you to add fields to the products table (see the docs, or the top of the easypopulate.php file). Export, then change the products_id column header to the products model header. Delete the empty model number column. Then clear the products tables in the db and then re-import.

 

Method 2 will result in the model numbers matching the current products_id in the table.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×