Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

1) If i select the "normal" import option it will duplicate the categories 1100 to 3110evol and create the same phone model with 1 sub category and then the product?

 

but i thought EP wouldnt do that because it should know not to replace something which is already there?

 

to see an example of this if you click here http://www.mobim8.com/mobile-accs-nokia-c-57_65.html you will see the first two categories are the same Nokia 1100, however when you click on each link you will notice the orignal one has 14 sub categories, but the new one which has been created by my most recent EP import has one sub category which has one new product....

 

2) IF i select the "add new only" opttion before importing it for some reason only imports the FIRST product in the CSV file. and seems to ignore the rest of the items in there.

At first i thought this was because my product model's are the same but then i was told that because EP is intelligent enough to know that its the same product in the different category, that wouldnt be a problem?

2 things I'm thinking....

1) I see you have 20 configured for the model number size. make sure you have increased the field in the database also, if not, that will create duplicate products. TABLE: products, FIELD products_model

2) the reason your categories are being duplicated is that you have spaces after the category names in the import file, so EP is looking for "Nokia 1101 " instead of "Nokia 1101".

if cleaning all the cat names of spaces is a big hastle, you can make this change that may help:

find:

des.categories_name like '" . tep_db_input($thiscategoryname) . "'";

change to:

des.categories_name like '" . tep_db_input(trim($thiscategoryname)) . "'";

find:

'".(!empty($v_categories_name[$categorylevel][$lang['id']])?tep_db_input($v_categories_name[$categorylevel][$lang['id']]):'')."'

change to:

'".(!empty($v_categories_name[$categorylevel][$lang['id']])?tep_db_input(trim($v_categories_name[$categorylevel][$lang['id']])):'')."'

 

You item #2, that option will only add new products, will not update any existing ones. If you are absolutely SURE all the other products in that import where new, I'll look into that. I would have thought I would have heard from another if that option didn't work as it was suppose to.

let me know if you have issues beyond that.

Edited by surfalot

Share this post


Link to post
Share on other sites

I'm having an issue where it says "No products_model field in record. This line was not imported:" a bunch of times, with mostly blank parts where it says whats missing, and a few of the ones it lists actually have product model tags in the sql.

 

Also, it is not adding any of the things I add in. They way I tried to do it was copy the entire row of the item in the category that the new one is like, and pasting it, and change the model, and description.

 

I'm doing all this on a test store, and not my real store to prevent any loss, so its not a huge deal to mess with it, but its not adding anything I'm trying to add.

 

The way I tried to do it is this-

 

I downloaded the "Complete" EP file from the menu in my admin panel, opened it up in excep, and saved it as a Text (Tab Delimited) file, and then tried importing it in normal mode in the "Upload and Import EP File" box. And it does not show any of the new things I added to test... What am I doing wrong here?

 

I followed the installation guide carefully and put the 2 php files in the admin folder, and the other one in the other folder, wherever it was, so I'm pretty sure it was installed right since its relatively straight forward.

 

Any help would be greatly appreciated!

 

Thanks.

Share this post


Link to post
Share on other sites

Hi there - and thanks for the reply, appreciate your time,

ill try removing the spaces in the category names as soon as i can in the morning, but i have checked the phpmyadmin for the Product model field and yes i have defintely changed it to a varchar(20) for product_model - it shouldnt be a problem for me to remove the spaces after the category names and try again

 

will post back as soon as i have cleaned the data and re-imported with a good result (fingers crossed)

 

best regards

Share this post


Link to post
Share on other sites

I solved my problem by moving the individual shipping table values into the descriptions table and then changing all the files for the Individual shipping module that used TABLE_PRODUCTS_SHIPPING to TABLE_PRODUCTS_DESCRIPTION.

 

I then just added those new fields into the already provided area of easypopulate that had the custom descriptions and it works like a champ. Took less than 10 minutes to change the files as opposed to the hours I wasted trying to modify they easy populate file. I got close but gave up and took the easy way out.

 

Perhaps a nice update to the instructions for future release would be how to add additional tables to the mix.

 

This is great contribution that solved a huge problem for us.

Share this post


Link to post
Share on other sites
I'm having an issue where it says "No products_model field in record. This line was not imported:" a bunch of times, with mostly blank parts where it says whats missing, and a few of the ones it lists actually have product model tags in the sql.

 

please see the How to ask for Help section of the manual for additional details needed to offer an answer.

Share this post


Link to post
Share on other sites

My mistake... I knew I was forgetting to do something...

 

Heres all the info-

 

Settings & Info

 

EP vers: 2.76g-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.26.5-grsec

HTTP: Apache/1.3.41 (Unix) mod_log_bytes/1.2 mod_bwlimited/1.4 mod_auth_passthrough/1.8 FrontPage/5.0.2.2635 mod_ssl/2.8.31 OpenSSL/0.9.7a

DB: MySQL 5.0.51a-community

PHP: 5.2.5 (Zend: 2.2.0)

 

Temp Directory:

/home/racetec/public_html/storetest/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

Error Messages-

 

File uploaded.

Temporary filename: /tmp/phpUFwnqW

User filename: EP2008Sep24-2210.txt

Size: 477434

 

No products_model field in record. This line was not imported: | es) 400lb- | Bar/Plate | Powder coa | Stainless | High quali | Scotch Bri | Bar/Plate | Powder coa | Stainless | High quali

 

 

No products_model field in record. This line was not imported:

 

 

No products_model field in record. This line was not imported: | A4 2.8 199 | Bar/Plate | Powder coa | Stainless | High quali

 

 

No products_model field in record. This line was not imported: | (OFE Serie | Customizab

 

 

No products_model field in record. This line was not imported:

 

 

No products_model field in record. This line was not imported:

 

 

No products_model field in record. This line was not imported:

 

 

No products_model field in record. This line was not imported:

 

 

No products_model field in record. This line was not imported:

 

 

No products_model field in record. This line was not imported:

 

 

No products_model field in record. This line was not imported: | 3" 27 E93 | 100% OEM f

 

 

No products_model field in record. This line was not imported: | heel (Ligh | 100% OEM f | Authentic | DUKE DYNAM | OEM Fitmen | Fits both | UV protect | Re-use sto | Unique des | Using the | Highest-Ra | Smooth Rol | Easy Insta | Satisfacti | Double sid | Pack with | DUKE DYNAM | OEM Fitmen | Fits both | UV protect | Re-use sto | Unique des | Using the | Highest-Ra | Smooth Rol | Easy Insta | Satisfacti | Double sid

 

 

No products_model field in record. This line was not imported:

 

 

No products_model field in record. This line was not imported:

 

 

File-

http://racetec-us.com/storetest/temp/EP2008Sep24-2210.txt

 

Please help!

Share this post


Link to post
Share on other sites

The first thing I noticed with your import file is the missing end of line tag. The entire sheet (All lines) (including the header row) must end with a column of "EOREOR" (no quotes). It should be there in an export, it must remain for the import. See the manual section: VIII. EP FILE FORMAT

 

The second thing I noticed is that you are using a tab delimited format, and you have the Excel safe output: true. Although EP should be smart enough to pick-up your tab delimited format on import, it would work best if you used the CSV (MS-DOS) format, which is comma delimited (for english language US, UK, & AU). See step 4 of the VII. USAGE HELP section in the manual (for those with EP_EXCEL_SAFE_OUTPUT set to true).

 

other then that, I don't see any major formatting problems in the import.

Share this post


Link to post
Share on other sites
The first thing I noticed with your import file is the missing end of line tag. The entire sheet (All lines) (including the header row) must end with a column of "EOREOR" (no quotes). It should be there in an export, it must remain for the import. See the manual section: VIII. EP FILE FORMAT

 

The second thing I noticed is that you are using a tab delimited format, and you have the Excel safe output: true. Although EP should be smart enough to pick-up your tab delimited format on import, it would work best if you used the CSV (MS-DOS) format, which is comma delimited (for english language US, UK, & AU). See step 4 of the VII. USAGE HELP section in the manual (for those with EP_EXCEL_SAFE_OUTPUT set to true).

 

other then that, I don't see any major formatting problems in the import.

 

Whats interesting, is if I save anything other than the complete download of my database on EP, I see the "EOREOR" in the last column... but not this one. When opening the file in excel, I get some sort of message sometimes that says "File not Loaded Completely" Which I figured was disregardable since some of these programs like excel arent flawless with things like this.

Share this post


Link to post
Share on other sites
Whats interesting, is if I save anything other than the complete download of my database on EP, I see the "EOREOR" in the last column... but not this one. When opening the file in excel, I get some sort of message sometimes that says "File not Loaded Completely" Which I figured was disregardable since some of these programs like excel arent flawless with things like this.

 

that's not something to disregard for yourself or when posting your errors. Excel previous to v2007 can't handle more then 255 columns.

Share this post


Link to post
Share on other sites
The first thing I noticed with your import file is the missing end of line tag. The entire sheet (All lines) (including the header row) must end with a column of "EOREOR" (no quotes). It should be there in an export, it must remain for the import. See the manual section: VIII. EP FILE FORMAT

 

The second thing I noticed is that you are using a tab delimited format, and you have the Excel safe output: true. Although EP should be smart enough to pick-up your tab delimited format on import, it would work best if you used the CSV (MS-DOS) format, which is comma delimited (for english language US, UK, & AU). See step 4 of the VII. USAGE HELP section in the manual (for those with EP_EXCEL_SAFE_OUTPUT set to true).

 

other then that, I don't see any major formatting problems in the import.

 

Ok, so I changed the EP_EXCEL_SAFE_OUTPUT to "false" and used the text (tab deliminted) format again after using a different save method from EP so that it didnt exceed the 255 row maximum and It is still not working properly. I'm getting this now-

 

File uploaded.

Temporary filename: /tmp/phpaxmFZu

User filename: EP2008Sep25-1604.txt

Size: 149874

 

No products_model field in record. This line was not imported: | rything is | | | | | | |

 

No products_model field in record. This line was not imported: | | | | | | | |

 

No products_model field in record. This line was not imported: | =""mailto: | 100% OEM f | Authentic | 100% OEM f | Authentic | DUKE DYNAM | OEM Fitmen | Fits both | UV protect | Re-use sto | Unique des | Using the | Highest-Ra | Smooth Rol | Easy Insta | Satisfacti | Double sid | Pack with | DUKE DYNAM | OEM Fitmen | Fits both | UV protect | Re-use sto | Unique des | Using the | Highest-Ra | Smooth Rol | Easy Insta | Satisfacti | Double sid

 

No products_model field in record. This line was not imported: | | | | | | | |

Share this post


Link to post
Share on other sites

Have another read of the documentation, each product must have a unique value in the product model field.

 

If they are blank then you get this error message.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Have another read of the documentation, each product must have a unique value in the product model field.

 

If they are blank then you get this error message.

 

They all have product models. Some of them are the same because the product is linked to a few categories... would that cause a problem?

 

Aside from that though... things I attempt to add are still not showing up at all...

Edited by overspun

Share this post


Link to post
Share on other sites
Ok, so I changed the EP_EXCEL_SAFE_OUTPUT to "false" and used the text (tab deliminted) format again after using a different save method from EP so that it didnt exceed the 255 row maximum and It is still not working properly. I'm getting this now-

 

where's the file link? just can't help much if I don't know what you are doing.

As I said earlier, you'd be best off using the excel safe and CSV format, is there a reason why you wouldn't want to?

Edited by surfalot

Share this post


Link to post
Share on other sites

heya all, great contrib! but i was wondering how do i export all of the data, when opening it excel it will only display 126 products. what do other people use to export it? :blink:

Share this post


Link to post
Share on other sites

hello

 

i.m having a trouble while importing data from csv file with easy populate

 

it always give me this error

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '5, manufacturers_id = 5, ' at line 11

 

UPDATE products SET products_price='0.51', products_image=NULL, products_price2='0.31',products_ordered='0',products_short_1='',products_short_2='',products_short_3='',products_short_4='',products_short_5='',products_date_featured='1899-12-31', products_weight='', products_tax_class_id='', products_date_available='0000-00-00 00:00:00', products_date_added='2014-06-26 00:00:00', products_last_modified='2008-09-26 12:29:32', products_quantity = 752,5, manufacturers_id = 5, products_status = 1 WHERE (products_id = 121) LIMIT 1

 

[TEP STOP]

 

and i dunno what does it means

 

my sets are:

 

Settings & Info

 

EP vers: 2.76g-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.24.2-grsec

HTTP: Apache

DB: MySQL 4.1.22-standard

PHP: 4.4.7 (Zend: 1.3.0)

 

Temp Directory:

/home/elpept/public_html/loja/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 50

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 2

Enable attributes: false

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

 

 

i checker line 11 at files easypopulate.php and functions and theres nothing on it that could be solved:/

 

i´m stuck at here

 

any help apreciated

 

tks in advance

Share this post


Link to post
Share on other sites

sry for double post

 

i just found the answer

 

its a comma in the csv file in products qty

 

inestad of 752

its 752,5

 

so Ep reads that comma wrongly

 

;)

Share this post


Link to post
Share on other sites

two questions

 

1 why are all my items from my store post without any prices

 

and

 

2 all my items are posting 1 by 1 not in the headings I set up examples books instead of all books going in that catagory they post under seperate headings (does that make sense?)

Share this post


Link to post
Share on other sites
i.m having a trouble while importing data from csv file with easy populate

 

it always give me this error

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '5, manufacturers_id = 5, ' at line 11

check your import file for a product quantity of "752,5". should you have a comma in your quantity?

(sorry, should have read ahead)

Edited by surfalot

Share this post


Link to post
Share on other sites
heya all, great contrib! but i was wondering how do i export all of the data, when opening it excel it will only display 126 products. what do other people use to export it? :blink:

please take a look at the support section of the manual. instead of the a link to the import file, maybe a link to your result file.

Share this post


Link to post
Share on other sites
two questions

 

1 why are all my items from my store post without any prices

 

and

 

2 all my items are posting 1 by 1 not in the headings I set up examples books instead of all books going in that catagory they post under seperate headings (does that make sense?)

 

please see the Support section of the manual "how to ask for help" if you are using one of my versions of EP.

Share this post


Link to post
Share on other sites
where's the file link? just can't help much if I don't know what you are doing.

As I said earlier, you'd be best off using the excel safe and CSV format, is there a reason why you wouldn't want to?

 

I'm back to using Excel Safe mode, and I made a file that is in CSV DOS format as the directions said. I also noted something though... it has special instructions for Mac users, which I am... I dont understand exactly what to do though.

 

 

It says-

 

SPECIAL INSTRUCTIONS FOR MAC USERS

 

----------------------------------

 

 

 

Because of the differences in the end-of-line characters used by Apple's operating systems,

 

after editing and saving the tab-delimited file, you'll need to open the file in BBedit or

 

equivalent and change the line endings to "Unix".

 

 

 

When the product name contains characters with accents they are translated to other characters

 

in the database. Û, for example becomes A with a ~ and a superscript 3.

 

Saving the file as ISO-8859-1 solves the problem. (thanks for BenBogart for this!)

 

 

 

Here is the newest file I made-

 

http://racetec-us.com/storetest/temp/EP2008Sep25-1503.csv

 

 

and settings once more-

 

Settings & Info

 

EP vers: 2.76g-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.26.5-grsec

HTTP: Apache/1.3.41 (Unix) mod_log_bytes/1.2 mod_bwlimited/1.4 mod_auth_passthrough/1.8 FrontPage/5.0.2.2635 mod_ssl/2.8.31 OpenSSL/0.9.7a

DB: MySQL 5.0.51a-community

PHP: 5.2.5 (Zend: 2.2.0)

 

Temp Directory:

/home/racetec/public_html/storetest/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

Errors once more-

 

File uploaded.

Temporary filename: /tmp/phppyW76N

User filename: EP2008Sep25-1503.csv

Size: 146146

 

No products_model field in record. This line was not imported: | he lifespa | | | | | | |

 

No products_model field in record. This line was not imported: | | | | | | | |

 

No products_model field in record. This line was not imported: | iles. As a | 100% OEM f | Authentic | 100% OEM f | Authentic | DUKE DYNAM | OEM Fitmen | Fits both | UV protect | Re-use sto | Unique des | Using the | Highest-Ra | Smooth Rol | Easy Insta | Satisfacti | Double sid | Pack with | DUKE DYNAM | OEM Fitmen | Fits both | UV protect | Re-use sto | Unique des | Using the | Highest-Ra | Smooth Rol | Easy Insta | Satisfacti | Double sid

 

No products_model field in record. This line was not imported: | | | | | | | |

Share this post


Link to post
Share on other sites
I'm back to using Excel Safe mode, and I made a file that is in CSV DOS format as the directions said. I also noted something though... it has special instructions for Mac users, which I am... I dont understand exactly what to do though.

 

It says-

 

SPECIAL INSTRUCTIONS FOR MAC USERS

----------------------------------

Because of the differences in the end-of-line characters used by Apple's operating systems,

after editing and saving the tab-delimited file, you'll need to open the file in BBedit or

equivalent and change the line endings to "Unix".

 

When the product name contains characters with accents they are translated to other characters

in the database. Û, for example becomes A with a ~ and a superscript 3.

Saving the file as ISO-8859-1 solves the problem. (thanks for BenBogart for this!)

I got the same output you got using the file as is. I opened it in Windows Wordpad, clicked save, then it imported correctly. That tells me MAC help is correct. The MACs end of line character isn't right for Linus/Unix. You will need to find some software (TextWrangler) that is free, that will open and then save your import file as Linux/Unix format so that the end-of-line character is correct (not MAC). BBedit is not free, same company offers the TextWrangler for free (use google).

Share this post


Link to post
Share on other sites

Hello Surfalot,

 

I've exhausted all my options. I have a store with 20,000 products. So, I know I must split the files manually or with EP. I chose to split files by EP. However, I can't get Easypopulate to Upload and Split files as it should. I have EP_EXCEL_SAFE_OUTPUT set to true so I saved as CSV (MS-DOS) per the instructions. Now I've compared the paths of the temp folder In Tools>Files to the path in the error messages. I don't see anything obvious that I could be missing something.

 

(1) Here's the the paths of what's in the error messages and Tools->temp

 

Tools->temp: /home/discxpre/public_html/temp/

 

Error messages: Warning: fopen(/home/discxpre/public_html/temp/EP2008Sep28-0303.csv) [function.fopen]: failed to open stream: No such file or directory in /home/discxpre/public_html/admin/easypopulate.php on line 1223

 

Warning: fgets(): supplied argument is not a valid stream resource in /home/discxpre/public_html/admin/easypopulate.php on line 1226

Creating file EP_Split1.csv ...

Warning: fgets(): supplied argument is not a valid stream resource in /home/discxpre/public_html/admin/easypopulate.php on line 1236

Added 0 records and closing file...

 

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/discxpre/public_html/admin/easypopulate.php on line 1263

You can download your split files in the Tools/Files under /home/discxpre/public_html/temp/

 

(2) Here's a screenshot of my settings:

 

scrnshot.PNG

 

These are the problems I experienced when trying to upload and split with Easypopulate. If you need anyomre info, please let me know.

 

Thanks for reading and any help you provide.

Share this post


Link to post
Share on other sites
Hello Surfalot,

 

I've exhausted all my options. I have a store with 20,000 products. So, I know I must split the files manually or with EP. I chose to split files by EP. However, I can't get Easypopulate to Upload and Split files as it should. I have EP_EXCEL_SAFE_OUTPUT set to true so I saved as CSV (MS-DOS) per the instructions. Now I've compared the paths of the temp folder In Tools>Files to the path in the error messages. I don't see anything obvious that I could be missing something.

 

(1) Here's the the paths of what's in the error messages and Tools->temp

 

Tools->temp: /home/discxpre/public_html/temp/

 

Error messages: Warning: fopen(/home/discxpre/public_html/temp/EP2008Sep28-0303.csv) [function.fopen]: failed to open stream: No such file or directory in /home/discxpre/public_html/admin/easypopulate.php on line 1223

 

so what you are doing is clicking the Browse button under Upload and Split EP File, selecting the file and clicking the Split file button, RIGHT then this error appears?

 

What is the size of the file? Ask your host what the max PHP file upload and/or max PHP post size on your web space is.

 

with that number of products, I hope your database is a localhost database.

Share this post


Link to post
Share on other sites
I got the same output you got using the file as is. I opened it in Windows Wordpad, clicked save, then it imported correctly. That tells me MAC help is correct. The MACs end of line character isn't right for Linus/Unix. You will need to find some software (TextWrangler) that is free, that will open and then save your import file as Linux/Unix format so that the end-of-line character is correct (not MAC). BBedit is not free, same company offers the TextWrangler for free (use google).

 

So basically, all I would need to do is open the file that I posted as my import file in wordpad, and just save it from there and it'll work? No format changes or anything? I have another machine that is a PC that I can use for that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×