Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Now maybe you are beginning to grasp why I asked the question in the fist place :rolleyes: That is the WHOLE POINT of my initial post. See, reading AND thinking helps LOL! I would not have asked "Where are my products stored?" if I could see them in the SQL tables. I did look on the Moon but they weren't there either.

 

Anyway, I have fixed the problem and moved on.

 

I'm glad you fixed the problem.

EP contribution is the one of my favorite contributions and makes life easier at least in some cases, and it is absolutely MUST HAVE in most cases.


Computers777dotcom

Share this post


Link to post
Share on other sites

hey guys,

 

Newbie to osc and have just installed the easypopulate following the read me instructions however I am having some issues. When I upload/download/create a file in the easy populate admin section nothing happens. No errors, no files created, nothing - just a page refresh. I have altered the temp folder address and created temp folders with 777 permissions all over the site. Nothing changes.

 

I would be happier with errors because at least then I would have something work with. Could there be something on my server that would cause this contrib to not work at all?

 

Only error I found (not sure if it is related) is a "Call to a member function read() on a non-object in /home/domainname/public_html/shopping/admin/file_manager.php on line 185" when I try to view the file manager.

 

Any help would be great.

Thanks

Danni.

Share this post


Link to post
Share on other sites
If I can NOT download an SQL file with the 'error' how would you suggest I send you a set of data?

as described in the "how to ask for help" section of the manual as mentioned earlier. I would suggest rereading that section if you are going to post here for help in the future.

 

Please drop the drama queen act (the cop-outs, the NOT acceptables, and the WHOLE POINTs), it's simply not appropriate. If you find that someone taking time from their busy schedule to read your post and respond to you doesn't understand what you are describing, ask it another way (please see the forum rules). It won't help telling anyone to reread your original post if they didn't get it the first time. Obviously we're just not as bright as you.

Share this post


Link to post
Share on other sites
hey guys,

 

Newbie to osc and have just installed the easypopulate following the read me instructions however I am having some issues. When I upload/download/create a file in the easy populate admin section nothing happens. No errors, no files created, nothing - just a page refresh. I have altered the temp folder address and created temp folders with 777 permissions all over the site. Nothing changes.

 

I would be happier with errors because at least then I would have something work with. Could there be something on my server that would cause this contrib to not work at all?

 

Only error I found (not sure if it is related) is a "Call to a member function read() on a non-object in /home/domainname/public_html/shopping/admin/file_manager.php on line 185" when I try to view the file manager.

 

Any help would be great.

Thanks

Danni.

First, ask your host if PHP errors are turn on in your host space and make sure you know where to look if they are on.

 

Then, if it is one of the versions I uploaded, please see the "how to ask for help" section of the manual (very bottom) and post the requested details. you may xxx out any sensitive info in the temp folder detail if needed.

Edited by surfalot

Share this post


Link to post
Share on other sites

When I do a normal update through easy populate and the item is deleted, it also deletes the PHOTO.

 

Where do I do in the code so it does not delete the PHOTO. I may need it later, if I add the producted back.

 

BTW ... GREAT contribution !!! :rolleyes:

 

 

Thanks

Share this post


Link to post
Share on other sites

Hello,

 

First off this a fantastic constribution. I've got the latest version installed and it works great except for:

 

I created some some custom fields. One of the fields is a TEXT field.

 

When I edit the excel file and only put enough text in the field so it won't wrap to the second line in the cell, it works just dandy. However, when I add in more text and it wraps to the second line, I get the following error when uploading:

 

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 's Track and Field coaching staff, this series helps establish a solid fundamenta' at line 5

 

 

If I go throught the admin panel and add the text, it get's placed into the field just fine.

 

Is there a setting in the easypoplulate file that is limiting the number of characters for a custom field?

 

I'm stumped.

Share this post


Link to post
Share on other sites

I am using Easy Populate 2.76g-MS2. I am exporting my products into excel and change the paths they reside in. I then go to re-upload the saved excel spreadsheet containing all of my products. I select the file and select Update Only in the dropdown menu. Easy Populate is not changing the catagorie that my product resides in but instead creates a hole new product in the newly specified location in addition to leaving the original product in its original location.

 

Please Help

I need to upload over 4000 products and routinely change the catagories they reside in

 

thanks

cameront21

Share this post


Link to post
Share on other sites

Do you have single quotes in the text you are trying to import?

 

If so read the documentation that comes with the contribution. The solution is in there.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Cameron

 

If you want to delete an item you need to set the active flag on the product in the existing categories to inactive. If you read the documentation there may be some info on deleting products.

 

Where you change the categories you are effectivly saying create a new product with this information in this new location / categories.

 

G


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Cameron

 

If you want to delete an item you need to set the active flag on the product in the existing categories to inactive. If you read the documentation there may be some info on deleting products.

 

Where you change the categories you are effectivly saying create a new product with this information in this new location / categories.

 

G

 

 

I know how and where to set the FLAG to delete an item, what I do not want to do is not delete the photo in the thumbnail directory.

 

Any suggestions ? :blink:

Share this post


Link to post
Share on other sites
When I do a normal update through easy populate and the item is deleted, it also deletes the PHOTO.

 

Where do I do in the code so it does not delete the PHOTO. I may need it later, if I add the producted back.

 

BTW ... GREAT contribution !!! :rolleyes:

 

 

Thanks

EP uses the Stock osCommerce product remove, which removes the image. You would have to change the tep_remove_product(() function to change that behavior.

Share this post


Link to post
Share on other sites
Hello,

 

First off this a fantastic constribution. I've got the latest version installed and it works great except for:

 

I created some some custom fields. One of the fields is a TEXT field.

 

When I edit the excel file and only put enough text in the field so it won't wrap to the second line in the cell, it works just dandy. However, when I add in more text and it wraps to the second line, I get the following error when uploading:

 

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 's Track and Field coaching staff, this series helps establish a solid fundamenta' at line 5

 

 

If I go throught the admin panel and add the text, it get's placed into the field just fine.

 

Is there a setting in the easypoplulate file that is limiting the number of characters for a custom field?

 

I'm stumped.

if you use the 2.76g version, this should not be a problem.

Share this post


Link to post
Share on other sites
I am using Easy Populate 2.76g-MS2. I am exporting my products into excel and change the paths they reside in. I then go to re-upload the saved excel spreadsheet containing all of my products. I select the file and select Update Only in the dropdown menu. Easy Populate is not changing the catagorie that my product resides in but instead creates a hole new product in the newly specified location in addition to leaving the original product in its original location.

 

Please Help

I need to upload over 4000 products and routinely change the catagories they reside in

 

thanks

cameront21

What you describe is the default action. Otherwise we would not be able to add a product to multiple categories.

If you want to move a product from one category to another, you must use 2 rows for the product in the import sheet. The first row with that model number should have a status of: Delete (case sensitive). The second row would be as normal with the new category.

Share this post


Link to post
Share on other sites
EP uses the Stock osCommerce product remove, which removes the image. You would have to change the tep_remove_product(() function to change that behavior.

 

 

Where would I find that piece of code ?

Share this post


Link to post
Share on other sites

/admin/includes/functions/general.php


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Hi All,

I was wondering: has somebody of you come out with a way to upload with just ONE excel file both normal products field and extra fields?

 

I know that usually we all use easy populate & products extra fields together, but uploading 2 different excel files with only the product model in common it gets kind of tricky expecially for unexperienced endusers.

 

I had a look around on google, and found this post dated 2007 from a Zen Cart developer, that modified from scratch the DB to host another extra product field and then modified an old easy populate version to be used to upload every data with only a single file.

Basically, no product extra fields needed.

 

Here are the links; do you think this kind of patch is appliable to oscommerce as well?

 

ADDING PRODUCT FIELD: http://anekostudios.com/2007/04/25/my-first-zencart-tip/9/

 

EASYPOPULATE MOD: http://anekostudios.com/2007/05/01/editing-easy-populate/

Share this post


Link to post
Share on other sites

Everything is possible but the documentation covers what needs to be in a PEF EP update file and gives a sample, so I am quite happy to do it as a 2 phase operation.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Goeffry,

didn't want to criticize the present work or anything.

I'm perfectly happy as well in having this solution. It would be worse in not having.

But I think that many people in here have got customers that at least once have been requesting this kind of feature.

I think that the next level of PEF EP would really be a joint update, saving a lot of work by doing this.

I was here to start a dialogue over the intrest of evolving or not and already good product. Surely I don't have lots of PHP skills, but I would gladly do my part to help.

Share this post


Link to post
Share on other sites

I agree it would be nice to have but it is not the simplest of things to do.

 

Do you allow PEFs to be created by EP?

 

How do you cater for multi-lingual sites?

 

You would need to allow several columns

 

v_pef_key_value "New"

v_pef_key_language "All"

 

You cant match up on the field name as they can be the same in several languages.

 

I give up at this point.

 

What happens if a language is missed out?

 

Easier to pump it into an access db and spit out 2 files in the required EP format.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

You should also keep in mind the 255 column restriction in MS office previous to office 2007. Adding the extra fields to a spreadsheet that is already near that max would be even harder to handle.

Share this post


Link to post
Share on other sites

I've got this contribution installed and working great.

 

I've also got the individual shipping prices contribution installed and working.

 

I'm trying to get the easypopulate.php form to recognize the PRODUCTS_SHIPPING table for the individual shipping.

 

So far, I've been able to get it to actually output the CSV file with the new shipping fields however I'm having diffuculty getting to put the values into them. I've followed allong the code and seem to mess it up where it calls and updates the database table SHIPPING.

 

Is there any type of instructions out there for doing this or could someone point me to the lines I need to modify to get it to read the the data in the new table?

 

I've searched this subject but there are not real answers that have been posted.

Share this post


Link to post
Share on other sites

Hi folks,

 

Im using:

OSC V2.2 RC2

EP V2.76g MS2

 

I was wonderin if anyone could help on a problem i am having with EP - i have been trying to get it going for a couple of days but something funny is going on - i have installed EP and everything seems to be working fine, i am trying to input the same product into different categories in my site... so obviously the product model is the same since it is the same product, the file is structurally sound as i have downloaded an exported file from EP and worke from that as a guide. For some reason when i upload a file regardless of how many products (have tried from 2 - 200 per file) (in this case instances of the same product but in different categories - denoted by different image names and category names) the system only imports the FIRST product, and it doesnt generate any errors. the EOREOR header is ok and inplace.

 

Another weird issue was when i done this the first few times it duplicated all the categories and products that were already existing in the database (this was when i chose to use the "Normal" input option... what is the difference between "normal" "add new only" and "update only" option?

 

I have excel safe mode turned to true and am importing files as CSV (MS-DOS) files.

 

ALSO, has anyone used any products from here before http://conceptlaboratory.com/ or does anyone know of any other paid addons i can use to populate my store like the ones at concept labs?

 

Your time is appreciated as always

Best Regards

Share this post


Link to post
Share on other sites

please see the How to ask for Help section of the manual for additional details need to offer an answer.

Share this post


Link to post
Share on other sites

Hi again - sorry should have done this in the first place!

 

Settings & Info

 

EP vers: 2.76g-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.26.5-grsec

HTTP: Apache/1.3.41 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_ssl/2.8.31 OpenSSL/0.9.8h

DB: MySQL 5.0.51a-community

PHP: 5.2.6 (Zend: 2.2.0)

 

Temp Directory:

/home/mobim8c/public_html/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 20

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: true

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

im not recieving any error messages as such

 

A sample of the file i am trying to upload can be found here http://www.mobim8.com/temp/1100-3110e.csv

 

If i try to upload this file and import it into my database it will do some weird things.

 

You can see how my site is structured at the following URL http://www.mobim8.com

 

The category 1 is mobile accessories (Mobile Acc's)

Category 2 is the Manufacturer of the phone (Nokia)

Cat 3 is the model of the phone Nokia 1100, Nokia 1200 etc....

Cat 4 includes 14 different categories such as chargers, batteries,, handsfree kits etc...

 

What im trying to do is insert one product into many different phone models, particularly in the "parts & Spares" section which is in Category 4.

 

1) If i select the "normal" import option it will duplicate the categories 1100 to 3110evol and create the same phone model with 1 sub category and then the product?

 

but i thought EP wouldnt do that because it should know not to replace something which is already there?

 

to see an example of this if you click here http://www.mobim8.com/mobile-accs-nokia-c-57_65.html you will see the first two categories are the same Nokia 1100, however when you click on each link you will notice the orignal one has 14 sub categories, but the new one which has been created by my most recent EP import has one sub category which has one new product....

 

2) IF i select the "add new only" opttion before importing it for some reason only imports the FIRST product in the CSV file. and seems to ignore the rest of the items in there.

At first i thought this was because my product model's are the same but then i was told that because EP is intelligent enough to know that its the same product in the different category, that wouldnt be a problem?

 

i dont know if that is true

 

 

So if anyon can help i'd be grateful, as by the end of this week i should have had many thousands of products online !! :huh:

 

many thanks again

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×