Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Its not that I don't believe you that its not working (after image), I want to check what you are changing in the file to make sure you are doing it right. I want to see a virgin upload file (downloaded without any changes), and an upload file with your change in it, side-by-side.

Sorry i misunderstood your original post.

 

Here's the csv before, the item i'm changing is FMS-FMCL007P which is on line 42. Link

 

Here's the modified csv, to make things easier i've deleted all lines bar the one i've modified. The column modified is CF, i've changed this from blank to 0. Link

 

Screenshot of Easypopulate after upload

 

Screenshot of product after upload

 

Just a little extra info, easypopulate has worked for me when the number of products and attributes was smaller

 

Thanks


Scott

Share this post


Link to post
Share on other sites
Of course I'm bias, but my latest (surfalot v2.76g) is the most fixed and works with the RCx admin and register globals off.

 

Surfalot. Your version of EP V 2.76g -- to clarify is 2.2 rc2a compatible and you can use it with either registered globals on or off? You can set registered globals on or off in the PHP files of 2.76g?

 

That is all I need to know and I am off to coding. :rolleyes:

 

Leon

Share this post


Link to post
Share on other sites
Sorry i misunderstood your original post.

 

Here's the csv before, the item i'm changing is FMS-FMCL007P which is on line 42. Link

 

Here's the modified csv, to make things easier i've deleted all lines bar the one i've modified. The column modified is CF, i've changed this from blank to 0. Link

 

Screenshot of Easypopulate after upload

 

Screenshot of product after upload

 

Just a little extra info, easypopulate has worked for me when the number of products and attributes was smaller

 

Thanks

I'm sorry I can't do anything with this. You need to provide something that is complete. meaning I can start with your before, then test the after. This doesn't produce a complete product that can be tested.

 

Have you tried to make the change in the admin and export to see what changes? then duplicate the process?

Share this post


Link to post
Share on other sites
Surfalot. Your version of EP V 2.76g -- to clarify is 2.2 rc2a compatible and you can use it with either registered globals on or off? You can set registered globals on or off in the PHP files of 2.76g?

 

That is all I need to know and I am off to coding. :rolleyes:

 

Leon

correct

Share this post


Link to post
Share on other sites
I'm sorry I can't do anything with this. You need to provide something that is complete. meaning I can start with your before, then test the after. This doesn't produce a complete product that can be tested.

 

I really don't understand what you mean????

 

I've exported the attributes which is the first csv file (therefore this is my before), i've then modified them which is the second file (therefore my after). If this isn't a complete test then can you be a little more specific as to what is please.

 

Have you tried to make the change in the admin and export to see what changes? then duplicate the process?

 

Yes the files in my post show this. The "before" already has an attribute on the product which was added in admin right before i exported it.

 

Would a copy of my backup file help you?


Scott

Share this post


Link to post
Share on other sites
I really don't understand what you mean????

 

I've exported the attributes which is the first csv file (therefore this is my before), i've then modified them which is the second file (therefore my after). If this isn't a complete test then can you be a little more specific as to what is please.

 

Yes the files in my post show this. The "before" already has an attribute on the product which was added in admin right before i exported it.

 

Would a copy of my backup file help you?

 

exporting only the attributes is not a complete product. If I import it for a test, a complete product does not get created. I don't have your products in my test database. So providing me with an attributes only sheet doesn't help be reproduce the problem you have having. I need a complete product in the csv.

Share this post


Link to post
Share on other sites
exporting only the attributes is not a complete product. If I import it for a test, a complete product does not get created. I don't have your products in my test database. So providing me with an attributes only sheet doesn't help be reproduce the problem you have having. I need a complete product in the csv.

 

ok got ya, here's a complete list from just 1 brand then same as before but its a complete list not just attributes.

Link

 

Thanks


Scott

Share this post


Link to post
Share on other sites
Sorry, it's there now!

 

go into your admin -> Catalog -> Product Attributes.

 

look at Product Options.

 

Do you have an entry starting with ID 0 ? maybe the "Option Name" is blank?

Share this post


Link to post
Share on other sites

Hi,

I'm new to the community and absolutely love your latest contribution of Easy Populate, but I was wondering is there a way to add support for Separate Pricing Per Customer v4.21? If there is it would be more of a lifesaver and time saver. What I want is editable fields for customer group and price. Thank you for any help. :blush:

Share this post


Link to post
Share on other sites
Has anyone successfully used SPPC, EP and Master Products?

Yes!!

I have used SPPC succesfully, but it was almost a pain to install because I was new but here is how I did it.

 

step1:

If you already have categories and sub categories set up please perform a backup onto your hard drive.

 

step2:

Perform a fresh install of oscommerse.

 

step3:

perform a fresh install of sppc v421 by the directions given in install.html. If you have access to myphpadmin use it. First upload the files that came with the install package in the new installation folder using filezilla, this is a free ftp program and my favorite, or use the upload function on your website admin to upload the file catalog from the sppc new installation folder.

Second run sppc_v421_install.sql in phpmyadmin by clicking on osc_01 database to your left then running the inport function on the right side. Browse for sppc_v421_install.sql and press go. You should see a message that it was completed successfully.

 

step4:

hopefully it should work!! Even when you upload your backup! Good Luck! If it doesn't work :( with the back up I would suggest getting easy populate and creating your catalog from scratch.

Share this post


Link to post
Share on other sites
Hi,

I'm new to the community and absolutely love your latest contribution of Easy Populate, but I was wondering is there a way to add support for Separate Pricing Per Customer v4.21? If there is it would be more of a lifesaver and time saver. What I want is editable fields for customer group and price. Thank you for any help. :blush:

Hi,

Sorry for the misunderstanding I found out how to include the SPPC variables into my database

thankyou :D :D :D

 

For anyone else the answer is to find this line in easypopulate.php

 

define ('EP_SPPC_SUPPORT', false); and change it to

 

define ('EP_SPPC_SUPPORT', true);

 

that is it!

Share this post


Link to post
Share on other sites
go into your admin -> Catalog -> Product Attributes.

 

look at Product Options.

 

Do you have an entry starting with ID 0 ? maybe the "Option Name" is blank?

 

Yep had an ID 0 on the test site and thats the one i was taking the output from and then trying to upload it to the live site!

Deleted that and it all works fine now, thanks for your help!!!


Scott

Share this post


Link to post
Share on other sites

Hi,

 

I am now selling UK products inclusive of VAT @ 17.5%

 

I have the gross price of £8.49

 

When i add the tax rate of 17.5% in the admin panel my price changes to £9.98 (£8.49 + 17.5%)

 

I need the gross price to be £8.49 inclusive of VAT.

 

As I upload my 3000+ products via easypopulate it would appear that the v_products_price section in the csv file relates to the net price of the product.

 

How can I change this to relate to the gross price of the product.

 

In my admin panel I have the following settings:

 

Configuration>My Store>Display Prices with Tax>True

 

My Tax Rate is set at 17.5%

 

And in my epconfigure.php file within the admin folder i have changed the following line:

 

//**** Price includes tax? ****
// Set the v_price_with_tax to
// false if you want the price without the tax included
// true if you want the price to be defined for import & export including tax.
global $price_with_tax;
$price_with_tax = true;

 

This was originally set to false.

 

Hope someone can steer me in the right direction.

 

Thanks

D4

Edited by d4funky1

Share this post


Link to post
Share on other sites

Where are my products stored? I know it is a dumb question but I can not see them in phpMyAdmin.

 

I have uploaded 9 sample products to get a feel for using EP. The new products and categories are in the shop and in a downloaded complete .csv file.

 

Why can't I find them in phpMyAdmin? I can see the new entries in categories and categories_description but noting in products_to_categories, products or products_descriptions.

 

Settings & Info

 

EP vers: 2.76g-MS2

osCommerce Online Merchant v2.2 RC2a

OS: Linux 2.6.13.2z1-reseller

HTTP: Apache

DB: MySQL 4.1.18-log

PHP: 4.4.2 (Zend: 1.3.0)

 

Temp Directory:

/home/www/thestoreindevon.com/shop/tmp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: on

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: comma

Excel safe output: true

Preserve tab/cr/lf: false

Category depth: 7

Enable attributes: false

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

Paul.

Share this post


Link to post
Share on other sites
Where are my products stored? I know it is a dumb question but I can not see them in phpMyAdmin.

 

I have uploaded 9 sample products to get a feel for using EP. The new products and categories are in the shop and in a downloaded complete .csv file.

 

Why can't I find them in phpMyAdmin? I can see the new entries in categories and categories_description but noting in products_to_categories, products or products_descriptions.

 

 

 

Paul.

if you can see the product on the frontend and backend of the shop, as they should be, then I'd say everything is fine. There should entries in the products_to_categories.

Share this post


Link to post
Share on other sites
if you can see the product on the frontend and backend of the shop, as they should be, then I'd say everything is fine. There should entries in the products_to_categories.

 

Thanks for the response but - That is the easy cop out answer that brings heaps of problems later. Querying the database revealed omissions which is NOT acceptable. Create a building on dodgy foundations and spend the rest of your life fixing the cracks and propping up the bits about to fall down.

 

I built an SQL drop/create file with no records for all category and product tables. I then reloaded my test products. ALL check out correctly. I have no idea what the problem was so I will continue adding/monitoring.

Share this post


Link to post
Share on other sites

Hi there,

 

I need to have a product show up in more than one category but I don't want it duplicated, I want it linked. Is there a way to do that with this contribution?

Share this post


Link to post
Share on other sites
Hi there,

 

I need to have a product show up in more than one category but I don't want it duplicated, I want it linked. Is there a way to do that with this contribution?

 

just create a linked product in your admin, manually, then do a download and see how easypopulate does that. Then just do what EP does when it comes to upload!

Edited by pixclinic

Share this post


Link to post
Share on other sites
Thanks for the response but - That is the easy cop out answer that brings heaps of problems later. Querying the database revealed omissions which is NOT acceptable. Create a building on dodgy foundations and spend the rest of your life fixing the cracks and propping up the bits about to fall down.

 

I built an SQL drop/create file with no records for all category and product tables. I then reloaded my test products. ALL check out correctly. I have no idea what the problem was so I will continue adding/monitoring.

 

"cop out"? This code works fine on every installation/server combination that I have available. What would be acceptable to me is if you can't be more specific about the problem, you can resolve it and fix the code, then submit and support that code yourself. Otherwise, provide me a set of data and criteria in which I can reproduce the problem and quit the drama queen act. Please see the bottom of the docs, "how to ask for help" section.

Edited by surfalot

Share this post


Link to post
Share on other sites
Hi there,

 

I need to have a product show up in more than one category but I don't want it duplicated, I want it linked. Is there a way to do that with this contribution?

 

Fabulous answer pixclinic! :D that should work, but...

 

the short answer is yes, just duplicate the row in your import file and change only the category on the second line. EP will create a new link to the second category from the original product definition. There is no way to create duplicate products (with the same model number) with EP.

Share this post


Link to post
Share on other sites
"cop out"? This code works fine on every installation/server combination that I have available. What would be acceptable to me is if you can't be more specific about the problem, you can resolve it and fix the code, then submit and support that code yourself. Otherwise, provide me a set of data and criteria in which I can reproduce the problem and quit the drama queen act. Please see the bottom of the docs, "how to ask for help" section.

I suggest that you calm down and try re-reading my original question and subsequent post.

 

The problem was that the products appeared in the catalogue, admin pages and an EP download but did NOT show up in the SQL database by query or in a backup file. If I can NOT download an SQL file with the 'error' how would you suggest I send you a set of data?

 

If you took time to read instaed of throwing your toys out of your pram you would also have seen that I deleted and recreated the relevant tables as a reindexing failed to improve things. This has resolved the issue and the previous fault condition no longer exists. As to how/what corrupted the tables, I have no idea as the codition has not returned.

Share this post


Link to post
Share on other sites
I suggest that you calm down and try re-reading my original question and subsequent post.

 

The problem was that the products appeared in the catalogue, admin pages and an EP download but did NOT show up in the SQL database by query or in a backup file. If I can NOT download an SQL file with the 'error' how would you suggest I send you a set of data?

 

If you took time to read instaed of throwing your toys out of your pram you would also have seen that I deleted and recreated the relevant tables as a reindexing failed to improve things. This has resolved the issue and the previous fault condition no longer exists. As to how/what corrupted the tables, I have no idea as the codition has not returned.

 

GwilliamP,

 

you're kidding, right?

Where you think it stored f it "appeared in the catalogue, admin pages and an EP download"?

The only place is the database.

Check your sql queries, otherwise it looks like it stores somewhere on a moon...no offence...


Computers777dotcom

Share this post


Link to post
Share on other sites
GwilliamP,

 

you're kidding, right?

Where you think it stored f it "appeared in the catalogue, admin pages and an EP download"?

The only place is the database.

Check your sql queries, otherwise it looks like it stores somewhere on a moon...no offence...

 

Now maybe you are beginning to grasp why I asked the question in the fist place :rolleyes: That is the WHOLE POINT of my initial post. See, reading AND thinking helps LOL! I would not have asked "Where are my products stored?" if I could see them in the SQL tables. I did look on the Moon but they weren't there either.

 

Anyway, I have fixed the problem and moved on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×