Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

I had a feeling it might be to do with includes/boxes/categories.php but comparing my loaded one to the original shows only one change, at line 68, to try to get round corners left and right. Strangely enough that is the only one that does not work.

 

I have to say, this is a curious thing. Your "after" pics of the categories and categories_description tables are exactly as they should be, as are they in my test site. But why the cats only display when viewing the product is beyond me. I would like to view your site when the products are entered. No big deal, just curious. The SQL is fine, it should pull up the new root cat.

Share this post


Link to post
Share on other sites
I have to say, this is a curious thing. Your "after" pics of the categories and categories_description tables are exactly as they should be, as are they in my test site. But why the cats only display when viewing the product is beyond me. I would like to view your site when the products are entered. No big deal, just curious. The SQL is fine, it should pull up the new root cat.

 

Sorry for the long delay in replying. To be honest, I needed a break as this is driving me NUTS.

 

During my 'break' I formulated a step by step analysis plan to determine where things are going wrong. I had a feeling it was SQL related but my results now have me completely baffled.

 

The procedure;

1. Rollback to 080807-2 (WinRar archive containing entire site files and SQL backups)

• Completed.

2. After SQL reset, use SQL file to create reset of categories, categories_xxx, products & products_xxx only BEFORE test data is added.

• USD, EURO removed & GBP Character Left set to £

• Italian & German languages removed

• ALL non ‘example’ products and categories removed

• Backup created.

• reset_to_original_prodsandcats.sql file created

• Test categories infobox and Admin is working with current cats/prods - OK

3. Manually create the 3 categories and products.

• Test1 category sort order set to 0 as EP appeared to set to this on last test.

• Using Admin it is not possible to specify images/test1/A.jpg. For categories or products.

 

4. Backup SQL database and extract categories and products tables as above.

• manual_prodsandcats_created.sql created

 

5. Use DiffMerge to compare the files. Note differences.

• DiffMrce compare reset_to_original_prodsandcats.sql and manual_prodsandcats_created.sql, no unexpected changes.

6. Reset Cats & prods using reset_to_original_prodsandcats.sql.

• Done

• Check Admin and Shop

i. Admin OK – no testx cats or prods

ii. Shop – test1/test2/tes3 cats exist! No prods in cats but tree browseable without errors. WTF!!!

iii. WAIT 1 hour to see if some form of server side cacheing is causing the issue.

iv. after_reset_to_original_prodsandcats-1.sql created and searched for test cat/prods. NO INSTANCES FOUND.

 

So;

1- The SQL database contains no instances of the 3 manually created test categories or products

2 - Admin sees no instances of the 3 manually created test categories or products

3 - The shop (catalog) sees the test1/test2/test3 categories but no products

 

My understanding is that the client requests from the server that builds a response based on a query to the SQL server. If I have proved that the SQL server has no relevant testx data, HOW ON EARTH IS THAT POSSIBLE?

 

What I am now seeing is the reverse of my original problem - categories exist in SQL and Admin but are not visible to the client.

 

<edit> I have just noiced that the categories infobox is still showing the testx category tree which is still browsable to the test1/tes2/ets3 level but the breadcrumb in the bar above does not follow while in the testx tree. I does follow the demo products category level.</edit>

 

I can post links to the .sql files mentioned if anyone wishes but as they contain nothing unusual I have not bothered at this time.

 

The only good news I can see is that this all came to light before adding EP so EP is not the culprit. That being the case, should I take this elsewhere and if so can anyone (politely) tell me where to go?

 

Cheers,

 

Paul.

Edited by GwilliamP

Share this post


Link to post
Share on other sites

If you look in the actual tables the products will be there but not in a category.

 

The contribution Database Checking Tool v1.2 will show products not in a category.

 

echo "select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$value . "' and c.categories_id = cd.categories_id and cd.language_id='" . (int)$languages_id ."' order by sort_order, cd.categories_name";

 

added in to categories.php just before the sql is run will show the command being run.

 

One of my add ons, clear db, will clear down the products, cat, manus etc in one click.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Just to remove the possibility it is the category image path messing things up and to make everything unique I have changed the category names.

 

What happens when you upload this file?

 

v_products_model,v_products_name,v_products_description,v_products_url,
v_products_image,v_products_price,v_products_quantity,v_products_weight,v_date_av
ail,v_date_added,v_categories_image_1,v_categories_name_1,v_categories_image_2,v_
categories_name_2,v_categories_image_3,v_categories_name_3,v_categories_image_4,v
_categories_name_4,v_categories_image_5,v_categories_name_5,v_categories_image_6,
v_categories_name_6,v_categories_image_7,v_categories_name_7,v_manufacturers_name
,v_tax_class_title,v_status,EOREOR
test1,test1PN,PD_test1,,B.jpg,1.99,100,0.01,,,,aaa,,,,,,,,,,,,,man1,--none--,Active,EOREOR
test2,test2PN,PD_test2,,E.jpg,2.99,102,0.02,,,,bbb,,ddd,,,,,,,,,,,man2,--none--,Active,EOREOR
test3,test3PN,PD_test3,,I.jpg,3.99,103,0.03,,,,ccc,,eee,,fff,,,,,,,,,man3,--none--,Active,EOREOR


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
If you look in the actual tables the products will be there but not in a category.

 

The contribution Database Checking Tool v1.2 will show products not in a category.

 

echo "select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$value . "' and c.categories_id = cd.categories_id and cd.language_id='" . (int)$languages_id ."' order by sort_order, cd.categories_name";

 

added in to categories.php just before the sql is run will show the command being run.

 

One of my add ons, clear db, will clear down the products, cat, manus etc in one click.

Thank you for your reply.

 

Unfortunately the products are not in the tables at all. As said above, I have been using the Admin/Tools/Database Backup Manager to backup the complete database. I then FTP to local and extract all category and product entries. The last one I produced (after_reset_to_original_prodsandcats-1.sql) can be viewed here and a search for "test" will only show it in two product descriptions. There are no test(x) categories or products at all, linked or un-linked.

 

I tried adding the echo line above but can see no output. It does go in includes/boxes/categories.php doesn't it? I added it at about line 73 like this

// Next line added to dispaly the query being run
 echo "select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . (int)$value . "' and c.categories_id = cd.categories_id and cd.language_id='" . (int)$languages_id ."' order by sort_order, cd.categories_name";
// end of query display
 $categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '0' and c.categories_id = cd.categories_id and cd.language_id='" . (int)$languages_id ."' order by sort_order, cd.categories_name");

 

While I am sure that 'clear db' might be a handy tool I don't see how it will help my current situation. This is down to a few possible culprits. 1) osC - if this is a bug it needs finding and fixing. 2) Me - have I done something to cause this? If I have, I need shooting! 3) - Server setup - that could be fun as I will need to persuade my hosts that a) a problem exists and then b) that they need to do something about it.

 

If you want to see the store in its current odd behaviour, click here.

 

Paul.

 

Paul.

Share this post


Link to post
Share on other sites
Just to remove the possibility it is the category image path messing things up and to make everything unique I have changed the category names.

 

What happens when you upload this file?

 

v_products_model,v_products_name,v_products_description,v_products_url,
v_products_image,v_products_price,v_products_quantity,v_products_weight,v_date_a
v
ail,v_date_added,v_categories_image_1,v_categories_name_1,v_categories_image_2,v
_
categories_name_2,v_categories_image_3,v_categories_name_3,v_categories_image_4,
v
_categories_name_4,v_categories_image_5,v_categories_name_5,v_categories_image_6
,
v_categories_name_6,v_categories_image_7,v_categories_name_7,v_manufacturers_nam
e
,v_tax_class_title,v_status,EOREOR
test1,test1PN,PD_test1,,B.jpg,1.99,100,0.01,,,,aaa,,,,,,,,,,,,,man1,--none--,Active,EOREOR
test2,test2PN,PD_test2,,E.jpg,2.99,102,0.02,,,,bbb,,ddd,,,,,,,,,,,man2,--none--,Active,EOREOR
test3,test3PN,PD_test3,,I.jpg,3.99,103,0.03,,,,ccc,,eee,,fff,,,,,,,,,man3,--none--,Active,EOREOR

 

<edit> The product and category images are not using paths. Admin uploaded them from locat to its standard images folder.</edit>

 

I did not get to the stage of installing EP. I rolled back the install to before EP so I could do the above test procedure. I went that far back as I needed to prove I was bolting EP onto a stable engine. I was amazed at my findings as I was expecting to prove everything was OK, install EP and then find problems.

 

Paul.

Edited by GwilliamP

Share this post


Link to post
Share on other sites

This is the query being run

 

select c.categories_id, cd.categories_name, c.parent_id from categories c, categories_description cd where c.parent_id = '0' and c.categories_id = cd.categories_id and cd.language_id='1' order by sort_order, cd.categories_name

 

See your home page categories section. Looks good sql to me.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

There are no test categories in the shop now. Have you removed them in admin?

 

Tell a lie, test1/2/3 is there, no products in there though.

 

What happens when you add one in admin at the lowest level?

Edited by geoffreywalton

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
There are no test categories in the shop now. Have you removed them in admin?

 

Tell a lie, test1/2/3 is there, no products in there though.

 

What happens when you add one in admin at the lowest level?

Did you look at the .sql file (no test(x)). That is what it is running on now so where the heck do the results come from?

 

OK I briefly saw the query results (FF3) but it is behaving oddly at my end. IE7 is no better - sometimes displaying but mostly not. As for 'good SQL' I wouldn't know a good on if it jumped up and bit me.

 

<edit>Just spotted your request - off to add test3 in test3 category - BRB</edit>

<edit2>Problem - the test categories do not exist in admin so I can not add them. I could create a .sql to add them to products etc but that will take me a while as I nee dto sort out the structure PLUS the products_to_categories table can not refer to categories as there is no entry to refer to DooH!</edit>

Edited by GwilliamP

Share this post


Link to post
Share on other sites

Test1 appears in the category box if you click on catalog and disappears if you expand dvd movies.

 

Add a product in to the catalog in the test3 folder.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Test1 appears in the category box if you click on catalog and disappears if you expand dvd movies.

 

Add a product in to the catalog in the test3 folder.

I would add a product in to the catalogue in the test3 folder if I could BUT I can't see ANY of the test category folders in Admin - hence my <Edit2> post in my previous reply. If I create the categories it will destroy the environment that is causing the issue and I don't want to do that yet as I am still trying to find out what is causing it in the first place. Bit of a bugger isn't it?

 

Paul.

Share this post


Link to post
Share on other sites

Do both /includes/configure.php and admin/includes/configure.php point to the same db?

 

Have you used phpmyadmin to inspect manually the contents of the dbs?

Edited by geoffreywalton

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Do both /includes/configure.php and admin/includes/configure.php point to the same db?

 

Admin/includes/configure.php
 define('DB_SERVER', 'pdb1.runhosting.com');
 define('DB_SERVER_USERNAME', 'xxxxxxx');
 define('DB_SERVER_PASSWORD', 'xxxxxxx');
 define('DB_DATABASE', '131819_tsidshop');
 define('USE_PCONNECT', 'false');
 define('STORE_SESSIONS', 'mysql');

includes/configure.php
 define('DB_SERVER', 'pdb1.runhosting.com');
 define('DB_SERVER_USERNAME', 'xxxxxxx');
 define('DB_SERVER_PASSWORD', 'xxxxxxx');
 define('DB_DATABASE', '131819_tsidshop');
 define('USE_PCONNECT', 'false');
 define('STORE_SESSIONS', 'mysql');

Looks OK to me.

Share this post


Link to post
Share on other sites

Bu**er, another fine theory out the window.

 

The 3 categories Test 1/ 2 / 3 must be in the db for them to show on the shop. I'd check using phpmyadmin.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Back up your boxes/categories.php and try this in its' place

 

<?php
/*
 $Id: categories.php 1739 2007-12-20 00:52:16Z hpdl $

 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2003 osCommerce

 Released under the GNU General Public License

 Converted from spaghetti-code/table soup 2008
*/ 


/**
* take array from get_cats and build nested unordered list
* 
* @param  array  $tree Nested array of categories
* @param  int    $parent Parent id of previous iteration
* @return string $cat_string HTML nested unordered list
*/ 
function build_cats($tree, $parent = 0, $cat_string = ""){

foreach($tree as $key => $value){
	if($value['parent'] == $parent){
		if($parent != 0 && !$close_tag){
			$cat_string.= '<ul>';
			$close_tag = true;
		}

		$cat_string.= '<li><a href="'.
					  tep_href_link(FILENAME_DEFAULT, 'cPath='.$value['path']).
					  '">'.$value['name'].'</a>';		
		$cat_string = build_cats($tree, $key, $cat_string);
		$cat_string.= "</li>";
	}
}
if($close_tag){
	$cat_string.= '</ul>';
}
return $cat_string;
}

/**
* fetch categories from the database (recursively)
*  bonus points for figuring out where $languages_id is set
*  without resorting to grep.
* 
* @param  array  $tree 
* @param  int    $parent_id
* @param  string $path underscore separated path used by osCommerce
* @return array  $tree Nested array of sorted categories
*/
function get_cats($tree = array(), $parent_id = 0,$path = false){
global $languages_id;

$categories_query = tep_db_query("select c.categories_id, cd.categories_name, c.parent_id from " . TABLE_CATEGORIES . " c, " . TABLE_CATEGORIES_DESCRIPTION . " cd where c.parent_id = '" . $parent_id . "' and c.categories_id = cd.categories_id and cd.language_id='" . (int)$languages_id ."' order by sort_order, cd.categories_name");

if (tep_db_num_rows($categories_query)) {
	$new_path .= $path;
	while ($row = tep_db_fetch_array($categories_query)) {
		$path = $parent_id > 0 ? $new_path . '_' .$row['categories_id'] : $row['categories_id'];
		$tree[$row['categories_id']] = array('name'   => $row['categories_name'],
											 'parent' => $row['parent_id'],
											 'level'  => count(explode("_",$path)) - 1,
											 'path'   => $path,
											 'next_id'=> false);

		$tree = get_cats($tree,$row['categories_id'],$path);
	}
}
return $tree;
}

$tree = get_cats();
$cat_string = build_cats($tree);

?>
<tr>
	<td>

	<div class="new_info_box">
		<h1><?=BOX_HEADING_CATEGORIES?></h1>
		<div class="new_info_box_contents" style="padding:0;margin:0;">
			<ul class="nav">
				<?=$cat_string;?>
			</ul>
			<div style="clear:both"></div>
		</div>
	</div>

       </td>
   </tr>
<!-- categories_eof //-->


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Bu**er, another fine theory out the window.

 

The 3 categories Test 1/ 2 / 3 must be in the db for them to show on the shop. I'd check using phpmyadmin.

That is where I begin to fail as my abilities with phpmyadmin are absolutely minimal. I can click on a table and click on GO where it says "SELECT * FROM `products` WHERE 1" and look at the results but that is all.

 

There are 27 product. products_to_categories puts the 27 products in 20 categories. The 20 categories are the demo ones. Ther is NOTHING else that I can find.

 

If you can suggest a query I am willing to give it a go.

 

I did do an Export from phpmyadmin but that had no test entries anywhere either.

Share this post


Link to post
Share on other sites

Start phpmy admin

 

Select the db 131819_tsidshop in the left column.

 

All the table in the db should appear in the left column

 

Click on categories_description

 

click on browse on the tabs across the page.

 

Scroll dwn to find and "test" categories with a language ID of 1.

 

Note the category ids.

 

Click on categories

 

Click on browse

 

Do those category IDs exist


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Back up your boxes/categories.php and try this in its' place

 

<snip>

 

Done and loaded but I see no change. What should I be looking for. I 'dumped' it up there without reading the code because being a dumb NooB I just trusted you.

 

Paul.

Share this post


Link to post
Share on other sites

Or a bit of sql

 

select c.categories_id, cd.categories_name, c.parent_id, cd.language_id from categories c, categories_description cd where c.categories_id = cd.categories_id order by sort_order, cd.categories_name


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Just if category test 1 appeared every time.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Or a bit of sql

 

select c.categories_id, cd.categories_name, c.parent_id, cd.language_id from categories c, categories_description cd where c.categories_id = cd.categories_id order by sort_order, cd.categories_name

 

OK, I ran that and got the result below. It pastes as a mess but is sort of readable. I can post a screen shot if you want.

 

categories_id categories_name parent_id language_id

19 Action 2 1

10 Action 3 1

13 Cartoons 3 1

17 CDROM Drives 1 1

12 Comedy 3 1

15 Drama 3 1

4 Graphics Cards 1 1

8 Keyboards 1 1

16 Memory 1 1

9 Mice 1 1

6 Monitors 1 1

5 Printers 1 1

11 Science Fiction 3 1

18 Simulation 2 1

7 Speakers 1 1

20 Strategy 2 1

14 Thriller 3 1

1 Hardware 0 1

2 Software 0 1

3 DVD Movies 0 1

Share this post


Link to post
Share on other sites

Got me stumped, I'm off for a good nights sleep.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
Got me stumped, I'm off for a good nights sleep.

 

Makes 2 of us - THANK YOU for at least having a go.

 

Paul.

Share this post


Link to post
Share on other sites
Admin/includes/configure.php
  define('DB_SERVER', 'pdb1.runhosting.com');
  define('DB_SERVER_USERNAME', 'xxxxxxx');
  define('DB_SERVER_PASSWORD', 'xxxxxxx');
  define('DB_DATABASE', '131819_tsidshop');
  define('USE_PCONNECT', 'false');
  define('STORE_SESSIONS', 'mysql');

includes/configure.php
  define('DB_SERVER', 'pdb1.runhosting.com');
  define('DB_SERVER_USERNAME', 'xxxxxxx');
  define('DB_SERVER_PASSWORD', 'xxxxxxx');
  define('DB_DATABASE', '131819_tsidshop');
  define('USE_PCONNECT', 'false');
  define('STORE_SESSIONS', 'mysql');

Looks OK to me.

 

my recomendation to you would be to find a host with a localhost database and a 30 day trail period, see if you have the same trouble there. I would avoid (like the plague) hosts that use remote databases. Firstly because they REALLY slow down an osCommerce site and second because the really slow down EP if you have a sizable product list and thirdly the list goes on. As I said earlier, your "after" sql of the categories and categories_description tables in the original post were perfect. The only think that could have been failing you is the osCommerce code or your host configuration. It looks like you were using the default (unmodified) categories.php box, so I'm going out on a limb here and counting out the osCommerce code. That only leaves your host.

Share this post


Link to post
Share on other sites
my recomendation to you would be to find a host with a localhost database and a 30 day trail period, see if you have the same trouble there. I would avoid (like the plague) hosts that use remote databases. Firstly because they REALLY slow down an osCommerce site and second because the really slow down EP if you have a sizable product list and thirdly the list goes on. As I said earlier, your "after" sql of the categories and categories_description tables in the original post were perfect. The only think that could have been failing you is the osCommerce code or your host configuration. It looks like you were using the default (unmodified) categories.php box, so I'm going out on a limb here and counting out the osCommerce code. That only leaves your host.

Oh S**T! That is not the answer I wanted but somehow it is the answer I expected, hence one of my previous comments.

 

Clutching at a straw I just tried 'repair table' on all the category and product tables in the desperate hope that it might be a corrupted index that was causing it. No luck, the blasted test categories refuse to die.

 

This is so frustrating. Not being able to get decent debug information to see what is going on means I am unable to properly diagnose the source of the problem. I can see that the breadcrumb above the categories infobox never shows the test categories but the infobox does. There MUST be a difference in the code that will give me a clue to the source of this issue but my coding experience with PHP and SQL is so limited that I am as good as blind. Once I find the 'bug' I can evaluate my options. I can either put a patch in place to work around the issue or get the host to reconfigure but the latter is less likely.

 

Unfortunately I have committed more funds to this than my minimal/non-existent budget can afford so moving host presents insurmountable problems. Stuck between a rock and a hard place.

 

I will open a thread in 'Installation and Configuration' and see if I can get any help there as this is now off topic for this thread.

 

Thank you all for taking so much time with this issue and I am sorry if I caused unwarranted concerns about the EP contribution.

 

Best regards,

 

Paul.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×