Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

you didn't provide a whole lotta environment detail with your initial post does " latest osC w/admin login and register globals off" describe you? I know the register globals off is correct.

 

Sorry, I thought the assumption was so accurate I didn't need to supply the info...

 

We are running OSC 2.2 rc2 with register_globals off. I'm not sure what "with admin login" means, but we have to login to the admin function. Is there anything else that would help?

 

Cheers

Tony

Edited by tonyc2001

Share this post


Link to post
Share on other sites
Sorry, I thought the assumption was so accurate I didn't need to supply the info...

 

We are running OSC 2.2 rc2 with register_globals off. I'm not sure what "with admin login" means, but we have to login to the admin function. Is there anything else that would help?

 

Cheers

Tony

this should work for the new admin logins in the RC versions as well as the admin login contribution.

 

find

<form enctype="multipart/form-data" action="easypopulate.php?split=0" method="post">

 

find

<form enctype="multipart/form-data" action="easypopulate.php?split=1" method="post">

 

find

<form enctype="multipart/form-data" action="easypopulate.php" method="post">

 

find

<?php echo tep_draw_form('custom', 'easypopulate.php', 'id="custom"', 'get'); ?>

 

after each add

<?php if (defined('SID') && tep_not_null(SID)) { echo tep_draw_hidden_field(tep_session_name(), tep_session_id()); } ?>

 

this fixes the forms only. :) the quick links are not addressed. :(

Share this post


Link to post
Share on other sites

Which version of Easy Populate do I need to install with Oscommerce-2.2rc2a ? Or does it even matter?

Share this post


Link to post
Share on other sites
what is your PHP vers, database type & vers, Apache vers?, OS type and version?

 

there is nothing like a dump for php. if you server has been configured this way, you need to look for a file on your server in the same folder as easypopulate.php call "error_log". Or look at the end of the file EP is generating for the error.

 

I'm assuming you have tried to increase the max_execution_time and that your file generation is not stopping right at that max.

 

try this...

 

find in easypopulate.php...

//*******************************
//*******************************
// DOWNLOAD FILE (EXPORT)
//*******************************
//*******************************
if ( !empty($_GET['download']) && ($_GET['download'] == 'stream' or $_GET['download'] == 'activestream' or $_GET['download'] == 'tempfile') ){
 $filestring = ""; // this holds the csv file we want to download
 $result = tep_db_query($filelayout_sql);
 $row =  tep_db_fetch_array($result);

 

add just after that this...

	$counter = 1;
 while ($row){
   $row =  tep_db_fetch_array($result);
   $counter++;
 }
 echo 'records='.$counter;
 exit;

Run an export to the temp directory. It should just display a number, then quit.

remove that code and post the number of records.

Also, please time the execution and let me know the approximate time it took to come back with the number.

 

Hi,

 

here is the result

 

records=155012

 

it takes 5 sec.

Iam using

phpVersion = 4.4.1

mysql = 4.1.21

 

rgs

 

Jasi

Edited by Jasi

Share this post


Link to post
Share on other sites
Which version of Easy Populate do I need to install with Oscommerce-2.2rc2a ? Or does it even matter?

v2.76f rev 1 with the changes in post 6507, 6486, 6488.

Share this post


Link to post
Share on other sites
Hi,

 

here is the result

 

records=155012

 

it takes 5 sec.

Iam using

phpVersion = 4.4.1

mysql = 4.1.21

 

rgs

 

Jasi

no errors (ERROR_LOG file in your admin folder)? maybe at the bottom of the on-the-fly export file?

how big is the file that your get in size?

Is your MySQL server on the same machine or a remote ("localhost" in your configure.php)?

Edited by surfalot

Share this post


Link to post
Share on other sites
no errors (ERROR_LOG file in your admin folder)? maybe at the bottom of the on-the-fly export file?

how big is the file that your get in size?

Is your MySQL server on the same machine or a remote ("localhost" in your configure.php)?

do you get a different number of records exported if you choose price instead of name?

Share this post


Link to post
Share on other sites

Sorry no Error_log.

when i choose on the fly it starts with the download but the file is not complete and there are no error in the last line.

If i make the on the fly download once more the file is not the the same in size as the first try (sometime 16 MB, sometime only 10 MB). So everytime i start the on the fly download i get a different file size.

And the last line in the file is a different product.

The Mysql runs on the same maschine (localhost)

 

rgs

 

Jasi

Share this post


Link to post
Share on other sites
this should work for the new admin logins in the RC versions as well as the admin login contribution

 

...(code snippets removed)...

 

this fixes the forms only. :) the quick links are not addressed. :(

 

Surfalot, you're a genius! This worked a treat and within a few minutes our database has been converted over!

 

Now looking for an easy way to convert over the colors and sizes... Is there a summary anywhere on how to do this? We have about 50 each of color and size categories. From what I can see in the docs, this is going to make the matching of color and size categories to the respective products almost as tedious as hand entering it.

 

Thanks again! This is a great contribution...

 

Cheers

Tony

Share this post


Link to post
Share on other sites
Sorry no Error_log.

when i choose on the fly it starts with the download but the file is not complete and there are no error in the last line.

If i make the on the fly download once more the file is not the the same in size as the first try (sometime 16 MB, sometime only 10 MB). So everytime i start the on the fly download i get a different file size.

And the last line in the file is a different product.

The Mysql runs on the same maschine (localhost)

 

rgs

 

Jasi

so far the only thing I can come up with is maybe your host has a policy & enforcing scripts to prevent users from using too many resources such as memory and CPU usage. I do myself. But I've been able to dump 50-60MB files and that's only 8000 prods though. In that case the MySQL footprint is 80MB in memory and can see a 50-80% CPU usage on a small-med server.

 

If it were a script bug or data issue, usually it would blow up in the same place or after the same product is processed.

 

one thing to try is the setting in admin/includes/application_top.php:

error_reporting(E_ALL & ~E_NOTICE);

that setting switches off the "notice" level errors. those messages don't point out problematic errors in the code, but sometimes can provide clues when something is failing. to see all notice messages also, change to:

error_reporting(E_ALL);

Edited by surfalot

Share this post


Link to post
Share on other sites

Hello,

 

I'm having a little trouble with certain characters and the Easy Populate & Products Attributes module. I have version "2.76f-MS2 r1".

 

When the product name contains characters with accents they are translated to other characters in the database. ó, for example becomes A with a ~ and a superscript 3. It must have something to do with the character set but I how can I change what easypopulate uses as the character set for the uploaded file?

 

EDIT: More info

* Updating products manually the characters store with no problem.

* Excel Safe output is on

 

Any help appreciated.

Edited by benbogart

Share this post


Link to post
Share on other sites

Sorry for the post. I figured it out.

 

For others with the same problem my mistake was saving the csv with the UTF-8 character set from my mac. I think this has to do with the way mac handles precomposed characters. Saving the file as ISO-8859-1 solves the problem.

Share this post


Link to post
Share on other sites

I'm using EP_v2_76f_MS2 and I would like to know, how I can change the order in which items appears in the header of the .cvs file?

 

For example, I want v_products_image to be right after

v_products_name_1 as currently, that is not the case.

Share this post


Link to post
Share on other sites

This is a double post, I mistakenly put it in General Contrib Support the first time instead of here where I meant to, sorry!!

 

I had to update my previous version of EP (2.76c) as it quit working with the 1136 error starting all of a sudden and I could not seem to fix, updated to surfalots v2.76f and it works great but I need to add one custom product field (already exists in the tables) to the EP file. I did this with the old version no problem but 2.76f appears to use far more code in the file and I don't want to miss any lines as after a search in this forum I've read a couple posts saying old instructions for adding fields don't work now. So far I have mapped the following lines from the old easypopulate.php to the new one:

 

old line 1005 to new line 1491

old line 1320 to new line 1956

old line 1705 to new line 2385

old line 1741 to new line 2409 or close by

old line 1776 to new line 2456 or close by

 

also line 373 in the new file appears to list all default fields I assume I also add mine to this.

 

anyone able to confirm these are all that required to add fields? I've been reading forums for 2 days without finding anything concrete to work with. I don't use product attributes at all and don't intend to and chose this version of EP because it seems supported AND stable. I don't want to add any other contribs like product extra fields as there is only 1 custom field and modding ep seems far more logical than adding another contrib. Any direction with this much appreciated - thanks!

Share this post


Link to post
Share on other sites

I'm having a little trouble with Easy Populate and products that are in multiple parallel categories. I have a category "CDs", and in that category there are multiple categories for different artists. Some CDs have 2 artists so they are listed in two of the categories.

 

Problem 1: when I export the file I get two lines for the product if it is in 2 categories.

 

Problem 2: when importing the file with two lines for the categories the second category overwrites the first.

 

Is there a way to import export products to multiple parallel categories with easy populate??

 

Thanks in advance,

Share this post


Link to post
Share on other sites
I'm having a little trouble with Easy Populate and products that are in multiple parallel categories. I have a category "CDs", and in that category there are multiple categories for different artists. Some CDs have 2 artists so they are listed in two of the categories.

 

Problem 1: when I export the file I get two lines for the product if it is in 2 categories.

 

Problem 2: when importing the file with two lines for the categories the second category overwrites the first.

 

Is there a way to import export products to multiple parallel categories with easy populate??

 

Thanks in advance,

#1: expected

#2: also expected.

that is how you get the product in 2 cats. yes, it will overwrite the first product with

the info on the second line. So both lines must contain the same product info, just different

a category.

 

If a second row is found with the same Model number, but a different category,

then that product is added to the second cateogry and all product information is updated

again. This is similar to the osCommerce "Copy Product" using the Link Product method.

Share this post


Link to post
Share on other sites
I'm using EP_v2_76f_MS2 and I would like to know, how I can change the order in which items appears in the header of the .cvs file?

 

For example, I want v_products_image to be right after

v_products_name_1 as currently, that is not the case.

you have to rearrange the order of how the $filelayout array is assembled the code in the ep_create_filelayout() function. :thumbsup:

Share this post


Link to post
Share on other sites

I'll play a little and see if I can figure this out.

 

So If I upload a csv with only one line for the product, it will be deleted from other categories except the one listed on that line??

 

Thanks a lot for your help. Now I understand more clearly how it works.

Share this post


Link to post
Share on other sites
I'll play a little and see if I can figure this out.

 

So If I upload a csv with only one line for the product, it will be deleted from other categories except the one listed on that line??

 

Thanks a lot for your help. Now I understand more clearly how it works.

the default behavior is to add/update. No moves, no deletes, unless you use the Status column delete fuction (see the manual and previous discussions in the last few pages here)(please do a little reading before posting).

Share this post


Link to post
Share on other sites
the default behavior is to add/update. No moves, no deletes, unless you use the Status column delete fuction (see the manual and previous discussions in the last few pages here)(please do a little reading before posting).

 

I've done a lot of reading but have not found the answer so I posted. This thread has 66 pages of posts with about 100 posts per page. I'm not about to read over 6,000 posts to get answers to a question like this.

 

Thanks for your help.

Ben

Share this post


Link to post
Share on other sites
I've done a lot of reading but have not found the answer so I posted. This thread has 66 pages of posts with about 100 posts per page. I'm not about to read over 6,000 posts to get answers to a question like this.

 

Thanks for your help.

Ben

Good Man !! :D must have missed that discussion then, that was in just the last few pages. all we ask is a few pages just so we don't have to keep repeating current stuff. :thumbsup:

Share this post


Link to post
Share on other sites

Easy Populate 2.76g-MS2 (with attributes) released.

 

+ Added easy method to define custom fields to the "products" & "products_description" tables.

+ Added multi-language category support.

*****************************************************************************

** Exports from previous versions of EP will not work correctly since the **

** category header names have changed in this version !! **

*****************************************************************************

+ Added import selector to specify to only add new products from the import file, or

to only update products from the import file, or normal operation which does both.

Thanks to Paul H. for contributing this!

+ Fixed issues with RC1 & RC2 bouncing to login screen.

+ Fixed manufacturer not inserting when it contained quotes.

+ Fixed category not inserting when it contained quotes.

+ Fixed attributes not inserting when it contained quotes.

+ Fixed manufacturer not inserting with an error about:

1364 - Field 'manufacturers_url' doesn't have a default value

+ Adjusted flawed logic that checked for a quote at the end of an input field but not

the beginning, then removed first and last chars. Now checks the first and last chars

before trimming the field.

+ Added an alternate field parcer to the fgetcsv() PHP function which has had issues. Routine based

on posted code offered by Maynard. (slightly modified)

+ Some W3C issues reported by mauriziomagnino. Some not for backward compatibility with EP.

+ Added instructions for dealing with non-Roman character sets, such as cyrillic. (thanks to Richard!)

+ Changed Extra fields contribution addition to use Model Number instead of product ID. (thanks to geoffreywalton!)

Share this post


Link to post
Share on other sites

I become mad traing to understend example cvs file of easy populate ... the problem is Office for MAC !!!!

Using OpenOffice all become simple !!

 

 

Hope to help some other Mac user.

Share this post


Link to post
Share on other sites
you have to rearrange the order of how the $filelayout array is assembled the code in the ep_create_filelayout() function. :thumbsup:

 

Thank you surfalot I managed to make the necessary changes.

Share this post


Link to post
Share on other sites

What's the most number of lines anyone's been able to use Easy Populate to import at once?

 

I think my record is about 18,000... which, given that I have a 50,000 line .csv to import, doesn't help.

I've been trying to get some community support on that for months to no avail. But, anyway.

 

I'm curious to just -know- if anyone's been able to clear that 50,000 plateau, or something significantly larger?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×