Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

hi all,

 

I am using Easy Populate 2.76d-MS2 for while now,

most of my use is to update bulk stock quantity every day.

 

Until now I have to add

v_products_model v_products_quantity v_date_avail v_date_added v_status EOREOR

 

to update product quantity. I tried to only use followoing fields to update stock to make it bit quicker, but then it bring this stock as new product as well, means date added change itself to current date and time:

 

v_products_model v_products_quantity EOREOR

 

is there any way to update stock only required fields and every thing else remain same as when product first added.

 

 

Thanks

 

zee

Share this post


Link to post
Share on other sites

Seems like there is a small problem with quotes in product descriptions:

The code assumes that if the last character is a quote then there are bracketing quotes that have to be removed.

Actually, if the description has dimensions in it and the last character is a (") meaning inches, then the 'inch' character and the first character are removed.

 

I altered the code as follows:

// check if the last character is a quote;

// if it is, chop off the 1st and last character of the string.

if (substr($items[$i],-1) == '"' && substr($items[$i],0,1) == '"'){

 

 

Thanks for this great piece of work for which osCommerce would be useless to us.

 

chuckg

Share this post


Link to post
Share on other sites

I'm having a very strange issue.

 

No error messages, everything looks fine. Products are added to the database.

 

However products we modify with Easy Populate will reflect the changes in the front-end. Only if we make the changes from the backend.

 

We do have the multi-store contribution installed, does that render Easy Populate useless?

 

Thanks,

Justin

Share this post


Link to post
Share on other sites
Seems like there is a small problem with quotes in product descriptions:

The code assumes that if the last character is a quote then there are bracketing quotes that have to be removed.

Actually, if the description has dimensions in it and the last character is a (") meaning inches, then the 'inch' character and the first character are removed.

 

I altered the code as follows:

// check if the last character is a quote;

// if it is, chop off the 1st and last character of the string.

if (substr($items[$i],-1) == '"' && substr($items[$i],0,1) == '"'){

Thanks for this great piece of work for which osCommerce would be useless to us.

 

chuckg

 

Chuckg,

 

Where did you put this modification? I would love to fix this little bug.

 

TIA

Jeff

Share this post


Link to post
Share on other sites
Seems like there is a small problem with quotes in product descriptions:

The code assumes that if the last character is a quote then there are bracketing quotes that have to be removed.

Actually, if the description has dimensions in it and the last character is a (") meaning inches, then the 'inch' character and the first character are removed.

 

I altered the code as follows:

// check if the last character is a quote;

// if it is, chop off the 1st and last character of the string.

if (substr($items[$i],-1) == '"' && substr($items[$i],0,1) == '"'){

 

 

Thanks for this great piece of work for which osCommerce would be useless to us.

 

chuckg

would be good to include what version you are working with.

Share this post


Link to post
Share on other sites
I'm having a very strange issue.

 

No error messages, everything looks fine. Products are added to the database.

 

However products we modify with Easy Populate will reflect the changes in the front-end. Only if we make the changes from the backend.

 

We do have the multi-store contribution installed, does that render Easy Populate useless?

 

Thanks,

Justin

most likely. I don't know of any version that accommodates that contrib. but look through the versions available since I haven't used them all. there is most likely a field in the products table that will designate which store it is referencing.

Share this post


Link to post
Share on other sites
quick answers for people been redirected to the login page each time they use easypopulate

 

I had my admin/include/configure.php with a / at the end of the site url

 

comparing with another one, I decided to remove the trailing / and have no problems anymore

 

this is due to the sessions ID that is different if you have a trailing / or not, so play with it and you should find the best setting for your site

 

below is an example of my configure :

<?php
  define('HTTP_SERVER', 'http://www.myserver.com');
  define('HTTP_CATALOG_SERVER', 'http://www.myserver.com');
  define('HTTPS_CATALOG_SERVER', 'http://www.myserver.com');
  define('ENABLE_SSL_CATALOG', 'true');
  define('DIR_FS_DOCUMENT_ROOT', '/var/www/localhost/htdocs/myserver/');
  define('DIR_WS_ADMIN', '/admin/');
  define('DIR_FS_ADMIN', '/var/www/localhost/htdocs/myserver/admin/');
  define('DIR_WS_CATALOG', '/');
  define('DIR_FS_CATALOG', '/var/www/localhost/htdocs/myserver/');
  define('DIR_WS_IMAGES', 'images/');
  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');
  define('DIR_WS_INCLUDES', 'includes/');
  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');
  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
  //sets default image directories
  define('DIR_FS_MANUFACTURERS_IMAGES', 'manufacterers/');
  define('DIR_FS_CATEGORIES_IMAGES', 'categories/');
  define('DIR_FS_PRODUCTS_IMAGES', 'products/');
  //

  define('DB_SERVER', 'localhost');
  define('DB_SERVER_USERNAME', 'Iwillnottellyou');
  define('DB_SERVER_PASSWORD', 'iamnotcrazy');
  define('DB_DATABASE', 'osc22rc1');
  define('USE_PCONNECT', 'false');
  define('STORE_SESSIONS', 'mysql');
?>

 

anyone that want to improve on this, please fell free

 

reup

just one comment. DIR_FS_DOCUMENT_ROOT should not have a trailing slash either.

 

All config options above that in the file should not have a trailing slash. All config items below that should include a trailing slash. This is an issue that has still not been addressed in the osC installation (which is installing the config errantly with a trailing slash). Be careful though, some contributions are written to expect a trailing slash (also errantly)

Share this post


Link to post
Share on other sites

I have been using EasyPopulate for 3 years now and have thoroughly enjoyed it! I know what to change to make it do pretty much

whatever I want all by myself and it dependably responds! Thank you soooo Much for this wonderful code!

 

With a forced migration coming to php5 and register globals off, I decided it was time to rebuild my cart with a more recent

version of OsC - which led me to a shiny new EasyPopulate: Sadly, I am totally stopped - Only being a 'Very Adept Copy-and-Paste'

person, after two days of banging my head on my monitor, I must beg for your help....

 

I installed EP - and the register globals fix by jb 20040815 from a previous posting - and uncommented the php5 line....

 

EP vers: 2.76f-MS2 r1

Temp Dir:

/home/myaccount/public_html/shop/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: tab

Excel safe output: false

Preserve tab/cr/lf: false

Category depth: 3

Enable attributes: false

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

Every time I go to the EP page, the error log shows;

PHP Warning: Invalid argument supplied for foreach() in /home/myaccount/public_html/shop/admin/easypopulate.php on line 45

 

LIne 45 is the foreach line of the register globals fix by jb 20040815:

foreach( $HTTP_POST_FILES as $varname => $fileinfo ){

 

I can download just fine even though the error log shows the same Php Warning for line 45

but I can not upload at all:

Error 406 Not Acceptable An appropriate representation of the requested resource /shop/admin/easypopulate.php could not be found on this server.

Apache/1.3.39 Server at myaccount Port 80

 

The error log shows nothing.

 

If I take Out the register globals fix by jb 20040815, I get the same 406 page with NOTHING in the error log.

If I take out the Php5, I get the same 406 page with NOTHING in the error log.

If I take them Both out, I get the same 406 page with NOTHING in the error log.

 

I am at a loss where to go from here: I just can't imagine a store without EasyPopulate!

 

Help, please......

Share this post


Link to post
Share on other sites
I have been using EasyPopulate for 3 years now and have thoroughly enjoyed it! I know what to change to make it do pretty much

whatever I want all by myself and it dependably responds! Thank you soooo Much for this wonderful code!

 

With a forced migration coming to php5 and register globals off, I decided it was time to rebuild my cart with a more recent

version of OsC - which led me to a shiny new EasyPopulate: Sadly, I am totally stopped - Only being a 'Very Adept Copy-and-Paste'

person, after two days of banging my head on my monitor, I must beg for your help....

 

I installed EP - and the register globals fix by jb 20040815 from a previous posting - and uncommented the php5 line....

 

EP vers: 2.76f-MS2 r1

Temp Dir:

/home/myaccount/public_html/shop/temp/

Temp Dir is Writable

Magic Quotes is: off

register_globals is: off

Split files on: 300 records

Model Num Size: 12

Price with tax: false

Calc Precision: 2

Replace quotes: false

Field seperator: tab

Excel safe output: false

Preserve tab/cr/lf: false

Category depth: 3

Enable attributes: false

SEF Froogle URLS: false

More Pics: false

Unknown Pics: false

HTC: false

SPPC: false

Extra Fields: false

 

Every time I go to the EP page, the error log shows;

PHP Warning: Invalid argument supplied for foreach() in /home/myaccount/public_html/shop/admin/easypopulate.php on line 45

 

LIne 45 is the foreach line of the register globals fix by jb 20040815:

foreach( $HTTP_POST_FILES as $varname => $fileinfo ){

 

I can download just fine even though the error log shows the same Php Warning for line 45

but I can not upload at all:

Error 406 Not Acceptable An appropriate representation of the requested resource /shop/admin/easypopulate.php could not be found on this server.

Apache/1.3.39 Server at myaccount Port 80

 

The error log shows nothing.

 

If I take Out the register globals fix by jb 20040815, I get the same 406 page with NOTHING in the error log.

If I take out the Php5, I get the same 406 page with NOTHING in the error log.

If I take them Both out, I get the same 406 page with NOTHING in the error log.

 

I am at a loss where to go from here: I just can't imagine a store without EasyPopulate!

 

Help, please......

you shouldn't need any globals fix for my most recent version.

 

the 406 error sounds to me like your host is using mod_security. My guess it they have a ruleset that is not allowing the upload file to be saved as part of an HTTP POST. try to upload the file to your temp using ftp and process the file from there. if that works, ask your host to add an exception for the EP script in their mod_security rules so you can do the upload from the EP form. Assure them you have the page/form secured with a password in your shop's admin (as you should) so no unauthorized folks will be able to circumvent their mod_security server protection if they add the exception for you.

Share this post


Link to post
Share on other sites
you shouldn't need any globals fix for my most recent version.

 

the 406 error sounds to me like your host is using mod_security. My guess it they have a ruleset that is not allowing the upload file to be saved as part of an HTTP POST. try to upload the file to your temp using ftp and process the file from there. if that works, ask your host to add an exception for the EP script in their mod_security rules so you can do the upload from the EP form. Assure them you have the page/form secured with a password in your shop's admin (as you should) so no unauthorized folks will be able to circumvent their mod_security server protection if they add the exception for you.

 

Thank you:) I 'thought' you had covered the globals....

 

EP (jb globals fix removed) found the file I ftp'd into the Temp folder as you suggested.... but, I get the same Error when I clicked UpLoad.

 

Could this still be a server mod_security issue?

Share this post


Link to post
Share on other sites

Hey, everyone.

 

Easy Populate was a very useful program in getting the demonstration version of our osCommerce site up and running. Thank you!

 

But, we've run into a wall.

 

The site ( http://www.gameparlorstore.com/catalog ) has a few items set up for now for demonstration, but we've got a .csv file waiting to upload with a whopping 49,368 lines.

 

Tried, and it grossly violated the 334455352 or whatnot max size (8mb?). The error message mentioned about line 900 or so. Can we really only use .csv files with about a half-thousand lines per .csv file upload? Is there any way we can upload the entire 49,368 line file and import it successfully? As it stands, we only use five fields.. here's an example slice:

 

v_products_model	v_categories_name_1	v_products_name_1	v_products_price	v_products_quantity
FPR 10973	MIN-F	AeroTech 2 Record Sheets - Classic Battletech	29.99	3
IWM 20-639	MIN-F	KGA 28 Kanga Jump HovTank - Classic Battletech	8.95	2
IWM 20-685	MIN-F	Bandit Hovercraft (2) - Classic Battletech	11.95	2
IWM 20-785	MIN-F	Demolisher II Tank - Classic Battletech	9.5	2
IWM 20-975	MIN-F	Fafnir Mech - Classic Battletech	10.95	1
IWM 20-976	MIN-F	Hellion Mech - Classic Battletech	6.5	1
IWM 20-977	MIN-F	Cestus Mech - Classic Battletech	9.5	2
KEN 901	ZINE	SpaceHack #1 (of 3) -	2.99	3
PIN 1115	RPG	The Way of the Brave d20 - Hell on Earth, Deadlands	19.95	13
GOO 13-200	RPG	Fast Play Rules - (d20)Silver Age Sentinels	2.95	4
GOO 13-202	RPG	Character Record Folio - Silver Age Sentinels	4.95	3
GRR 1102	RPG	Wrath & Rage: Guidebook - To Orcs (d20)	16.95	2
JUL02 2227	COMIC	2000 AD #1308 -	3.25	1
AUG02 0265	COMIC	Black Sun #2 -	2.95	1
JUL02 0237	COMIC	American Century #19 -	2.75	1
AUG02 0290	COMIC	The Filth #5 (of 13) -	2.95	1
AUG02 0294	COMIC	Midnight Mass #7 (of 8) -	2.5	2

 

 

 

Now, since our online store has to share inventory with our local store, we need to update the online store with our local store's quantities as often as possible. That means frequent database updates.. with the size of the .csv, is that a realistic idea?

 

Also, we get new items in fairly often.. any way for an Easy Populate to tell what item codes are just getting quantity updates and what ones are new lines (that is, "new products" ?)

Share this post


Link to post
Share on other sites
Thank you:) I 'thought' you had covered the globals....

 

EP (jb globals fix removed) found the file I ftp'd into the Temp folder as you suggested.... but, I get the same Error when I clicked UpLoad.

 

Could this still be a server mod_security issue?

did you miss-type when you said you clicked "upload" ? you use the "Import EP file from Temp Dir" section when importing a file that has been FTPed to the temp folder.

Share this post


Link to post
Share on other sites
Hey, everyone.

 

Easy Populate was a very useful program in getting the demonstration version of our osCommerce site up and running. Thank you!

 

But, we've run into a wall.

 

The site ( http://www.gameparlorstore.com/catalog ) has a few items set up for now for demonstration, but we've got a .csv file waiting to upload with a whopping 49,368 lines.

 

Tried, and it grossly violated the 334455352 or whatnot max size (8mb?). The error message mentioned about line 900 or so. Can we really only use .csv files with about a half-thousand lines per .csv file upload? Is there any way we can upload the entire 49,368 line file and import it successfully? As it stands, we only use five fields.. here's an example slice:

 

v_products_model	v_categories_name_1	v_products_name_1	v_products_price	v_products_quantity
FPR 10973	MIN-F	AeroTech 2 Record Sheets - Classic Battletech	29.99	3
IWM 20-639	MIN-F	KGA 28 Kanga Jump HovTank - Classic Battletech	8.95	2
IWM 20-685	MIN-F	Bandit Hovercraft (2) - Classic Battletech	11.95	2
IWM 20-785	MIN-F	Demolisher II Tank - Classic Battletech	9.5	2
IWM 20-975	MIN-F	Fafnir Mech - Classic Battletech	10.95	1
IWM 20-976	MIN-F	Hellion Mech - Classic Battletech	6.5	1
IWM 20-977	MIN-F	Cestus Mech - Classic Battletech	9.5	2
KEN 901	ZINE	SpaceHack #1 (of 3) -	2.99	3
PIN 1115	RPG	The Way of the Brave d20 - Hell on Earth, Deadlands	19.95	13
GOO 13-200	RPG	Fast Play Rules - (d20)Silver Age Sentinels	2.95	4
GOO 13-202	RPG	Character Record Folio - Silver Age Sentinels	4.95	3
GRR 1102	RPG	Wrath & Rage: Guidebook - To Orcs (d20)	16.95	2
JUL02 2227	COMIC	2000 AD #1308 -	3.25	1
AUG02 0265	COMIC	Black Sun #2 -	2.95	1
JUL02 0237	COMIC	American Century #19 -	2.75	1
AUG02 0290	COMIC	The Filth #5 (of 13) -	2.95	1
AUG02 0294	COMIC	Midnight Mass #7 (of 8) -	2.5	2

 

 

 

Now, since our online store has to share inventory with our local store, we need to update the online store with our local store's quantities as often as possible. That means frequent database updates.. with the size of the .csv, is that a realistic idea?

 

Also, we get new items in fairly often.. any way for an Easy Populate to tell what item codes are just getting quantity updates and what ones are new lines (that is, "new products" ?)

I would suggest re-reading the Usage Help section of the docs. Also, as asked in the readme, read through configurations options at the top of the easypopulate.php file for additional options in dealing with large files in large shops. If you need additional explanation of these functions let me know specifically what you are having trouble with.

Share this post


Link to post
Share on other sites
I would suggest re-reading the Usage Help section of the docs. Also, as asked in the readme, read through configurations options at the top of the easypopulate.php file for additional options in dealing with large files in large shops. If you need additional explanation of these functions let me know specifically what you are having trouble with.

 

I read through the easypopulate.php file but didn't find any variables that would help. Maybe I'm missing something?

I also didn't see anything in the osCommerce variables. (I'm possibly blind, but much more likely dumb.)

 

Do I need to make adjustments to php.ini for such a large file, maybe? Timeout extension, larger memory, etc.

 

And, has anyone else tried using EasyPopulate to import such a hefty database? (~50,000 items) What was your experience like?

Share this post


Link to post
Share on other sites
I read through the easypopulate.php file but didn't find any variables that would help. Maybe I'm missing something?

I also didn't see anything in the osCommerce variables. (I'm possibly blind, but much more likely dumb.)

 

Do I need to make adjustments to php.ini for such a large file, maybe? Timeout extension, larger memory, etc.

 

And, has anyone else tried using EasyPopulate to import such a hefty database? (~50,000 items) What was your experience like?

yes. there is help for large files in the Usage Help section and at the very top of the easypopulate file just after the temp folder config. Need to read a little more carefully.

Edited by surfalot

Share this post


Link to post
Share on other sites

Please read the EasyPopulate_Manual.txt file Usage Help section

Share this post


Link to post
Share on other sites

Can anybovy help me out here.

 

I am getting the following error.

 

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ',' or ';' in D:\hshome\eoinheal\bopselectronics.com\admin\easypopulate.php on line 659

 

I am not at this very long and still comming to terms with PHP, but learning fast. Its a wonderful language is PHP :D

 

Anyway, I did everything the instruction in the PDF installation guild told me to do and I am now stuck here with this error.

This is the most complex thing I have had to do yet so I though I should ask the experts before I screw it all up and have to restart again.


If it does not kill you don't worry about it -Stay Positive!

Share this post


Link to post
Share on other sites

This is the line its referring to:

 

if ($localfile){

// move the file to where we can work with it

$file = tep_get_uploaded_file('usrfl'); $attribute_options_query = "select distinct products_options_id from " . TABLE_PRODUCTS_OPTIONS . " order by products_options_id";

 

$attribute_options_values = tep_db_query($attribute_options_query);

 

$attribute_options_count = 1;

//while ($attribute_options = tep_db_fetch_array($attribute_options_values)){

if (is_uploaded_file($file['tmp_name'])) {

tep_copy_uploaded_file($file, DIR_FS_DOCUMENT_ROOT . $tempdir);

}

 

echo "<p class=smallText>";

echo FILENAME ': ' . $localfile . "<br>";

 

// get the entire file into an array

$readed = file(DIR_FS_DOCUMENT_ROOT . $tempdir . $localfile);

}

Edited by dropbop085

If it does not kill you don't worry about it -Stay Positive!

Share this post


Link to post
Share on other sites
This is the line its referring to:

 

if ($localfile){

// move the file to where we can work with it

$file = tep_get_uploaded_file('usrfl'); $attribute_options_query = "select distinct products_options_id from " . TABLE_PRODUCTS_OPTIONS . " order by products_options_id";

 

$attribute_options_values = tep_db_query($attribute_options_query);

 

$attribute_options_count = 1;

//while ($attribute_options = tep_db_fetch_array($attribute_options_values)){

if (is_uploaded_file($file['tmp_name'])) {

tep_copy_uploaded_file($file, DIR_FS_DOCUMENT_ROOT . $tempdir);

}

 

echo "<p class=smallText>";

echo FILENAME ': ' . $localfile . "<br>";

 

// get the entire file into an array

$readed = file(DIR_FS_DOCUMENT_ROOT . $tempdir . $localfile);

}

 

provided "FILENAME" is actually defined, this would be correct...

echo FILENAME . ': ' . $localfile . "<br>";

 

what version are you using and why did you decide to use it?

Share this post


Link to post
Share on other sites
did you miss-type when you said you clicked "upload" ? you use the "Import EP file from Temp Dir" section when importing a file that has been FTPed to the temp folder.

After some very serious bang-head-on-monitor time, I finally decided to try it on a different server..... many more hours later, I found that it works on Php 5.2.5.....

with one small error that "does not seem" to impact anything:

After completing the upload it says:

File uploaded.

Temporary filename: /tmp/phpKpZWZb

User filename: EP2008Feb09-2210.txt

Size: 464

| 1 | Test | testing th | | | 1 | 99 | 0.01 | | 2006-12-13 | | test | coming_soo | | | | | Taxable Go | Active Updated

 

No products_model field in record. This line was not imported: | | | | | | | | | | | | | | | | | | |

 

 

Warning: array_walk() expects at most 3 parameters, 5 given in /home/premium/public_html/shop/admin/easypopulate.php on line 962

 

Lines 961 & 962 are:

// isn't working in PHP5

array_walk($readed, $filelayout, $filelayout_count, $default_these, 'process_row');

 

 

And, I only said "does not seem" because my prelimiary checks revealed nothing wrong....

The servers that it would NOT work are running Php 5.2.3

(Yes, I have carts on 2 different 5.2.3 servers and carts on a 5.2.5 server - so you can plainly see I REALLY DO LOVE EASY POPULATE!)

Share this post


Link to post
Share on other sites
provided "FILENAME" is actually defined, this would be correct...

echo FILENAME . ': ' . $localfile . "<br>";

 

what version are you using and why did you decide to use it?

 

Hi surfalot,

 

I'm using osc 2.2 as far as i can tell. and easy populate 2.27

 

I have about 100 or so products to upload to my website and wanted to be able to organise them off-line so when i'm ready to upload them it wont take me a week. :'(

 

PHP is new to me so I dont want to go messing around with what i'm not sure of, that's why I asked for help. Allot of PHP is fairly straight forward but I am a bit confused with this bit.

 

Thanks surfalot


If it does not kill you don't worry about it -Stay Positive!

Share this post


Link to post
Share on other sites
After some very serious bang-head-on-monitor time, I finally decided to try it on a different server..... many more hours later, I found that it works on Php 5.2.5.....

with one small error that "does not seem" to impact anything:

After completing the upload it says:

File uploaded.

Temporary filename: /tmp/phpKpZWZb

User filename: EP2008Feb09-2210.txt

Size: 464

| 1 | Test | testing th | | | 1 | 99 | 0.01 | | 2006-12-13 | | test | coming_soo | | | | | Taxable Go | Active Updated

 

No products_model field in record. This line was not imported: | | | | | | | | | | | | | | | | | | |

 

 

Warning: array_walk() expects at most 3 parameters, 5 given in /home/premium/public_html/shop/admin/easypopulate.php on line 962

 

Lines 961 & 962 are:

// isn't working in PHP5

array_walk($readed, $filelayout, $filelayout_count, $default_these, 'process_row');

 

 

And, I only said "does not seem" because my prelimiary checks revealed nothing wrong....

The servers that it would NOT work are running Php 5.2.3

(Yes, I have carts on 2 different 5.2.3 servers and carts on a 5.2.5 server - so you can plainly see I REALLY DO LOVE EASY POPULATE!)

now I'm really confused. first, you didn't answer my question you replied to.

 

second, none of the versions I posted have that on lines 961 & 962. They are near-bouts line 1030.

 

third, all versions with those lines (but not on those line numbers) have the "array_walk" commented out because it doesn't work with PHP 5 (a known bug in PHP 5)

 

forth, are you saying you fixed it, or just providing more info?

 

and last, since this looks like a modified version, please try an unmodified 2.76f R1 before we go any further.

Share this post


Link to post
Share on other sites
After some very serious bang-head-on-monitor time, I finally decided to try it on a different server..... many more hours later, I found that it works on Php 5.2.5.....

and just to clearify, as far as I know, v2.76d & e have worked on PHP 5

Share this post


Link to post
Share on other sites

Hi all,

 

I've just upgraded from a very early version of EP to version 2.76d with admin. Everything seems to work well except for Field Separator. No matter what I put in the field, it stays at comma. I use phpMyAdmin to manage my DB and I can see that the configuration value is being changes as I update the settings in admin and the admin panel shows the changes correctly, but when I open Easypopulate the separator is set to comma. Any idea how I can fix this?

 

Thanks,

Rick

Share this post


Link to post
Share on other sites

So I have the Attibute Sort 1.0, and the Easy populate 2.76f modules installed.

 

I need to be able to sort my attributes via the EP module, and despite looking through the forums, and playing with the modules I haven't been able to get the sort to be modifiable via EP.

 

Has anyone been able to sort via EP?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×