Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

which is the best EP with attributes ?

Were can i download it.

 

Ihave look to the ones on contributions but there too much and some are not complete please help.

I have OS 2.2

Share this post


Link to post
Share on other sites

which is the best EP with attributes ?

Were can i download it.

 

Ihave look to the ones on contributions but there too much and some are not complete please help.

I have OS 2.2

Share this post


Link to post
Share on other sites

which is the best EP with attributes ?

Were can i download it.

 

Ihave look to the ones on contributions but there too much and some are not complete please help.

I have OS 2.2

Share this post


Link to post
Share on other sites
which is the best EP with attributes ?

Were can i download it.

 

Ihave look to the ones on contributions but there too much and some are not complete please help.

I have OS 2.2

try the v2.76d I uploaded. with the fix just above if you have php globals off.

read the direction carefully. Use the excel safe option if you have any single or double quotes in the data (see post 5698).

ignore any changes to your configure.php files and just set your temp folder in the easypopulate.php file.

Share this post


Link to post
Share on other sites
Thanks again surfalot. My host has globals setting to off, but done a search on globals off in easy populate support and found a fix. It seems to be working, i just need to test fully. As i have approx 700 products and still more to add. If anyone else has a similiar problem i used the following fix.

 

 

// fix by jb 20040815 set the strings to http post/request, since they don't seem to work on the new server, with register globals=off...

$dltype=$_REQUEST['dltype'];

$download=$_REQUEST['download'];

 

global $HTTP_POST_FILES;

 

foreach( $HTTP_POST_FILES as $varname => $fileinfo ){

$GLOBALS[$varname] = $fileinfo["tmp_name"];

$GLOBALS[$varname.'_name'] = $fileinfo["name"];

}

// end fix jb

 

 

This is NOT my fix, but provided by jbrolin, and can be found at - http://forums.oscommerce.com/index.php?showtopic=108825

Thanks again for all your help and advice.

 

Kind Regards,

 

 

Steven

nice find! renews my faith that at least some folks are searching for answers. :P

Share this post


Link to post
Share on other sites

Not to sound like the one idiot in the room, but I just downloaded OScommerce and before I dive into it, I want to make sure that there is a way to take an invetory list from Excel and update it into osCOmmerce all at once. The product list I am trying to use with osCommerce comes with these attributes: Item#, Qty, Long Descrip, Short Descript, Pkg, inventory and Cost. Unfortunately the 3000 images are on a seperate disk, but the images and the item numbers are the same. The images have jpg and gif.

 

If not could you point me somewhere or to someone who would be willing to install the product list initially and show me how to maintian it. I dont have much time before I go back to the 9-5 working job. I of course would be willing to pay for thier time.

 

Kind Regards,

Jeff Johnson

Share this post


Link to post
Share on other sites

I am interested in trying this but I have a question before I jump in.

 

 

Will this work with more pics?

 

 

 

Thank you all in advance

Edited by theantiquestore

Share this post


Link to post
Share on other sites
Not to sound like the one idiot in the room, but I just downloaded OScommerce and before I dive into it, I want to make sure that there is a way to take an invetory list from Excel and update it into osCOmmerce all at once. The product list I am trying to use with osCommerce comes with these attributes: Item#, Qty, Long Descrip, Short Descript, Pkg, inventory and Cost. Unfortunately the 3000 images are on a seperate disk, but the images and the item numbers are the same. The images have jpg and gif.

 

If not could you point me somewhere or to someone who would be willing to install the product list initially and show me how to maintian it. I dont have much time before I go back to the 9-5 working job. I of course would be willing to pay for thier time.

 

Kind Regards,

Jeff Johnson

as long as the Item # is unique throughout all products, should be relatively easy. see post 5779 on the last page for getting started tips.

 

In addition, setup your default shop with this contrib. do a full export and you will see the header line format which is important. then you should be able to setup your header line correctly and copy in your columns of data.

Share this post


Link to post
Share on other sites
I am interested in trying this but I have a question before I jump in.

 

Will this work with more pics?

 

Thank you all in advance

I suppose you could try the version of easypopulate (modified v2.8) that I included in the last version of morepics (More_pics_6 v1.2c For osC 2.2 MS2) I uploaded.

Share this post


Link to post
Share on other sites

I have a questions about the product model number when uploading using easypopulate.

 

I have a product number "CIS-EP-CX4900-CX4900"

 

when i upload it using easy populate the product code gets truncated to 'CIS-EP-CX490'

 

Any ideas why this is happening?

Share this post


Link to post
Share on other sites
I have a questions about the product model number when uploading using easypopulate.

 

I have a product number "CIS-EP-CX4900-CX4900"

 

when i upload it using easy populate the product code gets truncated to 'CIS-EP-CX490'

 

Any ideas why this is happening?

 

 

I figured out the problem.. i had to go to my phpMyAdmin and find the products_model and set the varchar(12) to a larger number

Share this post


Link to post
Share on other sites
I figured out the problem.. i had to go to my phpMyAdmin and find the products_model and set the varchar(12) to a larger number

you also need to set that in the easypopulate settings. please do read the docs and the settings area of easy populate thoroughly.

Share this post


Link to post
Share on other sites
Thanks again surfalot. My host has globals setting to off, but done a search on globals off in easy populate support and found a fix. It seems to be working, i just need to test fully. As i have approx 700 products and still more to add. If anyone else has a similiar problem i used the following fix.

// fix by jb 20040815 set the strings to http post/request, since they don't seem to work on the new server, with register globals=off...

$dltype=$_REQUEST['dltype'];

$download=$_REQUEST['download'];

 

global $HTTP_POST_FILES;

 

foreach( $HTTP_POST_FILES as $varname => $fileinfo ){

$GLOBALS[$varname] = $fileinfo["tmp_name"];

$GLOBALS[$varname.'_name'] = $fileinfo["name"];

}

// end fix jb

This is NOT my fix, but provided by jbrolin, and can be found at - http://forums.oscommerce.com/index.php?showtopic=108825

Thanks again for all your help and advice.

 

Kind Regards,

Steven

 

 

I was having the same problem as you, with a register_globals off website and exporting but no importing. You say that you can import now, but how is that possible if the fix you posted above only fixes the dl_type and download undefined variables, but not the usrf undefined variables that the upload mechanism uses?

 

I still can't import after using EP 2.76d globals off + the fix above on OSC 2.2MS2. I'm assuming the problem is that $usrfl isn't defined, along with the errors steven already posted.

Share this post


Link to post
Share on other sites

^won't let me edit for some reason

 

My problem might be different from Steven's, since he said he received errors upon attempting to import data. My problem is that after clicking on "db import" the EP page just refreshes. There is no "File Upload" message or anything like that.

Share this post


Link to post
Share on other sites

Sorry for the triple post, but I thought some additional info might be helpful.

 

PHP Version 5.1.6

Apache/1.3.37 (Unix)

 

I can downgrade to PHP v 4 if it would help the problem.

Edited by black0ut

Share this post


Link to post
Share on other sites

I have installed Easy Populate but when I click on the link I get:

 

http://localhost/catalog/admin/FILENAME_IMP_EXP_CATALOG

 

Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

 

If you think this is a server error, please contact the webmaster.

 

Error 404

localhost

05/25/07 08:33:28

Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.1

 

Can anyone please help?

 

Thanks

 

-AL

Share this post


Link to post
Share on other sites

Hi,

 

I have tried using numerous versions of easy populate and turning on SPPC support , however regardless of what version i use none of the downloaded complete tab files contain the fields i need for SPPC.

 

I am currently only using Retail and Wholesale, hence i uncommented the lines in the easypopulate.php file v_customer_price_1 and _2 , however these fields are still not being exported when i do a complete dump.

 

in my product_groups table, my the fields i have are customer_group_price_1 etc: not customer_price_1 like it is in the easy populate.php file, i wasnt sure whether this would be because i am using a different version of SPPC where the field names were different and this is why the fields arent being exported correctly.

 

If anybody has had similar issues and been able to fix any help would be muchly appreciated ( i have been searching support forums all day and have not found anything to help sad.gif sad.gif )

 

cheers

 

dlyxzen

Share this post


Link to post
Share on other sites

Hi Guys, sorry if these questions have come up earlier in the thread..

 

How hard would it be to modify this to,

 

A) Remove all products not found in the uploaded CSV

B) ONLY update price/stock/availability on products found

 

Thanks.

Share this post


Link to post
Share on other sites

I had previously paid an employee to set up my website and he chose to use osCommerce as the shopping cart. He set it up and modified for me for a few years. I've moved the business and he is no longer with me so I'm trying to get up to speed on doing this myself. I don't have any osC experience and very little HTML. I've figured out most of what I need but have a couple more questions.

 

1. v_status column : I can download the FULL catalog tab-delimited text file of the existing products (Easy Populate) , convert it Excel and can see the columns including one called v_status which for all items has an entry of ACTIVE. The question is, do I need to leave products that are now obsolete in the Excel file and somehow label them "INACTIVE" or can I just delete the row for that product in which case I would wonder why the column exists. Will deleting the row delete them from the osC cart ?

 

2. colors / sizes : Each row (product) contains many many columns including colors/sizes/etc that may not be available for that product. When I add new products do I need to copy/paste all those columns ? Do I need to include those columns at all in the Excel file since this is an existing cart ?

 

3. delete second language : My employee spoke Spanish (I don't really speak it well) so he included Spanish as a second language and I see Spanish entries for everything. The question is can I just use the Admin feature to remove the Spanish language ? Should I then download the tab-delimited file and start from there ?

 

4. categories / subcategories : I produce 2-4 different catalogs (print) per year and my employee had set up each (seasonal) catalog as a category at the root level, as I click down into the seasonal catalog I get another list of categories for the different products. Does this seem like a good way to do it ? It seems that in the Excel (EP) file some products are listed more than once (multiple rows same product) as they are sold in mulitiple seasonal catalogs. The only difference is the categories_name_1 (or 2, etc.). Should I continue this practice.

 

5. product database : So it looks to me like in order to add products I do the following : (please confirm)

a. add new lines in the Excel (EP) file that reference JPEG photos and contain code numbers, prices, categories (seasonal and product type)

b. generate the JPEG photos and upload to the images directory

c. upload the Excel (EP) file - not sure how yet but I assume it's easy

 

6. product attributes : For each product it looks to me like I need to use the Admin function one at a time to add the specific attributes (size, color) that apply to that product. Is that right ? Is there a way to specify these applicable attributes in the Excel (EP) file ? It appears that each product has columns representing all possible attributes in the existing EP file.

 

Thank you so much in advance - I'm getting close ...

 

Ed

Share this post


Link to post
Share on other sites

I installed Simple Price Break, I want to add the two database variables to the Excel that simple price break created. Is there something already made for this? Or do I need to change some of the code in Easy Populate? If i have to change the code, I would need to add two options v_example v_example2 which come from simple price break. Could someone lead me in the right direction ? thanks.

Share this post


Link to post
Share on other sites

I am having a problem uploading with easy populate. I get the measage file uploaded /tmp/something and nothing has been uploaded to my store. can someone help?

Share this post


Link to post
Share on other sites

Hi,

I've a quick question. I've had easy Populate installed for a few months.. its been fine.

Recently, i went to edit my site so that when an item became sold out the item would remain active, i thought that if i changed the setting below to false

 

$zero_qty_inactive = false

 

that that would work, but everything something becomes sold out, it becomes inactive.

 

Have i misunderstood the setting or is there something else i need to do?

 

Thanks,

Mike

Share this post


Link to post
Share on other sites

Hi all,

 

I don't understand why there are so many illogic version number in the contribution repository.

for instance :

- a v3 in 2006 then a v2.76 in 2007

- the brand new one states you have in install a old 2.78 version

- etc...

 

Can someone make it clear please ?

And why not just using a excel to mysql odbc connection or something like that ?

 

Thank you for your answers

 

SALYM

Edited by SALYM

Share this post


Link to post
Share on other sites
Hi all,

 

I don't understand why there are so many illogic version number in the contribution repository.

for instance :

- a v3 in 2006 then a v2.76 in 2007

- the brand new one states you have in install a old 2.78 version

- etc...

 

Can someone make it clear please ?

And why not just using a excel to mysql odbc connection or something like that ?

 

Thank you for your answers

 

SALYM

In a nutshell, versions over 2.76x often have other contributions integrated that won't work well with virgin shops. So folks like myself have gone back to previous "cleaner" versions for compatibility.

 

The original code is quite a mess and there is a lack of experienced coders with available time to clean them up and advance the base project.

And why not just using a excel to mysql odbc connection or something like that ?

If you have a better way of doing it, by all means, submit your project. I think once you get elbow deep in it you'll know why it is like it is. :thumbsup:

Share this post


Link to post
Share on other sites

Hi guys, i'm quite sure this problem has been covered before (i know of at least 2 other post i myself have made) but i am being driven insane

by EP

 

i have installed various version and found 2.76d to be stable (once i patched it with jb's fix)

 

my problem is that when i upload to the database i get a message saying the file was uploaded

but the file size remains blank and i get no other output

and nothing goes into the database.

 

If any has seen this before and knows a fix PLEASE put me out of my misery.

 

thx (in advance). :'(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×