Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Regarding easy populate

i am new and just installed ep

i got a pricelist from a supplier in csv or xls

i asume its compadible cause it sort of looks similar

if i send it to you could you tell me what i need to do with it

like can i set it all up so its easy to modify my products

 

 

 

 

here is a snipit of their pricelist

 

ZBUNDLEA01 A-01 WHITE CRYSTAL KB+OPTICAL MOUSE TASK In Stock $38.00

TASK

HOT! Crystal Keyboard and Mouse

- PS/2 Interface keyboard and mouse

- Fully compatible with Windows ME / 2000/ XP/ NT/ 98/ 95

- Mouse Resolution: 400

 

 

Thanks

 

Peter Wilding

wilding@xnet.co.nz

Share this post


Link to post
Share on other sites

Hope somebody can help

 

I have set it up and everythign seems ot be workign fine, except for the upload

 

I get this error

 

 

Easy Populate 2.76d-MS2 - Default Language : English(1)

Warning: move_uploaded_file(/hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/catalog/temp/rapid-import-2.txt): failed to open stream: No such file or directory in /hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/admin/easypopulate_functions.php on line 43 Warning: move_uploaded_file(): Unable to move '/tmp/phpQg2J7M' to '/hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/catalog/temp/rapid-import-2.txt' in /hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/admin/easypopulate_functions.php on line 43

File uploaded.
Temporary filename: /tmp/phpQg2J7M
User filename: rapid-import-2.txt
Size: 77591
Warning: file(/hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/catalog/temp/rapid-import-2.txt): failed to open stream: No such file or directory in /hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/admin/easypopulate.php on line 805 Warning: Invalid argument supplied for foreach() in /hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/admin/easypopulate.php on line 844

Share this post


Link to post
Share on other sites
Sorry to waste your time - looks like an issue with my server or my FTP program. Fixed now.

 

Hi! I am getting the same error. Would you mind sharing what the problem was and how it was resolved? Thanks so much! I'm using EP 2.7.6. Here's my error:

 

Warning: move_uploaded_file(DIR_FS_DOCUMENT_ROOT/temp/EP2007Apr30-2007.txt): failed to open stream: No such file or directory in /web/osc/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/var/tmp/php016832' to 'DIR_FS_DOCUMENT_ROOT/temp/EP2007Apr30-2007.txt' in /web/osc/admin/easypopulate_functions.php on line 32

 

 

File uploaded.

Temporary filename: /var/tmp/php016832

User filename: EP2007Apr30-2007.txt

Size: 68451

 

Warning: file(DIR_FS_DOCUMENT_ROOT/temp/EP2007Apr30-2007.txt): failed to open stream: No such file or directory in /web/osc/admin/easypopulate.php on line 702

 

Warning: Invalid argument supplied for foreach() in /web/osc/admin/easypopulate.php on line 725

Edited by jsliedtke

Share this post


Link to post
Share on other sites

I forgot: I'm using EP 2.7.6, php v 4.4.2, globals & reporting are off, SQL 4.0.27 on Unix servers. Thanks!

Edited by jsliedtke

Share this post


Link to post
Share on other sites
Hi! I am getting the same error. Would you mind sharing what the problem was and how it was resolved? Thanks so much! I'm using EP 2.7.6. Here's my error:

 

Warning: move_uploaded_file(DIR_FS_DOCUMENT_ROOT/temp/EP2007Apr30-2007.txt): failed to open stream: No such file or directory in /web/osc/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/var/tmp/php016832' to 'DIR_FS_DOCUMENT_ROOT/temp/EP2007Apr30-2007.txt' in /web/osc/admin/easypopulate_functions.php on line 32

 

 

File uploaded.

Temporary filename: /var/tmp/php016832

User filename: EP2007Apr30-2007.txt

Size: 68451

 

Warning: file(DIR_FS_DOCUMENT_ROOT/temp/EP2007Apr30-2007.txt): failed to open stream: No such file or directory in /web/osc/admin/easypopulate.php on line 702

 

Warning: Invalid argument supplied for foreach() in /web/osc/admin/easypopulate.php on line 725

your DIR_FS_DOCUMENT_ROOT isn't setup correctly in your admin/includes/configure.php. search this topic (lower left) for DIR_FS_DOCUMENT_ROOT for lots a help with correcting that.

Edited by surfalot

Share this post


Link to post
Share on other sites
Hope somebody can help

 

I have set it up and everythign seems ot be workign fine, except for the upload

 

I get this error

 

 

Easy Populate 2.76d-MS2 - Default Language : English(1)

Warning: move_uploaded_file(/hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/catalog/temp/rapid-import-2.txt): failed to open stream: No such file or directory in /hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/admin/easypopulate_functions.php on line 43 Warning: move_uploaded_file(): Unable to move '/tmp/phpQg2J7M' to '/hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/catalog/temp/rapid-import-2.txt' in /hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/admin/easypopulate_functions.php on line 43

File uploaded.
Temporary filename: /tmp/phpQg2J7M
User filename: rapid-import-2.txt
Size: 77591
Warning: file(/hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/catalog/temp/rapid-import-2.txt): failed to open stream: No such file or directory in /hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/admin/easypopulate.php on line 805 Warning: Invalid argument supplied for foreach() in /hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/admin/easypopulate.php on line 844

 

you have to look at the path given in the error:

/hsphere/local/home/rapidrc/rapid-rc.co.uk/shop/catalog/catalog/temp/rapid-import-2.txt

"catalog" is twice, you probably haven't configured the temp folder path in the easypopulate.php file. help should be in the docs for that. (ignore the instructions about admin/includes/configure.php)

Share this post


Link to post
Share on other sites

I am try to download filenames from excell csv and past to DB (products_attributes_download).

 

My excell file like this:

 

v_products_model v_filename v_products_image v_products_largeimage v_products_name_1 v_products_description_1

 

I insert one column: v_filename

 

 

Add code to easypopulate.php file

Line: 265

 

#'MY CODE!!!',

'v_filename',
'v_products_attributes_id'

#'MY CODE!!!',

 

Line: 534

 

//!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! MY CODE

	if (isset($filelayout['v_filename'])){
		if ($row['v_products_attributes_id'] != ''){
			$sql2 = "SELECT products_attributes_filename
				FROM ".TABLE_PRODUCTS_ATTRIBUTES_DOWNLOAD."
				WHERE
				products_attributes_id = " . $row['v_products_attributes_id']
			;
			$result2 = tep_db_query($sql2);
			$row2 =  tep_db_fetch_array($result2);
			$row['v_filename'] = $row2['products_attributes_filename'];
		}
	}

	//!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! MY CODE

 

Line: 1049

 

 //!!!!!!!!!!!!!!!!!!!!!!!!! MY CODE 

	   $cells[0][] = array('text' => '<table border="0" cellpadding="0" cellspacing="0"><tr><td class="smallText">' . tep_draw_checkbox_field('epcust_filename', 'show', (!empty($HTTP_GET_VARS['epcust_filename'])?true:false)) . '</td><td class="smallText"> filename' . '</td></tr></table>');

//!!!!!!!!!!!!!!!!!!!!!!!!! MY CODE

 

Line: 1339

 

//!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! MY CODE !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

	$header_array['v_filename'] = $iii++;
	$filelayout = array_merge($filelayout, $header_array);

//!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! MY CODE !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

 

Line: 1497

 

//!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! MY CODE
	if (!empty($HTTP_GET_VARS['epcust_filename'])) {
	  $filelayout  = array_merge($filelayout , array( 'v_filename' => $iii++ ));
	}
//!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! MY CODE

 

Line: 1597

 

# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!MY CODE

		'v_filename'		=> $iii++,

# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!MY CODE

 

To insert into DB (products_attributes_download) I need to do this:

 

 

INSERT INTO `products_attributes_download` ( `products_attributes_id` , `products_attributes_filename` , `products_attributes_maxdays` , `products_attributes_maxcount` ) 
VALUES ('41380', 'unreal.zip', '2', '3');

 

 

How can I insert to my DB this column with filename?

 

Thank you for the help...

Share this post


Link to post
Share on other sites
your DIR_FS_DOCUMENT_ROOT isn't setup correctly in your admin/includes/configure.php. search this topic (lower left) for DIR_FS_DOCUMENT_ROOT for lots a help with correcting that.

 

Thanks again, Todd. Got it!

Share this post


Link to post
Share on other sites

Ok it me back again lol, ok let me explain that I am exporting my products from my quick books, and then just copying what is in there, to the proper fields in the standard ep.txt I downloaded when I first installed. I have almost 3,000 products so trust me, this is the easiest way I think lol.

 

Anyways I was able to do one or two products, but when I add all of them I get this message.

 

File uploaded. 
Temporary filename: /tmp/phpVTqzWq
User filename: Items List.xls
Size: 274684
| Ice Cream | | | | | | | | | | | | | | | Updated
| ZZ01-MIXPR | | | IMPORTANT | | 0.00 | PRICING | | | | | | | | | Updated
| BA01-00000 | | | * * * * BA | | 0.00 | | | | 0.00 | | Baked Misc | | | | INACTIVE Updated
| BA01-00531 | | | Cake - 8' | | 0.00 | 24 each 12 | | | 0.00 | | Baked Misc | Cake | | | INACTIVE Updated
| BA01-00532 | | | Cake - 8' | | 0.00 | 24 each 12 | | | 0.00 | | Baked Misc | Cake | | | INACTIVE Updated
| BA01-15915 | | | Brownie - | | 0.00 | Half sheet | | | 0.00 | | Baked Misc | Brownie | | | INACTIVE Updated
| BA01-15915 | | | Brownie - | | 0.00 | Half sheet | | | 0.00 | | Baked Misc | Brownie | | | INACTIVE Updated
| BA01-39220 | | | Cake - Cho | | 0.00 | Half sheet | | | 4.00 | | Baked Misc | Cake | | | ACTIVE Updated
| BA01-39440 | | | Cake - Yel | | 0.00 | Half sheet | | | 9.00 | | Baked Misc | Cake | | | ACTIVE Updated
| BA01-63003 | | | Brownie - | | 0.00 | Case = 3-9 | | | 4.00 | | Baked Misc | Brownie | | | ACTIVE Updated
| BA01-63011 | | | Brownie - | | 0.00 | Case = 3-8 | | | 0.00 | | Baked Misc | Brownie | | | INACTIVE Updated
| BA01-82410 | | | Brownie - | | 0.00 | 12'x16' sh | | | 0.00 | | Baked Misc | Brownie | | | INACTIVE !New Product!
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'x16' sheet / Case = 4 each', '0.00', 'NULL')' at line 21

INSERT INTO products ( products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( '', 'BA01-82410000-C', '0', '0', CURRENT_TIMESTAMP, CURRENT_TIMESTAMP, NULL, '', '12'x16' sheet / Case = 4 each', '0.00', 'NULL') 

[TEP STOP]


 

Now I think if I look at it correctly, it is doing this because I want to have my v_products_weight to show text instead of decimals, so I went into my database and changed that field to text, and size to 34, did I do this incorrectly, or is this an entire different error???

 

Thanks

 

Tom

Share this post


Link to post
Share on other sites
Ok it me back again lol, ok let me explain that I am exporting my products from my quick books, and then just copying what is in there, to the proper fields in the standard ep.txt I downloaded when I first installed. I have almost 3,000 products so trust me, this is the easiest way I think lol.

 

Anyways I was able to do one or two products, but when I add all of them I get this message.

 

File uploaded. 
Temporary filename: /tmp/phpVTqzWq
User filename: Items List.xls
Size: 274684
| Ice Cream | | | | | | | | | | | | | | | Updated
| ZZ01-MIXPR | | | IMPORTANT | | 0.00 | PRICING | | | | | | | | | Updated
| BA01-00000 | | | * * * * BA | | 0.00 | | | | 0.00 | | Baked Misc | | | | INACTIVE Updated
| BA01-00531 | | | Cake - 8' | | 0.00 | 24 each 12 | | | 0.00 | | Baked Misc | Cake | | | INACTIVE Updated
| BA01-00532 | | | Cake - 8' | | 0.00 | 24 each 12 | | | 0.00 | | Baked Misc | Cake | | | INACTIVE Updated
| BA01-15915 | | | Brownie - | | 0.00 | Half sheet | | | 0.00 | | Baked Misc | Brownie | | | INACTIVE Updated
| BA01-15915 | | | Brownie - | | 0.00 | Half sheet | | | 0.00 | | Baked Misc | Brownie | | | INACTIVE Updated
| BA01-39220 | | | Cake - Cho | | 0.00 | Half sheet | | | 4.00 | | Baked Misc | Cake | | | ACTIVE Updated
| BA01-39440 | | | Cake - Yel | | 0.00 | Half sheet | | | 9.00 | | Baked Misc | Cake | | | ACTIVE Updated
| BA01-63003 | | | Brownie - | | 0.00 | Case = 3-9 | | | 4.00 | | Baked Misc | Brownie | | | ACTIVE Updated
| BA01-63011 | | | Brownie - | | 0.00 | Case = 3-8 | | | 0.00 | | Baked Misc | Brownie | | | INACTIVE Updated
| BA01-82410 | | | Brownie - | | 0.00 | 12'x16' sh | | | 0.00 | | Baked Misc | Brownie | | | INACTIVE !New Product!
1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'x16' sheet / Case = 4 each', '0.00', 'NULL')' at line 21

INSERT INTO products ( products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( '', 'BA01-82410000-C', '0', '0', CURRENT_TIMESTAMP, CURRENT_TIMESTAMP, NULL, '', '12'x16' sheet / Case = 4 each', '0.00', 'NULL') 

[TEP STOP]


 

Now I think if I look at it correctly, it is doing this because I want to have my v_products_weight to show text instead of decimals, so I went into my database and changed that field to text, and size to 34, did I do this incorrectly, or is this an entire different error???

 

Thanks

 

Tom

I think the problem is the single qoutes in your data. you would have better luck using the excel safe option and CSV file type exported from Excel for the EP import/export.

 

see post 5698, does any of that help you?

Share this post


Link to post
Share on other sites

I have EP version 2.76d installed and working fine as it would seem so far.

I have also just added MVS and Quantity Price Breaks for SPPC to my Seperate Price Per Customer shop.

 

A) I need to adjust the EP tool to accomodate the quantity price breaks for each customer group.

If someone has any thing I can use as a guide, it would be highly appreciated.

 

B) Additionally, can I download the CSV file from EP and open it in Excel (2007) then put formulas in the price cells to auto generate the required prices for all the different price breaks? Then save it again as a CSV file and upload it using EP. Will it work?

 

Many Thanks,

RJ


I like these mods, there fun! ...65 70 72 75 80 85 125+ contributions installed and counting...

 

Tools I'm using: OSC2.2 milestone2, Filezilla for FTP, PHP Designer 2007PE (nice), Araxis Merge 6.5 to compare files, XP(my box), Remote Server is shared Apache 1.3 Cpanel, CURL, and PHPmyAdmin through my hosts Cpanel to mess up the database.

Share this post


Link to post
Share on other sites

I installed Surfalot's version 2.76 d

 

I am encountering the same issue as so many. I have installed everything and no errors.

 

I can create txt files... no problems.

 

I haven't changed any of the settings in the Configuration Variables but for the model size that I have set to 12.

 

I did set the permissions to 777 on my temp folder. I tried and tried adn although I am getting the message that the products are updated when I go back to the store... the products are not updated.

 

I did manage at one point to make it work by FTPing the modified txt file to the temp folder and changing the permissions on the file to 777 and using the INSERT from temp dir. But only once did it worked. I am doing exactly the same thing now and it's not working.

 

I still don't get any error and get confirmation that the everything is updated but when I go back to the store...no changes.

 

I can't figure out why it would work once and then no more. I didn't change anything since. yes my products all have unique model numbers.

 

Any help would be greatly appreciated. I have read over 40 pages of this contribution here and tried all that I could find... still can't figure out what I am doing wrong.

 

Thanks in advance

Share this post


Link to post
Share on other sites
I think the problem is the single qoutes in your data. you would have better luck using the excel safe option and CSV file type exported from Excel for the EP import/export.

 

see post 5698, does any of that help you?

 

 

Thanks for the reply, have not gave it a shot yet, but just wanted to post to say thank you and I will give it a try tomorrow and let you know.

Share this post


Link to post
Share on other sites
I have EP version 2.76d installed and working fine as it would seem so far.

I have also just added MVS and Quantity Price Breaks for SPPC to my Seperate Price Per Customer shop.

 

A) I need to adjust the EP tool to accomodate the quantity price breaks for each customer group.

If someone has any thing I can use as a guide, it would be highly appreciated.

 

B) Additionally, can I download the CSV file from EP and open it in Excel (2007) then put formulas in the price cells to auto generate the required prices for all the different price breaks? Then save it again as a CSV file and upload it using EP. Will it work?

 

Many Thanks,

RJ

the code for SPPC is in that version. But not tested. Some help on import-file formatting in the docs also. Should just need to uncomment certain areas (search the file). there is a version that includes MVS, I think 2.76c has a MVS mod in the package. I'm not sure what is in it, but the 2.8 package has been popular and has a number of other contributions in it.

 

If you picked 2.76d because of the CVS additions and quotes handling, you may be able to easily add the relatively few additional code lines back on some of the MVS capable code using a compare tool.

 

I'm not sure how formulas will work with the CVS export, just make sure your numbers don't have $'s and comma formatting.

Share this post


Link to post
Share on other sites
I installed Surfalot's version 2.76 d

 

I am encountering the same issue as so many. I have installed everything and no errors.

 

I can create txt files... no problems.

 

I haven't changed any of the settings in the Configuration Variables but for the model size that I have set to 12.

 

I did set the permissions to 777 on my temp folder. I tried and tried adn although I am getting the message that the products are updated when I go back to the store... the products are not updated.

 

I did manage at one point to make it work by FTPing the modified txt file to the temp folder and changing the permissions on the file to 777 and using the INSERT from temp dir. But only once did it worked. I am doing exactly the same thing now and it's not working.

 

I still don't get any error and get confirmation that the everything is updated but when I go back to the store...no changes.

 

I can't figure out why it would work once and then no more. I didn't change anything since. yes my products all have unique model numbers.

 

Any help would be greatly appreciated. I have read over 40 pages of this contribution here and tried all that I could find... still can't figure out what I am doing wrong.

 

Thanks in advance

What is displayed when importing the file? Ask your host if your hosting space has php errors turned off.

so if you export a small category (price,name,description), change one thing, like price, then import, nothing changes? please post the messages from the import and a link to the import file used (or PM me if the data is sensitive).

** always backup first **

Share this post


Link to post
Share on other sites
What is displayed when importing the file? Ask your host if your hosting space has php errors turned off.

so if you export a small category (price,name,description), change one thing, like price, then import, nothing changes? please post the messages from the import and a link to the import file used (or PM me if the data is sensitive).

** always backup first **

 

I haven't gotten a reply from my host yet... but here is the info I have so far.

 

and yes that's exactly it. I am asking to create a file of the descriptions in one category and I change the wording in it and go import it and insert it into the database. It worked once but not after that. At first it wouldn't work at all and then at one point I realized that although my temp folder had the proper permissions... my EP file wasn't writable. I decided to try changing the permissions to 777 on the file itself and it worked. But when I tried again for a different category it wouldn't work. So just for fun, I tried again with the first category that I had managed to make it work and it's a no go. Can't make it happen again even with the same category.

 

So here is what it says:

 

Filename: EP2007May03-2210.txt

| V22 | ©My Embr Updated

| V22B | ©My Embr Updated

| V11 | ©My Embr Updated

| V50 | ©My Embr Updated

| V53 | ©My Embr Updated

| V55 | ©My Embr Updated

| V13 | ©My Embr Updated

| V28 | ©My Embr Updated

| V67 | ©My Embr Updated

| V48 | ©My Embr Updated

| V30 | ©My Embr Updated

| V69 | ©My Embr Updated

| V72 | ©My Embr Updated

| V19 | ©My Embr Updated

| V38 | ©My Embr Updated

| V83 | ©My Embr Updated

| V35 | ©My Embr Updated

| V98B | ©My Embr Updated

| V61 | ©My Embr Updated

| V78 | ©My Embr Updated

| V24 | ©My Embr Updated

| |

 

No products_model field in record. This line was not imported

 

It tells me everything is updated but when I go to the store. The change in the description isn't being reflected. And I've tested this ... see how the first words are C My Embr... well I changed that once and imported the file and I could see that the change was appearing somewhere in the database because my change would show in the message but still wouldn't show in the store.

 

As for my hosting company having php error turned off.. I have a couple of questions...

 

Since that other change I made that finally worked... and then a change in that same category again won't work... wouldn't it be safe to assume that since the changes I was making was in the wording of the description and I wasn't adding any weird caracters like : or " or ' that could have affected the PHP... that there isn't a PHP error in at least that category since it worked once?? Sorry if this is a really dumb question.

 

Second question... any chance I can check myself in my admin panel for php error off or on and change it myself... ? Just in case this could be done and I could get this working sooner :rolleyes:

Share this post


Link to post
Share on other sites
Second question... any chance I can check myself in my admin panel for php error off or on and change it myself... ? Just in case this could be done and I could get this working sooner :rolleyes:

 

Just had a flash but it might be a dumb one, still I thought i would ask...

 

when you say... php error turned off... do you mean that if there is an error in my php text do I get the alert on my screen... for instance... many in the 40 something pages I read in the last 2 days had the "warning... can't write to file???" that sort of thing?

 

If that is what you mean... then php errors are on because I did get those the very first time when I forgot to change the permission on my temp folder.

 

and just in case I forget... THANK YOU for trying to help AND for the work you did on this contribution. It sure made it easier for me to decide where to start from.

Edited by mariemeh

Share this post


Link to post
Share on other sites
Just had a flash but it might be a dumb one, still I thought i would ask...

 

when you say... php error turned off... do you mean that if there is an error in my php text do I get the alert on my screen... for instance... many in the 40 something pages I read in the last 2 days had the "warning... can't write to file???" that sort of thing?

 

If that is what you mean... then php errors are on because I did get those the very first time when I forgot to change the permission on my temp folder.

 

and just in case I forget... THANK YOU for trying to help AND for the work you did on this contribution. It sure made it easier for me to decide where to start from.

are you doing just the product description? try again with both the product name & description (as I eluded to in the last post) :P . There is a bug in this version that requires the product name to be specified if you need to change the description or product URL. same the other way, if you just specify the product name and not the other two, those will get blanked in the database. Play safe and always use the name, description and URL for all export/import moves with the v2.76x contribs.

Share this post


Link to post
Share on other sites
are you doing just the product description? try again with both the product name & description (as I eluded to in the last post) :P . There is a bug in this version that requires the product name to be specified if you need to change the description or product URL. same the other way, if you just specify the product name and not the other two, those will get blanked in the database. Play safe and always use the name, description and URL for all export/import moves with the v2.76x contribs.

 

HA HA HA oh man... now I know why it worked that one time. I was getting tired of trying and trying and that one time I must have felt lazy and didn't uncheck what I didn't need... thus why that one time it worked cause the name and price was there... too funny.

 

Thank you soooooo much... you are wonderfully helpful.

 

p.s. was my last question really a dumb one? about the php error turned off or on...do you mean that if there is an error in my php text do I get the alert on my screen... for instance... many in the 40 something pages I read in the last 2 days had the "warning... can't write to file???" that sort of thing?

 

If the question is a dumb one, I apologize for being such a bore but would like a confirmation if possible.. :blush:

 

thanks again... it's working wonderfully well now

Share this post


Link to post
Share on other sites
HA HA HA oh man... now I know why it worked that one time. I was getting tired of trying and trying and that one time I must have felt lazy and didn't uncheck what I didn't need... thus why that one time it worked cause the name and price was there... too funny.

 

Thank you soooooo much... you are wonderfully helpful.

 

p.s. was my last question really a dumb one? about the php error turned off or on...do you mean that if there is an error in my php text do I get the alert on my screen... for instance... many in the 40 something pages I read in the last 2 days had the "warning... can't write to file???" that sort of thing?

 

If the question is a dumb one, I apologize for being such a bore but would like a confirmation if possible.. :blush:

 

thanks again... it's working wonderfully well now

if you recieved errors or warnings along the way, then your PHP errors are on. Don't know why, but some hosts have them switched off by default. one thing to be aware of is the setting in includes/application_top.php:

error_reporting(E_ALL & ~E_NOTICE);

that setting switches off the "notice" level errors. those messages don't point out problematic errors in the code, but sometimes can provide clues when something is failing. to see all notice messages also, change to:

error_reporting(E_ALL);

Share this post


Link to post
Share on other sites

OK maybe I am losing it but I read your post 5698 and it said to change the excel output options on line 105 of the easypopulate.php, I have version 2.76, and I do not see that option anywhere on line 105, am I missing something?

Share this post


Link to post
Share on other sites
OK maybe I am losing it but I read your post 5698 and it said to change the excel output options on line 105 of the easypopulate.php, I have version 2.76, and I do not see that option anywhere on line 105, am I missing something?

 

 

OK nevermine, come to find out the 2.76 I downloaded was still the 2.75, so I upgraded, working good so far, just one problem, when I add he products, the prices are showing up before the model number, so you see 0.00 for price and model number for example looks like this [34.04 bbg000-9] any thoughts on that?

Share this post


Link to post
Share on other sites
if you recieved errors or warnings along the way, then your PHP errors are on. Don't know why, but some hosts have them switched off by default. one thing to be aware of is the setting in includes/application_top.php:

error_reporting(E_ALL & ~E_NOTICE);

that setting switches off the "notice" level errors. those messages don't point out problematic errors in the code, but sometimes can provide clues when something is failing. to see all notice messages also, change to:

error_reporting(E_ALL);

 

 

done... thanks for the info

Share this post


Link to post
Share on other sites

I use SPPC 4.15 with EP2.76d with the bug fix for sppc by removing the line

 

. $v_products_price .

 

of every group. I have uncomment some line in easypopulate.php as instruction in EP2.76d contribution

 

My problem is I cannot upload the same file I downloaded from the model/price/quantity quick link at the bottom back to server.

 

This problem is just the model/price/quantity. The other feature is worked well.

 

Any can help me? Please advise.

 

Thank you so much.

Share this post


Link to post
Share on other sites

The error message is here

 

 

1136 - Column count doesn't match value count at row 1

 

INSERT INTO products_groups VALUES ( 1, 1.2000, 55 )

 

 

Please advise

 

 

Newbie of oscommerce

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×