Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Type 844 into the "Search Topic" Box located at the bottom left corner of this forum. Your sure to find some good info:)

 

-Dano

 

File uploaded.

Temporary filename: C:\Documents and Settings\MR22\My Documents\DACE\WEB\XAMPP\xampp\tmp\phpDB.tmp

User filename: EP2007Apr14-2008.txt-2.xls

Size: 125

 

Warning: file(DIR_FS_DOCUMENT_ROOT/catalog/temp/EP2007Apr14-2008.txt-2.xls) [function.file]: failed to open stream: No such file or directory in C:\Documents and Settings\MR22\My Documents\DACE\WEB\XAMPP\xampp\htdocs\catalog2\admin\easypopulate.php on line 805

 

Warning: Invalid argument supplied for foreach() in C:\Documents and Settings\MR22\My Documents\DACE\WEB\XAMPP\xampp\htdocs\catalog2\admin\easypopulate.php on line 844

 

Got some of the errors away, but left with two, that is if the first part is normal. There is loads of mentions of the 805/844 problem, so am onto that now. It seems quite close for resolving it, but who knows. Can anyone see a problem with the local code above? It looks like a config error

Share this post


Link to post
Share on other sites
File uploaded.

Temporary filename: C:\Documents and Settings\MR22\My Documents\DACE\WEB\XAMPP\xampp\tmp\phpDB.tmp

User filename: EP2007Apr14-2008.txt-2.xls

Size: 125

 

Warning: file(DIR_FS_DOCUMENT_ROOT/catalog/temp/EP2007Apr14-2008.txt-2.xls) [function.file]: failed to open stream: No such file or directory in C:\Documents and Settings\MR22\My Documents\DACE\WEB\XAMPP\xampp\htdocs\catalog2\admin\easypopulate.php on line 805

 

Warning: Invalid argument supplied for foreach() in C:\Documents and Settings\MR22\My Documents\DACE\WEB\XAMPP\xampp\htdocs\catalog2\admin\easypopulate.php on line 844

 

Got some of the errors away, but left with two, that is if the first part is normal. There is loads of mentions of the 805/844 problem, so am onto that now. It seems quite close for resolving it, but who knows. Can anyone see a problem with the local code above? It looks like a config error

first, you can't upload an xls file. there are no versions of EP that will take the xls

second, the spaces are invalid in web URLs and it would be best if you run your test system from a path that doesnt have spaces.

third, you still don't have your configure.php correct. there are lots of post in the forums that will help you streighten that out.

forth, once you have the configure.php correct, you need to set the temp path in the EP script file (v2.76d uploaded by surfalot). you may find that setting elsewhere for other versions.

fifth, you need to make sure your temp directory has the correct permissions. See the docs.

sixth, reread the EP doc for each problem. most of the help you need is there.

Share this post


Link to post
Share on other sites
first, you can't upload an xls file. there are no versions of EP that will take the xls

second, the spaces are invalid in web URLs and it would be best if you run your test system from a path that doesnt have spaces.

third, you still don't have your configure.php correct. there are lots of post in the forums that will help you streighten that out.

forth, once you have the configure.php correct, you need to set the temp path in the EP script file (v2.76d uploaded by surfalot). you may find that setting elsewhere for other versions.

fifth, you need to make sure your temp directory has the correct permissions. See the docs.

sixth, reread the EP doc for each problem. most of the help you need is there.

 

I've moved away from test local machine to resolve this matter.On the main server there seems to be one error, please see below:

 

File uploaded.

Temporary filename: /tmp/phpXqIVll

User filename: EP2007Apr15-1402.txt

Size: 1495

 

Warning: file(DIR_FS_DOCUMENT_ROOT/catalog/temp/EP2007Apr15-1402.txt): failed to open stream: No such file or directory in /home/daceuk/public_html/catalog/admin/easypopulate.php on line 795

 

This is my admin config line define('DIR_FS_$DOCUMENT_ROOT', '/home/daceuk/public_html/catalog/temp/'); // where the pages are located on the server

 

I'm trying to resolve this now but posted in case anyone would throw me a few lines to sort this last bit. Thanks in advance, i'm nearly there but would prefer to resolve this before setting up main site live

Edited by Darky10

Share this post


Link to post
Share on other sites

that's a real common problem. please do some searching and Dano suggested. Many posts with answers to that.

good searches:

DIR_FS_$DOCUMENT_ROOT

DIR_FS_DOCUMENT_ROOT

Share this post


Link to post
Share on other sites

I installed Easy Populate with Attributes, so now the Store Feeds aren't working anymore. I get this when I "run feed" now:

 

Warning: fopen(/home/charm3/public_htmlfeeds/FROOGLE_US_FTP_FILENAME) [function.fopen]: failed to open stream: No such file or directory in /home/charm3/public_html/store/admin/froogle_us.php on line 408

Warning: fwrite(): supplied argument is not a valid stream resource in /home/charm3/public_html/store/admin/froogle_us.php on line 409

Warning: fclose(): supplied argument is not a valid stream resource in /home/charm3/public_html/store/admin/froogle_us.php on line 410

Warning: fopen(/home/charm3/public_htmlfeeds/FROOGLE_US_FTP_FILENAME) [function.fopen]: failed to open stream: No such file or directory in /home/charm3/public_html/store/admin/froogle_us.php on line 416

Warning: fwrite(): supplied argument is not a valid stream resource in /home/charm3/public_html/store/admin/froogle_us.php on line 417

Warning: fclose(): supplied argument is not a valid stream resource in /home/charm3/public_html/store/admin/froogle_us.php on line 418
File completed: FROOGLE_US_FTP_FILENAME

Warning: chmod() [function.chmod]: No such file or directory in /home/charm3/public_html/store/admin/froogle_us.php on line 420

Warning: ftp_connect() [function.ftp-connect]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/charm3/public_html/store/admin/froogle_us.php on line 428
FTP open connection failed to FROOGLE_FTP_SERVER

Script timer: 0.495197 seconds.

Share this post


Link to post
Share on other sites

Can anyone please help me with this?

Hello, I've installed Three images with admin 1.0 http://www.oscommerce.com/community/contri...l/search,3image and am trying to get easypopulate to recognize theadditional images to upload and download. I am using Easy Populate 2.76d-MS2 - Default Language : English(1) . I followed this
			// unmcomment these lines if you are running the image mods
		/*
			$query .=		. $v_products_mimage . '", "'
						. $v_products_bimage . '", "'
						. $v_products_subimage1 . '", "'
						. $v_products_bsubimage1 . '", "'
						. $v_products_subimage2 . '", "'
						. $v_products_bsubimage2 . '", "'
						. $v_products_subimage3 . '", "'
						. $v_products_bsubimage3 . '", "'
		*/

here is what it shows in my sql product table for the images

  products_image varchar(64) latin1_swedish_ci  Yes NULL  Browse distinct values Change Drop Primary Unique Index Fulltext 
 products_image_medium varchar(64) latin1_swedish_ci  No   Browse distinct values Change Drop Primary Unique Index Fulltext 
 products_image_large varchar(64) latin1_swedish_ci  No   Browse distinct values Change Drop Primary Unique Index Fulltext 

Changed easypopulate to this but with no success

			// unmcomment these lines if you are running the image mods
		/*
			$query .=		. $v_products_mimage . '", "'
						. $v_products_bimage . '", "'
						. $v_products_image_medium . '", "'
						. $v_products_bimage_medium . '", "'
						. $v_products_image_large . '", "'
						. $v_products_bimage_large . '", "'
						. $v_products_subimage3 . '", "'
						. $v_products_bsubimage3 . '", "'
		*/

If anyone can help me with this it would be greatly appreciated


Your help and suggestions are greatly appreciated.

Thanks

Wayne

Share this post


Link to post
Share on other sites
I installed Easy Populate with Attributes, so now the Store Feeds aren't working anymore. I get this when I "run feed" now:

 

Warning: fopen(/home/charm3/public_htmlfeeds/FROOGLE_US_FTP_FILENAME) [function.fopen]: failed to open stream: No such file or directory in /home/charm3/public_html/store/admin/froogle_us.php on line 408

Warning: fwrite(): supplied argument is not a valid stream resource in /home/charm3/public_html/store/admin/froogle_us.php on line 409

Warning: fclose(): supplied argument is not a valid stream resource in /home/charm3/public_html/store/admin/froogle_us.php on line 410

Warning: fopen(/home/charm3/public_htmlfeeds/FROOGLE_US_FTP_FILENAME) [function.fopen]: failed to open stream: No such file or directory in /home/charm3/public_html/store/admin/froogle_us.php on line 416

Warning: fwrite(): supplied argument is not a valid stream resource in /home/charm3/public_html/store/admin/froogle_us.php on line 417

Warning: fclose(): supplied argument is not a valid stream resource in /home/charm3/public_html/store/admin/froogle_us.php on line 418
File completed: FROOGLE_US_FTP_FILENAME

Warning: chmod() [function.chmod]: No such file or directory in /home/charm3/public_html/store/admin/froogle_us.php on line 420

Warning: ftp_connect() [function.ftp-connect]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/charm3/public_html/store/admin/froogle_us.php on line 428
FTP open connection failed to FROOGLE_FTP_SERVER

Script timer: 0.495197 seconds.

looks like you messed up your configure.php. You should restore that back to before adding this contrib. then adjust only the temp directory setting in EP.

Edited by surfalot

Share this post


Link to post
Share on other sites

I'm using Easy Populate 2.76d-MS2. As it stands right now when I import new items and they have the same Products Model as an existing product, EP overwrites/updates that product.

 

I was wondering if it's possible to make it so that IF the Products Model already exists in the database to skip that import line and continue with the rest until another one is found, then skip that, etc?

 

Then output a line along the way of the rest saying the item was skipped or something?

Share this post


Link to post
Share on other sites
I'm using Easy Populate 2.76d-MS2. As it stands right now when I import new items and they have the same Products Model as an existing product, EP overwrites/updates that product.

 

I was wondering if it's possible to make it so that IF the Products Model already exists in the database to skip that import line and continue with the rest until another one is found, then skip that, etc?

 

Then output a line along the way of the rest saying the item was skipped or something?

 

I think the easiest way to do that is to upload a partial file with only the items you wish to import.

Share this post


Link to post
Share on other sites
I think the easiest way to do that is to upload a partial file with only the items you wish to import.

I was just thinking in case of a dupe product number or something like that, since I operate with thousands of products. Any clue if it's possible to do?

Share this post


Link to post
Share on other sites

Hey folks. Im using version v2.71 MS2.

 

When trying to populate database, I am getting the following error.

 

File uploaded.
Temporary filename: /tmp/phpCWTD0i
User filename: Sheet1.txt
Size:

Warning: file(Sheet1.txt): failed to open stream: No such file or directory in /home/httpd/vhosts/my-domain.com/httpdocs/admin/easypopulate.php on line 656

Warning: Invalid argument supplied for foreach() in /home/httpd/vhosts/my-domain.com/httpdocs/admin/easypopulate.php on line 679

 

Here is what line 656 states

 

655		// get the entire file into an array
656		$readed = file(DIR_FS_DOCUMENT_ROOT . $tmp_dir . $usrfl_name);
657	}
658	if ($localfile){
659		// move the file to where we can work with it
660		$file = tep_get_uploaded_file('usrfl');			$attribute_options_query = "select distinct products_options_id from " . TABLE_PRODUCTS_OPTIONS . " order by products_options_id";

 

And line 679 says the following:

 

677	// now we string the entire thing together in case there were carriage returns in the data
678	$newreaded = "";
678	foreach ($readed as $read){
680		$newreaded .= $read;
681	}

 

Any suggestions on how to fix this error

Share this post


Link to post
Share on other sites

Ok, so in my ordinary do-it-yourself spirit I have almost made it.

 

Here are the modifications I have done so far (should be pretty much all of them):

		} else {
		// existing product, get the id from the query
		// and update the product data
		$row =  tep_db_fetch_array($result);
		$v_products_id = $row['products_id'];
		echo "<font color='red'> SKU exists, so we skipped it!</font><br>";
		/*$row =  tep_db_fetch_array($result);
		$query = 'UPDATE '.TABLE_PRODUCTS.'
				SET
				products_price="'.$v_products_price.
				'" ,products_image="'.$v_products_image;*/

		// uncomment these lines if you are running the image mods
			/*$query .=
				'" ,products_mimage="'.$v_products_mimage.
				'" ,products_bimage="'.$v_products_bimage.
				'" ,products_subimage1="'.$v_products_subimage1.
				'" ,products_bsubimage1="'.$v_products_bsubimage1.
				'" ,products_subimage2="'.$v_products_subimage2.
				'" ,products_bsubimage2="'.$v_products_bsubimage2.
				'" ,products_subimage3="'.$v_products_subimage3.
				'" ,products_bsubimage3="'.$v_products_bsubimage3;
*/

		/*$query .= '", products_weight="'.$v_products_weight .
				'", products_tax_class_id="'.$v_tax_class_id . 
				'", products_date_available= ' . $v_date_avail .
				', products_date_added= ' . $v_date_added .
				', products_last_modified=CURRENT_TIMESTAMP
				, products_quantity="' . $v_products_quantity .  
				'", products_briefdesc="' . $v_products_briefdesc .
				'", products_condition="' . $v_products_condition .
				'", vendors_id="' . $v_vendors_id .
				'" ,manufacturers_id=' . $v_manufacturer_id . 
				' , products_status=' . $v_db_status . '
				WHERE
					(products_id = "'. $v_products_id . '")';

		$result = tep_db_query($query);*/
	}

 

else {
					// already in the description, let's just update it
					/*$sql =
						"UPDATE ".TABLE_PRODUCTS_DESCRIPTION." SET
							products_name='" . addslashes($name) . "',
							products_description='" . addslashes($v_products_description[$key]) . "',
							products_url='" . $v_products_url[$key] . "'
						WHERE
							products_id = '$v_products_id' AND
							language_id = '$key'";*/
					// support for Lindas Header Controller 2.0
					if (isset($v_products_head_title_tag)){
						// override the sql if we're using Linda's contrib
						$sql =
							"UPDATE ".TABLE_PRODUCTS_DESCRIPTION." SET
								products_name = '" . addslashes($name) . "',
								products_description = '" . addslashes($v_products_description[$key]) . "',
								products_url = '" . $v_products_url[$key] ."',
								products_head_title_tag = '" . $v_products_head_title_tag[$key] ."',
								products_head_desc_tag = '" . $v_products_head_desc_tag[$key] ."',
								products_head_keywords_tag = '" . $v_products_head_keywords_tag[$key] ."'
							WHERE
								products_id = '$v_products_id' AND
								language_id = '$key'";
					}
					// end support for Linda's Header Controller 2.0
					//$result = tep_db_query($sql);
				//}

 

There is just one minor thing left; how do I stop it from updating the date of the skipped product, so that it doesn't end up in the New Products infobox?

Share this post


Link to post
Share on other sites

Hi,

 

I am using EP 2.76d and I need to add things in French language which contains a lot of ' (quotes).

 

If I add a back slash \ before them the slash appears in the name/description.

 

How do I add quotes without the back slash appearing?

 

Thanks,

Share this post


Link to post
Share on other sites

Hi All

 

Can anyone help with this problem?

 

I've followed the previous as much as I can (this thread is WAY big now!!) :blink:

 

I have HTML in my descriptions as follows:

 

Tafetta, satin and tulle one piece gown<br><br>
Champagne and ivory option pictured<br><br>
Normal delivery time approx 4 weeks

<!-- 
Happi Multi Pix. Presented to the PHP community in fraternal thanks by Tim Fahy (www.ambermines.co.uk). 24 January 2004.
// -->

<script LANGUAGE="JavaScript" type="text/javascript">
 <!--
   function ShowPopup(page,name,options)
   {
   Window = window.open(page,name,options);
   }

// -->
</SCRIPT>


<TABLE BORDER=0 CELLSPACING=6 CELLPADDING=6>
<TR>

<TD> 
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01B.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01B.jpg" width="80" height="100" border="1" alt="Wholesale wedding dresses"></a>
</TD>


<TD>
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01C.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01C.jpg" width="80" height="100" border="1" alt="Wholesale wedding dresses"></a>
</TD>


<TD> 
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01A.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01A.jpg" width="80" height="100" border="1" alt="Wholesale wedding dresses"></a>
</TD>



<TD>
</TD>

</TR>

<!-- 
7. Next, there is room for picture number five. Just copy the text from cell 1 above
-->

<TD> 

</TD>

<!--
8. Next, there is room for picture number six. Just copy the text from cell 1 above
 // -->

<TD>

</TD>

<!--
9. Next, there is room for picture number seven. Just copy the text from cell 1 above
 // -->
<TD>

</TD>

<!--
10. Next, there is room for picture number eight. Just copy the text from cell 1 above
 // -->

<TD>

</TD>

</TR> 
</TABLE>

 

I have the excel option set to truw. I've installed the suggested code regarding the quotes. But the HTML still doesn't show properly.

 

This is what shows on the actual prduct in the admin

Tafetta, satin and tulle one piece gown<br><br>
Champagne and ivory option pictured<br><br>
Normal delivery time approx 4 weeks

<!-- 
Happi Multi Pix. Presented to the PHP community in fraternal thanks by Tim Fahy (www.ambermines.co.uk). 24 January 2004.
// -->

<script LANGUAGE="JavaScript" type="text/javascript">
 <!--
   function ShowPopup(page,name,options)
   {
   Window = window.open(page,name,options);
   }

// -->
</SCRIPT>


<TABLE BORDER=0 CELLSPACING=6 CELLPADDING=6>
<TR>

<TD> 
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01B.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01B.jpg" width=඘" height=蔴" border=ŕ" alt="Wholesale wedding dresses"></a>
</TD>


<TD>
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01C.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01C.jpg" width=඘" height=蔴" border=ŕ" alt="Wholesale wedding dresses"></a>
</TD>


<TD> 
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01A.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01A.jpg" width=඘" height=蔴" border=ŕ" alt="Wholesale wedding dresses"></a>
</TD>



<TD>
</TD>

</TR>

<!-- 
7. Next, there is room for picture number five. Just copy the text from cell 1 above
-->

<TD> 

</TD>

<!--
8. Next, there is room for picture number six. Just copy the text from cell 1 above
 // -->

<TD>

</TD>

<!--
9. Next, there is room for picture number seven. Just copy the text from cell 1 above
 // -->
<TD>

</TD>

<!--
10. Next, there is room for picture number eight. Just copy the text from cell 1 above
 // -->

<TD>

</TD>

</TR> 
</TABLE>

 

 

And on the actual store, all I get is the first few lines but none of the stuff within HTML.

 

Losing the will to live....... :'(

Share this post


Link to post
Share on other sites

I would have to say thank you for this contribution and I am going to make a contribution to you as well here shortly. I installed all of it correctly and can download everything, the only problem is when I download the complete versions (actually and version) when I open it in excel, all the fields are in the cell of A1, and not seperated for example A1, B1, C1 etc. Is there something I have missed??

Share this post


Link to post
Share on other sites
I would have to say thank you for this contribution and I am going to make a contribution to you as well here shortly. I installed all of it correctly and can download everything, the only problem is when I download the complete versions (actually and version) when I open it in excel, all the fields are in the cell of A1, and not seperated for example A1, B1, C1 etc. Is there something I have missed??

 

 

Nevermine I figured it out, just reuploaded the php files and all is good now!!

Share this post


Link to post
Share on other sites
I would have to say thank you for this contribution and I am going to make a contribution to you as well here shortly. I installed all of it correctly and can download everything, the only problem is when I download the complete versions (actually and version) when I open it in excel, all the fields are in the cell of A1, and not seperated for example A1, B1, C1 etc. Is there something I have missed??

 

 

Nevermine I figured it out, just reuploaded the php files and all is good now!!

Share this post


Link to post
Share on other sites

Warning: move_uploaded_file(/home/swoop/public_html/store/catalog//catalog/temp/EP2007Apr22-1705.txt) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/swoop/public_html/store/catalog/admin/easypopulate_functions.php on line 32

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpglfppY' to '/home/swoop/public_html/store/catalog//catalog/temp/EP2007Apr22-1705.txt' in /home/swoop/public_html/store/catalog/admin/easypopulate_functions.php on line 32


File uploaded. 
Temporary filename: /tmp/phpglfppY
User filename: EP2007Apr22-1705.txt
Size: 256971

Warning: file(/home/swoop/public_html/store/catalog//catalog/temp/EP2007Apr22-1705.txt) [function.file]: failed to open stream: No such file or directory in /home/swoop/public_html/store/catalog/admin/easypopulate.php on line 667

Warning: Invalid argument supplied for foreach() in /home/swoop/public_html/store/catalog/admin/easypopulate.php on line 690


 

 

I was wondering if anyone could give me some insight on this problem???????

Share this post


Link to post
Share on other sites

(/home/swoop/public_html/store/catalog//catalog/temp/

 

you have something wrong with configure.php file, you have catalog twice along with two slashes

 

 

 

Warning: move_uploaded_file(/home/swoop/public_html/store/catalog//catalog/temp/EP2007Apr22-1705.txt) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/swoop/public_html/store/catalog/admin/easypopulate_functions.php on line 32

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpglfppY' to '/home/swoop/public_html/store/catalog//catalog/temp/EP2007Apr22-1705.txt' in /home/swoop/public_html/store/catalog/admin/easypopulate_functions.php on line 32
File uploaded. 
Temporary filename: /tmp/phpglfppY
User filename: EP2007Apr22-1705.txt
Size: 256971

Warning: file(/home/swoop/public_html/store/catalog//catalog/temp/EP2007Apr22-1705.txt) [function.file]: failed to open stream: No such file or directory in /home/swoop/public_html/store/catalog/admin/easypopulate.php on line 667

Warning: Invalid argument supplied for foreach() in /home/swoop/public_html/store/catalog/admin/easypopulate.php on line 690

I was wondering if anyone could give me some insight on this problem???????


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
(/home/swoop/public_html/store/catalog//catalog/temp/

 

you have something wrong with configure.php file, you have catalog twice along with two slashes

 

 

// Please set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php
$tempdir = "/catalog/temp/";
$tempdir2 = "/catalog/temp/";

 

I went into the easyconfigure.php and saw this line. I do not see this in the easyconfigure I printed out before and I do not see this in the catalog/admin/includes/configure.php or do I need to add that to it like this?

 

define('DOCUMENT_ROOT,'$DOCUMENT_ROOT)

 

or change the line

 

('DIR_FS_DOCUMENT_ROOT', '/home/swoop/public_html/store/catalog/'); //

 

to

 

('$DIR_FS_DOCUMENT_ROOT', '/home/swoop/public_html/store/catalog/'); //

 

I think this may help out my problem that I was having before in the above quote.

Share this post


Link to post
Share on other sites

document rot is where your whole site is, ie /home/swoop/public_html/ or $document_root (you can see this by going into the store admin, tools, server info and then search for document_root


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
Hi,

 

I am using EP 2.76d and I need to add things in French language which contains a lot of ' (quotes).

 

If I add a back slash \ before them the slash appears in the name/description.

 

How do I add quotes without the back slash appearing?

 

Thanks,

If it's the 2.76d version I uploaded, you're in luck. That version has an option that should make EP handle the quotes.

 

When you create the file for upload (from excel) you need to "save as..." CVS (MS-DOS).

 

look at your export file with notepad or wordpad. Look at the first line. Is it separated with a comma or a semi-colon? (remember for later)

 

Enable the excel safe option at the top of the easypopulate.php file. set it to true.

 

then look for this line (105) in the EP file:

if ($excel_safe_output == true) { $separator = ","; }

change the $separator = "," part to include the separator you found when viewing your file to import. I suspect you are using the semi-colon, so the line will look like this:

if ($excel_safe_output == true) { $separator = ";"; }

please let me know how it goes

Share this post


Link to post
Share on other sites
Hey folks. Im using version v2.71 MS2.

 

When trying to populate database, I am getting the following error.

 

File uploaded.
Temporary filename: /tmp/phpCWTD0i
User filename: Sheet1.txt
Size:

Warning: file(Sheet1.txt): failed to open stream: No such file or directory in /home/httpd/vhosts/my-domain.com/httpdocs/admin/easypopulate.php on line 656

Warning: Invalid argument supplied for foreach() in /home/httpd/vhosts/my-domain.com/httpdocs/admin/easypopulate.php on line 679

 

Here is what line 656 states

 

655		// get the entire file into an array
656		$readed = file(DIR_FS_DOCUMENT_ROOT . $tmp_dir . $usrfl_name);
657	}
658	if ($localfile){
659		// move the file to where we can work with it
660		$file = tep_get_uploaded_file('usrfl');			$attribute_options_query = "select distinct products_options_id from " . TABLE_PRODUCTS_OPTIONS . " order by products_options_id";

 

And line 679 says the following:

 

677	// now we string the entire thing together in case there were carriage returns in the data
678	$newreaded = "";
678	foreach ($readed as $read){
680		$newreaded .= $read;
681	}

 

Any suggestions on how to fix this error

my guess would be your temp directory in easypopulate.php not set to the temp folder you created and set to permissions 777. And _maybe_ your DIR_FS_DOCUMENT_ROOT in configure.php. search this thread for DIR_FS_DOCUMENT_ROOT for some good help with that.

Share this post


Link to post
Share on other sites
Hi All

 

Can anyone help with this problem?

 

I've followed the previous as much as I can (this thread is WAY big now!!) :blink:

 

I have HTML in my descriptions as follows:

 

Tafetta, satin and tulle one piece gown<br><br>
Champagne and ivory option pictured<br><br>
Normal delivery time approx 4 weeks



<script LANGUAGE="JavaScript" type="text/javascript">

</SCRIPT>


<TABLE BORDER=0 CELLSPACING=6 CELLPADDING=6>
<TR>

<TD> 
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01B.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01B.jpg" width="80" height="100" border="1" alt="Wholesale wedding dresses"></a>
</TD>


<TD>
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01C.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01C.jpg" width="80" height="100" border="1" alt="Wholesale wedding dresses"></a>
</TD>


<TD> 
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01A.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01A.jpg" width="80" height="100" border="1" alt="Wholesale wedding dresses"></a>
</TD>



<TD>
</TD>

</TR>



<TD> 

</TD>



<TD>

</TD>


<TD>

</TD>



<TD>

</TD>

</TR> 
</TABLE>

 

I have the excel option set to truw. I've installed the suggested code regarding the quotes. But the HTML still doesn't show properly.

 

This is what shows on the actual prduct in the admin

Tafetta, satin and tulle one piece gown<br><br>
Champagne and ivory option pictured<br><br>
Normal delivery time approx 4 weeks



<script LANGUAGE="JavaScript" type="text/javascript">

</SCRIPT>


<TABLE BORDER=0 CELLSPACING=6 CELLPADDING=6>
<TR>

<TD> 
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01B.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01B.jpg" width=඘" height=蔴" border=ŕ" alt="Wholesale wedding dresses"></a>
</TD>


<TD>
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01C.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01C.jpg" width=඘" height=蔴" border=ŕ" alt="Wholesale wedding dresses"></a>
</TD>


<TD> 
<a href="java script:;" onClick="ShowPopup('http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01A.jpg','popup','resizable=yes,width=600,height=800');"><img src="http://www.bridal-online.co.uk/catalog/photogallery/2007SPRING-BG01A.jpg" width=඘" height=蔴" border=ŕ" alt="Wholesale wedding dresses"></a>
</TD>



<TD>
</TD>

</TR>



<TD> 

</TD>



<TD>

</TD>


<TD>

</TD>



<TD>

</TD>

</TR> 
</TABLE>

 

 

And on the actual store, all I get is the first few lines but none of the stuff within HTML.

 

Losing the will to live....... :'(

 

see post 5698 above, does any of that help you?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×