Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

VJ

Easy Populate & Products Attributes

Recommended Posts

Hi,confused abou this errors, maybe somebody could help me?

 

 

Thanks

 

Warning: move_uploaded_file(/home/grinda/domains/maksas.lt/public_html/os//catalog/temp/Copy of XL-import-dummy.xls) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/grinda/domains/maksas.lt/public_html/os/admin/easypopulate_functions.php on line 43

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/php8jmr2j' to '/home/grinda/domains/maksas.lt/public_html/os//catalog/temp/Copy of XL-import-dummy.xls' in /home/grinda/domains/maksas.lt/public_html/os/admin/easypopulate_functions.php on line 43

File uploaded.
Temporary filename: /tmp/php8jmr2j
User filename: Copy of XL-import-dummy.xls
Size: 663040

Warning: file(/home/grinda/domains/maksas.lt/public_html/os//catalog/temp/Copy of XL-import-dummy.xls) [function.file]: failed to open stream: No such file or directory in /home/grinda/domains/maksas.lt/public_html/os/admin/easypopulate.php on line 807

Warning: Invalid argument supplied for foreach() in /home/grinda/domains/maksas.lt/public_html/os/admin/easypopulate.php on line 846

Share this post


Link to post
Share on other sites
sorry, had to reread. Do you see the download on-the-fly option with the category and manufacturer filter? It's a bordered box above the list of quick links for downloading. (v2.76d) Use that to download sub-sets of products. download on the fly should do it.

 

Hi,

 

Tried downloading 1 category and recieve the following error:

 

1065 - Query was empty

 

 

 

[TEP STOP]

 

Any further ideas?

 

Many Thanks

D4

Share this post


Link to post
Share on other sites
I think you are in the "nothing-happens" group, see post 5289.

Easy Populate version?

PHP version? (register globals ? on/off)

MySQL version?

any info you can provide would help greatly. :)

 

osC: 2.2MS2

Easypopulate: v 2.76d

PHP: 5.0.5 w/Register Globals set to 'off' in php.ini

MySQL: 4.1.16

 

The problem I am having is that I cannot export anything. No files are ever created in my temp directory.

 

Below are the confguration settings:

<?php
/*
 $Id: easypopulate.php,v 2.76d 2006/10/16 22:50:52 surfalot Exp $

 Designed for osCommerce, Open Source E-Commerce Solutions
 http://www.oscommerce.com

 Copyright (c) 2003 osCommerce

 Released under the GNU General Public License
*/

// Current EP Version
$curver = '2.76d-MS2';

require('includes/application_top.php');
require('includes/database_tables.php');

//
//*******************************
//*******************************
// C O N F I G U R A T I O N
// V A R I A B L E S
//*******************************
//*******************************

// **** Temp directory ****
// if you changed your directory structure from stock and do not have /catalog/temp/, then you'll need to change this accordingly.
//
// Please set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php
$tempdir = DIR_FS_DOCUMENT_ROOT . "/store/temp/";

//**** File Splitting Configuration ****
// we attempt to set the timeout limit longer for this script to avoid having to split the files
// NOTE:  If your server is running in safe mode, this setting cannot override the timeout set in php.ini
// uncomment this if you are not on a safe mode server and you are getting timeouts
// set_time_limit(330);

// if you are splitting files, this will set the maximum number of records to put in each file.
// if you set your php.ini to a long time, you can make this number bigger
global $maxrecs;
$maxrecs = 300; // default, seems to work for most people.  Reduce if you hit timeouts
//$maxrecs = 4; // for testing

//**** Image Defaulting ****
global $default_images, $default_image_manufacturer, $default_image_product, $default_image_category;

// set them to your own default "We don't have any picture" gif
//$default_image_manufacturer = 'no_image_manufacturer.gif';
//$default_image_product = 'no_image_product.gif';
//$default_image_category = 'no_image_category.gif';

// or let them get set to nothing
$default_image_manufacturer = '';
$default_image_product = '';
$default_image_category = '';

//**** Status Field Setting ****
// Set the v_status field to "Inactive" if you want the status=0 in the system
// Set the v_status field to "Delete" if you want to remove the item from the system <- THIS IS NOT WORKING YET!
// If zero_qty_inactive is true, then items with zero qty will automatically be inactive in the store.
global $active, $inactive, $zero_qty_inactive, $deleteit;
$active = 'Active';
$inactive = 'Inactive';
//$deleteit = 'Delete'; // not functional yet
$zero_qty_inactive = true;

//**** Size of products_model in products table ****
// set this to the size of your model number field in the db.  We check to make sure all models are no longer than this value.
// this prevents the database from getting fubared.  Just making this number bigger won't help your database!  They must match!
global $modelsize;
$modelsize = 25;

//**** Price includes tax? ****
// Set the v_price_with_tax to
// 0 if you want the price without the tax included
// 1 if you want the price to be defined for import & export including tax.
global $price_with_tax;
$price_with_tax =false;

// **** Quote -> Escape character conversion ****
// If you have extensive html in your descriptions and it's getting mangled on upload, turn this off
// set to 1 = replace quotes with escape characters
// set to 0 = no quote replacement
global $replace_quotes;
$replace_quotes = false;

// **** Field Separator ****
// change this if you can't use the default of tabs
// Tab is the default, comma and semicolon are commonly supported by various progs
// Remember, if your descriptions contain this character, you will confuse EP!
global $separator;
//$separator = "\t"; // tab is default
//$separator = ","; // comma
//$separator = ";"; // semi-colon
$separator = "~"; // tilde
//$separator = "-"; // dash
//$separator = "*"; // splat

// *** Excel safe output ***
// this setting will supersede the previous $separator setting and create a file
// that excel will import without spanning cells from embedded commas.
global $excel_safe_output;
$excel_safe_output = false; // default is: false
if ($excel_safe_output == true) { $separator = ","; }

// *** Preserve Tabs, Carriage returns and Line feeds ***
// this setting will preserve the special chars that can cause problems in 
// a text based output. When used with $excel_safe_output, it will safely
// preserve these elements in the export and import.
global $preserve_tabs_cr_lf;
$preserve_tabs_cr_lf = false; // default is: false

// **** Max Category Levels ****
// change this if you need more or fewer categories
global $max_categories;
$max_categories = 7; // 7 is default

// VJ product attributes begin
// **** Product Attributes ****
// change this to false, if do not want to download product attributes
global $products_with_attributes;
$products_with_attributes = true; 

// change this to true, if you use QTYpro and want to set attributes stock with EP.
global $products_attributes_stock;
$products_attributes_stock = false; 


// change this if you want to download selected product options
// this might be handy, if you have a lot of product options, and your output file exceeds 256 columns (which is the max. limit MS Excel is able to handle)
global $attribute_options_select;
//$attribute_options_select = array('Size', 'Model'); // uncomment and fill with product options name you wish to download // comment this line, if you wish to download all product options
// VJ product attributes end

// *** Show settings on EP page ***
global $show_ep_settings;
$show_ep_settings = true; // default is: false



// ****************************************
// Froogle configuration variables
// -- YOU MUST CONFIGURE THIS!  IT WON'T WORK OUT OF THE BOX!
// ****************************************

// **** Froogle product info page path ****
// We can't use the tep functions to create the link, because the links will point to the admin, since that's where we're at.
// So put the entire path to your product_info.php page here
global $froogle_product_info_path;
$froogle_product_info_path = "http://www.internetshoppersdepot.com/store/product_info.php";

// **** Froogle product image path ****
// Set this to the path to your images directory
global $froogle_image_path;
$froogle_image_path = "http://www.internetshoppersdepot.com/store/images/";

// **** Froogle - search engine friendly setting
// if your store has SEARCH ENGINE FRIENDLY URLS set, then turn this to true
// I did it this way because I'm having trouble with the code seeing the constants
// that are defined in other places.
global $froogle_SEF_urls;
$froogle_SEF_urls = false;


// ****************************************
// End Froogle configuration variables
// ****************************************

//*******************************
//*******************************
// E N D
// C O N F I G U R A T I O N
// V A R I A B L E S
//*******************************
//*******************************

Share this post


Link to post
Share on other sites
sorry, had to reread. Do you see the download on-the-fly option with the category and manufacturer filter? It's a bordered box above the list of quick links for downloading. (v2.76d) Use that to download sub-sets of products. download on the fly should do it.

 

Hi,

 

Okay, using the on the fly box of tools i am able to download my database via ep :D However, when i make some changes and try to re-upload the file i click the Insert Into DB button and quick as a flash the page refreshes.

 

I check in my database and the products are not there :( I have tried all three options and i am presented with the same results?

 

Can anyone suggest how to crack this?

 

Many Thanks

D4

Share this post


Link to post
Share on other sites
Hi,confused abou this errors, maybe somebody could help me?

Thanks

 

Warning: move_uploaded_file(/home/grinda/domains/maksas.lt/public_html/os//catalog/temp/Copy of XL-import-dummy.xls) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/grinda/domains/maksas.lt/public_html/os/admin/easypopulate_functions.php on line 43

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/php8jmr2j' to '/home/grinda/domains/maksas.lt/public_html/os//catalog/temp/Copy of XL-import-dummy.xls' in /home/grinda/domains/maksas.lt/public_html/os/admin/easypopulate_functions.php on line 43

File uploaded.
Temporary filename: /tmp/php8jmr2j
User filename: Copy of XL-import-dummy.xls
Size: 663040

Warning: file(/home/grinda/domains/maksas.lt/public_html/os//catalog/temp/Copy of XL-import-dummy.xls) [function.file]: failed to open stream: No such file or directory in /home/grinda/domains/maksas.lt/public_html/os/admin/easypopulate.php on line 807

Warning: Invalid argument supplied for foreach() in /home/grinda/domains/maksas.lt/public_html/os/admin/easypopulate.php on line 846

I guess you need to ask yourself if this is a valid path to your temporary location?

/home/grinda/domains/maksas.lt/public_html/os//catalog/temp/

probably not since there are 2 slashes together. Have you configured the temp path location in the easypopulate.php file? Did you go through all those settings and make sure how they are set makes sense? Read the docs?

And lastly, the file you are uploading "Copy of XL-import-dummy.xls"

This contribution does not import xls files. Probably should read though the docs again. You need to upload the exact same file type that was exported.

Share this post


Link to post
Share on other sites
Hi,

 

Okay, using the on the fly box of tools i am able to download my database via ep :D However, when i make some changes and try to re-upload the file i click the Insert Into DB button and quick as a flash the page refreshes.

 

I check in my database and the products are not there :( I have tried all three options and i am presented with the same results?

 

Can anyone suggest how to crack this?

 

Many Thanks

D4

are you simply turning the same export file around to import? how about posting a link to the file you are trying for me to look at.

Share this post


Link to post
Share on other sites
osC: 2.2MS2

Easypopulate: v 2.76d

PHP: 5.0.5 w/Register Globals set to 'off' in php.ini

MySQL: 4.1.16

 

The problem I am having is that I cannot export anything. No files are ever created in my temp directory.

 

Below are the confguration settings:

The is most likely due to the register globals off setting. I don't think anything that has been uploaded has completely addressed the issue. So you are going to have to be patient with the rest of the folks waiting for at register globals off fix. Sorry, still no ETA.

Some hosts allow you to override the php.ini settings by placing a php.ini file on your site. Check with your host.

Share this post


Link to post
Share on other sites
Hi,

 

Tried downloading 1 category and recieve the following error:

 

1065 - Query was empty

[TEP STOP]

 

Any further ideas?

 

Many Thanks

D4

So what was this problem?

Share this post


Link to post
Share on other sites
The is most likely due to the register globals off setting. I don't think anything that has been uploaded has completely addressed the issue. So you are going to have to be patient with the rest of the folks waiting for at register globals off fix. Sorry, still no ETA.

Some hosts allow you to override the php.ini settings by placing a php.ini file on your site. Check with your host.

I have turned on Register Globals and it works fine now. Do most sites running OSC have this on or off? Are there any security concerns with having it on?

 

Thanks!

Share this post


Link to post
Share on other sites
So what was this problem?

 

Hi,

 

Not sure i think it was the fact i was trying to download the attributes with the file.

 

Although my next issue still remains see Post #5304

 

Thanks

D4

Share this post


Link to post
Share on other sites
I have turned on Register Globals and it works fine now. Do most sites running OSC have this on or off? Are there any security concerns with having it on?

 

Thanks!

Disregard, I found the info I was looking for.

 

If anyone else wants to read about register_globals, take a look at this link: http://uk.php.net/register_globals

Share this post


Link to post
Share on other sites
Hi,

 

Not sure i think it was the fact i was trying to download the attributes with the file.

 

Although my next issue still remains see Post #5304

 

Thanks

D4

see post 5306

Share this post


Link to post
Share on other sites

Hi,

 

I have the SPPC mod working on my site and its almost working properly with Easy Populate.

 

I can download the catalog by model/price/qty and see the extra group prices appearing in excel. When i copy all the prices from the price column over to the customer_price_1 column in Excel, then make all the cells of customer_group_id_1 equal to 1 so the prices apply to that group.

 

I then upload the the file through the admin and it uploads successfully but when i check the catalog side of the site, all the products that were deactivated have now become active, which i dont want to happen happen. Can you exclude fields from being changed in the upload file somehow?

 

So, whats the best way to solve this, make easy populate download the file with the v_status field included in the EP file or how do you stop easy populate from reactivating products even though those fields shouldnt be changed in the uploaded file, only the following fields are in the uploaded file:

 

v_products_model

v_products_price

v_products_quantity

v_customer_price_1

v_customer_group_id_1

v_customer_price_2

v_customer_group_id_2

v_customer_price_3

v_customer_group_id_3

 

Can anyone help? Thanks.

Share this post


Link to post
Share on other sites
I have the SPPC mod working on my site and its almost working properly with Easy Populate.

WE HAVE A WINNER! yup that's a logic bug.

 

What did you win? THE FIX (hopefully)

 

if you have v2.76d, try this

 

find in easypopulate.php

 

// now do a query to get the record's current contents
$sql = "SELECT
	p.products_id as v_products_id,
	p.products_model as v_products_model,

 

add just after:

 

p.products_status as v_status_current,

 

find:

 

// default the stock if they spec'd it or if it's blank
$v_db_status = '1'; // default to active
if ($v_status == $inactive){
	// they told us to deactivate this item
	$v_db_status = '0';
}

 

change to:

 

// default the stock if they spec'd it or if it's blank
	if (isset($v_status_current)){
	  $v_db_status = strval($v_status_current); // default to current value
	} else {
	  $v_db_status = '1'; // default to active
	}
	if (trim($v_status) == $inactive){
		// they told us to deactivate this item
		$v_db_status = '0';
	} elseif (trim($v_status) == $active) {
		$v_db_status = '1';
	}

 

It was coded on the fly, please leave feedback. B)

Share this post


Link to post
Share on other sites

One question more

 

what about splitting files? I split file in to several parts but still get error wich say that mysql querry is limited to 30 seconds only.

 

Fatal error: Maximum execution time of 30 seconds exceeded in /home/grinda/domains/maksas.lt/public_html/parduotuve/admin/easypopulate.php on line 1595

 

How I can split files in to smaller pieces?

Share this post


Link to post
Share on other sites
One question more

 

what about splitting files? I split file in to several parts but still get error wich say that mysql querry is limited to 30 seconds only.

 

Fatal error: Maximum execution time of 30 seconds exceeded in /home/grinda/domains/maksas.lt/public_html/parduotuve/admin/easypopulate.php on line 1595

 

How I can split files in to smaller pieces?

do you have many attributes you are trying to import?

 

see this setting in the configuration. this is in the docs... >_<

$maxrecs = 300; // default, seems to work for most people. Reduce if you hit timeouts

 

please do read through all the settings.

Share this post


Link to post
Share on other sites

Hi installed EP yeaterday and been playing with it in preparation for the uploading of a large product catalogue.

 

Firstly it took quite a bit of time to work out which packages of EP I needed, in the end I looked at them all and decided on EP_v2_76d_MS2 and ep_2.76d_with_admin.

 

I then started reading the may bits of documentation & it all becomes very confusing with what is actually current.

 

The only part of the instruction I've not followed with regards to the install is to (quote 1readmeFIRST.txt) "copy admin/includes/classes/table_block.php to same place on your shop, replacing the old file. (backup old file in case changes have been made) This corrects a bug that was reported to osCommerce."

 

The reason I have not followed is the date on 1readmeFIRST.txt is Aug 2003 - Has the bug reported to osc been fixed? I compared the EP file with my file and can only see 2 minor changes on line 44 & 47.

 

The problem I'm experiancing is getting the attributes out of my dummy store in to the spreadsheet. most items have 1 or 2 attributes usually size and colour. I've checked the settings and attributes is set to 'true'. So why do they dont get put into the "complete" spreadsheet dump? I've also tried the attributes selection for export and all I get is a 2 column spreadsheet with v_products_model & EOREOR.

 

Any ideas to what I have done wrong?

 

Many thanks for what looks like could be an excellent time saver for me.

Share this post


Link to post
Share on other sites
WE HAVE A WINNER! yup that's a logic bug.

 

What did you win? THE FIX (hopefully)

 

if you have v2.76d, try this

 

find in easypopulate.php

 

// now do a query to get the record's current contents
$sql = "SELECT
	p.products_id as v_products_id,
	p.products_model as v_products_model,

 

add just after:

 

p.products_status as v_status_current,

 

find:

 

// default the stock if they spec'd it or if it's blank
$v_db_status = '1'; // default to active
if ($v_status == $inactive){
	// they told us to deactivate this item
	$v_db_status = '0';
}

 

change to:

 

// default the stock if they spec'd it or if it's blank
	if (isset($v_status_current)){
	  $v_db_status = strval($v_status_current); // default to current value
	} else {
	  $v_db_status = '1'; // default to active
	}
	if (trim($v_status) == $inactive){
		// they told us to deactivate this item
		$v_db_status = '0';
	} elseif (trim($v_status) == $active) {
		$v_db_status = '1';
	}

 

It was coded on the fly, please leave feedback. B)

 

Hi, thanks for the reply. I tried those changes you mentioned and it actually looked like it was going to work but it didnt. I made the changes to easy_populate.php and then downloaded a new model/price/qty version of the file, made the changes to customer_price_1 and customer_group_1 and reuploaded the file.

Now most of the 400 or so products seem to have been changed to inactive but yet there are 8 products that are still set to active (not sure why coz there's no difference between them and the rest of the products online or on the downloaded file)

 

Would it help if the v_status column was downloaded with the model/price/qty file so when uploading again, the v_status will be set correctly already without it having to guess what state to leave the product in? What code would i need to change to retrieve the v_status info and upload the v_status info again?

 

Forgot to mention, im using EP v2.90

 

Thanks for the help Surfalot! :)

Edited by sonictrip.net

Share this post


Link to post
Share on other sites
Hi, thanks for the reply. I tried those changes you mentioned and it actually looked like it was going to work but it didnt. I made the changes to easy_populate.php and then downloaded a new model/price/qty version of the file, made the changes to customer_price_1 and customer_group_1 and reuploaded the file.

Now most of the 400 or so products seem to have been changed to inactive but yet there are 8 products that are still set to active (not sure why coz there's no difference between them and the rest of the products online or on the downloaded file)

 

Would it help if the v_status column was downloaded with the model/price/qty file so when uploading again, the v_status will be set correctly already without it having to guess what state to leave the product in? What code would i need to change to retrieve the v_status info and upload the v_status info again?

 

Forgot to mention, im using EP v2.90

 

Thanks for the help Surfalot! :)

I'm only supporting 2.76x. You should look at all the setting at the top of the file, particularly this one:

 

$zero_qty_inactive = true;

 

if it's true, that's why product is being set inactive and some not. description of this setting is in the docs.

 

does it work now?

 

BTW: if you were using my version, you would be able to choose the status download with your other columns for export. :-"

Edited by surfalot

Share this post


Link to post
Share on other sites
Hi installed EP yeaterday and been playing with it in preparation for the uploading of a large product catalogue.

 

Firstly it took quite a bit of time to work out which packages of EP I needed, in the end I looked at them all and decided on EP_v2_76d_MS2 and ep_2.76d_with_admin.

 

I then started reading the may bits of documentation & it all becomes very confusing with what is actually current.

 

The only part of the instruction I've not followed with regards to the install is to (quote 1readmeFIRST.txt) "copy admin/includes/classes/table_block.php to same place on your shop, replacing the old file. (backup old file in case changes have been made) This corrects a bug that was reported to osCommerce."

 

The reason I have not followed is the date on 1readmeFIRST.txt is Aug 2003 - Has the bug reported to osc been fixed? I compared the EP file with my file and can only see 2 minor changes on line 44 & 47.

 

The problem I'm experiancing is getting the attributes out of my dummy store in to the spreadsheet. most items have 1 or 2 attributes usually size and colour. I've checked the settings and attributes is set to 'true'. So why do they dont get put into the "complete" spreadsheet dump? I've also tried the attributes selection for export and all I get is a 2 column spreadsheet with v_products_model & EOREOR.

 

Any ideas to what I have done wrong?

 

Many thanks for what looks like could be an excellent time saver for me.

copy admin/includes/classes/table_block.php (I failed to change that update date)

 

from the troubleshooting tips in the docs:

----------------------------------

I don’t see the "Custom Export" window, all I see is a tiny little box where is should be.

If you upload the fixed file from /catalog/admin/includes/classes/table_block.php This should be fixed. If not you may want to look at this. I (surfalot) truly apologize for introducing this problem by using this class in the project. Bug has been documented here: http://www.oscommerce.com/community/bugs,2003

 

open: /catalog/admin/includes/classes/table_block.php

 

find:

if (isset($contents[$i][$x]['text']) && tep_not_null(isset($contents[$i][$x]['text']))) {

 

replace line with this

if (isset($contents[$i][$x]['text']) && tep_not_null($contents[$i][$x]['text'])) {

 

find:

if (isset($contents[$i][$x]['params']) && tep_not_null(isset($contents[$i][$x]['params']))) {

 

replace with:

if (isset($contents[$i][$x]['params']) && tep_not_null($contents[$i][$x]['params'])) {

 

--------------------------------------------------

do you have attributes defined AND assigned to a product in the shop now? Do you have unique model numbers assigned to each product?

 

This contrib is not going to be a time-saver if you are looking to import lots of products with attributes. It works good if you have the attributes and products setup in the store and wish to export and then import in another store or later, etc.

 

If your intention is to cut time to import a file with attributes already setup (by hand, yourself, in the file), you may be in for more then you bargained. Unfortunately. The way it was implemented is quite convoluted and not easy to understand.

Share this post


Link to post
Share on other sites

Hi Surfalot,

 

Thanks for the reply, although you worry me slightly with your comments on importing data.

 

Anyway, back to the problem. I have copied in the revised admin/includes/classes/table_block.php -

 

result, I can see the custom options to select.

However even with attributes ticked, I still get no attributes in my downloaded file - tried it with custom & complete.

(yes my data does have attributes assigned & unique product code)

The only headers & data I get are....

v_products_model v_status v_products_name_1 v_products_description_1 v_products_url_1 v_products_image v_products_price v_products_quantity v_products_weight v_date_added v_date_avail v_manufacturers_name v_categories_name_1 v_categories_name_2 v_categories_name_3 v_tax_class_title EOREOR

 

I want to do a download first so I can workout how to format the large spreadsheet of data I wish to upload.

 

Many thanks for any help you can give

Graeme

Share this post


Link to post
Share on other sites
Guest

The only way my site will properly output a froogle feed, due to a large inventory, is with easy populate.

 

1. How can easy populate be adjusted so that it can produce the google base feed according to new requirements?

 

2. What needs to be done to easy populate so that it can produce a yahoo feed and a shopzilla feed?

 

Thanks.

Share this post


Link to post
Share on other sites

I'm having a good success with my EP. I've now got it to export all my fields (I've added two extra fields 'v_vendors_id' and 'v_vendors_prod_id') :) I've also got it to import without comming up with errors :) However......

 

Although the report at the top of the EP page shows its importing all the fields, when a product is checked, its not updating my two extra fields :(

 

I felt its not a good idea to post thousands of lines of code, so I've uploaded it to this location, I've coloured my extra fields in red, so hopefully you can find my changes reasonably easily.

 

Can anyone give me any clues where to start looking to make good my lack of updating fields please?

 

Thanks in advance for any help and guidence :D

Edited by UncleSteve

____________________________________________________________________

____________________________________________________________________

Share this post


Link to post
Share on other sites
Hi Surfalot,

 

Thanks for the reply, although you worry me slightly with your comments on importing data.

 

Anyway, back to the problem. I have copied in the revised admin/includes/classes/table_block.php -

 

result, I can see the custom options to select.

However even with attributes ticked, I still get no attributes in my downloaded file - tried it with custom & complete.

(yes my data does have attributes assigned & unique product code)

The only headers & data I get are....

v_products_model v_status v_products_name_1 v_products_description_1 v_products_url_1 v_products_image v_products_price v_products_quantity v_products_weight v_date_added v_date_avail v_manufacturers_name v_categories_name_1 v_categories_name_2 v_categories_name_3 v_tax_class_title EOREOR

 

I want to do a download first so I can workout how to format the large spreadsheet of data I wish to upload.

 

Many thanks for any help you can give

Graeme

questions still stand...

do you have attributes defined AND assigned to a product in the shop now? Do you have unique model numbers assigned to each product?

and don't forget the system details. PHP ver? register globals setting? MySQL ver? server?

can't help much if I don't know what you are working with.

Edited by surfalot

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×