Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

I have a moderate background in PHP and MySQL. First-timer for OS & its world. Installed current stable OS 2.2ms2-060817 along with Contributions for Register_Globals_v1.5 to get around my ISP's server settings, and EP_v2_76d from surfalot because... well, because I am a lazy SOG.

 

First step is to make an export file with EP but I can't make it work. Folder is /temp/, created and laid bare to the world with 777 chmod. I can use file manager (or ftp) to create a text file. But when I run EP I don't even get the civility of an error message - it just comes back to the basic EP screen from which I started. No file is created, and no error message is thrown onto my screen. No guidance, no diagnostics. I've spent two days (in my spare time) trying to find someone who has reported a similar problem on this board, but haven't found anyone. Feels darn lonely.

 

Anybody have ideas?

 

Silver State Bob.

Share this post


Link to post
Share on other sites

Hello

 

I read some posts from this thread but can't find an answer to my problem:

 

So, what i did: clean up database, then start to upload my products; new product! message appear but at bottom of report "No products_model field in record. This line was not imported" also appear.

 

I try again, thinking that no product was imported: now i receive Update product! message and of course, "No products_model field in record. This line was not imported"??.

 

I check my database, all products are imported, all categories was added on the fly, everything it's ok...but i can't see my categories/products in admin :)

 

Looking at fronpage of my site (www.mallromania.com) i can see prices for my products but nothing else?

 

Of course, products are Active..

 

P.S: it's ok to add images as link to supplier page? I mean, he give me a list of products including links to products images but i don't know how to use this. I add links into image field but it's not ok..

 

Thanks

Share this post


Link to post
Share on other sites
each item requires a product model, they have to be distinct from one another.

thanks for your response. each product have it's own unique product model

Share this post


Link to post
Share on other sites
thanks for your response. each product have it's own unique product model

 

Ok, i found if i switch to my other language (romanian in my case, who is set as default but for some reason my browser still use english language ) i can see all products :) Now..how can i do to see them in english part also?

Share this post


Link to post
Share on other sites
I have a moderate background in PHP and MySQL. First-timer for OS & its world. Installed current stable OS 2.2ms2-060817 along with Contributions for Register_Globals_v1.5 to get around my ISP's server settings, and EP_v2_76d from surfalot because... well, because I am a lazy SOG.

 

First step is to make an export file with EP but I can't make it work. Folder is /temp/, created and laid bare to the world with 777 chmod. I can use file manager (or ftp) to create a text file. But when I run EP I don't even get the civility of an error message - it just comes back to the basic EP screen from which I started. No file is created, and no error message is thrown onto my screen. No guidance, no diagnostics. I've spent two days (in my spare time) trying to find someone who has reported a similar problem on this board, but haven't found anyone. Feels darn lonely.

 

Anybody have ideas?

 

Silver State Bob.

did you try splitting it and then loading from the split?

it sounds like you are having the same problem as I am.

Share this post


Link to post
Share on other sites
did you try splitting it and then loading from the split?

it sounds like you are having the same problem as I am.

 

I can't get the sample data to export out of OSC and into my /temp/ directory.

Share this post


Link to post
Share on other sites
is your problem only with importing or exporting the data?

 

I haven't tried importing because I wanted to learn the import file format from studying the export file. Can't make it export.

Share this post


Link to post
Share on other sites
I haven't tried importing because I wanted to learn the import file format from studying the export file. Can't make it export.

the problem is the register globals. this contrib has never been updated for that and won't work on that server at the moment. There are many other versions you could try such as the v2.8. but many other versions above v2.76 have other contribs hard coded.

Share this post


Link to post
Share on other sites
I used "download on the fly" to try and update some product names , i chose only to build the file with the product names.

 

After i edited the names and uploaded the edited file, it deleted all my product descriptions ?

 

I had to restore them from a DB back-up .

 

Is it supposed to do this ?

 

I though i could update certain fields on a product and leave the rest as is

 

The model numbers remained the same in the file i downloaded , i never edited them , just the product name. The file had the correct ending tag on every line.

 

Is this human error on my part or is something wrong ?

Mmm, sounds like there could be a bug. can you post the settings? (a "show settings" setting will display them on the main page for easy copying)

I think I'm reading you right that the data imported did not include a "description" column, but yet the description was blanked. Was it only the products that were change, or did that affect more products?

Share this post


Link to post
Share on other sites
Well, I believe the file did upload but it sorta messed up my products. It doubled up on a lot of them and put some in the wrong category. I rechecked the downloaded Excel file to correct any mistakes because the download has some things wrong...categories, mostly.

 

When uploaded I got the double entries only in some of the categories.

 

Any idea what is going wrong???

 

Marcia

I think you missed the instruction that every product you import must have a unique model number defined in the first column of the import file. your products on the shop must also have a unique model number.

Share this post


Link to post
Share on other sites
Mmm, sounds like there could be a bug. can you post the settings? (a "show settings" setting will display them on the main page for easy copying)

I think I'm reading you right that the data imported did not include a "description" column, but yet the description was blanked. Was it only the products that were change, or did that affect more products?

 

 

The file contained only these headings on the columns -

 

v_products_model - v_products_name_1 - EOREOR

 

 

it was edited in excel , which i've used before with EP , and saved as tab de-limited.

 

It took away all the product descriptions. The file contained about 269 products , i edited only about 60 of the product names, the rest were left as they were. I re-uploaded it with "Upload and Import EP File"

 

Settings are -

 

Temp Dir:

/var/www/domain/temp/

 

Split files on: 300 records

 

Model Num Size: 25

 

Price with tax: true

 

Replace quotes: false

 

Field seperator: tab

 

Excel safe output: false

 

Preserve tab/cr/lf: false

 

Category depth: 3

 

Enable attributes: true

 

SEF Froogle URLS: false

 

 

 

Thanks for your help

Share this post


Link to post
Share on other sites

Ok, so now I have a question I should have asked months ago.

 

is it possible to configure EP to accept a longer category name?

I have some VERY long Category names, but they get cut off when I Import them. anyone know if there is way to make the categories names longer?

PLEASE help

help.gif

Share this post


Link to post
Share on other sites
The file contained only these headings on the columns -

 

v_products_model - v_products_name_1 - EOREOR

it was edited in excel , which i've used before with EP , and saved as tab de-limited.

 

It took away all the product descriptions. The file contained about 269 products , i edited only about 60 of the product names, the rest were left as they were. I re-uploaded it with "Upload and Import EP File"

 

Settings are -

 

Temp Dir:

/var/www/domain/temp/

 

Split files on: 300 records

 

Model Num Size: 25

 

Price with tax: true

 

Replace quotes: false

 

Field seperator: tab

 

Excel safe output: false

 

Preserve tab/cr/lf: false

 

Category depth: 3

 

Enable attributes: true

 

SEF Froogle URLS: false

Thanks for your help

 

 

I'm having the same problem and have similar settings, though I've tried making Excel safe 'true' and tried various field separators, used custom to build the file and then "Upload and Import EP File". On upload all the descriptions disappear. I've also got attributes set to false. $tempdir = DIR_FS_DOCUMENT_ROOT . "temp/"; Seen this problem brought up in an earlier post with no answer, figured I'd say how I was updating the file - maybe I'm still doing something wrong. Thanks

 

only products updated were affected.

Edited by jblausey

Share this post


Link to post
Share on other sites

yes, there is a setting in the easypopulate.php file, probably set to 15 at the default. you will need to alter your database too, else it doesnt make any difference.

 

Ok, so now I have a question I should have asked months ago.

 

is it possible to configure EP to accept a longer category name?

I have some VERY long Category names, but they get cut off when I Import them. anyone know if there is way to make the categories names longer?

PLEASE help

help.gif


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

what version of ep are you using?

 

I'm having the same problem and have similar settings, though I've tried making Excel safe 'true' and tried various field separators, used custom to build the file and then "Upload and Import EP File". On upload all the descriptions disappear. I've also got attributes set to false. $tempdir = DIR_FS_DOCUMENT_ROOT . "temp/"; Seen this problem brought up in an earlier post with no answer, figured I'd say how I was updating the file - maybe I'm still doing something wrong. Thanks

 

only products updated were affected.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
yes, there is a setting in the easypopulate.php file, probably set to 15 at the default. you will need to alter your database too, else it doesnt make any difference.

Do you by chance know where it is in the file?

I'm running 2.74 with MVS installed.

Share this post


Link to post
Share on other sites
v_products_model - v_products_name_1 - EOREOR

it was edited in excel , which i've used before with EP , and saved as tab de-limited.

 

It took away all the product descriptions. The file contained about 269 products , i edited only about 60 of the product names, the rest were left as they were. I re-uploaded it with "Upload and Import EP File"

try this. in v2.76d. find around line 1890 this block:

		if (isset($filelayout['v_products_name_' . $l_id ])){
		//we set dynamically the language values
		$v_products_name[$l_id] 	= $items[$filelayout['v_products_name_' . $l_id]];
		$v_products_description[$l_id] 	= $items[$filelayout['v_products_description_' . $l_id ]];
		$v_products_url[$l_id] 		= $items[$filelayout['v_products_url_' . $l_id ]];
		// support for Linda's Header Controller 2.0 here
		if(isset($filelayout['v_products_head_title_tag_' . $l_id])){
			$v_products_head_title_tag[$l_id] 	= $items[$filelayout['v_products_head_title_tag_' . $l_id]];
			$v_products_head_desc_tag[$l_id] 	= $items[$filelayout['v_products_head_desc_tag_' . $l_id]];
			$v_products_head_keywords_tag[$l_id] 	= $items[$filelayout['v_products_head_keywords_tag_' . $l_id]];
		}
		// end support for Header Controller 2.0
	}

 

replace with this:

 

		if (isset($filelayout['v_products_name_' . $l_id ])){
		$v_products_name[$l_id] 	= $items[$filelayout['v_products_name_' . $l_id]];
	}
	if (isset($filelayout['v_products_description_' . $l_id ])){
		$v_products_description[$l_id] 	= $items[$filelayout['v_products_description_' . $l_id ]];
	}
	if (isset($filelayout['v_products_url_' . $l_id ])){
		$v_products_url[$l_id] 		= $items[$filelayout['v_products_url_' . $l_id ]];
	}
	// support for Linda's Header Controller 2.0 here
	if(isset($filelayout['v_products_head_title_tag_' . $l_id])){
		$v_products_head_title_tag[$l_id] 	= $items[$filelayout['v_products_head_title_tag_' . $l_id]];
		$v_products_head_desc_tag[$l_id] 	= $items[$filelayout['v_products_head_desc_tag_' . $l_id]];
		$v_products_head_keywords_tag[$l_id] 	= $items[$filelayout['v_products_head_keywords_tag_' . $l_id]];
	}
	// end support for Header Controller 2.0

 

by the look of the code, I would say the product URL would get blanked also.

Edited by surfalot

Share this post


Link to post
Share on other sites

I'm getting the following errors when I try to insert the the .txt file in the Database

can someone help me please?

 

I'm using EP_v2_76d_MS2

 

 

Warning: move_uploaded_file(DIR_FS_DOCUMENT_ROOT/e-commerce/temp/EP2007Jan20-0012.txt) [function.move-uploaded-file]: failed to open stream: No such file or directory in D:\wamp\www\e-commerce\admin\easypopulate_functions.php on line 43

 

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move 'd:/Wamp/tmp\php3.tmp' to 'DIR_FS_DOCUMENT_ROOT/e-commerce/temp/EP2007Jan20-0012.txt' in D:\wamp\www\e-commerce\admin\easypopulate_functions.php on line 43

 

File uploaded.

Temporary filename: d:/Wamp/tmp\php3.tmp

User filename: EP2007Jan20-0012.txt

Size: 2152

 

Warning: file(DIR_FS_DOCUMENT_ROOT/e-commerce/temp/EP2007Jan20-0012.txt) [function.file]: failed to open stream: No such file or directory in D:\wamp\www\e-commerce\admin\easypopulate.php on line 805

 

Warning: Invalid argument supplied for foreach() in D:\wamp\www\e-commerce\admin\easypopulate.php on line 844

Edited by veni

Share this post


Link to post
Share on other sites
I'm getting the following errors when I try to insert the the .txt file in the Database

can someone help me please?

 

I'm using EP_v2_76d_MS2

Warning: move_uploaded_file(DIR_FS_DOCUMENT_ROOT/e-commerce/temp/EP2007Jan20-0012.txt) [function.move-uploaded-file]: failed to open stream: No such file or directory in D:\wamp\www\e-commerce\admin\easypopulate_functions.php on line 43

 

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move 'd:/Wamp/tmp\php3.tmp' to 'DIR_FS_DOCUMENT_ROOT/e-commerce/temp/EP2007Jan20-0012.txt' in D:\wamp\www\e-commerce\admin\easypopulate_functions.php on line 43

 

File uploaded.

Temporary filename: d:/Wamp/tmp\php3.tmp

User filename: EP2007Jan20-0012.txt

Size: 2152

 

Warning: file(DIR_FS_DOCUMENT_ROOT/e-commerce/temp/EP2007Jan20-0012.txt) [function.file]: failed to open stream: No such file or directory in D:\wamp\www\e-commerce\admin\easypopulate.php on line 805

 

Warning: Invalid argument supplied for foreach() in D:\wamp\www\e-commerce\admin\easypopulate.php on line 844

DIR_FS_DOCUMENT_ROOT is not setup correctly in your /catalog/admin/includes/configure.php. please see one of the many posts about this on the last few pages.

Share this post


Link to post
Share on other sites
DIR_FS_DOCUMENT_ROOT is not setup correctly in your /catalog/admin/includes/configure.php. please see one of the many posts about this on the last few pages.

 

In my /catalog/admin/includes/configure.php I have it set this way

define('DIR_FS_$DOCUMENT_ROOT', 'D:/Wamp/www/e-commerce/'); // where the pages are located on the server

 

But as per the errors I'm getting, it seems to not like something about the easypopulate_functions.php on line 43

Share this post


Link to post
Share on other sites
In my /catalog/admin/includes/configure.php I have it set this way

define('DIR_FS_$DOCUMENT_ROOT', 'D:/Wamp/www/e-commerce/'); // where the pages are located on the server

 

But as per the errors I'm getting, it seems to not like something about the easypopulate_functions.php on line 43

 

 

Or maybe it's because EP cannot write to the temp folder. I'm hosting everything using Wamp on my local machine

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×