Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Model numbers are a requirement of this contribution. they must exist before doing an update since this is the item it will matchup with the item in the shop database. This contribution does not delete products. Please read though the entire docs.

 

Got it! I missed the deleting products part...sorry. I will also make sure the models numbers are in the products catalog before the next download/upload.

 

Great contribution, really makes life easier!

 

Marcia

Share this post


Link to post
Share on other sites
Hi,

 

I am getting the following error:

 

Warning: move_uploaded_file($DOCUMENT_ROOT/temp/EP2007Jan02-1604.csv): failed to open stream: No such file or directory in /home/html/admin/easypopulate_functions.php on line 43

 

Oh yeah and,
PLEASE HELP!

the line in you /admin/configure.php should be:

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT);

 

if that doesn't work for you. you need to contact you host, ask them what the physical path to your web hosting space is, and make it something like this instead:

 

define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html'); // no trailing slash

 

if you have you shop in the "catalog" sub-directory of you hosting space, then something like this:

 

define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html/catalog'); // no trailing slash

Share this post


Link to post
Share on other sites
the line in you /admin/configure.php should be:

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT);

 

if that doesn't work for you. you need to contact you host, ask them what the physical path to your web hosting space is, and make it something like this instead:

 

define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html'); // no trailing slash

 

if you have you shop in the "catalog" sub-directory of you hosting space, then something like this:

 

define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html/catalog'); // no trailing slash

 

Thanks, surfalot. I got it fixed, the problem was a simple error on my part. I was uploading the /admin/includes/configure.php file to the /catalog/includes/configure.php by mistake... just figured it out last night.

 

Mike


Installed Modules:

Dynamenu, InfoBox Admin, Master Products v.1.2, Header Tags Controller, Multiple Products Manager, Quick Edit in Admin, Secure Admin, Ultimate SEO URL's, EZ Secure Order, Easy Populate v.2.76d MS2, AuthorizeNet_AIM, ChangeFinal Breadcrumb Title, FedEx Labels, Fedex Direct 2.06, How Did you Hear 1.5, Login a la Amazon, UPS XML 1.2.4, USPS Labels, USPS Methods API MS2

Share this post


Link to post
Share on other sites

EP_v2_76_MS2 is the version installed

 

few errorswhen i try to create txt file comes up with

 

Warning: fopen(/home/sites/deckbits.com/public_html/chandlers//catalog/temp/EP2007Jan03-1907.txt) [function.fopen]: failed to open stream: No such file or directory in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate.php on line 678

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate.php on line 679

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate.php on line 680

You can get your file in the Tools/File Manager here: /home/sites/deckbits.com/public_html/chandlers//catalog/temp/EPEP2007Jan03-1907.txt

 

 

when i try to upload txt file used on previous version Easy Populate 2.74-MS2 comes up with following errors

 

Warning: move_uploaded_file(/home/sites/deckbits.com/public_html/chandlers//catalog/temp/ronstan blocks.txt) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate_functions.php on line 43

 

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/php3N6ALv' to '/home/sites/deckbits.com/public_html/chandlers//catalog/temp/ronstan blocks.txt' in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate_functions.php on line 43

 

 

File uploaded.

Temporary filename: /tmp/php3N6ALv

User filename: ronstan blocks.txt

Size: 68619

 

Warning: file(/home/sites/deckbits.com/public_html/chandlers//catalog/temp/ronstan blocks.txt) [function.file]: failed to open stream: No such file or directory in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate.php on line 805

 

Warning: Invalid argument supplied for foreach() in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate.php on line 844

 

 

pretty sure its not the permission for the temp file, this is a brand new store with the only other contribution installed so far is Header Tags Controller v2.6.1

all the text files are from my old store which worked fine with the 2.74 version, tried installing 2.74 on the new store but couldnt get that working either,

 

any help gratefully received

Edited by mukka

Share this post


Link to post
Share on other sites

what do you have for your document_root setting in your configure.php file? if you look at your path above, you have chandlers//catalog

you have an extra / (slash) somewhere.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Getting this parse error:

 

Parse error: syntax error, unexpected '.' in /home/mythgame/public_html/shop/admin/easypopulate.php on line 2113

 

Any idea what this is and how to fix it?

 

Thanks!

Share this post


Link to post
Share on other sites
EP_v2_76_MS2 is the version installed

 

few errorswhen i try to create txt file comes up with

when i try to upload txt file used on previous version Easy Populate 2.74-MS2 comes up with following errors

pretty sure its not the permission for the temp file, this is a brand new store with the only other contribution installed so far is Header Tags Controller v2.6.1

all the text files are from my old store which worked fine with the 2.74 version, tried installing 2.74 on the new store but couldnt get that working either,

 

any help gratefully received

 

 

what do you have for your document_root setting in your configure.php file? if you look at your path above, you have chandlers//catalog

you have an extra / (slash) somewhere.

 

changed the configure now im getting this error

 

Warning: move_uploaded_file(/home/sites/deckbits.com/public_html/chandlers/catalog/temp/Winches.txt) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate_functions.php on line 43

 

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpQMHOoP' to '/home/sites/deckbits.com/public_html/chandlers/catalog/temp/Winches.txt' in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate_functions.php on line 43

 

 

File uploaded.

Temporary filename: /tmp/phpQMHOoP

User filename: Winches.txt

Size: 62050

 

Warning: file(/home/sites/deckbits.com/public_html/chandlers/catalog/temp/Winches.txt) [function.file]: failed to open stream: No such file or directory in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate.php on line 805

 

Warning: Invalid argument supplied for foreach() in /home/sites/deckbits.com/public_html/chandlers/admin/easypopulate.php on line 844

Share this post


Link to post
Share on other sites
changed the configure now im getting this error

if you created the file with v2.74, you should use that version to import your file. Then create a new file with the new version and move on from there. May or may not actually be differences, just playing safe.

 

Other then that, make sure /home/sites/deckbits.com/public_html/chandlers/catalog/temp/ exists and has permissions 777. Ask your host if you do not know.

Share this post


Link to post
Share on other sites
Parse error: syntax error, unexpected '.' in /home/mythgame/public_html/shop/admin/easypopulate.php on line 2113

EP version? have you modified it? PHP and MySQL versions?

Share this post


Link to post
Share on other sites
EP version? have you modified it? PHP and MySQL versions?

 

Havn't touched a thing on it. I set up the configs like the read me text said and had to change the word catalog to shop.

 

I removed the # on the images as I have manypics loaded. Other than that it is the stock files.

Share this post


Link to post
Share on other sites
the line in you /admin/configure.php should be:

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT);

 

if that doesn't work for you. you need to contact you host, ask them what the physical path to your web hosting space is, and make it something like this instead:

 

define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html'); // no trailing slash

 

if you have you shop in the "catalog" sub-directory of you hosting space, then something like this:

 

define('DIR_FS_DOCUMENT_ROOT', '/home/myaccount/public_html/catalog'); // no trailing slash

 

 

 

I had the exact same error , i ended putting configure.php back as it was and it all worked ??

 

so I don't know what the score is with changing the configure.php file as detailed in the install instructions ?

Share this post


Link to post
Share on other sites
I had the exact same error , i ended putting configure.php back as it was and it all worked ??

 

so I don't know what the score is with changing the configure.php file as detailed in the install instructions ?

if your configure.php is setup correctly, there is no need to change it for any contribution. Any directions in this contrib refering to configure.php *should* be for trouble-shooting only.

Edited by surfalot

Share this post


Link to post
Share on other sites
EP Version is 2.76

PHP is 4.4.3

MYSQL 5.0.24 Standard

try the v2.76d version. It shouldn't have any parsing errors in it.

Share this post


Link to post
Share on other sites
Havn't touched a thing on it. I set up the configs like the read me text said and had to change the word catalog to shop.

 

I removed the # on the images as I have manypics loaded. Other than that it is the stock files.

that line number refers to a section that has been commented out. I have no idea if any commented-out code works or not. I'm supporting the v2.76d version only, as uploaded, no contrib integration help. Maybe someone else can help with that.

Edited by surfalot

Share this post


Link to post
Share on other sites

Hello, sorry if this has been discussed, but I can't find any info on what I'm trying to do here.

 

I really only want to use a single category level for our store. For instance, I have one item that belongs in the 'animals' category, and also in the 'cats' category.

 

Is there any way to make EP insert the items ONLY in the root level? I've tried fiddling with the

 

$max_categories = 4; // 7 is default

 

line, but if I lower this number to '1' all this does is make it ignore the previous categories, so the item shows up under 'cats', but not under 'animals'

 

(I realize that cats could be a subcategory of animals, but that is not how the boss wants it...)

 

I hope this makes sense!

 

Thanks in advance :)

Share this post


Link to post
Share on other sites

I should mention that I do already know about using multiple lines in the upload file with different categories. I have tried it, and it works, however this makes the upload file much, much larger than I'd like, it's getting pretty slow to upload. I was hoping for a modification to the easypopulate.php to get the same effect.

 

Hello, sorry if this has been discussed, but I can't find any info on what I'm trying to do here.

 

I really only want to use a single category level for our store. For instance, I have one item that belongs in the 'animals' category, and also in the 'cats' category.

 

Is there any way to make EP insert the items ONLY in the root level? I've tried fiddling with the

 

$max_categories = 4; // 7 is default

 

line, but if I lower this number to '1' all this does is make it ignore the previous categories, so the item shows up under 'cats', but not under 'animals'

 

(I realize that cats could be a subcategory of animals, but that is not how the boss wants it...)

 

I hope this makes sense!

 

Thanks in advance :)

Share this post


Link to post
Share on other sites

I keep getting the following error and I cant figure out what it is.

The precondition on the request for the URL /tango/admin/easypopulate.php evaluated to false.

 

I have been searching and searching to figure it out and I cant find what the problem is. I followed the instructions and have everything setup properly as far as I know.

 

Any help would be great.

Share this post


Link to post
Share on other sites
try the v2.76d version. It shouldn't have any parsing errors in it.

 

Have that version. Just unziped it again and loaded the files withough any changes and it works now.

 

Thanks

Share this post


Link to post
Share on other sites
Have that version. Just unziped it again and loaded the files withough any changes and it works now.

 

Thanks

 

Okay, so I have the download working now. Do I need to download every field?

 

I'm getting a host of errors and warnings when I try to upload the file.

 

Yes, I have created the temp directory and set the permissions to 777

 

One thing I am confused on is this line:

 

// Please set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php

 

(I have not touched this as I am not 100% sure that this needs to be done or what the lines should lool like afterwards as in is it supposed to be: DIR_FS_$DOCUMENT_ROOT or something else?)

 

Thanks

 

Cory

 

Here are the errors when I use the "split file". I have saved my excel sheet as tab seperated

 

Warning: move_uploaded_file(DIR_FS_DOCUMENT_ROOT/shop/temp/EP2007Jan07-1500.txt) [function.move-uploaded-file]: failed to open stream: No such file or directory in /home/mythgame/public_html/shop/admin/easypopulate_functions.php on line 43

 

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpdO0AjV' to 'DIR_FS_DOCUMENT_ROOT/shop/temp/EP2007Jan07-1500.txt' in /home/mythgame/public_html/shop/admin/easypopulate_functions.php on line 43

 

Warning: fopen(DIR_FS_DOCUMENT_ROOT/shop/temp/EP2007Jan07-1500.txt) [function.fopen]: failed to open stream: No such file or directory in /home/mythgame/public_html/shop/admin/easypopulate.php on line 884

 

Warning: fgets(): supplied argument is not a valid stream resource in /home/mythgame/public_html/shop/admin/easypopulate.php on line 887

Creating file EP_Split1.txt ...

Warning: fopen(DIR_FS_DOCUMENT_ROOT/shop/temp/EP_Split1.txt) [function.fopen]: failed to open stream: No such file or directory in /home/mythgame/public_html/shop/admin/easypopulate.php on line 893

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home/mythgame/public_html/shop/admin/easypopulate.php on line 894

 

Warning: fgets(): supplied argument is not a valid stream resource in /home/mythgame/public_html/shop/admin/easypopulate.php on line 897

Added 0 records and closing file...

 

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/mythgame/public_html/shop/admin/easypopulate.php on line 923

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/mythgame/public_html/shop/admin/easypopulate.php on line 924

You can download your split files in the Tools/Files under DIR_FS_DOCUMENT_ROOT/shop/temp/

Share this post


Link to post
Share on other sites
if your configure.php is setup correctly, there is no need to change it for any contribution. Any directions in this contrib refering to configure.php *should* be for trouble-shooting only.

 

 

Ok , thats great. i didn't want to mess anything up , i really need this working.

 

 

The problem I have at the moment is when a file is uploaded it doesn't change anything in the database ????

 

No errors are reported , but nothing gets changed , added or anything. It's one way traffic

 

Have i missed something somewhere ?

Share this post


Link to post
Share on other sites
Ok , thats great. i didn't want to mess anything up , i really need this working.

The problem I have at the moment is when a file is uploaded it doesn't change anything in the database ????

 

No errors are reported , but nothing gets changed , added or anything. It's one way traffic

 

Have i missed something somewhere ?

 

 

Cancel that ! :blush: :blush:

 

It was an ID10T error....

 

 

model No length was wrong.... no error was shown because "show errors" is turned off on the server :blush:

 

 

 

Great contrib.... works out of the box and does what it says on the tin !

Share this post


Link to post
Share on other sites

Hi,

Does easy populate support html coding in the description tab?

Do i require additional changes if i have the header tags control added

 

thank you

Share this post


Link to post
Share on other sites

i get this error can anyone help

 

Filename: osCommerce30.txt

 

Fatal error: Maximum execution time of 10 seconds exceeded in /home/kingdub/public_html/Store/admin/easypopulate.php on line 750

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×