Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Just installed Easy Populate 2.76c and I'm having trouble downloading/creating an initial txt file due to "Maximum execution time exceeded" fatal errors. I've come across a post referencing another post that apparently described how to edit easypopulate.php to output in small enough segments. I haven't been able find this post, though, so I wonder if someone could point me in the right direction. :D

Share this post


Link to post
Share on other sites
try uploading a single product (new one) and see what happens

 

Thanks for responding!

 

It acts as though it is uploading and clears the form. No error message. The product was not uploaded.

Share this post


Link to post
Share on other sites

I tried to download the "easypopulate_1_2_3_4_5_6_7.zip" file and when trying to extract it, there doesn't seem to be any files in the .zip

Share this post


Link to post
Share on other sites

I'll be honest, I'm a bit confused as to which download to use on this mod. Can someone point out what the best version to use is.....it appears that there's multiple downloads on the page that has the mod and then some notes saying that there is "There is mass confusion below".......

 

http://www.oscommerce.com/community/contributions,500

 

From my past design experience, there seems to be a user experience issue on the contribution area. Is there a way to get someone to approve the "latest" version and place a link at the top of the page to "download the latest/greatest" stable version of the mod

Edited by Robert_ja

Share this post


Link to post
Share on other sites
I'll be honest, I'm a bit confused as to which download to use on this mod. Can someone point out what the best version to use is.....it appears that there's multiple downloads on the page that has the mod and then some notes saying that there is "There is mass confusion below".......

 

http://www.oscommerce.com/community/contributions,500

 

From my past design experience, there seems to be a user experience issue on the contribution area. Is there a way to get someone to approve the "latest" version and place a link at the top of the page to "download the latest/greatest" stable version of the mod

 

That is the one I use, 2.76c and it's a clean version and doesn't have anything else plugged into it.

 

It's the one entitled Easy Populate is EASY just start here FIRST !!!! It's the one that says "There is mass confusion below".......

 

I found it easy to modify when I had to because there wasn't all those other contrib codes in it.

 

Just my opinion


No Good Deed EVER Goes Unpunished

Share this post


Link to post
Share on other sites

Thanks for the help Druid6900,

 

But I have one small problem and need to know what files I need to change. Instead of leaving the root catalog folder as "CATALOG" I changed it to "SHOP" when I did my installation

 

Now when I upload a file thru EP in my admin area I get the following error:

 

Warning: move_uploaded_file(/usr/home/web/domains/www.line-man.com/shop//catalog/temp/lineman-shop.xls) [function.move-uploaded-file]: failed to open stream: No such file or directory in /usr/home/web/users/a0026398/html/shop/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/var/tmp/php8QKAIM' to '/usr/home/web/domains/www.line-man.com/shop//catalog/temp/lineman-shop.xls' in /usr/home/web/users/a0026398/html/shop/admin/easypopulate_functions.php on line 32

 

File uploaded.

Temporary filename: /var/tmp/php8QKAIM

User filename: lineman-shop.xls

Size: 796

 

Warning: file(/usr/home/web/domains/www.line-man.com/shop//catalog/temp/lineman-shop.xls) [function.file]: failed to open stream: No such file or directory in /usr/home/web/users/a0026398/html/shop/admin/easypopulate.php on line 667

 

Warning: Invalid argument supplied for foreach() in /usr/home/web/users/a0026398/html/shop/admin/easypopulate.php on line 690

 

Again thanks for the help,

Robert

Edited by Robert_ja

Share this post


Link to post
Share on other sites
Thanks for the help Druid6900,

 

But I have one small problem and need to know what files I need to change. Instead of leaving the root catalog folder as "CATALOG" I changed it to "SHOP" when I did my installation

 

Now when I upload a file thru EP in my admin area I get the following error:

Again thanks for the help,

Robert

 

Well, first thing is that you seem to have a double backslash (//) in the error message between shop and catalog, so, you have a trailing / in your setup which shouldn't be there.


No Good Deed EVER Goes Unpunished

Share this post


Link to post
Share on other sites
any quick fixes on this?

R

 

Did your shop work before you installed the contrib?

 

If so, then something that you modified in the contrib file(s) to reflect your actual path has a / on the end of the path that shouldn't be there.


No Good Deed EVER Goes Unpunished

Share this post


Link to post
Share on other sites

Yes, everything worked fine and still does except the .xls upload.

 

Here's one problem

 

the root structure is www.line-man.com/shop/temp/

 

not www.line-man.com/shop//catalog/temp/ as indicated in the error

 

remove the red and it will be correct

Edited by Robert_ja

Share this post


Link to post
Share on other sites
any quick fixes on this?

R

 

I'd guess that in admin/easypopulate.php file, around lines 22 and 23, where they define the temp directory, removing the /catalog/ from both lines should fix the problem.

 

Richard


No Good Deed EVER Goes Unpunished

Share this post


Link to post
Share on other sites

HOLD THAT, looks like I found the error.

 

the upload was successful w/ NO errors, but now when I go to the storefront.....

 

1- there is a new product listed

2- when clicked on nothing is there

3- in the admin, there is no product under that category

 

 

Line-Man.com/shop

see the Bucket Truck Category

Edited by Robert_ja

Share this post


Link to post
Share on other sites
I'm just going to suggest a workaround, because I really don't know that much about it...After completing the upload, have you then tried to "Import from Temp Dir"? This may work for you.

 

Thanks, Edgy,

 

Unfortunately, that did not work either. I've tried every configuration change available in the easypopulate.php file, messed with the easypopulate_function.php file, adjusted my configure.php file. I can't get the darned thing to import. I still get:

 

File uploaded.

Temporary filename: /tmp/phpIj9uvS

User filename: EP2006Nov29-1302-test.txt

Size: 3916

 

I've looked in the /tmp/ directory and it's empty. Is it possible that the temp file is being deleted before it is imported? I don't know... :blink:

 

I'd love to use easypopulate but just can't get around this problem. And I just don't have weeks and weeks of time to dig through the code line by line to find it.

 

But when I do find the problem, I'll be sure to post my solution here for the next poor guy who has this problem.

 

Warmly,

Joseph


Steep learning curve? Hell, I don't even know enough to formulate a stupid question!!

Share this post


Link to post
Share on other sites
Yes, everything worked fine and still does except the .xls upload.

 

Here's one problem

 

the root structure is www.line-man.com/shop/temp/

 

not www.line-man.com/shop//catalog/temp/ as indicated in the error

 

remove the red and it will be correct

 

Go into your easypopulate.php file and under

 

// Please set DOCUMENT_ROOT to $DOCUMENT_ROOT in your /catalog/admin/includes/configure.php
$tempdir = "/temp/";
$tempdir2 = "/temp/";

 

Just try to use what i have. It looks like your path might be wrong. Im using the same version as you and i had the same problem at first!

 

By the way you don't have to do the Document Root thing...

Edited by JJ21

===========================

Remember Always Back UP!

___________________________________

Share this post


Link to post
Share on other sites
HOLD THAT, looks like I found the error.

 

the upload was successful w/ NO errors, but now when I go to the storefront.....

 

1- there is a new product listed

2- when clicked on nothing is there

3- in the admin, there is no product under that category

Line-Man.com/shop

see the Bucket Truck Category

 

 

Are you putting the ERROR at the line also? The file will go ahead and upload but if you don't have have ERROR at the end of the line EP will just throw it out. And remember when you upload more than one file, reaname it to a different file. Don't have two files named the same unless you are updating that file!


===========================

Remember Always Back UP!

___________________________________

Share this post


Link to post
Share on other sites
Are you putting the ERROR at the line also? The file will go ahead and upload but if you don't have have ERROR at the end of the line EP will just throw it out. And remember when you upload more than one file, reaname it to a different file. Don't have two files named the same unless you are updating that file!

 

 

Umm, I believe that's EOREOR (End Of Row)


No Good Deed EVER Goes Unpunished

Share this post


Link to post
Share on other sites
(Robert_ja @ Nov 28 2006, 12:39 PM)

 

Yes, everything worked fine and still does except the .xls upload.

 

be sure you are not trying to upload xls files, but TXT files. The Excel format is not recognized by EP

Share this post


Link to post
Share on other sites
be sure you are not trying to upload xls files, but TXT files. The Excel format is not recognized by EP

 

 

Hey Pix,

 

I thought that too, but, it seems that, as long as it's a tab-deliminated file, the extension doesn't matter, EP sees it for what it is.

 

I'm working with someone and the file he had was an xls, so, I thought it may have been the problem, brought it into excel (it was tabbed) and saved it out as a TD text file and it gave exactly the same error.

 

Probably good practice to save it with a txt extension, but, apparently, not essential.


No Good Deed EVER Goes Unpunished

Share this post


Link to post
Share on other sites
Hey Pix,

 

I thought that too, but, it seems that, as long as it's a tab-deliminated file, the extension doesn't matter, EP sees it for what it is.

 

I'm working with someone and the file he had was an xls, so, I thought it may have been the problem, brought it into excel (it was tabbed) and saved it out as a TD text file and it gave exactly the same error.

 

Probably good practice to save it with a txt extension, but, apparently, not essential.

 

Yes of course (and a jpg file with a gif extension will still be a jpeg "inside") but I saw so many stupid reasons something didn't work in that forum... who knows what others know :-)

Share this post


Link to post
Share on other sites
Yes of course (and a jpg file with a gif extension will still be a jpeg "inside") but I saw so many stupid reasons something didn't work in that forum... who knows what others know :-)

 

Yeah, I suppose we should set an example and encourage the newbies to do it "by the book", just to be on the safe side. :D

 

Ok, you people heard him, Tab-delimited TXT files only, no screwing around here LOL


No Good Deed EVER Goes Unpunished

Share this post


Link to post
Share on other sites

Hi,

 

I am using the 2.76c version. I used the Froogle Export feature and uploaded the file to google. Everything went well except I received an email from google, saying that I am using old fields.

 

Here is the email:

Hello,

 

Good news - the content of your bulk upload has been approved. However, we noticed that there were a few changes you could make to help users find your items:

 

- Using Froogle attributes (fields)

 

-----------------

Using Froogle attributes (fields): We noticed that your bulk upload is using attribute names specified in the old Froogle product feed format. For example, you've included "product_url" as an attribute name, although this attribute is named "link" in the Google Base format. Please convert your product feed to the new Google Base format by changing the attribute names in your header line:

 

http://base.google.com/support/bin/answer.py?answer=40443

 

Using Google Base attributes will allow you to provide more structured information about your items, which will help us to match search queries to your items.

 

After you've made any changes, please be sure to re-submit the new version of your bulk upload with the same filename. If you have any questions, or need additional information about these suggestions, do not hesitate to respond to this email.

 

Sincerely,

 

The Google Team

 

Is there a fix on that?

 

Thank You,

Leibtek

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×