Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Ok, but there's only an easypopulate.php file. ?!? :(


Sorry for my bad english language!

Share this post


Link to post
Share on other sites
Ok, but there's only an easypopulate.php file. ?!? :(

 

download the 2.74 just below, following the instructions, install the fucntions files and replace the main easypop by the 2.81

Edited by pixclinic

Share this post


Link to post
Share on other sites

Well, I installed the 2,74 version like you said, but after I added easypopulate.php from 2.81 it gave me this error:

 

Warning: main(includes/functions/easypopulate_functions.php) [function.main]: failed to open stream: No such file or directory in /usr/local/psa/home/vhosts/maycon.ro/subdomains/sh/httpdocs/admin/easypopulate.php on line 53

Warning: main() [function.include]: Failed opening 'includes/functions/easypopulate_functions.php' for inclusion (include_path='.:/usr/local/psa/apache/share/pear') in /usr/local/psa/home/vhosts/maycon.ro/subdomains/sh/httpdocs/admin/easypopulate.php on line 53

 

 

On line 53 there's:

 

include (DIR_WS_FUNCTIONS . 'easypopulate_functions.php');

 

Any idea?


Sorry for my bad english language!

Share this post


Link to post
Share on other sites
Well, I installed the 2,74 version like you said, but after I added easypopulate.php from 2.81 it gave me this error:

 

Warning: main(includes/functions/easypopulate_functions.php) [function.main]: failed to open stream: No such file or directory in /usr/local/psa/home/vhosts/maycon.ro/subdomains/sh/httpdocs/admin/easypopulate.php on line 53

Warning: main() [function.include]: Failed opening 'includes/functions/easypopulate_functions.php' for inclusion (include_path='.:/usr/local/psa/apache/share/pear') in /usr/local/psa/home/vhosts/maycon.ro/subdomains/sh/httpdocs/admin/easypopulate.php on line 53

On line 53 there's:

 

include (DIR_WS_FUNCTIONS . 'easypopulate_functions.php');

 

Any idea?

 

 

you need to intall the easypopulate_functions.php file file that comes with the 2.74 package and install this in the proper directory.

Share this post


Link to post
Share on other sites
you need to intall the easypopulate_functions.php file file that comes with the 2.74 package and install this in the proper directory.

 

Yeap, my mistake. :D

 

After I replaced the file this appears in my Admin:

 

easypopkb9.th.jpg

 

I looked at the file from 2.74 and managed to make some changes to the 2.81 file and now it looks like this:

 

easypop2lj5.th.jpg

 

I can't change the upper text and "INACTIVATE_EP", I don't know how.

 

Also, I haven't tried the contrib until now, I read that it would be a good thing to read the instructions first, so I decided to do it by the book. This way I eliminate one possible problem: ME. :))


Sorry for my bad english language!

Share this post


Link to post
Share on other sites

Hi, can someone please help me?

 

I have my Tax rate set up as 17.5% (UK VAT)

 

I want to upload all my product prices as INCLUDING TAX

 

If i upload prices excluding tax, and have v_tax_class_title set to "Taxable Goods" and then set the admin to "show prices with tax" oscommerce still displays the ex tax price. and adds the tax at the checkout

 

What i need to be able to do is:

show including tax price in product_listing, and product_info

Then at checkout, show the including tax price as the bottom line, (which will be the same as on the info pages) then show above it the amount of tax that has been charged to get to that price...

 

I.e i only want to upload the GROSS price, not the net.

 

PLEASE HELP!

Share this post


Link to post
Share on other sites

I have easypopulate ver 2.79 installed and works in most respects apart from this.

 

Manufacturers I have uploaded through easypopulate show in the Catalog section but they do not show in the Admin section.

 

When I manually inset them in admin I end up with 2 of the same showing in catalog ie 2 Microsofts instead of one.

 

Any ideas anyone ?

 

Thanks in advance.

 

Edwin

Share this post


Link to post
Share on other sites

i have installed EP 2.76c-ms2 and when i try to upload my .CSV using my admin page within osC i get this in big bold red letters

 

Warning: move_uploaded_file(/data/members/paid/i/n/iniquityclothing.com/htdocs/www/www/temp/EP2006Oct13-2008.txt): failed to open stream: No such file or directory in /data/members/paid/i/n/iniquityclothing.com/htdocs/www/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpWfbseU' to '/data/members/paid/i/n/iniquityclothing.com/htdocs/www/www/temp/EP2006Oct13-2008.txt' in /data/members/paid/i/n/iniquityclothing.com/htdocs/www/admin/easypopulate_functions.php on line 32

 

 

File uploaded.

Temporary filename: /tmp/phpWfbseU

User filename: EP2006Oct13-2008.txt

Size: 2179

 

Warning: file(): Unable to access /data/members/paid/i/n/iniquityclothing.com/htdocs/www/www/temp/EP2006Oct13-2008.txt in /data/members/paid/i/n/iniquityclothing.com/htdocs/www/admin/easypopulate.php on line 667

 

Warning: file(/data/members/paid/i/n/iniquityclothing.com/htdocs/www/www/temp/EP2006Oct13-2008.txt): failed to open stream: No such file or directory in /data/members/paid/i/n/iniquityclothing.com/htdocs/www/admin/easypopulate.php on line 667

 

Warning: Invalid argument supplied for foreach() in /data/members/paid/i/n/iniquityclothing.com/htdocs/www/admin/easypopulate.php on line 690

 

Any ideas what the prob is and how to fix this?? As far as i can tell i have followed all instructions to the letter! Please Help!

Thanks

Edited by Iniquityclothing

View recent 'helpfull' threads:

 

403 Error problems | Ultimate SEO (contribution support)

Share this post


Link to post
Share on other sites
i have installed EP 2.76c-ms2 and when i try to upload my .CSV using my admin page within osC i get this in big bold red letters

Any ideas what the prob is and how to fix this?? As far as i can tell i have followed all instructions to the letter!

 

Is there a directory called /data/members/paid/i/n/iniquityclothing.com/htdocs/www/www/temp/ ? I guess it may look like /htdocs/www/www/temp/ from your login. What are the permissions set on it? Try setting it to chmod 777.

Share this post


Link to post
Share on other sites

Hi folks i keep getting this error when i try to insert my spreadsheet file onto my db with easypopulate 2.76c-ms2

 

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 's knee boot with 3 inch heel and multi buckle fastening. Crafted

 

INSERT INTO oscommerce_products_description (products_id, language_id, products_name, products_description, products_url) VALUES ( '60', 1, 'Chunky sole knee boot', 'Men's knee boot with 3 inch heel and multi buckle fastening. Crafted from black pu.', '' )

 

[TEP STOP]

 

Any ideas how to correct this problem, Cheers!! :thumbsup:


View recent 'helpfull' threads:

 

403 Error problems | Ultimate SEO (contribution support)

Share this post


Link to post
Share on other sites
Hi folks i keep getting this error when i try to insert my spreadsheet file onto my db with easypopulate 2.76c-ms2

Any ideas how to correct this problem, Cheers!! :thumbsup:

 

probably comes from the text of your description: try to remove any apostrophes from yoru description text and see if it works.

Share this post


Link to post
Share on other sites

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 's neck cau', '' )' at line 11

 

i get the above message when i upload a text file

 

please help regards

Share this post


Link to post
Share on other sites

Can somebody help,

There appears to be 3 listings in my "new products" section at the bottom of the main page that are not actually listings, they come up as ?0.00 and i cannot seem to remove them?? even if i list something new they still appear at the top! any ideas?

Thanks

please have a look here

www.iniquityclothing.com

Edited by Iniquityclothing

View recent 'helpfull' threads:

 

403 Error problems | Ultimate SEO (contribution support)

Share this post


Link to post
Share on other sites

hi

 

easy question here, I cant see what im doing wrong or what I need to change to include Vat (tax) in my prices when i download the EP file. I'm php illiterate and have read the manual but i just cant see it. heres my code that i think refers to whatever needs to be changed.

 

//**** Price includes tax? ****
global $price_with_tax;
$price_with_tax = (EP_PRICE_INC_TAX =='true' ? 1 : 0);
define (EP_DELIMITER , '\t');
global $separator;
if (EP_DELIMITER == '\t') {
 $separator = "\t"; // oscommerce stores escaped delimeters in mySQL as a string and not an actual tab.
} else {
$separator = EP_DELIMITER;
}

 

What do I need to do?

 

I also want prices to include tax when I download the Froogle file too. :blush:

Share this post


Link to post
Share on other sites
hi

 

easy question here, I cant see what im doing wrong or what I need to change to include Vat (tax) in my prices when i download the EP file. I'm php illiterate and have read the manual but i just cant see it. heres my code that i think refers to whatever needs to be changed.

 

//**** Price includes tax? ****
global $price_with_tax;
$price_with_tax = (EP_PRICE_INC_TAX =='true' ? 1 : 0);
define (EP_DELIMITER , '\t');
global $separator;
if (EP_DELIMITER == '\t') {
 $separator = "\t"; // oscommerce stores escaped delimeters in mySQL as a string and not an actual tab.
} else {
$separator = EP_DELIMITER;
}

 

What do I need to do?

 

I also want prices to include tax when I download the Froogle file too. :blush:

 

there should be a setting in your admin section with a radio button.

close your Easypopulate file, and go look in your store settings :-)

Share this post


Link to post
Share on other sites

hi pixclinic, remember me? :), we emailed each other a while ago trying to get EP to work but sort of lost contact...

 

As im not running the latest version of EP i cant find the button or a way to change this via the web interface. Would you recommend i install the newest version, and if so how would i go about implementing this on a store that is already up and running?

Share this post


Link to post
Share on other sites
hi pixclinic, remember me? :), we emailed each other a while ago trying to get EP to work but sort of lost contact...

 

As im not running the latest version of EP i cant find the button or a way to change this via the web interface. Would you recommend i install the newest version, and if so how would i go about implementing this on a store that is already up and running?

 

I talk to so many people, I'm sure sure I remember you. anyway which version are you using again?

Share this post


Link to post
Share on other sites

well im not completely sure, you sent me your verison that you were using at the time as you knew that it worked ok for you.

 

At the top of my EP it says this, does it help?

 

<?php

// Current EP Version
$curver = '2.8-MS2';

/*
 $Id: easypopulate.php,v 2.8 2006/03/21 TommyVo @ www.ITSS.com.au Exp $
*/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×