Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

I want to use Easy Populate with More Pics - is this just a matter of making new columns in excel for the extra images? Or can these 2 contribs not work together?

 

 

as well as uncommenting the code in easypopulate.php is there anything else I should do?


For my contribution (to society) see my profile link.

--

my new charity store features: STSv4.5.2 and HTCv2.6.3 Bundle, Australian Post Shipping, Paymate, Category Trees Minimum Order Quantity, Enable/Disable Categories, Super Download Store, Paypal IPN, Free Dowloads, Anti-Robot Registration 2.6, Master Products, Lightbox for STS ... the rebuild continues...

Share this post


Link to post
Share on other sites
Will give it a blast and yet you know if it worked, thanks.

 

Still no joy.

 

Could the problem be that I'm using openoffice rather than excel as when I open the downloaded txt file from the site with the products that are already added it just shows it as like a text file (not in cols*) so I can't edit that I have had to make my own with cols* that are easy to edit. (if that makes any sense)

 

Thanks for any help.

Share this post


Link to post
Share on other sites

I'm not familiar with open office, but you might want to read page 197 of this thread. Nat8100 had a very similar easy populate problem, and got it worked out...ended up switching to ep 2.76, though...I think.

 

The posts are here

 

Still no joy.

 

Could the problem be that I'm using openoffice rather than excel as when I open the downloaded txt file from the site with the products that are already added it just shows it as like a text file (not in cols*) so I can't edit that I have had to make my own with cols* that are easy to edit. (if that makes any sense)

 

Thanks for any help.

Share this post


Link to post
Share on other sites
I want to use Easy Populate with More Pics - is this just a matter of making new columns in excel for the extra images? Or can these 2 contribs not work together?

 

They can work together, but there's more to it that adding columns.

 

as well as uncommenting the code in easypopulate.php is there anything else I should do?

 

What version of ep are you using? Do you have other fields you need, or just More pics? The commented lines for extra images don't match the More Pics fields, not in the versions I looked at anyway. They're close, but not close enough ;) I have EP 2.74 fixed to use with More Pics. If you'd like to try 2.74, let me know.

Share this post


Link to post
Share on other sites
I'm not familiar with open office, but you might want to read page 197 of this thread. Nat8100 had a very similar easy populate problem, and got it worked out...ended up switching to ep 2.76, though...I think.

 

The posts are here

 

 

Thanks for that, spent the last few hours reading posts. I can now edit the files in OpenOffice fine with cols*

 

But for some unknown reason when i download the complete list make a change to the title and then save and upload it doesn't make the changes.

 

Just get the same

File uploaded.

Temporary filename: /tmp/phpvt85DY

User filename: EP2006May15-1503(2).csv

Size: 923

 

File goes like:

 

"v_products_model"|"v_products_image"|"v_products_name_1"|"v_products_description_1"|"v_products_url_1"|"v_products_price"|"v_products_weight"|"v_date_avail"|"v_date_added"|"v_products_quantity"|"v_manufacturers_name"|"v_categories_name_1"|"v_categories_name_2"|"v_categories_name_3"|"v_tax_class_title"|"v_status"|"EOREOR"

"ade34"|"654656.jpg"|"product name here blah blah"|"description here blah blah blah"||10.99|170||15/05/2006 13:32:30|5||"Cat1"|"Cat2"||"--none--"|"Inactive"|"EOREOR"

 

Does anything seem wrong with that? pulling me hair out :)

 

Thanks

Share this post


Link to post
Share on other sites
File uploaded.

Temporary filename: /tmp/phpvt85DY

User filename: EP2006May15-1503(2).csv

Size: 923

 

If your easypopulate.php file is set with the default delimeter as tab, then your upload file needs to be saved as a ".txt (tab delimited)" file. That's the only thing I see at this point.

Share this post


Link to post
Share on other sites
If your easypopulate.php file is set with the default delimeter as tab, then your upload file needs to be saved as a ".txt (tab delimited)" file. That's the only thing I see at this point.

 

Thanks for the reply, yeah I tried that. Even tried using a different comp with excel installed but still no joy. Am a little stumped.

Share this post


Link to post
Share on other sites
Hi,

1- which EP version are you using ? I read posts that ver.3 and above should not be used. That's why I took the EP 2.79. with functions in admin side now.

2- on the admin side chosse "replace quotes" = False

3- Define precisely your problem; is it on upload or download that quotes are changed for & # 3 4 ?

Choose a product in your catalogue, put " many times inside it description, and download a EP file. Is there still the quotes ?

If yes, Then re-upload this files and go to the product description in your products catalogue to see again if " are still there.

4- Every problem has a solution... ;)

 

seb

 

Hello,

 

1- I'm using version 2.79

2- I did that

3- ("Upload" My html layout is destroied becouse all "s is changed to & # 34. I can see in product desription in admin) ("download" I see & # 34 instead og "s)

4- Don't know :blush:

 

This is where is quotes are coded:

function walk( $item1 ) {
	global $filelayout, $filelayout_count, $modelsize;
	global $langcode, $default_these;
	global $epdlanguage_id, $price_with_tax;
	global $separator;
	// first we clean up the row of data

	// chop blanks from each end
	$item1 = ltrim(rtrim($item1));

	// blow it into an array, splitting on the tabs
	$items = explode($separator, $item1);

	// make sure all non-set things are set to '';
	// and strip the quotes from the start and end of the stings.
	// escape any special chars for the database.
	foreach( $filelayout as $key=> $value){
			$i = $filelayout[$key];
			if (isset($items[$i]) == false) {
					$items[$i]='';
			} else {
					// Check to see if either of the magic_quotes are turned on or off;
					// And apply filtering accordingly.
					if (function_exists('ini_get')) {
							//echo "Getting ready to check magic quotes<br>";
							if (ini_get('magic_quotes_runtime') == 1){
									// The magic_quotes_runtime are on, so lets account for them
									// check if the last character is a quote;
									// if it is, chop off the quotes.
									if (substr($items[$i],-1) == '"'){
											$items[$i] = substr($items[$i],2,strlen($items[$i])-4);
									}
									// now any remaining doubled double quotes should be converted to one doublequote
									$items[$i] = str_replace('\"\"',""",$items[$i]);
									if (EP_REPLACE_QUOTES == 'true'){
											$items[$i] = str_replace('\"',""",$items[$i]);
											$items[$i] = str_replace("\'","'",$items[$i]);
									}
							} else { // no magic_quotes are on
									// check if the last character is a quote;
									// if it is, chop off the 1st and last character of the string.
									if (substr($items[$i],-1) == '"'){
											$items[$i] = substr($items[$i],1,strlen($items[$i])-2);
									}
									// now any remaining doubled double quotes should be converted to one doublequote
									$items[$i] = str_replace('""',""",$items[$i]);
									if (EP_REPLACE_QUOTES == 'true'){
											$items[$i] = str_replace('"',""",$items[$i]);
											$items[$i] = str_replace("'","'",$items[$i]);
									}
							}
					}
			}
	}

 

 

Thanks


?,???`???,?? God must love stupid people, he made so many ??,???`???,?

Share this post


Link to post
Share on other sites
They can work together, but there's more to it that adding columns.

What version of ep are you using? Do you have other fields you need, or just More pics? The commented lines for extra images don't match the More Pics fields, not in the versions I looked at anyway. They're close, but not close enough ;) I have EP 2.74 fixed to use with More Pics. If you'd like to try 2.74, let me know.

 

 

Hi,

 

I'm using 2.76 - I think I just need the More Pics fields, at least at this stage :D

 

Any help would be appreciated and I'll add you to my list of wonderful people!


For my contribution (to society) see my profile link.

--

my new charity store features: STSv4.5.2 and HTCv2.6.3 Bundle, Australian Post Shipping, Paymate, Category Trees Minimum Order Quantity, Enable/Disable Categories, Super Download Store, Paypal IPN, Free Dowloads, Anti-Robot Registration 2.6, Master Products, Lightbox for STS ... the rebuild continues...

Share this post


Link to post
Share on other sites
No, i'm using a subdomain too :)

 

Now I'm really stumped :)

 

Will have to try making a fresh install on another subdomain without any contribs installed, can't see that being the problem though seeing as I only have STS installed at this point.

 

Will report back.

Share this post


Link to post
Share on other sites

Shaytaan,

post here the first 2 lines of your excel file you want to upload, with minimum information :

model number, product name and descritpion (make it light please). i'll upload it on my store to test.

example :

v_products_model  |  v_products_name_2  |  v_products_description_2	  |  EOREOR
TESTTEST  |  TESTname  |  Lots of fun with movement "up and down", "down and up"  |  EOREOR

Seb


Osc 2.2 MS2

Share this post


Link to post
Share on other sites
Will have to try making a fresh install on another subdomain without any contribs installed, can't see that being the problem though seeing as I only have STS installed at this point.

I'm not sure to have well understand you, but I've STS too. (old ver. 2.0).

Seb


Osc 2.2 MS2

Share this post


Link to post
Share on other sites

I didn't realize your need for master products, but I sent you a PM

 

You should be a lot closer now :blush:

 

Hi,

 

I'm using 2.76 - I think I just need the More Pics fields, at least at this stage :D

 

Any help would be appreciated and I'll add you to my list of wonderful people!

Share this post


Link to post
Share on other sites

I have installed version 2.9 . When I hit on create any of the froogle files, nothing happens I dont see any error or anything else

Share this post


Link to post
Share on other sites

Do any of the other functions work, such as

 

Download Complete tab-delimited .txt file to edit

Download Model/Price/Qty tab-delimited .txt file to edit

Download Model/Category tab-delimited .txt file to edit

Download Froogle tab-delimited .txt file

 

and

 

Create Complete tab-delimited .txt file in temp dir

Create Model/Price/Qty tab-delimited .txt file in temp dir

Create Model/Category tab-delimited .txt file in temp dir

 

Create Model/Attributes tab-delimited .txt file in temp dir

 

I have installed version 2.9 . When I hit on create any of the froogle files, nothing happens I dont see any error or anything else

Share this post


Link to post
Share on other sites
Do any of the other functions work, such as

 

Download Complete tab-delimited .txt file to edit

Download Model/Price/Qty tab-delimited .txt file to edit

Download Model/Category tab-delimited .txt file to edit

Download Froogle tab-delimited .txt file

 

and

 

Create Complete tab-delimited .txt file in temp dir

Create Model/Price/Qty tab-delimited .txt file in temp dir

Create Model/Category tab-delimited .txt file in temp dir

 

Create Model/Attributes tab-delimited .txt file in temp dir

No , none of that works at all

Share this post


Link to post
Share on other sites

Hi guys,

 

I've read through all most of the post on the support forum as well as the contributions support forum. Couldn't find an answer for a very simple question. I'm using EP_v2_76_MS2_1 and everything seems to work except for the import of products. When I import products from my tab-delimted file only the first product gets imported and i get the following message :

 

File uploaded.

Temporary filename: /tmp/phpeol8Xm

User filename: EP2006May16-1705.txt

Size: 4085

| JAMU0102EU | | Targus - A | | | | | | | | | 94 | | | | | | Accessorie | Targus Acc | | Taxable Go | Updated

| PA055E | PAUH210E | PAUM01E | PAKP004E | B0220 T | PAWM002E | PAUH216Y | PA025E | PAUH212E | PAKP003E | AMP01EU | PA870E | AMB01EU | APD10EU | APA01EU | APM12eu | ACP50EU | PA095E | ACB10EU | AWM04EU | PAWM001E | PA075E | AWE04EU | AWE05EU | AMP02EU | AKP01EU |

 

What seems to be the problem, as I'v read through most post an the ony two solutions are that the delimiter are not setup correctly, which I think I've done, and the PHP5 problems.

 

If anybody can please help me here...

 

Edwin

Share this post


Link to post
Share on other sites

Is your last column filled in with EOREOR on every line?

 

It seems like a lot of your fields are empty, even on that 1st product. I'm not sure how much of a problem that would be...but who knows. The description looks empty, but maybe I'm not seeing it right.

 

Since it lists all of the rest of your model numbers, but no other data, it would make me think that it didn't like your model numbers for some reason...but they're not too long, so I don't know what could be wrong?

 

I'm not much help, just a few ideas.

 

If you have a few products that already exist in your store, try downloading the EP file, then upload it. Don't edit it, just upload it again to see if you have the same problem. If you have the same problem, then you'll know that it's a problem with EP and not a problem with your txt file.

 

 

Hi guys,

 

I've read through all most of the post on the support forum as well as the contributions support forum. Couldn't find an answer for a very simple question. I'm using EP_v2_76_MS2_1 and everything seems to work except for the import of products. When I import products from my tab-delimted file only the first product gets imported and i get the following message :

 

File uploaded.

Temporary filename: /tmp/phpeol8Xm

User filename: EP2006May16-1705.txt

Size: 4085

| JAMU0102EU | | Targus - A | | | | | | | | | 94 | | | | | | Accessorie | Targus Acc | | Taxable Go | Updated

| PA055E | PAUH210E | PAUM01E | PAKP004E | B0220 T | PAWM002E | PAUH216Y | PA025E | PAUH212E | PAKP003E | AMP01EU | PA870E | AMB01EU | APD10EU | APA01EU | APM12eu | ACP50EU | PA095E | ACB10EU | AWM04EU | PAWM001E | PA075E | AWE04EU | AWE05EU | AMP02EU | AKP01EU |

 

What seems to be the problem, as I'v read through most post an the ony two solutions are that the delimiter are not setup correctly, which I think I've done, and the PHP5 problems.

 

If anybody can please help me here...

 

Edwin

Share this post


Link to post
Share on other sites
Hi is there anyway that I could change EP so that it could read the text file that I recieve, the text file contains data on stock availability, but it has different headings to that used in OSC.

 

here is an example of the text file:

 

**START...

As you can see it is set out differently from the normal EP file and it has different headings. Each book is seperated by the **

 

Iain, have you found a solution to this yet? If you're running a Linux machine, use the SED command to replace ** with EOREOR, and use carriage returns (\n) as your field delimiter in Easy Populate.

 

sed 's/\*\*/EOREOR/' your_text_file.txt > new_text_file.txt

 

Tim

Share this post


Link to post
Share on other sites

I just installed EP v2.90b on a clean install. I am getting this error when I upload a txt file and nothing is being imported:

 

Warning: move_uploaded_file(/home/bey12/public_htmlEP_TEMP_DIR/upload_test2.txt): failed to open stream: No such file or directory in /home/bey12/public_html/thehappiestmanalive/admin/includes/functions/easypopulate_functions.php on line 32

Share this post


Link to post
Share on other sites

It's looking for your file in

 

/home/bey12/public_htmlEP_TEMP_DIR/upload_test2.txt

 

It looks like you don't have a /temp/ directory, or that EP doesn't know the name of your /temp/ directory, since it's calling it EP_TEMP_DIR.

 

 

I just installed EP v2.90b on a clean install. I am getting this error when I upload a txt file and nothing is being imported:

 

Warning: move_uploaded_file(/home/bey12/public_htmlEP_TEMP_DIR/upload_test2.txt): failed to open stream: No such file or directory in /home/bey12/public_html/thehappiestmanalive/admin/includes/functions/easypopulate_functions.php on line 32

Share this post


Link to post
Share on other sites

Just in case, I created a temp file in the catalog (shopping cart is root of website - ie there is no "catalog" directory) and one above the website in the root (I have multiple websites "addon domains" on my account). Both are CHMOD 777.

 

I tried changing the path (and then changed it back) in the admin/includes configure.php file. Then I also tried adding a / to the end of the path in that file and got this error:

 

Warning: move_uploaded_file(/home/bey12/public_html/EP_TEMP_DIR/upload_test.txt): failed to open stream: No such file or directory in /home/bey12/public_html/thehappiestmanalive/admin/includes/functions/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpFXhSuN' to '/home/bey12/public_html/EP_TEMP_DIR/upload_test.txt' in /home/bey12/public_html/thehappiestmanalive/admin/includes/functions/easypopulate_functions.php on line 32

 

File uploaded.

Temporary filename: /tmp/phpFXhSuN

User filename: upload_test.txt

Size: 4415

 

Warning: file(/home/bey12/public_html/EP_TEMP_DIRupload_test.txt): failed to open stream: No such file or directory in /home/bey12/public_html/thehappiestmanalive/admin/easypopulate.php on line 719

 

Warning: Invalid argument supplied for foreach() in /home/bey12/public_html/thehappiestmanalive/admin/easypopulate.php on line 741

 

 

 

It's looking for your file in

 

/home/bey12/public_htmlEP_TEMP_DIR/upload_test2.txt

 

It looks like you don't have a /temp/ directory, or that EP doesn't know the name of your /temp/ directory, since it's calling it EP_TEMP_DIR.

Edited by sircuss

Share this post


Link to post
Share on other sites

Did you run the SQL file in the contribution?

 

There should be an entry in your admin panel, under configuration, for "easy populate". You should be able to define the EP temp file location there. It's still calling it EP_TEMP_DIR which indicates that EP doesn't know the name of your temp directory.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×