Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

made the changes..this is what I get:

 

File uploaded.

Temporary filename: /var/tmp/php018496

User filename: EP.txt

Size: 1645

| HP DesignJ | images/hp/ | HP DesignJ | kickazz pr | | 1000 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Inkjet Bon | | | | !New Product!

1136 - Column count doesn't match value count at row 1

 

INSERT INTO products ( products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( 'images/hp/500.gif', 'HP DesignJet 500', '1000', '1', CURRENT_TIMESTAMP, CURRENT_TIMESTAMP, NULL, '', '', '1', '', 'NULL')

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Hello Ken, I have the same problem. Before I try this solution, I would like to know if it can be resolved installing an extra contribution. I have installed SPPC, Quantity Price Breaks and Extra Fields and they work great with EP.

 

thanks

 

Here is an additional step:

 

Go to easypopulate.php, search for 'v_products_hide_from_groups' and '$v_products_hide_from_groups', comment them out by putting a # sign right before the line, i.e. #'v_products_hide_from_groups' and #'$v_products_hide_from_groups'. Or you can simply delete those lines.

 

Note: In the first instance of 'v_products_hide_from_groups', after you either comment it out or delete the line, remember to delete the , of the line above, i.e. 'v_products_height'. If not, you will get an SQL error.

 

Let me know if it works.

Share this post


Link to post
Share on other sites

Look under easypopulate.php again. Search for '$v_products_hide_from_groups' and delete the line. I belive you have missed to delete this one.

 

Let me know if it works.

 

made the changes..this is what I get:

 

File uploaded.

Temporary filename: /var/tmp/php018496

User filename: EP.txt

Size: 1645

| HP DesignJ | images/hp/ | HP DesignJ | kickazz pr | | 1000 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Inkjet Bon | | | | !New Product!

1136 - Column count doesn't match value count at row 1

 

INSERT INTO products ( products_image, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( 'images/hp/500.gif', 'HP DesignJet 500', '1000', '1', CURRENT_TIMESTAMP, CURRENT_TIMESTAMP, NULL, '', '', '1', '', 'NULL')

 

[TEP STOP]

Share this post


Link to post
Share on other sites

It can only be resolved if you have Products Hide from Groups. Google Products Hide from Groups and SPPC together. These 2 contributions work together. Products Hide from Groups is an "add-on" to SPPC since you may have products that sell to wholesalers only and you do not want your retail customers to see them.

 

I am NO expert in this (so I COULD BE WRONG) but the 2 contributions together works beautifully on my EP. Note: I do NOT have Quantity Price Breaks and Extra Fields installed though.

 

Hello Ken, I have the same problem. Before I try this solution, I would like to know if it can be resolved installing an extra contribution. I have installed SPPC, Quantity Price Breaks and Extra Fields and they work great with EP.

 

thanks

Share this post


Link to post
Share on other sites

another test...it did work (sortof) just didn't pull my images over..why is that?

 

File uploaded.

Temporary filename: /var/tmp/php007070

User filename: EP.txt

Size: 1645

| HP DesignJ | images/hp/ | HP DesignJ | kickazz pr | | 1000 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Inkjet Bon | | | | !New Product!

| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | |

 

No products_model field in record. This line was not imported

 

the products_model field..does this have to be a #? Also, what directory do the pics have to be in?

 

-bf

Share this post


Link to post
Share on other sites

Hi to all I have a small problem

 

I have installed Easy Populate 3.00 contribution and I'm using price per customer when I export my products info to my

CVS file, for the prices I only have 1 product price the rest are not filled are in "blank" any idea of why I don't get the rest

of prices info exported ?.

 

Thanks

 

Victor Noe

Edited by vchavezmex

Share this post


Link to post
Share on other sites

If I remember correctly, if you see "No products_model field in record. This line was not imported" means "Your EP file is all uploaded successfully." I COULD BE WRONG. I only remember if I see no ERROR message then my upload is successful.

 

As far as where the pics have to be in, it is usually under catalog/images for the default OSC setup.

 

another test...it did work (sortof) just didn't pull my images over..why is that?

 

File uploaded.

Temporary filename: /var/tmp/php007070

User filename: EP.txt

Size: 1645

| HP DesignJ | images/hp/ | HP DesignJ | kickazz pr | | 1000 | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Inkjet Bon | | | | !New Product!

| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | |

 

No products_model field in record. This line was not imported

 

the products_model field..does this have to be a #? Also, what directory do the pics have to be in?

 

-bf

Share this post


Link to post
Share on other sites

got it Ken..thanks for all your help..*whew* (wipes sweat from brow)..now I can get this done for my client..

 

-bf

Share this post


Link to post
Share on other sites

Quick question:

 

If I'm using the sample text file included as my base, how do I add the Model#, and the Model# that my clients assign? For instance, they want the manufacturers part # and their part # as well...

 

-bf

Share this post


Link to post
Share on other sites

Hi, I've followed the manual to install Easypopulate 2.90 on Milestone 2.2.

Have updated my sql with the update file and when I goto catalog > easy populate and Click on any of the links in: Export and download catalog's and Froogle's file or Creation catalog's and Froogle's file in the directory temp - I get this error:

 

1054 - Unknown column 'p.products_price1_qty' in 'field list'

SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_price as v_products_price, p.products_price1_qty as v_products_price1_qty, p.products_price1 as v_products_price1, p.products_price2_qty as v_products_price2_qty, p.products_price2 as v_products_price2, p.products_price3_qty as v_products_price3_qty, p.products_price3 as v_products_price3, p.products_price4_qty as v_products_price4_qty, p.products_price4 as v_products_price4, p.products_price5_qty as v_products_price5_qty, p.products_price5 as v_products_price5, p.products_price6_qty as v_products_price6_qty, p.products_price6 as v_products_price6, p.products_price7_qty as v_products_price7_qty, p.products_price7 as v_products_price7, p.products_price8_qty as v_products_price8_qty, p.products_price8 as v_products_price8, p.products_qty_blocks as v_products_qty_blocks, p.products_weight as v_products_weight, p.products_date_available as v_date_avail, p.products_date_added as v_date_added, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id, p.products_status as v_status FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND ptoc.categories_id = subc.categories_id

 

:blink:

 

Whatever is happening?

Share this post


Link to post
Share on other sites

I'm not sure, but it looks like those 'p.products_priceX_qty' fields are there for another contribution that you aren't using (Quanitity Price Breaks, maybe?). EP is looking for something that's not there.

Share this post


Link to post
Share on other sites

I was having the same prob not sure if this is a fix but the file easypopulate_function was in a different folder than the other contributions of EP so i moved the file "easypopulate_function.php" from the admin/includes/function folder to the admin/ folder and that error no longer appears. Some of the older versions had the easypopulate_function file in the admin file so i checked to see if it was file placement. It no longer shows the error -

 

the 1054 - Unknown column 'p.products_price1_qty' in 'field list'

 

Now when i click on any of the commands its just does a page reload and leaves you on that page but at least you can download the files with the databases and it uploads files too without it really uploading (it just reloads the screen with no info imported into the database)... sorry new here this sounds a little confussing hope you understood.

Share this post


Link to post
Share on other sites

Anyone could help me with this please please?

 

Hi to all I have a small problem

 

I have installed Easy Populate 3.00 contribution and I'm using price per customer when I export my products info to my

CVS file, for the prices I only have 1 product price the rest are not filled are in "blank" any idea of why I don't get the rest

of prices info exported ?.

 

Thanks

 

Victor Noe

Share this post


Link to post
Share on other sites

Hi,

 

Why if I open my downloaded .txt I can't see the product_id field? ----->>>>

 

v_products_model v_products_image v_products_name_3 v_products_description_3 v_products_url_3 v_products_price v_products_price1 v_products_price2 v_products_price3 v_products_price4 v_products_price5 v_products_price6 v_products_price7 v_products_price8 v_products_price1_qty v_products_price2_qty v_products_price3_qty v_products_price4_qty v_products_price5_qty v_products_price6_qty v_products_price7_qty v_products_price8_qty v_products_qty_blocks v_products_weight v_date_avail v_date_added v_products_quantity v_attribute_options_id_1 v_attribute_options_name_1_3 v_attribute_values_id_1_1 v_attribute_values_price_1_1 v_attribute_values_name_1_1_3 v_attribute_values_id_1_2 v_attribute_values_price_1_2 v_attribute_values_name_1_2_3 v_attribute_options_id_2 v_attribute_options_name_2_3 v_manufacturers_name v_categories_name_1 v_categories_name_2 v_categories_name_3 v_categories_name_4 v_categories_name_5 v_categories_name_6 v_categories_name_7 v_tax_class_title v_status EOREOR

 

If I change a product's model, a new product is added, not updated. Why?

 

Thanks


Forums, the perfect place to practice my English. From Spain.

Share this post


Link to post
Share on other sites
Why if I open my downloaded .txt I can't see the product_id field? ----->>>>

 

I can't either, but I thought the product_id was something we couldn't / shouldn't be editing anyway.

 

If I change a product's model, a new product is added, not updated. Why?

 

Correct, that's how EP works. If the products_model already exists, then it edits that product. If the products_model does not exist, it will create a new product. If you just need to update a product, then be sure to leave the products_model alone (don't change it for your upload).

 

I'm not an expert, but I've struggled through this already and it was worth it. EP works :D

Share this post


Link to post
Share on other sites

Hi, I would like to help if you can provide more info on the errors, if any. I have no idea why it happened. For my setup, I have successfully downloaded prices for retailer customers (customer group = 0), wholesalers (customer group = 1), and special prices.

 

Anyone could help me with this please please?

Share this post


Link to post
Share on other sites

Ok so I've downloaded 2.79b and had it installed. I'm having an issue with the model numbers downloading. If the model number happens to be letters or is a full 12 numbers long they won't download. How do I go about getting them to download.

Share this post


Link to post
Share on other sites

Thanks choosealogin.

 

As you say, that is the correct working (or operation? I'm not sure :P), but... in ADMIN.php, if you change the "model", the product is only edited. I think that EP must work thus, as admin.php works.

 

Someone could make a contrib mod with witch I say... :lol: I would do it, but I don't know how...

 

Thanks


Forums, the perfect place to practice my English. From Spain.

Share this post


Link to post
Share on other sites

1054 - Unknown column 'p.products_price1_qty' in 'field list'

 

I tried the comment out solution suggested by JOyride--no lock. Code below

 

PLEASE HELP!!

 

if (EP_CONTRIB_SPPC == 'true') {

$filelayout = array(

#'v_products_model' => $iii++,

 

#'v_products_price' => $iii++,

#'v_products_quantity' => $iii++,

#'v_products_qty_blocks' => $iii++,

#'v_products_price1' => $iii++,

#'v_products_price1_qty' => $iii++,

#'v_products_price2' => $iii++,

#'v_products_price2_qty' => $iii++,

#'v_products_price3' => $iii++,

#'v_products_price3_qty' => $iii++,

#'v_products_price4' => $iii++,

#'v_products_price4_qty' => $iii++,

#'v_products_price5' => $iii++,

#'v_products_price5_qty' => $iii++,

#'v_products_price6' => $iii++,

#'v_products_price6_qty' => $iii++,

#'v_products_price7' => $iii++,

#'v_products_price7_qty' => $iii++,

#'v_products_price8' => $iii++,

#'v_products_price8_qty' => $iii++,

 

#'v_customer_price_1' => $iii++,

#'v_customer_group_id_1' => $iii++,

#'v_products_qty_blocks_1' => $iii++,

#'v_products_price1_1' => $iii++,

#'v_products_price1_qty_1' => $iii++,

#'v_products_price2_1' => $iii++,

#'v_products_price2_qty_1' => $iii++,

#'v_products_price3_1' => $iii++,

#'v_products_price3_qty_1' => $iii++,

#'v_products_price4_1' => $iii++,

#'v_products_price4_qty_1' => $iii++,

#'v_products_price5_1' => $iii++,

#'v_products_price5_qty_1' => $iii++,

#'v_products_price6_1' => $iii++,

#'v_products_price6_qty_1' => $iii++,

#'v_products_price7_1' => $iii++,

#'v_products_price7_qty_1' => $iii++,

#'v_products_price8_1' => $iii++,

#'v_products_price8_qty_1' => $iii++,

 

(lots of scrolling)

 

// EOF for the separate prices per customer module

$filelayout_sql = "SELECT

#p.products_id as v_products_id,

#p.products_model as v_products_model,

#p.products_status as v_status,

#p.products_price as v_products_price,

#p.products_tax_class_id as v_tax_class_id,

#p.products_price1 as v_products_price1,

#p.products_price2 as v_products_price2,

#p.products_price3 as v_products_price3,

#p.products_price4 as v_products_price4,

#p.products_price5 as v_products_price5,

#p.products_price6 as v_products_price6,

#p.products_price7 as v_products_price7,

#p.products_price8 as v_products_price8,

#p.products_price1_qty as v_products_price1_qty,

#p.products_price2_qty as v_products_price2_qty,

#p.products_price3_qty as v_products_price3_qty,

#p.products_price4_qty as v_products_price4_qty,

#p.products_price5_qty as v_products_price5_qty,

#p.products_price6_qty as v_products_price6_qty,

#p.products_price7_qty as v_products_price7_qty,

#p.products_price8_qty as v_products_price8_qty,

#p.products_qty_blocks as v_products_qty_blocks,

#p.products_quantity as v_products_quantity

FROM

".TABLE_PRODUCTS." as p

";

Share this post


Link to post
Share on other sites

In responding to a couple of PM asking the same question:

 

Caveat Emptor - PLEASE READ: I believe I am using a different version of EP since my easypopulate.php does not have p.products_price1_qty in it.

 

HOWEVER, judging from the errors:

 

#p.products_price7_qty as v_products_price7_qty,

#p.products_price8_qty as v_products_price8_qty,

#p.products_qty_blocks as v_products_qty_blocks,

#p.products_quantity as v_products_quantity

FROM

".TABLE_PRODUCTS." as p

";

 

You may want to search

 

#p.products_quantity as v_products_quantity

FROM

".TABLE_PRODUCTS." as p

 

in your easypopulate.php file. Then pay close attention to the phrase 'after ".TABLE_PRODUCTS." as p', my guess is you will see '.products_price1_qty' after the 'p'.

 

Try deleting that term 'p.products_price1_qty' from there.

 

Hope it helps. As always, BACK UP FIRST BEFORE DOING THE DELETION!!! Let me know how it goes. Thank you.

Share this post


Link to post
Share on other sites

1054 - Unknown column 'p.products_price1_qty' in 'field list'

 

Have the latest OSC build & 2.90 of EP

 

Tried commenting out the 2 blocks of text at suggested by JOride, putting the functions file in admin and the latest from Ken, looking for ".TABLE_PRODUCTS." as p, and deleting the 'p.products_price1_qty' after it (does not exist in my code)

 

Cut to the chase--should I just upgrade?

 

To which version should I upgrade?

Share this post


Link to post
Share on other sites
Cut to the chase--should I just upgrade?

 

To which version should I upgrade?

 

I had problems with 3.0. I went with 2.74 by Mibble and it works fine for me.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×