Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Mibble who exactly are you reffering to?

 

Your post is kinda up in the air unless your reffering to everyone then I would feel like an idiot

 

O and I just installed your version of EP and it is far better than the others that I have tried I like being in the admin pannel to do what I have to do.

Edited by matrix2223

Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

Repeat post:

 

 

Can someone give me an idea on this please??????

 

Help Please:

 

I have 3 languages on my site: English, Brasilian and Spanish.

 

I am using easypopulate just fine but I have a small problem that I can not find the answer.

The text for the 3 languages are in the right place, but only the spanish and the english show up.

When I am in the website am I am in English and Spanish the products are there but when I switch to Brasilian the products are no longer there.

This only happens with the products that are uploaded using easypopulate.

Products that are uploaded using admin they are just fine.

This has to do with a configuration in easypopulate.

I tried to find it but I can not. Please someone advice.

Thank you.

Share this post


Link to post
Share on other sites

I just have one question. I am sorry if this is already been answered but I get lost in 192 pages of info. I have downloaded EP 2-79 (because I tried later versions but couldn't get them to work so I backed up before all the extras added) but when I look at my easypopulate.php it looks alot different than what I see in other posts. For instance, I have nothing on the &tempdir and I was looking for where to fix the quotes in my descriptions but can't figure it out. Here is the first part of my easypopulate.php

 

 

<?php

 

// Current EP Version

$curver = '2.78-MS2';

 

/*

$Id: easypopulate.php,v 2.74 2004/05/03 VJ Exp $

*/

 

require('includes/application_top.php');

 

//**** File Splitting Configuration ****

// we attempt to set the timeout limit longer for this script to avoid having to split the files

// NOTE: If your server is running in safe mode, this setting cannot override the timeout set in php.ini

if (EP_SET_TIME_LIMIT == 'true') {set_time_limit(330);}

 

//**** Size of products_model in products table ****

// This is automatically set to the maximum defined size of products_model in the products table. We check to make sure all models are no longer than this value.

global $modelsize;

$table_definition_query=tep_db_query("describe " . TABLE_PRODUCTS);

while ($product_definition=tep_db_fetch_array($table_definition_query)){

if ($product_definition[Field]=='products_model'){

if (substr($product_definition[Type],0,7)=='varchar'){

$modelsize=substr($product_definition[Type],8,strlen($product_definition[Type]));

$modelsize=substr($modelsize,0,(strlen($modelsize)-1));

}

}

}

//**** Price includes tax? ****

global $price_with_tax;

$price_with_tax = (EP_PRICE_INC_TAX =='False' ? 1 : 0);

 

global $separator;

if (EP_DELIMITER == '\t') {

$separator = "\t"; // oscommerce stores escaped delimeters in mySQL as a string and not an actual tab.

} else {

$separator = EP_DELIMITER;

}

 

 

// change this if you want to download selected product options

// this might be handy, if you have a lot of product options, and your output file exceeds 256 columns (which is the max. limit MS Excel is able to handle)

global $attribute_options_select;

//$attribute_options_select = array('Size', 'Model'); // uncomment and fill with product options name you wish to download // comment this line, if you wish to download all product options

// VJ product attributes end

Share this post


Link to post
Share on other sites

these lines of code should fallow "Price Includes Tax section"

 

// **** Quote -> Escape character conversion ****

// If you have extensive html in your descriptions and it's getting mangled on upload, turn this off

// set to 1 = replace quotes with escape characters

// set to 0 = no quote replacement

global $replace_quotes;

$replace_quotes = false;

 

Set to true to replace quotes


Eric

 

Keep up on osCommerce changes and updates at

Github | Understand osCommerce a little further at OsCommerce Documentation | Copy and paste your error message in Google add "in osCommerce" at the end to get relevant answers to most issues.

Share this post


Link to post
Share on other sites

I believe mibble was referring to my question from the previous page. If I need to enter an arbitrary model number for the products that don't have one I can do that. I have run into the issue of EP creating an insane amount of categories when it inserts the file into the db. I know that my file is in the correct format, well at least I hope. Here's what I have for the fields at the top:

 

v_products_model	v_products_image	v_products_name_1	v_products_description_1	v_products_price	v_categories_name_1	v_categories_name_2	v_categories_name_3	v_categories_name_4	v_categories_name_5	v_categories_name_6	v_categories_name_7	EOREOR

 

I had installed v 3.0 and don't have some of the mods installed that are incorporated into the file. Should I scrap v 3.0 and use another version or do I need to comment out some of the code. I'm just extremely frustrated at this point. I've used EP in the past without any trouble and it seems now that it's making it a heck of a lot harder than it should. Thanx all.

Share this post


Link to post
Share on other sites

As the person who uploads EP version 3.0, I suggest you to wait for the next version by dAbserver. My original intention of uploading is for people who do not want to modify MySQL for configuration, which is how EP started with, plus incorporating some add-ons (other contributions) to EP. I do NOT claim any credit to the contribution at all, as I did not incorporate anything new in there (except maybe writing 2 lines of MySQL query on pulling down special prices). And my version does not mean to be "superior" than the other versions and I have stated very clearly that it was heavily based on version 2.78. As I said before, I picked the number 3.0 in a totally random manner.

 

PLEASE WAIT FOR THE VERSION BY dAbserver. I am glad that someone smarter than me is willing to contribute to a better EP - this is what open source is all about, as it will benefit a lot of people.

 

 

I believe mibble was referring to my question from the previous page. If I need to enter an arbitrary model number for the products that don't have one I can do that. I have run into the issue of EP creating an insane amount of categories when it inserts the file into the db. I know that my file is in the correct format, well at least I hope. Here's what I have for the fields at the top:

 

v_products_model	v_products_image	v_products_name_1	v_products_description_1	v_products_price	v_categories_name_1	v_categories_name_2	v_categories_name_3	v_categories_name_4	v_categories_name_5	v_categories_name_6	v_categories_name_7	EOREOR

 

I had installed v 3.0 and don't have some of the mods installed that are incorporated into the file. Should I scrap v 3.0 and use another version or do I need to comment out some of the code. I'm just extremely frustrated at this point. I've used EP in the past without any trouble and it seems now that it's making it a heck of a lot harder than it should. Thanx all.

Share this post


Link to post
Share on other sites

Ok I give up, no matter what version 2.74 3.00, etc I have the same problem.

 

I go to import model / price updates. All goes fine.

 

When I go back to my new product section, EP has reset everyone of my products that I updated to being added on todays date. I have gone all over the code and narrowed it down to:

 

 

if ($v_date_added == '') {

$v_date_added = "CURRENT_TIMESTAMP";

} else {

// we put the quotes around it here because we can't put them into the query, because sometimes

// we will use the "current_timestamp", which can't have quotes around it.

$v_date_added = '"' . $v_date_added . '"';

 

But I cannot make it work, or this is not the right code.

Share this post


Link to post
Share on other sites
I have just installed ep 3.0 when i click on Download Complete tab-delimited .txt file to edit I get this error TABLE_PRODUCTS_STOCK' doesn't exist select products_stock_quantity from TABLE_PRODUCTS_STOCK where products_id = '1' and products_stock_attributes = '3-5'

I have split a file and uploaded and got File uploaded. Temporary filename: /tmp/php2uDKnM User filename:EP_Split1.txt Size: 60600 but no changes have been made to the db

Is this a sql error or do I need to make changes to easypopulate.php

 

Thanks

BArry

 

I had the same problems and couldn't find a good answer. But I did fix it!!!

 

In admin>easypopulate.php I made the following changes:

 

(I xxxx'd out my site specific info, you put in your own if needed.)

 

//*******************************

//*******************************

// C O N F I G U R A T I O N

// V A R I A B L E S

//*******************************

//*******************************

 

// **** Temp directory ****

// if you changed your directory structure from stock and do not have /catalog/temp/, then you'll need to change this accordingly.

//

$tempdir = "/temp/";

$tempdir2 = "/temp/";

 

//**** File Splitting Configuration ****

// we attempt to set the timeout limit longer for this script to avoid having to split the files

// NOTE: If your server is running in safe mode, this setting cannot override the timeout set in php.ini

// uncomment this if you are not on a safe mode server and you are getting timeouts

// set_time_limit(330);

 

// if you are splitting files, this will set the maximum number of records to put in each file.

// if you set your php.ini to a long time, you can make this number bigger

global $maxrecs;

$maxrecs = 300; // default, seems to work for most people. Reduce if you hit timeouts

//$maxrecs = 4; // for testing

 

//**** Image Defaulting ****

global $default_images, $default_image_manufacturer, $default_image_product, $default_image_category;

 

// set them to your own default "We don't have any picture" gif

$default_image_manufacturer = 'xxxxxxxxx.gif';

$default_image_product = 'xxxxxxxxxxxx.gif';

$default_image_category = 'xxxxxxxxxxxxx.gif';

 

// or let them get set to nothing

//$default_image_manufacturer = '';

//$default_image_product = '';

//$default_image_category = '';

 

//**** Status Field Setting ****

// Set the v_status field to "Inactive" if you want the status=0 in the system

// Set the v_status field to "Delete" if you want to remove the item from the system <- THIS IS NOT WORKING YET!

// If zero_qty_inactive is true, then items with zero qty will automatically be inactive in the store.

global $active, $inactive, $zero_qty_inactive, $deleteit;

$active = 'Active';

$inactive = 'Inactive';

//$deleteit = 'Delete'; // not functional yet

$zero_qty_inactive = false;

 

//**** Size of products_model in products table ****

// set this to the size of your model number field in the db. We check to make sure all models are no longer than this value.

// this prevents the database from getting fubared. Just making this number bigger won't help your database! They must match!

global $modelsize;

$modelsize = 25;

 

//**** Price includes tax? ****

// Set the v_price_with_tax to

// 0 if you want the price without the tax included

// 1 if you want the price to be defined for import & export including tax.

global $price_with_tax;

$price_with_tax = false;

 

// **** Quote -> Escape character conversion ****

// If you have extensive html in your descriptions and it's getting mangled on upload, turn this off

// set to 1 = replace quotes with escape characters

// set to 0 = no quote replacement

global $replace_quotes;

$replace_quotes = false;

 

// **** Field Separator ****

// change this if you can't use the default of tabs

// Tab is the default, comma and semicolon are commonly supported by various progs

// Remember, if your descriptions contain this character, you will confuse EP!

global $separator;

$separator = "\t"; // tab is default

//$separator = ","; // comma

//$separator = ";"; // semi-colon

//$separator = "~"; // tilde

//$separator = "-"; // dash

//$separator = "*"; // splat

 

// **** Max Category Levels ****

// change this if you need more or fewer categories

global $max_categories;

$max_categories = 3; // 7 is default

 

// VJ product attributes begin

// **** Product Attributes ****

// change this to false, if do not want to download product attributes

global $products_with_attributes;

$products_with_attributes = false;

 

// change this to true, if you use QTYpro and want to set attributes stock with EP.

global $products_attributes_stock;

$products_attributes_stock = false;

 

// change this if you want to download selected product options

// this might be handy, if you have a lot of product options, and your output file exceeds 256 columns (which is the max. limit MS Excel is able to handle)

global $attribute_options_select;

// $attribute_options_select = array('Size', 'Model'); // uncomment and fill with product options name you wish to download // comment this line, if you wish to download all product options

// VJ product attributes end

 

 

 

 

// ****************************************

// Froogle configuration variables

// -- YOU MUST CONFIGURE THIS! IT WON'T WORK OUT OF THE BOX!

// ****************************************

 

// **** Froogle product info page path ****

// We can't use the tep functions to create the link, because the links will point to the admin, since that's where we're at.

// So put the entire path to your product_info.php page here

global $froogle_product_info_path;

$froogle_product_info_path = "http://www.xxxxxxxxxxxx.com/catalog/product_info.php";

 

// **** Froogle product image path ****

// Set this to the path to your images directory

global $froogle_image_path;

$froogle_image_path = "http://www.xxxxxxxxxxxxxxx.com/catalog/images/";

 

// **** Froogle - search engine friendly setting

// if your store has SEARCH ENGINE FRIENDLY URLS set, then turn this to true

// I did it this way because I'm having trouble with the code seeing the constants

// that are defined in other places.

global $froogle_SEF_urls;

$froogle_SEF_urls = true;

 

 

// ****************************************

// End Froogle configuration variables

// ****************************************

 

//*******************************

//*******************************

// E N D

// C O N F I G U R A T I O N

// V A R I A B L E S

//*******************************

//*******************************

B)

I like these mods, there fun! ...65 70 72 75 80 85 125+ contributions installed and counting...

 

Tools I'm using: OSC2.2 milestone2, Filezilla for FTP, PHP Designer 2007PE (nice), Araxis Merge 6.5 to compare files, XP(my box), Remote Server is shared Apache 1.3 Cpanel, CURL, and PHPmyAdmin through my hosts Cpanel to mess up the database.

Share this post


Link to post
Share on other sites

Spoke too soon. Still errors showing up.


I like these mods, there fun! ...65 70 72 75 80 85 125+ contributions installed and counting...

 

Tools I'm using: OSC2.2 milestone2, Filezilla for FTP, PHP Designer 2007PE (nice), Araxis Merge 6.5 to compare files, XP(my box), Remote Server is shared Apache 1.3 Cpanel, CURL, and PHPmyAdmin through my hosts Cpanel to mess up the database.

Share this post


Link to post
Share on other sites

Hi,

 

Im pulling my hair out!!! when I try to upload a product file even if it's blank (just the headers) it failing with the error below. I have been through the authors instructions but to no avail.

 

I have also searched the internet before posting a request because I know how many stupid questions get posted on boards sometimes. (I just hope this is not one)

 

I used to have the old version of easy populate and it worked great but the new release must work differently! I have also reloaded the Easy Populate files just to be sure! I'm using the latest release of OS Commerce 2.2.

 

Is the answer just to scrap ver 3 abd revert to an older one, if so whats involved?

 

The error I recieve is:

 

File uploaded.

Temporary filename: C:\WINDOWS\TEMP\php12C4.tmp

User filename: EP2006Apr25-1402.txt

Size: 83

1054 - Unknown column 'p.products_hide_from_groups' in 'field list'

 

SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_added as v_date_avail, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.products_hide_from_groups as v_products_hide_from_groups, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND p.products_model = '' AND ptoc.categories_id = subc.categories_id

Share this post


Link to post
Share on other sites

I am having the exact same error..the fix listed a few pages back:

 

"1. Look for p.products_hide_from_groups in easypopulate.php and comment it out (or just delete the whole line). There should be 2 instances in the file.

2. Try and see if it works. If not go to your excel file and find v_products_hide_from_groups and delete that column and try to upload again."

 

Isn't working either...

This shouldn't be that difficult to get working..really

 

-bf

Share this post


Link to post
Share on other sites

Help please:

 

When I update the complete file I have the date included in the proper colum but it does not register on the product and the product shows no date updated.

I use the same text file that is downloaded, I make the right changes and then I upload it but the date does not register. The rest of the product info does get updated but not the date.

in the store it shows the phrase about the date but no date in front of it.

Any idea why???

Please reply and thank you.

Share this post


Link to post
Share on other sites

If you look at the file from the very beginning, starting

 

// C O N F I G U R A T I O N

// V A R I A B L E S

 

continue to scroll through the file until you see:

 

// VJ product attributes begin

// **** Product Attributes ****

// change this to false, if do not want to download product attributes

global $products_with_attributes;

$products_with_attributes = true;

 

Turn $products_with_attributes = true; to $products_with_attributes = false;

 

Let me know if it works.

 

I have just installed ep 3.0 when i click on Download Complete tab-delimited .txt file to edit I get this error TABLE_PRODUCTS_STOCK' doesn't exist select products_stock_quantity from TABLE_PRODUCTS_STOCK where products_id = '1' and products_stock_attributes = '3-5'

I have split a file and uploaded and got File uploaded. Temporary filename: /tmp/php2uDKnM User filename:EP_Split1.txt Size: 60600 but no changes have been made to the db

Is this a sql error or do I need to make changes to easypopulate.php

 

Thanks

BArry

Share this post


Link to post
Share on other sites

Go to easypopulate.php, search for p.products_hide_from_groups and delete the line (there should be 2 instances).

 

If this is not working, please let me know what error you encounter.

 

Hi,

 

Im pulling my hair out!!! when I try to upload a product file even if it's blank (just the headers) it failing with the error below. I have been through the authors instructions but to no avail.

 

I have also searched the internet before posting a request because I know how many stupid questions get posted on boards sometimes. (I just hope this is not one)

 

I used to have the old version of easy populate and it worked great but the new release must work differently! I have also reloaded the Easy Populate files just to be sure! I'm using the latest release of OS Commerce 2.2.

 

Is the answer just to scrap ver 3 abd revert to an older one, if so whats involved?

 

The error I recieve is:

 

File uploaded.

Temporary filename: C:\WINDOWS\TEMP\php12C4.tmp

User filename: EP2006Apr25-1402.txt

Size: 83

1054 - Unknown column 'p.products_hide_from_groups' in 'field list'

 

SELECT p.products_id as v_products_id, p.products_model as v_products_model, p.products_image as v_products_image, p.products_price as v_products_price, p.products_weight as v_products_weight, p.products_date_added as v_date_avail, p.products_tax_class_id as v_tax_class_id, p.products_quantity as v_products_quantity, p.products_hide_from_groups as v_products_hide_from_groups, p.manufacturers_id as v_manufacturers_id, subc.categories_id as v_categories_id FROM products as p, categories as subc, products_to_categories as ptoc WHERE p.products_id = ptoc.products_id AND p.products_model = '' AND ptoc.categories_id = subc.categories_id

Edited by ken.yong

Share this post


Link to post
Share on other sites

Here is an additional step:

 

Go to easypopulate.php, search for 'v_products_hide_from_groups' and '$v_products_hide_from_groups', comment them out by putting a # sign right before the line, i.e. #'v_products_hide_from_groups' and #'$v_products_hide_from_groups'. Or you can simply delete those lines.

 

Note: In the first instance of 'v_products_hide_from_groups', after you either comment it out or delete the line, remember to delete the , of the line above, i.e. 'v_products_height'. If not, you will get an SQL error.

 

Let me know if it works.

 

Go to easypopulate.php, search for p.products_hide_from_groups and delete the line (there should be 2 instances).

 

If this is not working, please let me know what error you encounter.

Share this post


Link to post
Share on other sites

Ken,

 

Thank you for your speedy responce but I am unable to locate the string 'p.products_hide_from_groups' do you have any idea of the line number it's on?

Share this post


Link to post
Share on other sites

I am not sure if this is a problem related to EP. I COULD BE WRONG.

 

Try to update the date by going the traditional way in the Admin. I tried it - it didn't work for me. So...

 

Googled the problem:

http://forums.oscommerce.com/index.php?sho...mode=linearplus

http://forums.oscommerce.com/lofiversion/i...php/t45044.html

 

Sorry I could not help further.

 

Help please:

 

When I update the complete file I have the date included in the proper colum but it does not register on the product and the product shows no date updated.

I use the same text file that is downloaded, I make the right changes and then I upload it but the date does not register. The rest of the product info does get updated but not the date.

in the store it shows the phrase about the date but no date in front of it.

Any idea why???

Please reply and thank you.

Share this post


Link to post
Share on other sites

If you search p.products_quantity as v_products_quantity , p.products_hide_from_groups should be just beneath it.

 

Ken,

 

Thank you for your speedy responce but I am unable to locate the string 'p.products_hide_from_groups' do you have any idea of the line number it's on?

Share this post


Link to post
Share on other sites

Ken,

 

When I do a search for p.products_quantity as v_products_quantity it finds a few instances of that entry but there is no p.products_hide_from_groups below it, in fact there is a blank line and then the next line is p.manufacturers_id as v_manufacturers_id

Share this post


Link to post
Share on other sites

Ken,

 

Sincere apologies, I found it!! and it works like a dream!!

 

Thank you for your quick responce and the fix

Share this post


Link to post
Share on other sites

It works fine if i upload a product in the traditional way.

it only does not register when I use the EP.

I hope we can find the answer. The product info looks rediculous without the date.

 

 

 

I am not sure if this is a problem related to EP. I COULD BE WRONG.

 

Try to update the date by going the traditional way in the Admin. I tried it - it didn't work for me. So...

 

Googled the problem:

http://forums.oscommerce.com/index.php?sho...mode=linearplus

http://forums.oscommerce.com/lofiversion/i...php/t45044.html

 

Sorry I could not help further.

Share this post


Link to post
Share on other sites

In your upload file, format the date column as "yyyy-mm-dd". It worked for me.

 

 

 

Help please:

 

When I update the complete file I have the date included in the proper colum but it does not register on the product and the product shows no date updated.

I use the same text file that is downloaded, I make the right changes and then I upload it but the date does not register. The rest of the product info does get updated but not the date.

in the store it shows the phrase about the date but no date in front of it.

Any idea why???

Please reply and thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×