Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

You are correct the other file had a lot more instructions, but, even those are wrong. I couldn't find this file: 6. Edit file \admin\modules\filenames.php and add in bottom before ?> : in the location in the directions.

 

I'm now getting errors when running the sql update.

 

Error 1

MySQL said:

 

#1062 - Duplicate entry '17' for key 1

 

Error 2

MySQL said:

 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1

 

Getting somewhere, just not sure where.

 

Scott

Your duplicate error is probebly from when you ran my SQL statement i posted earlier

 

SQL syntax error is im guessing the ' (apostrophe) in "you'll" in the following SQL statement:

INSERT INTO configuration VALUES ('', 'Temp Directory', 'EP_TEMP_DIR', 'temp/', 'If you changed your directory structure from stock and do not have /catalog/temp/, then you'll need to change this accordingly.', 17, 1, now(), now(), NULL, NULL);

Delete the ' and change it to "youll" and should solve that one if I am right.

Share this post


Link to post
Share on other sites

Please help,

 

I have sorted all of my other problems, but am left one.

 

If I import a file with additional second or third tier categories that I have never had before, they show up in the admin section.

 

However they do not show up when I try to access them through my shop.

 

If I add the additional character to the end of the URL they do show up.

ie

From

 

index.php?cPath=1_5

 

to

 

index.php?cPath=1_5_77

 

 

Am I missing a bit of code somewhere?

 

Can any one help.

 

Cheers

 

Scott

Share this post


Link to post
Share on other sites

Hello,

 

i would pay somebody to insert my 10500 products successfully into oscommerce, i dont have time to do it myself please pm me.

 

cheers

Share this post


Link to post
Share on other sites

I didn't fix any of my SQL errors yet. Is there any way to remove the line that contains the duplicate entry and run it again? Or, is there a way to remove from the DB what was already added? How could I change the syntax on the insert that I already did? I looked in phpmyAdmin and couldn't find the information.

 

For the hell of it I did change my spreadsheet and put the product number first and tried uploading the file. The file uploaded without errors, but, no products were entered into the DB.

 

 

Scott

Share this post


Link to post
Share on other sites
I didn't fix any of my SQL errors yet. Is there any way to remove the line that contains the duplicate entry and run it again? Or, is there a way to remove from the DB what was already added? How could I change the syntax on the insert that I already did? I looked in phpmyAdmin and couldn't find the information.

 

For the hell of it I did change my spreadsheet and put the product number first and tried uploading the file. The file uploaded without errors, but, no products were entered into the DB.

Scott

 

For your 2 SQL errors, delete the first line which causes the duplicate problem. and change the 3rd line to

 

INSERT INTO configuration VALUES ('', 'Temp Directory', 'EP_TEMP_DIR', 'temp/', 'If you changed your directory structure from stock and do not have /catalog/temp/, then you will need to change this accordingly.', 17, 1, now(), now(), NULL, NULL);

 

Did you notice I change "you'll" to "you will", because that's another problem I found in version 2.79

 

If you have problem to find admin\modules\filesnames (which is addressed in step 6 in the 1readmefirst file), use "admin\include\filesnames.php instead. That works for me.

Share this post


Link to post
Share on other sites

Hi,

 

I am trying to add Easy Populate to an existing (only just set up) catalog, but can't seem to download a file I can use. The headers look like this (as does the rest of the file.

 

v_products_modelEP_DELIMITERv_products_imageEP_DELIMITERv_products_name_1EP_DELI

MITERv_products_description_1EP_DELIMITERv_products_url_1EP_DELIMITERv_products_p

riceEP_DELIMITERv_products_weightEP_DELIMITERv_date_availEP_DELIMITERv_date_added

EP_DELIMITERv_products_quantityEP_DELIMITERv_manufacturers_nameEP_DELIMITERv_tax_

class_titleEP_DELIMITERv_statusEP_DELIMITEEP_DELIMITEREOREOR

 

easypopulate.php has this section at Line 33.

 

global $separator;

if (EP_DELIMITER == '\t') {

$separator = "\t"; // oscommerce stores escaped delimeters in mySQL as a string and not an actual tab.

} else {

$separator = EP_DELIMITER;

 

Should I edit this and what with?

 

Regards,

 

Graham

Share this post


Link to post
Share on other sites
For your 2 SQL errors, delete the first line which causes the duplicate problem. and change the 3rd line to

 

INSERT INTO configuration VALUES ('', 'Temp Directory', 'EP_TEMP_DIR', 'temp/', 'If you changed your directory structure from stock and do not have /catalog/temp/, then you will need to change this accordingly.', 17, 1, now(), now(), NULL, NULL);

 

Did you notice I change "you'll" to "you will", because that's another problem I found in version 2.79

 

If you have problem to find admin\modules\filesnames (which is addressed in step 6 in the 1readmefirst file), use "admin\include\filesnames.php instead. That works for me.

 

Finally, got the SQL right, My export includes my attributes. Now I just need to update my spreadsheet and try that again. I did try uploading it but nothing went into the DB. It is not fully formatted yet so I hope that is the issue. Thanks for helping the SQL issue.

 

Scott

Share this post


Link to post
Share on other sites

Hi - I'd like to install the Easy Populate contribution. But I'm confused about which download I'm supposed to use. Is there a current full package? Or do I choose the last full package and install all the follow-on fixes too?

 

I appreciate any help!

 

Thanks

Share this post


Link to post
Share on other sites

When I download the complete CSV, I don't get any products included, but when I just download the attribute CSV it has the products. Is that the way it works?

 

Scott

Share this post


Link to post
Share on other sites

I am installing EP on to OSC 2.2 ms2 with the UK optimised and Header Tag contributions already installed and working. I have managed to get it working enough to be able to use:

 

Download .txt file with TAB delimited to edit ( Complete )

 

but this does not have any categories. The header row is:

 

v_products_model v_products_image v_products_name_1 v_products_description_1 v_products_url_1 v_products_head_title_tag_1 v_products_head_desc_tag_1 v_products_head_keywords_tag_1 v_products_price v_products_weight v_date_avail v_date_added v_products_quantity v_manufacturers_name v_tax_class_title v_status EOREOR

 

When I try to add some products and upload the file:

 

File uploaded.

Temporary filename: C:\Program Files\xampp\tmp\php636.tmp

User filename: EP2006Mar11-1827.txt

SIZE_EP21390

 

Warning: file(C:/Program Files/xampp/htdocs/catalog/EP_TEMP_DIREP2006Mar11-1827.txt) [function.file]: failed to open stream: No such file or directory in C:\Program Files\xampp\htdocs\catalog\admin\easypopulate.php on line 628

 

Warning: Invalid argument supplied for foreach() in C:\Program Files\xampp\htdocs\catalog\admin\easypopulate.php on line 650

 

Anyone have any suggestions?

 

Regards,

 

Graham

Share this post


Link to post
Share on other sites

I have a simple question about Easy Populate...

 

I have products already entered in my database that have attributes, if I download the Model / Price / Quantity text file and add new products to it and then upload to my store...will it remove the attributes from the products that had them before because the attributes are not included in the text file that I last uploaded? Or will they still be there even though they werent in the Model / Price / Quantity file?

Share this post


Link to post
Share on other sites

Also, I just updated to version 2.79 and it says "Pulled configuration into Admin panel." Ok so I went into the panel Configuration > Easy Populate. But when I click on it there the table to the right with Title, Value and Action but there is no information below the blue line to adjust or modify the configuration. How do I get that info in there?

Share this post


Link to post
Share on other sites
I have a simple question about Easy Populate...

 

I have products already entered in my database that have attributes, if I download the Model / Price / Quantity text file and add new products to it and then upload to my store...will it remove the attributes from the products that had them before because the attributes are not included in the text file that I last uploaded? Or will they still be there even though they werent in the Model / Price / Quantity file?

 

No the effect is cumulative. If you have stock and attributes there and you run EP they will still be there

 

Nossum

Share this post


Link to post
Share on other sites

After almost en entire day triying to figure out how to succesfuly import my ~280 products, here I am:

 

I found out that category names do not accept accents (?, ? ? etc) ! So if you try to work with categories / subcategories, try this before reading the 179 pages of this thread.

 

So now this works, and it imports, updates my... first record... very well. But not the rest of the list....

 

I get something like:

 

Filename: sample.txt

| 701010 | | | | | Hiver | M?lange de | | Winter | A deliciou | | | | | 4.38 | 112 | | | 1 | | Thes et ti | Thes noirs | Ceylan | | | | | --none-- | EP_STATUS_ Updated (or created, the first time, of course)

| | 701014 | | 701020 | | 701024 | | 602010 | | 602011 | | 602012 | | 602013 | | 602014 | | 602015 | | 602016 | | 602017 | | 602018 | | 602019 | | 2105001 | | 2105010 |

 

and yes, all lines end with a EOREOR

The txt file I want to import is here : http://www.barton.ch/catalog/temp/sample.txt

 

and I'm really stuck.

I used EP very often, two years ago, and remembered it as a very easy tool, very fast and bug-free. Maybe I'm buggy now :blink:

 

Thanks in advance for your advice

Share this post


Link to post
Share on other sites

I'm looking for some help wit Post #3559, I have about 2 days, to either get this mod working of I'll have to start entering the products manually. This thread has helped me get alot further than I could of on my own.

 

Thanks

Scott

Share this post


Link to post
Share on other sites

Skotmiller, I guess you probably have the same kind of problem I may have. THe question seems to be in the way to format the csv, and the way you use, for instance, categories. I.E. I discovered that foreign language accents cannot be use. When you import only a few fields, it can work. And I also had less problems when I removed all products attributes added by the default Oscommerce sample data.

Stay tuned. And good luck.

Share this post


Link to post
Share on other sites

maybe someone can explain how to install it stepby step ? i'm new with using oscommerce. and its a little bit difficult to understand it for me.

 

thank you in advance for any help.

Share this post


Link to post
Share on other sites
Skotmiller, I guess you probably have the same kind of problem I may have. THe question seems to be in the way to format the csv, and the way you use, for instance, categories. I.E. I discovered that foreign language accents cannot be use. When you import only a few fields, it can work. And I also had less problems when I removed all products attributes added by the default Oscommerce sample data.

Stay tuned. And good luck.

I'm not having a problem importing (not one that I'm aware of yet). It is when I export the CSV. If I export the complete, I don't get any products included. If I export the attributes there are products included. I'm not sure how to add the products, if I have no cells for a manufacturer or other information. I have a full spreadsheet setup and I will add the correct column headers as soon as I can get a complete export.

 

Scott

Share this post


Link to post
Share on other sites

Hi,

 

Quick question about Easy Populate & Products Attributes...

 

If I have a clothing store and I need to track inventory for a tee shirt and it's sizes and colors can I accomplish this using this contribution?

Share this post


Link to post
Share on other sites

I would really appreciate if somebody could give me a hint explaining why I can only import one record... having the EOREOR at every single line (see post above).

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hello.

 

When I upload product with images via EP I can't "Open in new window" on images.

The screen just went blank?

 

What is the problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×