Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

I have easy populate working. No problems. Except...

 

I have installed Separate Pricing per Customer/Group contrib. It's working, but when I click on the "Download complete tab delimited EP file" I get all the expected columns except for separate pricing columns.

 

I have uncommented all the separate pricing columns I need in easypopulate.php, but they do not show up the tab delimited file. What am I missing here?

 

I ran into this same issue today. I replaced my old easypopulate.php with "Easy populate 2.78-Ms2" which was posted four days ago. I have made sure all of the separate pricing lines have been uncommented. Do I need to add the separate pricing code anywhere else in the file?


When the going gets weird, the weird turn pro.

Share this post


Link to post
Share on other sites

hi folks,

i have a few questions 4U, hopefully waiting 4 your answers, tnx!

 

01. how and where can i increase the maximum value of php script run time? i have a lot of products with lots of description and want them upload to site with only one file, is it possible?

 

02. i have a category with vinyls called "LP" so I am interested is any good way to force EasyPopulate to upload all LP products into "LP" category, but not only when column "v_categories_name_1" contains value "LP", but also when it contains "2LP", "2xLP", "double LP", "picture LP"...and other values featuring word LP????

no, i don't wanna upload them into subcategories, just want them all upload into "LP" category, is this possible?

Share this post


Link to post
Share on other sites
I'm still getting my 403 - you don't have permission to access easypopulate.php error. Anyone have any ideas at all?
This may be a stupid question, but in addition to 777 the file does the owner match the other files in your directory that are not receiving the 403 errors?

Share this post


Link to post
Share on other sites
This may be a stupid question, but in addition to 777 the file does the owner match the other files in your directory that are not receiving the 403 errors?

 

Well...I'm not sure how to tell. phpmyadmin lets me take ownership, but doesn't give me a way to display who/what the current owner is.

 

I also can't see any information like that in the IE FTP window.

 

Is there someplace else I should look?

Share this post


Link to post
Share on other sites
hi folks,

i have a few questions 4U, hopefully waiting 4 your answers, tnx!

 

01. how and where can i increase the maximum value of php script run time? i have a lot of products with lots of description and want them upload to site with only one file, is it possible?

 

02. i have a category with vinyls called "LP" so I am interested is any good way to force EasyPopulate to upload all LP products into "LP" category, but not only when column "v_categories_name_1" contains value "LP", but also when it contains "2LP", "2xLP", "double LP", "picture LP"...and other values featuring word LP????

no, i don't wanna upload them into subcategories, just want them all upload into "LP" category, is this possible?

 

so, does anyone has solutions for my problems?

i am also interested 4 2 more things about EP like:

 

01. if my product_name are the same on both of my languages, can i avoid importing this name twice/two times? so that i will only need one column for the name of my products while importing it via easy populate... same like a product_price or product_weight??? they need only one column. hope you understand it!

Share this post


Link to post
Share on other sites
I have easy populate working. No problems. Except...

 

I have installed Separate Pricing per Customer/Group contrib. It's working, but when I click on the "Download complete tab delimited EP file" I get all the expected columns except for separate pricing columns.

 

I have uncommented all the separate pricing columns I need in easypopulate.php, but they do not show up the tab delimited file. What am I missing here?

 

In order to download the "Separate price per customer 4.11" fields in "easy populate 2.78-Ms2" you need to add to following code:

 

Around line 961, find:

	// VJ product attribs begin
 $header_array = array(
					'v_products_price'				=> $iii++,
'v_products_weight'				=> $iii++,
					'v_date_avail'						=> $iii++,
					'v_date_added'						=> $iii++,
					'v_products_quantity'				=> $iii++,

 

After it add:

'v_customer_price_1'				=> $iii++,
'v_customer_group_id_1'				=> $iii++,
'v_customer_price_2'				=> $iii++,
'v_customer_group_id_2'				=> $iii++,

 

Of course add as many as you need, I am only using 2 customer groups. Also, make sure it matches the number of customer groups uncommented around line 1096.


When the going gets weird, the weird turn pro.

Share this post


Link to post
Share on other sites

Ok, I'm frustated and I know I must be missing something very basic here, since I have much more complicated contribs installed and working....

 

Anyways, here is the crux of the problem, I can export to the temp directory just fine, I can also export and download the file just fine.

 

I then upload the file either from the temp directory or the browser and it appears to go just fine, with this appearing in the top of the EasyPopulate section of the Admin....

 

Filename: EP2006Jan25-2109.txt

| AC115 | americolor | AmeriColor | Click here | | | | | | | | | | | | | | | | 1.29 | 0.25 | | 0000-00-00 | 12 | 2 | Size | 3 | Color | Americolor | Cake Suppl | Food Color | | Taxable Go | Active Updated

| AC120 am | AC104 am | AC109 am | AC116 am | AC125 am | AC122 am | AC119 am | AC114 am | AC123 am | AC107 am | AC111 am | AC112 am | AC106 am | AC105 am | AC103 am | AC108 am | AC113 am | 10RCB R | AC101 am | AC102 am | AC110 am | AC124 am | AC121 am | AC117 am | AC126 am | AC162 am | AC133 am | AC128 am | AC164 am | AC135 am | AC130 am | AC161 am | AC132 am | AC127 am | AC163 am | AC134 am | AC129 am | AC165 am | AC160 am | AC131 am | IT10211 | IT10214 | IT10220 | IT10219 | IT10217 | IT10212 | IT10217 | IT10218 | IT10213

 

But none of the edits take place, I can go each of the products and change the price, get the above statement after uploading and then go back to the store and all the prices are still their original set.

 

Any help with this would be appreciated.

 

If you want to see a sample file that is trying to be imported you can sample it here: http://www.intotheoven.com/temp/EP2006Jan25-2109.txt

Share this post


Link to post
Share on other sites

Is there any way to split a large file for downloading? I have no problems uploading my file, because I can split it, but since I added attributes, I can no longer download any of the files. They all time out. Any suggestions?


Laurel

Share this post


Link to post
Share on other sites

so, after 2 weeks of searching the contribution and forum threads i still have some unanswered questions hoping to get answers soon as possible, tnx and sorry 4 repeating the posts....

 

01. how and where can i increase the maximum value of php script run time? i have a lot of products with lots of description and want them upload to site with only one file, is it possible?

 

02. i have a category with vinyls called "LP" so I am interested is any good way to force EasyPopulate to upload all LP products into "LP" category, but not only when column "v_categories_name_1" contains value "LP", but also when it contains "2LP", "2xLP", "double LP", "picture LP"...and other values featuring word LP????

no, i don't wanna upload them into subcategories, just want them all upload into "LP" category, is this possible?

 

03. if my v_products_name are the same on both of my languages, can i avoid importing this name twice/two times? so that i will only need one column for the name of my products while importing it via easy populate... same like a v_products_price or v_products_weight??? they need only one column. hope you understand it!

Share this post


Link to post
Share on other sites
so, after 2 weeks of searching the contribution and forum threads i still have some unanswered questions hoping to get answers soon as possible, tnx and sorry 4 repeating the posts....

 

01. how and where can i increase the maximum value of php script run time? i have a lot of products with lots of description and want them upload to site with only one file, is it possible?

 

Sorry, I can't comment on the other two, but for #1, you will need to edit your php.ini file. Hopefully you manage your own server or you will have to ask your provider to do it for you, which is unlikely they would be willing to do because of the potential impact on their other customers.

 

Anyways, your ini file should be located in /etc/php.ini

 

Look for the following lines and it's pretty self explanatory....

 

max_execution_time = 30 ; Maximum execution time of each script, in seconds

max_input_time = 60 ; Maximum amount of time each script may spend parsing request data

memory_limit = 16M ; Maximum amount of memory a script may consume (8MB)

Share this post


Link to post
Share on other sites
Sorry, I can't comment on the other two, but for #1, you will need to edit your php.ini file. Hopefully you manage your own server or you will have to ask your provider to do it for you, which is unlikely they would be willing to do because of the potential impact on their other customers.

 

Anyways, your ini file should be located in /etc/php.ini

 

Look for the following lines and it's pretty self explanatory....

 

max_execution_time = 30 ; Maximum execution time of each script, in seconds

max_input_time = 60 ; Maximum amount of time each script may spend parsing request data

memory_limit = 16M ; Maximum amount of memory a script may consume (8MB)

 

thanx bro, this was easy!!!

now, i am only looking for 2 answers :-)))

 

bye

Share this post


Link to post
Share on other sites

I am having difficulty downloading a complete tab-delimited file from Easy Populate. My store has about 6500 items and only three attributes, so I'm not sure if the attributes are causing the problem or not. I'm getting the dreaded timeout error. Any suggestions? Is there a way to split the file for download like it does for upload?


Laurel

Share this post


Link to post
Share on other sites

Image problem with EasyPopulate.

 

After installation, the database is downloading and uploading fine, but images are not working.

 

After I FTP the image files (CHMOD 777) to the server, I am identifying the file name in the .txt file prior to uploading the database via EasyPopulate in the admin panel. Once I upload the .txt file, all the the product changes are showing correctly except the image. In the admin module, is says: "image does not exist".

 

IMPORTANT: I noticed that it DOES work when I CHANGE an existing image, but it does NOT work for new products (and images) added. I can't imagine EasyPopulate requires each image to be added first via the clunky admin panel??

 

I've looked all over this thread and elsewhere, but can't seem to find anything that helps.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

My question is about quantity per attribute. I sell shoes and boots and am using attributes for mens size, womens size, and youth size. I would like to integrate color as well. I have QT Pro 4 installed and working, and now I just want Easy Populate to take quantity values for each attribute combonation. How would I do this? It seems like in the text file I should add a column after each v_attribute_values_price_#_# and then I'm going to have to write some php code that takes that data and places it in the products_stock table which looks like this:

products_stock_id integer(11)

products_id int(11)

products_stock_attributes varchar(255)

products_stock_quantity int(11)

 

I don't know php, but have tweaked cgi, perl, and actionscript code.

 

Any ideas/help?

 

Jake

Share this post


Link to post
Share on other sites

I just want to be sure about this.

 

What header do I need to put in my .txt file before uploading?

 

Thank you,

Michael


Michael

Share this post


Link to post
Share on other sites

Marco,

You are awesome my friend!

 

This error has been bugging me for the past two weeks. You fix gave me what I needed.

 

Now Easy Populate is working as advertised!

 

I wonder if this mod will work with other versions of MySQL? If so, it might be better to have this code instead of the the other, because it's a hair puller.

 

FYI: I'm running MySQL v4.1.6

 

Found it:

 

easypopulate.php

 

Change function "array_walk($readed, 'walk') " to: 

$teller = 1;
while($readed[$teller] != '') {
walk($readed[$teller]);
$teller++;
}

 

Must be a PHP/MySQL version problem.

 

Marco

Share this post


Link to post
Share on other sites

Well it worked like a champ until I went to add a new product then it failed.

 

Any insight would be appreciated.

 

I'm using the EP v2.6 that came with Ultrapics.

 

When I add a new product I get:

 

CK43-1253 | /vendors/c | Aztec Gold | This produ | | /vendors/c | /vendors/c | | | | | | | | | | | | | 3.4 | 0.2 | 3/31/06 0: | 1/27/06 22 | 100 | 2 | Size | 3 | Color | | Dusts | Luster Dus | | Taxable Go | Active Updated

| IT10215 | /vendors/i | India Tree | Test | | /vendors/i | /vendors/i | | | | | | | | | | | | | 5.95 | 0.3 | 3/2/06 0:0 | 1/13/06 20 | 12 | 2 | Size | 3 | Color | India Tree | Cake Essen | Sparkling | | Taxable Go | Active !New Product!

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '/vendors/india_tree/it_spk_sgr_confetti_messed.jpg", "/vendors/india_tree/it_spk' at line 28

 

INSERT INTO products ( products_image, products_image_med, products_image_lrg, products_image_sm_1, products_image_xl_1, products_image_sm_2, products_image_xl_2, products_image_sm_3, products_image_xl_3, products_image_sm_4, products_image_xl_4, products_image_sm_5, products_image_xl_5, products_image_sm_6, products_image_xl_6, products_model, products_price, products_status, products_last_modified, products_date_added, products_date_available, products_tax_class_id, products_weight, products_quantity, manufacturers_id) VALUES ( '/vendors/india_tree/it_spk_sgr_confetti_small.jpg',/vendors/india_tree/it_spk_sgr_confetti_messed.jpg", "/vendors/india_tree/it_spk_sgr_confetti_large.jpg", "", "", "", "", "", "", "", "", "", "", "", "", " 'IT10215', '5.95', '1', CURRENT_TIMESTAMP, "1/13/06 20:48", "3/2/06 0:00", '1', '0.3', '12', '14')

 

Notice the "VALUES" the first image and the second do not have the appropriate quotes around them.

 

I can't seem to figure out the proper code for this.

 

I think it's in the easypopulate.php file in between lines 1041 and 1075 but I've tried all sorts of combinations and just can't get it to work.

 

Any help would be appreciated... See lines 1041 - 1075 below....

 

$filelayout_sql = "SELECT

p.products_id as v_products_id,

p.products_model as v_products_model,

p.products_image as v_products_image,

p.products_image_med as v_products_image_med,

p.products_image_lrg as v_products_image_lrg,

p.products_image_sm_1 as v_products_image_sm_1,

p.products_image_xl_1 as v_products_image_xl_1,

p.products_image_sm_2 as v_products_image_sm_2,

p.products_image_xl_2 as v_products_image_xl_2,

p.products_image_sm_3 as v_products_image_sm_3,

p.products_image_xl_3 as v_products_image_xl_3,

p.products_image_sm_4 as v_products_image_sm_4,

p.products_image_xl_4 as v_products_image_xl_4,

p.products_image_sm_5 as v_products_image_sm_5,

p.products_image_xl_5 as v_products_image_xl_5,

p.products_image_sm_6 as v_products_image_sm_6,

p.products_image_xl_6 as v_products_image_xl_6,

p.products_price as v_products_price,

p.products_weight as v_products_weight,

p.products_date_available as v_date_avail,

p.products_date_added as v_date_added,

p.products_tax_class_id as v_tax_class_id,

p.products_quantity as v_products_quantity,

p.manufacturers_id as v_manufacturers_id,

subc.categories_id as v_categories_id,

p.products_status as v_status

FROM

".TABLE_PRODUCTS." as p,

".TABLE_CATEGORIES." as subc,

".TABLE_PRODUCTS_TO_CATEGORIES." as ptoc

WHERE

p.products_id = ptoc.products_id AND

ptoc.categories_id = subc.categories_id

";

Share this post


Link to post
Share on other sites

i was wondering if someone could help me with my problem aswell. my problem is that easypopulate gets rid of textbox fields in my product descriptions. it sees them and has them in the speadsheet, but when you upload the spreadsheet all the text boxes are removed.

 

heres what it should look like:

http://yourspiritstore.com/store/product_i...abcc705377064f4

 

but once i upload the personalization, homeroom delivery and gift note fields are gone.

 

heres what speadsheet looks like (right-click, save-as):

http://72.49.114.240/EP2006Jan27-1010.txt

 

 

any help would be great! thanks!

Share this post


Link to post
Share on other sites

Does anyone have any ideas on this issue?

 

I am having difficulty downloading a complete tab-delimited file from Easy Populate. My store has about 6500 items and only three attributes, so I'm not sure if the attributes are causing the problem or not. I'm getting the dreaded timeout error. Any suggestions? Is there a way to split the file for download like it does for upload?

Laurel

Share this post


Link to post
Share on other sites

Laurel,

Do you have access to increase your php timeout? It's usually in the /etc/php.ini directory.

 

If you have access, adjust the parameter below...

 

;;;;;;;;;;;;;;;;;;;

; Resource Limits ;

;;;;;;;;;;;;;;;;;;;

 

max_execution_time = 30 ; Maximum execution time of each script, in seconds

max_input_time = 60 ; Maximum amount of time each script may spend parsing request data

 

Look for the line

Does anyone have any ideas on this issue?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×