Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

But i can´t CHMOD configure.php to not write.

My provider auto changes it back :(

 

Go to your hosts control panel and change it from there.

 

If that does not work ask your host's help desk.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Hi guys.

New to all this so please be patient.

I have tried installing os commerce through my control panel on the justhost control panel through their fantastico software.

 

Also tried uploading through ftp.

 

But the problem is that when I go to try and do the install it just gives me this message

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

#<IfModule mod_setenvif.c>

# <IfDefine SSL>

# SetEnvIf User-Agent ".*MSIE.*" \

# nokeepalive ssl-unclean-shutdown \

# downgrade-1.0 force-response-1.0

# </IfDefine>

#</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

 

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

# php_value session.use_trans_sid 0

# php_value register_globals 1

 

Don't know what to do?

Share this post


Link to post
Share on other sites

The above problem has been fixed by the hosting company. I don't know what the fault was they didn't give any details.

Wizbit7

Share this post


Link to post
Share on other sites

Can anyone make a tutorial how to add your country zones?I think other people haven't heard that. :)

Share this post


Link to post
Share on other sites

I am looking at using the installation process that godaddy includes in their webhosting.Are their any differences in how I would install? It looks like I would just click a button

 

thanks

 

chipinaw


nubee, but eager to learn...learning but oh so painful,

 

chipinaw

Share this post


Link to post
Share on other sites

Why not just try it and play around with the results.

 

If it does not install version rc2a it might be a good idea to then do a manual install and get the latest stable version.

 

Nothing ventured nothing gained.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites
I'm posting this here so that people who need to can find a quick Installation Guide for osCommerce. It goes a bit further than the Installation Guide in the Knowledge Base.

 

---------------------------------------------------------------------

 

Here's the quick install guide.

 

1. Create a blank database via your web hosting control panel.

 

2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

 

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

5. Then go to http://www.yourdomain.com/install and begin the install procedure. Your DB Server will probably be 'localhost', your db user name and password (for mysql access) will have been provided to you by your web hosting company. The name of the database you already know - because you just set it up. Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

6. After the install create a folder called 'backups' inside the 'admin' folder (via FTP), and delete the install folder. Reset permissions on the two configure.php files.

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

Away you go!

 

Vger

 

Hi,

 

I recently downloaded the Oscommerce version 2.2 package and uploaded the entire decompressed catalog file to the root directory via FTP. I followed the next step where it say to go http://yourserver/catalog/install/ which in my case is http://www.klwholesalers.com.au/catalog/install and I had a 404 error that page doesn't exist. Please help me out! Thanks :D

Share this post


Link to post
Share on other sites
I had a 404 error that page doesn't exist.

That doesn't look like a site that wants to install osC. Are you spamming the forums here?

Share this post


Link to post
Share on other sites

If your trying to run an oscommerce store in http/yoursite/catalog then get rid if the java script in the catalog folder. If you you have the oscommerce in another folder then it will be http://yoursite.com/whatevername the folder is. If you are putting it on the root then it is http://yoursite.com/install/install.php but you can't have a java script running and another site running in the same folder.

 

Bo

Share this post


Link to post
Share on other sites

Warning: require(database/mysql.php) [function.require]: failed to open stream: No such file or directory in /home/tony/public_html/osc/includes/classes/database.php on line 33

 

Fatal error: require() [function.require]: Failed opening required 'database/mysql.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tony/public_html/osc/includes/classes/database.php on line 33

 

After install on CentOS Server I get this error.

Share this post


Link to post
Share on other sites
Warning: require(database/mysql.php) [function.require]: failed to open stream: No such file or directory in /home/tony/public_html/osc/includes/classes/database.php on line 33

 

Fatal error: require() [function.require]: Failed opening required 'database/mysql.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tony/public_html/osc/includes/classes/database.php on line 33

 

After install on CentOS Server I get this error.

 

do you actually know the different versions of osCommerce? the database class referred to is only found in osc v3.x, so ask your question the osc v3.x forum.

btw r u sure u have uploaded all files to the server?

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites
Warning: require(database/mysql.php) [function.require]: failed to open stream: No such file or directory in /home/tony/public_html/osc/includes/classes/database.php on line 33

 

Fatal error: require() [function.require]: Failed opening required 'database/mysql.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tony/public_html/osc/includes/classes/database.php on line 33

 

After install on CentOS Server I get this error.

So you tinkered with your osC3 installation because otherwise you wouldn't get this error.

That file is indeed not there because alpha 5 only supports the mysqli functions. For this the file mysqli.php is in that folder.

 

You could try a mysql class and see if that works.

Share this post


Link to post
Share on other sites
So you tinkered with your osC3 installation because otherwise you wouldn't get this error.

That file is indeed not there because alpha 5 only supports the mysqli functions. For this the file mysqli.php is in that folder.

 

You could try a mysql class and see if that works.

 

Your right I just lookedinto it and nope msqli is not on my server.

Thanks for pointing out that.

I go and check how easy it is to get mysqli into my php without messing up my whm/cpanel installation.

Otherwise I try version 2

Share this post


Link to post
Share on other sites
includes/configure.php

admin/includes/configure.php

 

Vger

I have attempted to set the permissions to both of the config files, however it continues to tell me Warning: I am able to write to the configuration file: /includes/configure.php. This is a potential security risk - please set the right user permissions on this file. and I go and reset the attriubutes but whgen I do they are back to the previous setting.

 

Any pointers?

Share this post


Link to post
Share on other sites
I have attempted to set the permissions to both of the config files, however it continues to tell me Warning: I am able to write to the configuration file: /includes/configure.php.

Did you try the instructions in this post?

Share this post


Link to post
Share on other sites

Hello, I can go to step 5 with no problem but when I do step 5 the explorer gives "HTTP 404" ERROR, what is the reason of that? I put the catolog folder to my root directory via FTP, I am trying to install by www.mydomain.com/catolog/install but it give error, someone help please. Thank you

 

 

 

 

 

 

 

I'm posting this here so that people who need to can find a quick Installation Guide for osCommerce. It goes a bit further than the Installation Guide in the Knowledge Base.

 

---------------------------------------------------------------------

 

Here's the quick install guide.

 

1. Create a blank database via your web hosting control panel.

 

2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

 

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

5. Then go to http://www.yourdomain.com/install and begin the install procedure. Your DB Server will probably be 'localhost', your db user name and password (for mysql access) will have been provided to you by your web hosting company. The name of the database you already know - because you just set it up. Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

6. After the install create a folder called 'backups' inside the 'admin' folder (via FTP), and delete the install folder. Reset permissions on the two configure.php files.

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

Away you go!

 

Vger

Share this post


Link to post
Share on other sites
Hello, I can go to step 5 with no problem but when I do step 5 the explorer gives "HTTP 404" ERROR, what is the reason of that? I put the catolog folder to my root directory via FTP, I am trying to install by www.mydomain.com/catolog/install but it give error, someone help please. Thank you

 

 

It should be 'catalog' not 'catolog'

Share this post


Link to post
Share on other sites

Hi,

I've been using osCommerce for a while and updated it about twice. Well, I got lazy for years and now I'm looking for another (major) update. Last update was oscommerce-2.2ms-060817 and now I see 22rc2. Can I just jump in or I need to pass through rc1?

 

Will "Use Search-Engine Safe URLs (still in development)" be fixed after all the updates? :) (I don't see it on the Upgrade Notes though) Thanks.

Share this post


Link to post
Share on other sites

VGER thanks for the guide.

 

I've downloaded it today and got it up and running on my Xampp server without any major issues. However there are a couple of little problems

 

1/ I've set both my configure.php files to 'read only'(400) but I'm still getting the warning - "Warning: I am able to write to the configuration file: C:/xampp/htdocs/commerce/includes/configure.php. This is a potential security risk - please set the right user permissions on this file." I think I read all the post appertaining to this and acted accordingly, but the warning persists.

 

2/ Can you tell me how to:

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

using my localhost server.

Share this post


Link to post
Share on other sites

Hi,

 

I am creating a ecommerce site and expecting 200+ connections at a single instance. What hardware configuration or server architecture should i go for.

 

thanks in advance

 

saurabh

Share this post


Link to post
Share on other sites
1/ I've set both my configure.php files to 'read only'(400) but I'm still getting the warning - "Warning: I am able to write to the configuration file: C:/xampp/htdocs/commerce/includes/configure.php.
On Windows, go to the file. Right click, choose properties. Check the checkbox for Read Only. Click Apply. Click OK.

 

You should not need to protect your admin folder on localhost, as you should have it firewalled away from external connections. However, if you really want to do so, look up htpasswd. In particular, Google seems to have good results for "password protect apache directory".


Always back up before making changes.

Share this post


Link to post
Share on other sites

Hi All,

 

I'm new to web development and have been struggling with the initial setup of my local server for the purposes of testing. I have installed Xampp and Filezilla Client, and now need to upload and install osCommerce the local server but this is where I have so far had no luck.

 

In previous posts it has been suggested that Xampp installs with PHP5 as default, but osCommerce requires PHP4, is this still the case, and if so could someone walk me through the process of changing this on the local web server as I cannot find the 'switch-php.bat' file that is referred to in the original instructions?

 

In addition to this could someone please guide me through getting the upload correct using Filezilla, as I can not figure out where exactly I need to be upload the osCommerce installation files too.

 

Many thanks for any assistance you can give.

 

Tigger

Share this post


Link to post
Share on other sites

Man I've been trying for the last several hours to install osc without success, I ve been reading and following the intrsuctions of this post but i can't just get passed the database setup screen .So ive decided to finaly post here like the usual i get this: " There was a problem connecting to the database server. The following error had occured:

 

Access denied for user 'myname_name'@'box6777.host.com' (using password: YES)"

 

Please verify the connection parameters and try again.I set up all the folders to 777 and i get a blank page then to 755 and it s working but i still get this error, the both config.php i did set them to 777and i do have a new empty database set up, some help would be nice thanks

Share this post


Link to post
Share on other sites

×