Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

CHMOD works with Linux/Unix servers. It looks like you are on a Windows based server.

Try to make the file(s) read-only.

 

 

I saw another post that said you can't set permissions on a Windows server, I called GoDaddy, they confirmed, switched me to a linux server. Reinstalled, Perfect.

 

Thanks.


My experience relates to osCommerce Online Merchant v2.2 RC2

Share this post


Link to post
Share on other sites

After 65 pages of replies and what not I'm still in the dark, sorry. But so far what I have gathered about my error msg:

 

The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results.

 

Is that i need to change my .htaccess file, for I do not have the php.ini file. Of which the contents are:

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

#

# This is

 

used with Apache WebServers

#

# For this to work, you must

 

include the parameter 'Options' to

# the AllowOverride

 

configuration

#

# Example:

#

# <Directory

 

"/usr/local/apache/htdocs">

# AllowOverride Options

#

 

</Directory>

#

# 'All' with also work. (This configuration is

 

in the

# apache/conf/httpd.conf file)

 

# The following makes

 

adjustments to the SSL protocol for Internet

# Explorer

 

browsers

 

#<IfModule mod_setenvif.c>

# <IfDefine SSL>

#

 

SetEnvIf User-Agent ".*MSIE.*" \

# nokeepalive

 

ssl-unclean-shutdown \

# downgrade-1.0

 

force-response-1.0

# </IfDefine>

#</IfModule>

 

# If Search

 

Engine Friendly URLs do not work, try enabling the

# following

 

Apache configuration parameter

 

# AcceptPathInfo On

 

# Fix

 

certain PHP values

# (commented out by default to prevent

 

errors occuring on certain

# servers)

 

# php_value

 

session.use_trans_sid 0

# php_value register_globals 1

#

 

I have read a bit on php forum and found that I should add:

 

php_value register_globals

 

And if this is true, which I am not sure yet, for I have tried to add it, and nothing accurs differently. I am not sure where or how exactly to add it. I was thinking:

 

php_value register_globals 1

#

 

at the end of the file.

 

Still perplexed, any help would be wonderfull. Thank you in advance!

 

Cheers,

 

Chad

Share this post


Link to post
Share on other sites
I'm posting this here so that people who need to can find a quick Installation Guide for osCommerce. It goes a bit further than the Installation Guide in the Knowledge Base.

 

---------------------------------------------------------------------

 

Here's the quick install guide.

 

1. Create a blank database via your web hosting control panel.

 

2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

 

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

5. Then go to http://www.yourdomain.com/install and begin the install procedure. Your DB Server will probably be 'localhost', your db user name and password (for mysql access) will have been provided to you by your web hosting company. The name of the database you already know - because you just set it up. Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

6. After the install create a folder called 'backups' inside the 'admin' folder (via FTP), and delete the install folder. Reset permissions on the two configure.php files.

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

Away you go!

 

Vger

Share this post


Link to post
Share on other sites

i m having problem wid the installation...................as to add the root directory to my site via FTP...................i m confused.......can u pls help me out or elaborate on this.........

Share this post


Link to post
Share on other sites

Hello friends,

 

I am what Setup error when i access my catalog, but not my administration console? <_<

 

Many thanks for your future response

 

Sam

Share this post


Link to post
Share on other sites
I'm posting this here so that people who need to can find a quick Installation Guide for osCommerce. It goes a bit further than the Installation Guide in the Knowledge Base.

 

---------------------------------------------------------------------

 

Here's the quick install guide.

 

1. Create a blank database via your web hosting control panel.

 

2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

 

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

5. Then go to http://www.yourdomain.com/install and begin the install procedure. Your DB Server will probably be 'localhost', your db user name and password (for mysql access) will have been provided to you by your web hosting company. The name of the database you already know - because you just set it up. Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

6. After the install create a folder called 'backups' inside the 'admin' folder (via FTP), and delete the install folder. Reset permissions on the two configure.php files.

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

Away you go!

 

Vger

THHAAAANNNKKK YOU!

 

FROM THIS POINT THERE IS A "DUMMY SITE" OF VARIOUS COMPUTER DVD COMPONENTS. WHAT DO I DO FROM HERE? TEMPLATE IF SO WHERE IF NOT HMMM?


I appreciate your help!!

Share this post


Link to post
Share on other sites

You could go to http://www.yourdomain.com/catalog/admin and configure your shop.

 

My advice is read the documentation that comes with the download of your version of osc or if it is not there download a copy from this site and read that

 

Then read the knowledgebase or download a copy once again from this site

 

http://www.oscommerce.com/solutions/documentation

 

A roadmap for newbies by lindsayanng gives a good overview.

 

http://forums.oscommerce.com/index.php?sho...=307356&hl=

 

Also read the first 2 threads in the installation forum, they cover how to do loads of basic things.

 

http://forums.oscommerce.com/index.php?showforum=1

 

Try these 3 threads as well

 

http://forums.oscommerce.com/index.php?sho...307356&st=0

 

http://forums.oscommerce.com/index.php?sho...p;#entry1366452

 

http://www.oscommerce.com/ext/update-20060817.txt

 

Finally use the search term

 

site:forums.oscommerce.com xxxxxxxxxxxxxxx

 

in google whenever you get stuck.


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

hai, i would like to know how to move the existing web shop (os commerce) to new hosting? any guide? thanks

Share this post


Link to post
Share on other sites

After installing I encountered this problem:

 

Finished!

 

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in /home/bloomang/public_html/_dud_/admin/index.php on line 13

 

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in /home/bloomang/public_html/_dud_/admin/index.php on line 13

 

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/bloomang/public_html/_dud_/admin/index.php on line 13

 

 

What's the problem?!

help me ...pease ㅜㅜ

Share this post


Link to post
Share on other sites
After installing I encountered this problem:

 

Finished!

 

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in /home/bloomang/public_html/_dud_/admin/index.php on line 13

 

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in /home/bloomang/public_html/_dud_/admin/index.php on line 13

 

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/bloomang/public_html/_dud_/admin/index.php on line 13

 

 

What's the problem?!

help me ...pease ㅜㅜ

Check if you have application_top.php in the includes folder. seems its not there.

Share this post


Link to post
Share on other sites

Hi All, i've been told i may have config file error everything works fine on our site but for one contrib "googlesitemap" below are my two config files can anyone point me in the right direction.

 

Many Thanks

 

 

 

 

Shop admin
// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://doorsteppetfood.co.uk/'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://doorsteppetfood.co.uk');

define('HTTPS_CATALOG_SERVER', '/');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/hsphere/local/home/doorstep/doorsteppetfood.co.uk/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/hsphere/local/home/doorstep/doorsteppetfood.co.uk/admin/'); // absolute path required

define('DIR_WS_CATALOG', ''); // absolute path required

define('DIR_FS_CATALOG', '/hsphere/local/home/doorstep/doorsteppetfood.co.uk/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

Admin Config

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://doorsteppetfood.co.uk'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://doorsteppetfood.co.uk');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/hsphere/local/home/doorstep/doorsteppetfood.co.uk/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/office/'); // absolute path required

define('DIR_FS_ADMIN', '/hsphere/local/home/doorstep/doorsteppetfood.co.uk/office/'); // absolute pate required

define('DIR_WS_CATALOG', '/'); // absolute path required

define('DIR_FS_CATALOG', '/hsphere/local/home/doorstep/doorsteppetfood.co.uk/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

Share this post


Link to post
Share on other sites

THANK YOU THANK YOU THANK YOU SOOOO MUCH!!!

 

First time was a success with this guide !! :lol:

Share this post


Link to post
Share on other sites

Hi, thank you very much for yor help.

I have another question.

Im a beginer and I wonder how to get everything from my site to my PC.

I try to, but I have an error.

I download the public_htm carpet and I dump the database.

The error in my localhost is:

 

Warning: mysql_connect() [function.mysql-connect]: Acceso negado para usuario: 'v0070290_oc'@'localhost' (Usando clave: SI) in C:\Archivos de programa\EasyPHP 3.0\www\catalog\includes\functions\database.php on line 19

Unable to connect to database server!

 

Thank

olivia

 

---------------------------------------------------------------------

I'm posting this here so that people who need to can find a quick Installation Guide for osCommerce. It goes a bit further than the Installation Guide in the Knowledge Base.

 

Here's the quick install guide.

 

1. Create a blank database via your web hosting control panel.

 

2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

 

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

5. Then go to http://www.yourdomain.com/install and begin the install procedure. Your DB Server will probably be 'localhost', your db user name and password (for mysql access) will have been provided to you by your web hosting company. The name of the database you already know - because you just set it up. Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

6. After the install create a folder called 'backups' inside the 'admin' folder (via FTP), and delete the install folder. Reset permissions on the two configure.php files.

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

Away you go!

 

Vger

Share this post


Link to post
Share on other sites

Hi guys

 

I am new to Osc but luckily managed to install it OK a couple of weeks ago. I installed it to the root folder - www.mydomain.com. Then I made a welcome page for the shop and called my hosting company to ask how to add it to my store. The guy told me to rename my Osc shop to "store" and have the welcome page at www.mydomain.com and he told me how to do it. That seems to have created a problem however, because now when I want to edit the php files within OSc through the admin page it's just telling me that the directory doesn't exist because it's still set to www.mydomain.com. Is there a way to change the directory path within Osc (to www.mydomain.com/store) or will I have to reinstall it in order to get it outside of the root folder?

 

Any help will be greatly appreciated.

 

Thank you

Share this post


Link to post
Share on other sites

Ok, I'm stumped. I did a new install, followed the directions, reset the permissions on the configure files and folders per the quick install guide and the documentation (setting the configure files to 444), and I'm still getting an error message about a security risk. I don't know what else I can reset. And when I tried to go the admin page, it didn't ask me for a password -- it just told me I didn't have permission. I had set up a username and password, so what was that about? I must have done something wrong, but I don't know what. Can anyone help?

 

Thanks,

 

Riin

Share this post


Link to post
Share on other sites

Hello osCommerce!

 

Another newb here. I have a problem that I have not seen listed in here, but then, I only read about 45 pages of these 110. Perhaps I could get some guidance?

 

I am trying to create a new website on Inmotion hosting. The difficulty is that the website I'm rebuilding is currently hosted on Go-Daddy under the same domain name. We would like to keep the current domain name, which is why this is the case. The domain has not yet been pointed to Inmotion. I'm finding that most things won't work. Email is an obvious issue that won't work. I also can't publish the website that I have built on Inmotion, not even to the temporary URL they provided. Now, I realize that these issues are not relevant here, but I want to figure out if I have done all I can do to install osCommerce to the site.

 

I have followed the installation instructions, but since the website is not operating, I can't go to the /install directory, nor can I get things to work on Inmotion. As such, I can't really verify that osCommerce has loaded properly or view anything. I have the merchant admin tool that I can edit, but it's completely separate from Inmotion at this point. I haven't uploaded anything into the FTP directories other than the Catalog folder, but that shouldn't matter from what I'm reading.

 

Am I completely SOL until I redirect the domain to Inmotion from Go-Daddy or is there something I can do to test out the functions prior to going live?

 

Thanks for any help you can offer.

Share this post


Link to post
Share on other sites

Hello im newhere too, well i followed all the steps and its says i installed it but first when im installing it this appears:

 

New Installation

 

Warning: realpath() has been disabled for security reasons in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/includes/functions/general.php on line 23

 

Warning: realpath() has been disabled for security reasons in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/includes/functions/general.php on line 23

 

Warning: realpath() has been disabled for security reasons in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/includes/functions/general.php on line 23

 

Warning: realpath() has been disabled for security reasons in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/includes/functions/general.php on line 23

 

The webserver environment has been verified to proceed with a successful installation and configuration of your online store.

 

Please continue to start the installation procedure.

 

Whats wrong.....and when i finishe installing it this appears:

 

Finished!

 

Warning: fopen() [function.fopen]: SAFE MODE Restriction in effect. The script whose uid is 104823290 is not allowed to access / owned by uid 0 in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/templates/pages/install_4.php on line 116

 

Warning: fopen(/includes/configure.php) [function.fopen]: failed to open stream: No such file or directory in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/templates/pages/install_4.php on line 116

 

Warning: fputs(): supplied argument is not a valid stream resource in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/templates/pages/install_4.php on line 117

 

Warning: fclose(): supplied argument is not a valid stream resource in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/templates/pages/install_4.php on line 118

 

Warning: fopen() [function.fopen]: SAFE MODE Restriction in effect. The script whose uid is 104823290 is not allowed to access / owned by uid 0 in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/templates/pages/install_4.php on line 152

 

Warning: fopen(/admin/includes/configure.php) [function.fopen]: failed to open stream: No such file or directory in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/templates/pages/install_4.php on line 152

 

Warning: fputs(): supplied argument is not a valid stream resource in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/templates/pages/install_4.php on line 153

 

Warning: fclose(): supplied argument is not a valid stream resource in /data/members/free/tripod/es/e/l/r/elreybrujodeangmar/htdocs/install/templates/pages/install_4.php on line 154

 

The installation and configuration was successful!

Share this post


Link to post
Share on other sites
Go to http://www.apachefriends.org/en and download XAMPP to your computer. It's a 1-click install, and includes all you need, Apache server, PHP 4 and 5, Open SSL, Mail Server, FileZilla etc.

 

Once you've done the XAMPP installation then you can use the Quick Install Guide to get your local testing site up and running.

 

Be aware that XAMPP uses php5 by default, but comes bundled with php4 also. Go to http://localhost and into your XAMPP control panel. Then click on the XAMPP icon to shut down Apache, click on the switch-php.bat link and enter 4 when the terminal window pops up. Then restart Apache using php4.

 

Vger

 

I am new to this, and I am very grateful for all the help available. I have been following this advice, and I seem to be stuck. Either I have misread or missed something, but where do I find the switch-php.bat link

Thanks

 

Jim

Share this post


Link to post
Share on other sites
...where do I find the switch-php.bat link...

 

it is directly under the XAMPP folder but given that php has phased out php4 so the most recent XAMPP may no longer have this file.

 

Ken


commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Share this post


Link to post
Share on other sites

Hello

 

I am reinstalling the os commerce and now I have a problem here - when I delete English and leave only Lithuanian, I don't see the categories any more. They show the categories at the store, but in the admin shell it shows that I don't have anything for sale. What's wrong?

Share this post


Link to post
Share on other sites

newbie here. done everything but got this message from my hosted server.

 

Internal Server Error

 

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, webmaster@mypinoyshopping.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at www.mypinoyshopping.com Port 80

Share this post


Link to post
Share on other sites

Where do i find this?

Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

And i can´t do this:

Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel

 

My problem is this;

httpd.www/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

But i can´t CHMOD configure.php to not write.

My provider auto changes it back :(

Share this post


Link to post
Share on other sites

Hi Folks,

 

I installed as per the Quick Install Guide and when I try to access .../catalog, it gives the following errors:

 

Warning: main(includes/application_top.php) [function.main]: failed to open stream: Permission denied in /home/pforum/public_html/catalog/index.php on line 13

 

Warning: main(includes/application_top.php) [function.main]: failed to open stream: Permission denied in /home/pforum/public_html/catalog/index.php on line 13

 

Fatal error: main() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/pforum/public_html/catalog/index.php on line 13

 

The admin login works 100%.

 

Please help.

 

Many thanks,

Marc

 

p.s. Know someone posted about this previously, but from what I see, he/she never got a solution.

Share this post


Link to post
Share on other sites

×