Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

I figured that one out. It was the issue with /tmp needing to be changed just tmp.

 

I do have a remaining issue though. I can get into Administration tools no problem now, but when I try to go to the catalog, I get the following:

 

Fatal error: Call to a member function add_current_page() on a non-object in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/application_top.php on line 312

 

Anyone know what I need to do to get that error cleared up?

 

I just discovered there is an error coming up before this one:

Parse error: syntax error, unexpected T_STRING in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/languages/english/index.php on line 13

 

Thanks in advance.

Share this post


Link to post
Share on other sites
I figured that one out. It was the issue with /tmp needing to be changed just tmp.

 

I do have a remaining issue though. I can get into Administration tools no problem now, but when I try to go to the catalog, I get the following:

 

Fatal error: Call to a member function add_current_page() on a non-object in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/application_top.php on line 312

 

Anyone know what I need to do to get that error cleared up?

 

I just discovered there is an error coming up before this one:

Parse error: syntax error, unexpected T_STRING in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/languages/english/index.php on line 13

 

Thanks in advance.

ROFL. I just figured it out. Apparently I had an ' in a possessive word that confused the code. I reworded to drop the ' and it is all good. Thanks anyway. :)

Share this post


Link to post
Share on other sites

Oscommerce Information

Oscommerce Version 2.2ms2-060817

Oscommerce allocated space (MB) 8.0

Database Name datab

Database User Name datab

Directory Name osCommerce

Admin Name (provided at the time of installtion)

URL http://trincana.com/osCommerce/index.php

Admin URL http://trincana.com/osCommerce/admin/index.php

 

Could you please tell me what the log in is for admin/index/php

 

the pop up box Authentication required with user name and passwrod

 

I tried all that i know and cannot log in please tell me the exact steps

 

My pass word is xxxxxx

username daxxxx

database name xxxxxx

 

with this info please tell me how to log in.

Sorry but i have to ask checked knowledge base but could not find the answer,

Share this post


Link to post
Share on other sites

There is no 'admin' folder login for osCommerce 2.2 MS2 (060817), unless you make that folder Password Protected yourself.

 

If this was an automated installation then try using your hosting User Name for both User Name and Password for access to the admin folder.

 

Vger

Share this post


Link to post
Share on other sites

Hello,

I have problem with warnigs.

 

How can I change permissions on 777, when i use windows, not Linux ???

 

Please, can you help me ?

 

THANK YOU VERY MUCH !!!

 

Peter

 

----------------------------------------------------

Finished!

 

Warning: fopen(W:/domains/www.gugu.sk/public/www_root/catalog//includes/configure.php) [function.fopen]: failed to open stream: Permission denied in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 116

 

Warning: fputs(): supplied argument is not a valid stream resource in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 117

 

Warning: fclose(): supplied argument is not a valid stream resource in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 118

 

Warning: fopen(W:/domains/www.gugu.sk/public/www_root/catalog//admin/includes/configure.php) [function.fopen]: failed to open stream: Permission denied in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 152

 

Warning: fputs(): supplied argument is not a valid stream resource in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 153

 

Warning: fclose(): supplied argument is not a valid stream resource in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 154

 

The installation and configuration was successful!

Share this post


Link to post
Share on other sites

The Windows equivelant of 777 is Read,Write,Execute for each group (3 in total). Provided you can make the two configure.php files Writeable you should be able to complete the install correctly.

 

Vger

Share this post


Link to post
Share on other sites
Hello,

I have problem with warnigs.

 

How can I change permissions on 777, when i use windows, not Linux ???

 

Please, can you help me ?

 

THANK YOU VERY MUCH !!!

 

Peter

 

----------------------------------------------------

Finished!

 

Warning: fopen(W:/domains/www.gugu.sk/public/www_root/catalog//includes/configure.php) [function.fopen]: failed to open stream: Permission denied in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 116

 

Warning: fputs(): supplied argument is not a valid stream resource in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 117

 

Warning: fclose(): supplied argument is not a valid stream resource in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 118

 

Warning: fopen(W:/domains/www.gugu.sk/public/www_root/catalog//admin/includes/configure.php) [function.fopen]: failed to open stream: Permission denied in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 152

 

Warning: fputs(): supplied argument is not a valid stream resource in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 153

 

Warning: fclose(): supplied argument is not a valid stream resource in W:\domains\www.gugu.sk\public\www_root\catalog\install\templates\pages\install_4.php on line 154

 

The installation and configuration was successful!

In windows just right click on the file, hit the properties at the lower end and you will see three tabs ( General, Security,Summary) You can set the permissions from there.

Share this post


Link to post
Share on other sites

Hi, I'm a total newbie to OS Commerce and need some advice please. I've installed the catalogue and database on my domain and everything seems to be running except that at the top of the screen I have this:

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 636831 is not allowed to access /tmp owned by uid 0 in /customers/nibabo.com/nibabo.com/httpd.www/admin/includes/functions/sessions.php on line 165

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /customers/nibabo.com/nibabo.com/httpd.www/admin/includes/functions/sessions.php:165) in /customers/nibabo.com/nibabo.com/httpd.www/admin/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /customers/nibabo.com/nibabo.com/httpd.www/admin/includes/functions/sessions.php:165) in /customers/nibabo.com/nibabo.com/httpd.www/admin/includes/functions/sessions.php on line 102

 

Warning: Cannot modify header information - headers already sent by (output started at /customers/nibabo.com/nibabo.com/httpd.www/admin/includes/functions/sessions.php:165) in /customers/nibabo.com/nibabo.com/httpd.www/admin/includes/functions/general.php on line 22

 

Could someone please tell me what the problem is and, how do I actually manage my shop as in placing goods in it for sale etc?

 

Thanks in advance for any forthcoming help.

Share this post


Link to post
Share on other sites
Thanks in advance for any forthcoming help

 

Look through the last few pages of this forum thread. I have answered that question so many times on this forum.

 

Vger

Share this post


Link to post
Share on other sites
Look through the last few pages of this forum thread. I have answered that question so many times on this forum.

 

Vger

 

Thanks for that I found the info a few pages back. Since then I have tried to install a new template but when logging into the install folder I get this message:

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

How do I cure this please as I can't find the file php.ini

Share this post


Link to post
Share on other sites

"then upload the whole of the catalog folder to the root directory of your website via FTP. "

How do I do this function now that I have extracted the files?

Share this post


Link to post
Share on other sites

You install an FTP programme on your PC (WS FTP Home or Pro, FileZilla etc), learn how to use FTP, and then upload the files/folders.

 

Vger

Share this post


Link to post
Share on other sites

Hello,

i have problem when i trying open administration tools page :(

 

Warning: require(includes/classes/navigation_history.php) [function.require]: failed to open stream: No such file or directory in W:\domains\www.gugu.sk\public\www_root\catalog\admin\includes\application_top.php on line 126

 

Fatal error: require() [function.require]: Failed opening required 'includes/classes/navigation_history.php' (include_path='.') in W:\domains\www.gugu.sk\public\www_root\catalog\admin\includes\application_top.php on line 126

 

 

Is there anybody who can help me ? I was searching whatever but without result :(

 

Thank you for ideas!

 

Peter

Share this post


Link to post
Share on other sites

Check the settings in your admin/includes/configure.php file against those in your includes/configure.php file. It sounds as though the admin configure.php file may be incorrect.

 

Vger

Share this post


Link to post
Share on other sites
Check the settings in your admin/includes/configure.php file against those in your includes/configure.php file. It sounds as though the admin configure.php file may be incorrect.

 

Vger

 

I checked both configure.php files (all the settings), but i dont know what can be wrong :(

 

Do you have any next idea ?

 

Thank you!

 

Peter

Share this post


Link to post
Share on other sites

How do I make my admin area secure? have uploaded a template but anyone can access the admin area at the moment?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

1. FTP to your website and "Rename" the admin folder to something unique (not admin2 or new admin).

 

2. In admin/includes/configure.php change the two references to /admin/ to /new_name/

 

3. Go to your web hosting control panel and use the Directory or Password Protection link to protect the newly renamed admin folder.

 

Vger

Share this post


Link to post
Share on other sites

Hi Vgor

 

On the page http://www.4girlzshop.co.uk/index.php the following error message is displayed at the top of the page in red:

 

"Warning: I am able to write to the configuration file: /kunden/homepages/41/d231682781/htdocs/4girlzshop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file"

 

I have accessed my FTP to change the permissions to admin/configure.php and includes/configure.php to 777

 

Yet I have had no luck with resolving this error message.

 

I am still able to modify the layout... any ideas?

 

Cheers

Share this post


Link to post
Share on other sites
Hi Vgor

 

On the page http://www.4girlzshop.co.uk/index.php the following error message is displayed at the top of the page in red:

 

"Warning: I am able to write to the configuration file: /kunden/homepages/41/d231682781/htdocs/4girlzshop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file"

 

I have accessed my FTP to change the permissions to admin/configure.php and includes/configure.php to 777

 

Yet I have had no luck with resolving this error message.

 

I am still able to modify the layout... any ideas?

 

Cheers

 

I beleive you meant admin/includes/configure.php and includes/configure.php. These files should only be set to 777 or 775 during the initial setup phase of osCommerce. Afterwards, you need to restrict the permissions of these files. Try 644 instead and the error should go away.

 

Note: If you can't use FTP to change your permissions, login into your cPanel account and use the file manager to change the permission there, that is if you site is hosted on an Apache server.

 

Hope that helped,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I beleive you meant admin/includes/configure.php and includes/configure.php. These files should only be set to 777 or 775 during the initial setup phase of osCommerce. Afterwards, you need to restrict the permissions of these files. Try 644 instead and the error should go away.

 

Note: If you can't use FTP to change your permissions, login into your cPanel account and use the file manager to change the permission there, that is if you site is hosted on an Apache server.

 

Hope that helped,

 

Hi and thanks. Yep those are the files I meant. I'm using one&one as my host (if that helps). I didn't change the permission during installation! Oops.. so would it be an idea to wipe the entire site and begin the installation again?

 

Cheers and many thanks

Share this post


Link to post
Share on other sites
1. FTP to your website and "Rename" the admin folder to something unique (not admin2 or new admin).

 

2. In admin/includes/configure.php change the two references to /admin/ to /new_name/

 

3. Go to your web hosting control panel and use the Directory or Password Protection link to protect the newly renamed admin folder.

 

Vger

 

 

Uh! I did this...

 

Now when I go to my ex-admin panel I have: "Unable to connect to database server!" :blink:

 

Sorry, I'm newby. Any help?

Share this post


Link to post
Share on other sites

Check the database settings at the bottom of the ex-admin/includes/configure.php file against those which you have in the includes/configure.php file.

 

Vger

Share this post


Link to post
Share on other sites

Hi,

 

We have just installed osCommerce on our domain and keep encountering a slight problem...

 

on: http://www.4girlzshop.co.uk/index.php, the following error message is displayed on the top of the screen in red:

 

"Warning: I am able to write to the configuration file: /kunden/homepages/41/d231682781/htdocs/4girlzshop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file."

 

I have changed the permissions in includes/configure.php and admin/includes/configure.php both to 644 - but nothing really seems to make an effect.

 

When installing the osCommerce we did not actually change any of the permissions, so we are wondering that maybe we should delete all the files on our domain, upload the installation files again, and start changing the permissions before the installation takes place. Would this make a difference and would this effect my database and account if I was to do this?

 

Many thanks

Share this post


Link to post
Share on other sites

No need to reinstall. 644 is the normal setting for all files, and sometimes also the setting for the two configure.php file - but more normally the settings which will remove that warning are either 444 or 400.

 

Vger

Share this post


Link to post
Share on other sites

×