Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

using password: NO

 

MySQL requires a password in order to connect. It has to be the password assigned to that database when you created it.

 

Vger

Share this post


Link to post
Share on other sites

On installation, i got the following errors.

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 7679 is not allowed to access owned by uid 0 in /www/oxyhost.com/e/m/i/emixx/htdocs/catalog/includes/functions/sessions.php on line 169

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /www/oxyhost.com/e/m/i/emixx/htdocs/catalog/includes/functions/sessions.php:169) in /www/oxyhost.com/e/m/i/emixx/htdocs/catalog/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /www/oxyhost.com/e/m/i/emixx/htdocs/catalog/includes/functions/sessions.php:169) in /www/oxyhost.com/e/m/i/emixx/htdocs/catalog/includes/functions/sessions.php on line 102

 

 

How do I solve them?

 

Thanks.

Share this post


Link to post
Share on other sites
On installation, i got the following errors.

 

How do I solve them?

It doesn't hurt to search for those errors. I suggest you use Google:

safe mode /tmp sessions uid site:forums.oscommerce.com

 

This is the first search result.

Share this post


Link to post
Share on other sites

Ok, I have read so much, my head hurts.

 

I am having the standard server configuration problem with a bit of a twist.

 

I have entered, my domain name, localhost and get this error message:

 

Can't connect to MySQL server on 'www.shackscs.com' (10061)

I am able to log into the database with the same information that I am supplying the server setup page.

 

And if I put in the IP address provided by phpadmin (**.*.**.***) in, I get the error message:

 

Client does not support authentication protocol requested by server; consider upgrading MySQL client

 

Please verify the connection parameters and try again.

 

I see I may have two choices:

 

Have my hosting company update the version of MySql.

Switch to another database. I have acess to Access SQL and another that I forget.

 

My hosting company is Go Daddy.

Share this post


Link to post
Share on other sites

I forgot to mention that I have MySql 4.1 installed.

 

Ok, I have read so much, my head hurts.

 

I am having the standard server configuration problem with a bit of a twist.

 

I have entered, my domain name, localhost and get this error message:

 

Can't connect to MySQL server on 'www.shackscs.com' (10061)

I am able to log into the database with the same information that I am supplying the server setup page.

 

And if I put in the IP address provided by phpadmin (**.*.**.***) in, I get the error message:

 

Client does not support authentication protocol requested by server; consider upgrading MySQL client

 

Please verify the connection parameters and try again.

 

I see I may have two choices:

 

Have my hosting company update the version of MySql.

Switch to another database. I have acess to Access SQL and another that I forget.

 

My hosting company is Go Daddy.

Share this post


Link to post
Share on other sites

Have you tried localhost in place of the IP address?


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

Yup.

Still no go.

 

VGER, I will give your link a shot to see if that helps. I have never used Mysql before so I am not sure what direction to go in if I need to reconfigure something.

 

I will post my progress.

 

 

Thanks

 

Have you tried localhost in place of the IP address?

Share this post


Link to post
Share on other sites

I tried the following and got this error message:

 

Error

SQL query:

 

SET PASSWORD FOR Shackscs@10.8.11.154 = OLD_PASSWORD(Pleco123)

 

MySQL said:

 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Pleco123)' at line 1 `

 

I don't know MySql so I might need a bit of help with the syntax.

 

Any takers?

 

Yup.

Still no go.

 

VGER, I will give your link a shot to see if that helps. I have never used Mysql before so I am not sure what direction to go in if I need to reconfigure something.

 

I will post my progress.

 

 

Thanks

Share this post


Link to post
Share on other sites

Hi, I followed the instructions for a clean istall a few minutes ago and everythings works perfect, the only thing is that the Admin Interface looks a little strange... check it

admintk8.th.jpg

Did I made something wrong? :blink:

Thanks for the help :D

Share this post


Link to post
Share on other sites

Just out of curiousity, I am installing this on Windows Server platform.

 

Am I better of with Linux servers?

Share this post


Link to post
Share on other sites

Sorry folks, but my broadband connection is down. It's just too painful to reply to posts here with dial-up, so you'll have to talk amongst yourselves until my broadband is back onine.

 

Vger

Share this post


Link to post
Share on other sites

Apparently GoDaddy has a one click install for the OSCommerce package with thier Linux hosting. I purchased that today and will give this a shot tomorrow.

Share this post


Link to post
Share on other sites
Hi, I followed the instructions for a clean istall a few minutes ago and everythings works perfect, the only thing is that the Admin Interface looks a little strange... check it

admintk8.th.jpg

Did I made something wrong? :blink:

Thanks for the help :D

 

Check apache error log, I found there that problem may be .htaccess in admin/includes/.htaccess . Im not sure if its safe but I try'ed to comment all in there and problem was solved, if some body know something about that please tell us if its safe to do like that, or should we just modify it some how.

 

Thanks,

Reino Pesonen

Share this post


Link to post
Share on other sites

I got this up and running with but a few clicks and information.

If you use GoDaddy's install be sure to create a database before hand. The directions do not tell you that.

 

Check apache error log, I found there that problem may be .htaccess in admin/includes/.htaccess . Im not sure if its safe but I try'ed to comment all in there and problem was solved, if some body know something about that please tell us if its safe to do like that, or should we just modify it some how.

 

Thanks,

Reino Pesonen

Share this post


Link to post
Share on other sites
Check apache error log, I found there that problem may be .htaccess in admin/includes/.htaccess . Im not sure if its safe but I try'ed to comment all in there and problem was solved, if some body know something about that please tell us if its safe to do like that, or should we just modify it some how.

 

Thanks,

Reino Pesonen

 

I've got it now! Just add modify AccessFileName in Apache2.conf to look like this:

AccessFileName .htaccess

 

<Directory "/usr/local/apache/htdocs">

AllowOverride Limit

</Directory>

 

That work'd for me.

 

-reino

Share this post


Link to post
Share on other sites

Hi

 

I recently installed the OSCommerce and all worked fine. I have since done some work on the site and populated the database.

 

No I have noticed that when running the installation, I entered the web url as domain.com instead of www.domain.com....

 

So now the base URL of my site is domain.com.

 

I would like to change this to www.domain.com

 

If I re-run the install to change this URL, does it override all of my work or is there any easier way of fixing this?

 

any help appreciated!

 

Thanks

Glenn

Share this post


Link to post
Share on other sites

Do not reinstall, just edit the includes/configure.php and admin/includes/configure.php files.

 

Vger

Share this post


Link to post
Share on other sites
Do not reinstall, just edit the includes/configure.php and admin/includes/configure.php files.

 

Vger

 

 

Hi Vger

 

Thanks for your reply.

 

In this file: includes/configure.php

 

I have edited the following 2 lines:

define('HTTP_SERVER', 'http://www.mydomain.ie/catalog'); // eg, http://localhost - should not be empty for productive servers

define('DIR_WS_HTTP_CATALOG', 'http://www.mydomain.ie/catalog');

 

 

In this file: admin/includes/configure.php

 

I have edited the following 2 lines:

define('HTTP_SERVER', 'http://www.mydomain.ie'); // eg, http://localhost or - https://localhost should not be NULL for productive servers

define('HTTP_CATALOG_SERVER', 'http://www.mydomain.ie');

 

 

This hasn't worked for me... The main site and all links still point to the url without the WWW. Any idea what I have done wrong?

 

Thanks for your help.

 

Glenn

Share this post


Link to post
Share on other sites

When you edit the configure.php files and before you upload those edited files you will probably need to relax permissions on the existing files to allow them to be overwritten by the new files. Otherwise you think you have overwritten the old versions when in actual fact you have not. Afterwards you need to restore the Read Only permissions on the configure.php files.

 

If you have done this and the files have been changed but it's still not working - then look in both includes/local/ folders to see if there are any alternative configure.php files in the 'local' folders - and if you find any then rename or delete them.

 

Vger

Share this post


Link to post
Share on other sites

Dear Vger

 

I'm new in this site. I would like to install OSCommerce on a Windows Server 2003. I have a hard time understanding this Installation Guide that you posted. I'm not a Programmer or an IT so can you please help me as to how can i install this program in my server.

 

Please feel free to e - mail me or reply in this forum. Please. Thank you very much

Share this post


Link to post
Share on other sites

The "Quick Install Guide" is as simple as it gets I'm afraid.

 

Vger

Share this post


Link to post
Share on other sites

Hey Vger,

 

I have completed the installation. I am getting no warnings with a colored background but I am getting the following warnings at the top with no colored background:

 

The screen comes up clean with the two links: Catalog and Administration Tool

 

When I click on Catalog, I get the following warnings:

 

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 1001 is not allowed to access /tmp owned by uid 0 in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php on line 169

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php:169) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php:169) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php on line 102

 

When I click the Adminstration tool, I get the following warnings:

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 1001 is not allowed to access /tmp owned by uid 0 in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php on line 165

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php:165) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php:165) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php on line 102

 

Warning: Cannot modify header information - headers already sent by (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php:165) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/general.php on line 22

 

If these are not issues that would halt my store from working, how do I keep them from coming up. If they are actual problems, how do I fix them?

 

Thanks in advance for your help.

Share this post


Link to post
Share on other sites

Duplicate post --> http://forums.oscommerce.com/index.php?showtopic=310683

Hey Vger,

 

I have completed the installation. I am getting no warnings with a colored background but I am getting the following warnings at the top with no colored background:

 

The screen comes up clean with the two links: Catalog and Administration Tool

 

When I click on Catalog, I get the following warnings:

 

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 1001 is not allowed to access /tmp owned by uid 0 in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php on line 169

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php:169) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php:169) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/includes/functions/sessions.php on line 102

 

When I click the Adminstration tool, I get the following warnings:

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 1001 is not allowed to access /tmp owned by uid 0 in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php on line 165

 

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php:165) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php on line 102

 

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php:165) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php on line 102

 

Warning: Cannot modify header information - headers already sent by (output started at /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/sessions.php:165) in /hosted/domains/a/u/authors-pad.biz/public_html/Store/oscommerce-2.2rc2a/catalog/admin/includes/functions/general.php on line 22

 

If these are not issues that would halt my store from working, how do I keep them from coming up. If they are actual problems, how do I fix them?

 

Thanks in advance for your help.

Share this post


Link to post
Share on other sites

×