Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

That error means that the install did not write data to the admin/includes/configure.php file - so you'll have to enter the data yourself. Use the includes/configure.php file as a guide, but be careful because they are different.

 

Vger

Share this post


Link to post
Share on other sites

define('DB_SERVER', 'p50mysql115.secureserver.net'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'username');

define('DB_SERVER_PASSWORD', 'password');

define('DB_DATABASE', 'databasename');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', '');

 

I did this in includes/configure.php and still getting the same error. do I have to make changes somewhere else also?

Share this post


Link to post
Share on other sites

define('DB_SERVER', 'p50mysql115.secureserver.net'); <--- Still NOT correct

 

The database server information will not show on the url (locator) bar.

 

You'll see it once you've logged in to phpMyAdmin AND chosen your database.

On the top of the page below the locator bar, you'll see a server icon with an ip address and adjacent to that is the name of the database you created.

 

You need to log in to your database server. On the first page upon selecting a database(assuming you already created one), is an ip address, for example 10.3.2.1 <-- that is your databse server info you need to enter during installation.

Note: I'm pointing out a sample IP. Your database server ip is something else.

 

BTW, define('STORE_SESSIONS', 'mysql');

Share this post


Link to post
Share on other sites

define('DB_SERVER', '10.6.166.143'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'serverusername');

define('DB_SERVER_PASSWORD', 'password');

define('DB_DATABASE', 'databasename');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', 'mysql'); // leave empty '' for default handler or set to 'mysql'

?>

 

Can you tell me if I'm doing something wrong or if I have to make changes in different files because it still shows the same error.

Thanks for all the help.

Share this post


Link to post
Share on other sites

Check with your hosts that your db server address is an ip address. Usually it is just 'localhost' (without the quotation marks).

 

Vger

Share this post


Link to post
Share on other sites

Verify that the information is correct. Do not post real information, just verify.

 

 

define('DB_SERVER_USERNAME', 'serverusername');<-- This is the username you use to log in to phpMyAdmin, correct?

define('DB_SERVER_PASSWORD', 'password');<-- This is the password you use to log in to phpMyAdmin, correct?

 

define('DB_DATABASE', 'databasename');<-- This is the name of your database you created in phpMyAdmin, correct?

Share this post


Link to post
Share on other sites
Check with your hosts that your db server address is an ip address. Usually it is just 'localhost' (without the quotation marks).

 

Vger

define('DB_SERVER', 'usually an ip address or localhost'); <--Follow Vger's advice and check with host and verify.

define('DB_SERVER_USERNAME', 'username you use to log in to phpMyAdmin');

define('DB_SERVER_PASSWORD', 'password you use to log in to phpMyAdmin');

define('DB_DATABASE', 'name of your database you created in phpMyAdmin/mysql');

 

If you deleted your database and created another with the same database name, your DB_Server will change to a different ip address. Could you verify your DB_SERVER ip?

 

By the way how did you edit your configure.php files? After editing them, did you upload them back to their corresponding folders in your web server?

Share this post


Link to post
Share on other sites

You know, it'd be a whole lot easier, rather than go through all of this mess, to use a hosting company that installs osCommerce for you, renames and password protects the admin panel and sets it up to use their shared SSL - with Ultimate SEO URLs thrown in for free ;-)

 

Vger

Share this post


Link to post
Share on other sites

you are right vger.

 

i decided to switch to siteground, oscommerce installation was much more easy! everything worked.

 

i tried to install a new template, it gives me the register_global off error

 

I created a php.ini file with register_global on and then it gave me an error in catalog/includes/functions/database.php file line 19

 

so i edited database.php in cpanel to this

 

function tep_db_connect($server = ipaddress, $username = dbusername, $password = dbpassword, $database = dbname, $link = 'db_link') {

global $$link;

 

then i gave me this error

 

Parse error: syntax error, unexpected T_DNUMBER, expecting ')' in /public_html/catalog/includes/functions/database.php on line 13

 

now i am stuck again. :(

Share this post


Link to post
Share on other sites

Out of the frying pan and into the fire!

 

Sorry - you're on your own on this one.

 

Vger

Share this post


Link to post
Share on other sites

I ma having the following error...please help

 

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/usr/local/mysql-5.0/data/mysql.sock' (2) in /home/content/k/a/l/kalakriti24/html/osc/includes/functions/database.php on line 19

Unable to connect to database server!

Share this post


Link to post
Share on other sites

This error means that MySQL is not running on your server.

 

Vger

Share this post


Link to post
Share on other sites

I have OS Commerce v 2.2 RC1 installed already. I noticed that there is a newer version OS Commerce v 2.2 RC2a available. I have not seen this anywhere, but is there a way to upgrade without having to start from scratch with a new install? Thanks. Sorry if I have missed this somewhere this is a pretty big site.

Share this post


Link to post
Share on other sites
This error means that MySQL is not running on your server.

 

Vger

 

so i how do i do it... im new to all databases and i seriously need help...

Share this post


Link to post
Share on other sites
so i how do i do it... im new to all databases and i seriously need help...

 

If this is a hosted server then contact your hosting company.

 

If this is your own server then you need to find a specialist forum which helps people trying to self-manage their own server.

 

Vger

Share this post


Link to post
Share on other sites

Hi Vger,

 

Can you tell me what problem i get ?

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 32018 is not allowed to access /tmp owned by uid 0 in /home/dingshar/public_html/shop/includes/functions/sessions.php on line 169

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/dingshar/public_html/shop/includes/functions/sessions.php:169) in /home/dingshar/public_html/shop/includes/functions/sessions.php on line 102

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/dingshar/public_html/shop/includes/functions/sessions.php:169) in /home/dingshar/public_html/shop/includes/functions/sessions.php on line 102

 

http://dingshare.com/shop/index.php

 

And the Admin CP Page has the same problem !

 

Thanks!

 

I have changed the last line in configure.php to "mysql" like u said on the first page, it still doesn't work. I configured database in configure.php

Share this post


Link to post
Share on other sites
Session Save Path and Safe Mode

-------------------------------

The error is a by-product of using PHP in Safe Mode.

To get around the problem go to your osCommerce Admin Panel -->

Configuration --> Sessions and set Session Save Path to just tmp

with no forward slash before or after tmp. You get this error even if you

have elected to store sessions in the database.

 

If the error prevents you from accessing your admin panel then

access the database via phpMyAdmin, go to the 'configuration' table,

find the Session Save Directory entry (there are several pages of

entries for this table), open it for editing and change /tmp to

just tmp with no slash before (or after) it.

 

Vger

Share this post


Link to post
Share on other sites

I have a question that might seem terribly silly, but I haven't found the answer anywhere....

 

 

To change my store to be in Spanish, all I have to do is switch the default language in the Admin area, right? Instead of having a store in english I should have a store in spanish now?

 

 

I've switched to spanish as default, but my store is still in english.

 

Thanks for any help!

Share this post


Link to post
Share on other sites

The default osCommerce languages are English, German and Spanish.

 

The language you will see displayed will depend on the default language your Browser uses - so if your Browser's default language is Spanish then you'll see the Spanish version of the site.

 

Vger

Share this post


Link to post
Share on other sites
The default osCommerce languages are English, German and Spanish.

 

The language you will see displayed will depend on the default language your Browser uses - so if your Browser's default language is Spanish then you'll see the Spanish version of the site.

 

Vger

 

 

So I can't make it be in spanish for everyone, regardless of their browser settings? If not, I have to change both the english and spanish files for the text, right? (like the email, data forms, box names, etc?)

 

 

Thank you again!

Share this post


Link to post
Share on other sites

In osC Admin --> Localisation --> Languages - delete English and German - but don't delete the files via FTP - leave those in place.

 

Vger

Share this post


Link to post
Share on other sites

Thanks Vger!

 

 

I deleted the german...and left the english....maybe someday international shipping won't be that expensive (*dreams*). I'll just modify both files to get the text the way I like it, I guess.

 

Thanks again!

Share this post


Link to post
Share on other sites

possible stupid question but how do i solve this error

 

Warning: I am able to write to the configuration file: C:/wamp/www/OS/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

help :)

Share this post


Link to post
Share on other sites

For offline installs just go to the file, right-click, select Properties and then tick the Read Only box.

 

Vger

Share this post


Link to post
Share on other sites

×