Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

I did what you told me to do.

 

I went to the first page and I put 0755 on everything that was in the catalog folder, than i went to mydomain.com/install... didnt work

I changed EVERYTHING to 0755 and again didnt work

I changed the catalog folder to 777 didnt work the domain

than everything to 777 didnt work

 

I dont get that page to install I just get a page cannot be displayed, so pretty much I'm back to the same spot as before... I cannot get to www.mydomain.com/install page

 

Im going to delete everything again and just add whats in the catalog folder

If you place all the contents of the catalog folder to the root of your website (public_html), to install type mydomain.com/install

If you retain the folder, type mydomain.com/name_of_folder/install

 

Ex: mydomain.com/catalog/install

Share this post


Link to post
Share on other sites

I deleted everything and I reinstalled it again

 

I did what you said BryceJr, still nothing, now I get a blank page and at the bottom it says Done, and everything is at 777 permissions

 

EDIT: I cant find: Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install

Share this post


Link to post
Share on other sites

Hi, I have looked all over but can't seem to figure out how to allow customers to checkout without creating an account. Is there an easy way to set up checkout without an account. I am very new to this so any suggestions are much appreciated.

Share this post


Link to post
Share on other sites

Hi All,

 

 

I am planning to move my Oscommerce site from one server to new Hosting company, Site is all in working from Local server.

What procedure I have to follow to load site from local server to hosting server. can I Save date base as file and upload on hosting server database and then copy catelog FILES to public_html Folder, WIll this work normal or do i have to adjust every thing.

 

Thanks for help in advance.

Share this post


Link to post
Share on other sites

A guide to the configure.php files, Or how to move your site without breaking anything.

 

http://forums.oscommerce.com/index.php?showtopic=193738

 

How to move a site then go live

 

http://forums.oscommerce.com/index.php?showtopic=287726


Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Share this post


Link to post
Share on other sites

When I go to my page: hostname.com and I see the folders that I have uploaded but when I click on the catalog folder I get the 500 internal error message.

Share this post


Link to post
Share on other sites

Please read the Quick Install Guide at the start of this thread.

 

You should not be seeing any folders when you go to your domain. It appears that your hosting company has "Directory Indexing" turned on, which allows you and anybody else to see the contents of your hosting.

 

It also appears that you have not actually installed osCommerce.

 

Vger

Share this post


Link to post
Share on other sites
Please read the Quick Install Guide at the start of this thread.

 

You should not be seeing any folders when you go to your domain. It appears that your hosting company has "Directory Indexing" turned on, which allows you and anybody else to see the contents of your hosting.

 

It also appears that you have not actually installed osCommerce.

 

Vger

 

 

Yes, I have read the guide many times, I've done all the steps that you indicated to do. And I read the guide that comes with Oscommerce, when you download it. I wrote all the steps I've done. I'm still having the same problem

 

I do I turn off the Directory Indexing?

And what do you mean by installed osCommerce? How do I do that?

Share this post


Link to post
Share on other sites

By "install" I mean that:

 

1. You created a database and assigned a MySQL User and Password to it.

2. You uploaded all of the osCommerce files to your hosting via FTP.

3. You went to http://www.yourdomain.com/install or http://www.yourdomain.com/folder/install and followed the osCommerce install procedure through from start to finish.

4. At the end of the "install" you saw two links - one to your osCommerce website and one to your osCommerce admin panel.

 

Have you done all this?

 

Vger

Share this post


Link to post
Share on other sites
By "install" I mean that:

 

1. You created a database and assigned a MySQL User and Password to it.

2. You uploaded all of the osCommerce files to your hosting via FTP.

3. You went to http://www.yourdomain.com/install or http://www.yourdomain.com/folder/install and followed the osCommerce install procedure through from start to finish.

4. At the end of the "install" you saw two links - one to your osCommerce website and one to your osCommerce admin panel.

 

Have you done all this?

 

Vger

 

 

Yeap, done that about 20 times, I even got an older version of OsCommerce for the hell of it. Same thing.

When I go to to www.mydomain.com/install I get a blank page or a Page cannot be displayed.

If I go to mydomain.com~username.com (Index page) I get the 500 error message when I click on the Catalog folder and any other folder I can open it perfectly

Share this post


Link to post
Share on other sites

Change to a hosting company that installs osCommerce for you as part of the hosting package!

 

Vger

Share this post


Link to post
Share on other sites
Change to a hosting company that installs osCommerce for you as part of the hosting package!

 

Vger

 

The hosting company that Im using is hostrocket.com

When I go to the control panel, I click on an option called Fantastic (addon installer) and OsCommerce is there. I installed OsCommerce from there the very first time.

Share this post


Link to post
Share on other sites

It may be that the version of osCommerce they provide via Fantastico is not compatible with the versions of PHP and MySQL they are running - or it may just be that their Fantastico installer is just plain broke.

 

If you've tried it 20 times and it won't work then it's time to move.

 

Vger

Share this post


Link to post
Share on other sites

Vger or All,

 

I know that this was posted back 05, but I have a question that I just havnt been able to find out so far. This /catalog folder that is mentioned in the instalation docs, I am not sure what they are talking about. Do I need to create a /catalog folder? Because currently I have my site set up http://www.mysite.com/ I am just not sure if I need a /catalog folder in the main dir so I can install STS.

 

John

 

 

I'm posting this here so that people who need to can find a quick Installation Guide for osCommerce. It goes a bit further than the Installation Guide in the Knowledge Base.

 

---------------------------------------------------------------------

 

Here's the quick install guide.

 

1. Create a blank database via your web hosting control panel.

 

2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

 

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

5. Then go to http://www.yourdomain.com/install and begin the install procedure. Your DB Server will probably be 'localhost', your db user name and password (for mysql access) will have been provided to you by your web hosting company. The name of the database you already know - because you just set it up. Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

6. After the install create a folder called 'backups' inside the 'admin' folder (via FTP), and delete the install folder. Reset permissions on the two configure.php files.

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

Away you go!

 

Vger

Share this post


Link to post
Share on other sites
2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

The catalog folder is contained in the oscommerce.zip file. Once unzipped, the catalog folder and all the files inside the folder needed to install oscommerce will be available.

Do I need to create a /catalog folder?

No, you don't need to create a catalog folder.

Share this post


Link to post
Share on other sites
Vger or All,

 

I know that this was posted back 05, but I have a question that I just havnt been able to find out so far. This /catalog folder that is mentioned in the instalation docs, I am not sure what they are talking about. Do I need to create a /catalog folder? Because currently I have my site set up http://www.mysite.com/ I am just not sure if I need a /catalog folder in the main dir so I can install STS.

 

John

John, I suggest asking STS related questions in the STSv4 Support Thread in this forum (see STSv4 Forum link in my signature below).

Vger has explained this very well regarding the catalog folder. Keep in mind, the term "catalog" is a synonym for all of the files of your shop or "where the files are located". It could be in a file called eshop, mystore, etc. or it could be the actual root folder itself such as in your case.

 

So, where a contribution instructs to upload to the catalog folder, you would upload to your root.

 

Hope that makes sense,


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
It may be that the version of osCommerce they provide via Fantastico is not compatible with the versions of PHP and MySQL they are running - or it may just be that their Fantastico installer is just plain broke.

 

If you've tried it 20 times and it won't work then it's time to move.

 

Vger

 

Aight I was able to install it. I sent in a ticket letting them what was going on and they fixed it. So I did all the steps that your guide says and now I'm passed that step.

Share this post


Link to post
Share on other sites

Hi there!

 

 

Well this is one of the Thread which are not abandoned so I'll try it here.

 

I have installed OScommerce but get instead of the ADMIN Panel a Site full of Errors. I had solved it once but cannot find the Site anymore :blush:

 

Well the Errors look like this:

 

IN THE ADMIN AREA:

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 65534 is not allowed to access /tmp owned by uid 0 in /httproot/tobias.humbapa.ch/www/catalog/admin/includes/functions/sessions.php on line 165

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /httproot/tobias.humbapa.ch/www/catalog/admin/includes/functions/sessions.php:165) in /httproot/tobias.humbapa.ch/www/catalog/admin/includes/functions/sessions.php on line 102

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /httproot/tobias.humbapa.ch/www/catalog/admin/includes/functions/sessions.php:165) in /httproot/tobias.humbapa.ch/www/catalog/admin/includes/functions/sessions.php on line 102

Warning: Cannot modify header information - headers already sent by (output started at /httproot/tobias.humbapa.ch/www/catalog/admin/includes/functions/sessions.php:165) in /httproot/tobias.humbapa.ch/www/catalog/admin/includes/functions/general.php on line 22

Warning: Unknown: 1 result set(s) not freed. Use mysql_free_result to free result sets which were requested using mysql_query() in Unknown on line 0

 

IN THE NORMAL AREA:

 

Warning: session_save_path() [function.session-save-path]: SAFE MODE Restriction in effect. The script whose uid is 65534 is not allowed to access /tmp owned by uid 0 in /httproot/tobias.humbapa.ch/www/catalog/includes/functions/sessions.php on line 169

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /httproot/tobias.humbapa.ch/www/catalog/includes/functions/sessions.php:169) in /httproot/tobias.humbapa.ch/www/catalog/includes/functions/sessions.php on line 102

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /httproot/tobias.humbapa.ch/www/catalog/includes/functions/sessions.php:169) in /httproot/tobias.humbapa.ch/www/catalog/includes/functions/sessions.php on line 102

 

I know it has anything to do with the Sessions... And last time I had to fix something in the Database :)

 

I'll appreciate your answer

 

 

EDIT:

 

Ok I've found the Thread :D

 

http://forums.oscommerce.com/index.php?sho...mp;#entry754745

 

I've solved the main Problem!

 

But now there appear new errors:

 

IN THE ADMIN AREA:

 

 

Warning: mysql_query() [http://www.mysql.com/doc]: Duplicate entry '302f6a99e7002beab9453cb1e6a98e6d' for key 1 in /httproot/tobias.humbapa.ch/www/catalog/admin/includes/functions/database.php on line 45
1062 - Duplicate entry '302f6a99e7002beab9453cb1e6a98e6d' for key 1

insert into sessions values ('302f6a99e7002beab9453cb1e6a98e6d032f6427', '1212607804', 'language|s:6:\"german\";languages_id|s:1:\"2\";selected_box|s:13:\"configuration\";')

[TEP STOP]

Share this post


Link to post
Share on other sites

Acess the database via phpMyAdmin go to the 'sessions' table and click to 'Empty' (truncate) it. This will remove all sessions and get rid of the error.

 

Vger

Share this post


Link to post
Share on other sites
Yes I did that. My database server is localhost. It was mentioned in my control panel. I also created my own database, as well as user name and password. Does the user name come with an underscore? I didn't create it that way but for some reason after it was created it came with an underscore plus the name of the database I created. And is the password supposed to be combined with the user name? I'm confused!

 

I'm having the same problem can I get help with this?

Share this post


Link to post
Share on other sites

When you create a database on some servers (those using the Ensim Control Panel or Plesk Control Panel for instance) the database name works like this:

 

On Ensim you set up a database called database1, but its full name is yourdomain_com_database1

 

On Plesk you set up a database called database1 but its full name is sqluser_database1

 

Vger

Share this post


Link to post
Share on other sites

Hi, I'm new to this.. and I've run into some problems I haven't been able to find an answer for.. I currently have a site at www.mydomain.com... and I want to test out OsCommerce on a subdomain, so I created beta.mydomain.com, and pointed it to a folder I named 'testsite' on my server. Then I uploaded the catalog folder to the testsite folder. I got a database via my server, its a mysql DB running on ver 4.0... Then I ran the installation, and when I came to step 4, I got this...

 

Warning: fopen(C:/hosting/******/testsite/catalog/includes/configure.php) [function.fopen]: failed to open stream: Permission denied in C:\hosting\******\testsite\catalog\install\templates\pages\install_4.php on line 116

Warning: fputs(): supplied argument is not a valid stream resource in C:\hosting\******\testsite\catalog\install\templates\pages\install_4.php on line 117

Warning: fclose(): supplied argument is not a valid stream resource in C:\hosting\******\testsite\catalog\install\templates\pages\install_4.php on line 118

Warning: fopen(C:/hosting/******/testsite/catalog/admin/includes/configure.php) [function.fopen]: failed to open stream: Permission denied in C:\hosting\******\testsite\catalog\install\templates\pages\install_4.php on line 152

Warning: fputs(): supplied argument is not a valid stream resource in C:\hosting\******\testsite\catalog\install\templates\pages\install_4.php on line 153

Warning: fclose(): supplied argument is not a valid stream resource in C:\hosting\******\testsite\catalog\install\templates\pages\install_4.php on line 154

 

What should I do?

Share this post


Link to post
Share on other sites
What should I do?

 

Make sure that the permissions on the folders are set to 755, and that files are 644 except for the two configure.php files which need to be 755 during the install and then reset afterwards to either 644, 444 or 400 - which is the correct setting depends on your server.

 

Vger

Share this post


Link to post
Share on other sites
Make sure that the permissions on the folders are set to 755, and that files are 644 except for the two configure.php files which need to be 755 during the install and then reset afterwards to either 644, 444 or 400 - which is the correct setting depends on your server.

 

Vger

 

Ic... I'll try that... all I found in the documentation is to use 777 or 644 after the whole install... thanks!!

Share this post


Link to post
Share on other sites

×