Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

Vger,

 

This is a fantastic wealth of information. I'm also impressed with your lengthy commitment to this thread.

 

This will clear up somem issues for me too.

 

Thank you

 

Lee

Share this post


Link to post
Share on other sites

Becky - when you do the Search using Windows XP make sure the search is set to locate hidden files also. I have our computers set to show hidden files anyway, so have never had to use this option using Search - but you may need to do it (not sure if php.ini is a hidden file or not).

 

Vger

Share this post


Link to post
Share on other sites
Becky - when you do the Search using Windows XP make sure the search is set to locate hidden files also. I have our computers set to show hidden files anyway, so have never had to use this option using Search - but you may need to do it (not sure if php.ini is a hidden file or not).

 

Vger

 

Vger,

Thanks for the reply. I tried it again searching hidden files for php.ini and globals and ended up with the same matches as before. Now what? As far as I know, Xampp is installed correctly. I uninstalled and re-installed it several times because when I set up the passwords for security, I could never get into phpadmin. None of the passwords ever worked. When I installed it the last time I didn't set any passwords, which doesn't feel safe, but I'm hoping it will be okay while I'm working on my own computer. Any other suggestions will be appreciated.

Thanks,

Becky

Share this post


Link to post
Share on other sites

I'm sorry Becky, as I don't have access to your computer I can't help you any more than I have. The simple fact is that you must have php.ini files on your computer - else XAMPP wouldn't be working.

 

Vger

Share this post


Link to post
Share on other sites
So, would I change it in one of the Notepad boxes that I can open? If so, which one??

Notepad shoud work. Just don't use Word. There are better (text/html)editors at large, both free and not-so-free. As to the which one, I'd say it has to be "php.ini". It is possible to have several "php.ini" on one's machine. read the Xampp documentation to find out which and whether it has a slightly different name. The "recommended" is just that: it is recommended your php.ini should (probably) look like that. Read it.

BTW you can't find the globals-thing with windows search function, because it's inside the php.ini -file.

Also, the reason I asked about which version of PHP to use - my webhost has PHP 5, don't know if it's backward compatible.

I currently have a testsite on a mac with php5.something and another test with php4.something. Both have globals_off. Both work. Note: some contributions will also need some tinkering to work with globals_off.

I'd forget the php.ini. Just install the patch.

1. Read the patch instructions again.

2. And again.

3. Compare the folder/filesystem and filenames of the patch to that of osCommerce on your machine.

4. Open the files in Notepad or whatever-text-editor-you-choose.

5. Compare and change where necessary. It's only a few lines here and there. Copy-paste will do. Save.

6. Rerun the osC install with/from your browser.

 

You really have to get under the hood in osC.

 

You'll get it! 'cause I'm getting it and I'm a "Think Different" type. :blink:

 

Seagoofy

Share this post


Link to post
Share on other sites

Hello,

I'm VERY new to all this, & seem to be going round in cicles! I have got hosting with unitedhosting.co.uk & they have a button you press on their server to create an oscommerce shop & another to create the database in mysql that is automatically linked to that site.

I've done that, but there are problems: I can't create accounts because when I click the button it takes me to a "this page cannot be found" page; same with log in, checkout, my account (but that's proberly because I haven't created on yet though should't that be some sort of error message & not the not found message?).

Also, when I click on the link from my server that gives the address http://www.artyfactsforcrafts.com/oscommerce3/ it takes me to the shop but that has a title(?) of http & the index page that the server directs me to has an address starting https! That is also the start for the page it tries to find when you click "create account".

I don't know where to change the http to https & how to make the address of index page of my shop to read

http://www.artyfactsforcrafts.com/oscommerce3/index.php.

Could someone help me with this please?

I'll leave my other problems for now, but I've used up so much time on this already.

Thanks very much

Gay

Share this post


Link to post
Share on other sites

You used the Ensim Power Tools automated installation, which assumes you have a full ssl certificate for the website. It is also the old version of osCommerce. Delete the Power Tools install, upload the new version of MS2 via FTP (the contents of the 'catalog' folder but not the folder itself) and run the install manually by going to http://www.artyfactsforcraft.com/install

 

Vger

Share this post


Link to post
Share on other sites
You used the Ensim Power Tools automated installation, which assumes you have a full ssl certificate for the website. It is also the old version of osCommerce. Delete the Power Tools install, upload the new version of MS2 via FTP (the contents of the 'catalog' folder but not the folder itself) and run the install manually by going to http://www.artyfactsforcraft.com/install

 

Vger

Thanks for your quick reply. You can see how new I am: it took me nearly an hour to find out how to view posts I'd done because I'd been looking at other threads & couldn't find my question again!

What makes you think it is an old version? The name oscommerce3 is the name mysql gave to the database & the server gave to the shop because it was my 3rd attempt. The version used on the server is osCommerce Online Store 2.2ms2 (1.0-44)

Is the answer the same for this?

I was told by a friend, who pointed me in the direction of this server, that he had spent months setting up his store using oscommerce, only to find this server did it all by the push of a button. I assummed that it meant I didn't need to upload extra files, & I'm not sure what pathway to give them if I did.

Like walking in the dark & banging my head against walls I didn't see! :blush:

All help is most gratefully received

Gay

Share this post


Link to post
Share on other sites
You used the Ensim Power Tools automated installation, which assumes you have a full ssl certificate for the website. It is also the old version of osCommerce. Delete the Power Tools install, upload the new version of MS2 via FTP (the contents of the 'catalog' folder but not the folder itself) and run the install manually by going to http://www.artyfactsforcraft.com/install

 

Vger

Hello, forgot to add, though I don't know how significant it might be, when I clicked on the likn you gave me ending in install it came up with another "page not found" page

Regards

Gay

Share this post


Link to post
Share on other sites

Firstly, make sure that your website has been repointed to, or on, the server for at least 24 hrs (to allow it time to propagate). Don't try to do the install until then.

 

In order to run the osCommerce installer (not the Power Tools install), you do have to upload the contents of the 'catalog' folder (not the folder itself) to the root of your web (/var/www/html/) via FTP.

 

Vger

Share this post


Link to post
Share on other sites
What makes you think it is an old version?

 

Because the Ensim Power Tools version of osCommerce hasn't been updated in years. The updated version of MS2 only became available last November and is available for download from www.oscommerce.com

 

Vger

Share this post


Link to post
Share on other sites

Installation successful. But got error when I log in to admin page as below:-

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/yicco/public_html/admin/includes/application_top.php on line 130

 

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/yicco/public_html/admin/includes/application_top.php on line 130

 

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/yicco/public_html/admin/includes/application_top.php on line 130

 

 

Please help me what to do??

Share this post


Link to post
Share on other sites

The usual cause of this error is when your folders do not have sufficient permissions to allow the programme to read the files inside them. Check that your folders have permissions of 755, but if they already have those permissions you may need to increase them to 777 (but be aware that this is a security risk as 777 means 'full permissions'). Some hosts, because of their setup, require permissions of 777 on folders.

 

These permissions relate only to the folders and not to the files inside them. Those files should be 644, except for the two configure.php files which should be 644, or 444 or 400 (depending on the server).

 

Vger

Share this post


Link to post
Share on other sites
4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

Err, how do I do that :blush:

Share this post


Link to post
Share on other sites

Read other parts of this thread and you'll find posts which tell you that.

 

Vger

Share this post


Link to post
Share on other sites
Read other parts of this thread and you'll find posts which tell you that.

 

Vger

I've tried that but the setting don't appear in my FTP and it doesn't work manually coding it :(

Share this post


Link to post
Share on other sites

You can't 'manually code it' so I don't know what you mean by that. Try downloading and installing a good FTP programme like WS FTP Home (www.ipswitch.com), there's a 30 day trial version available.

 

Vger

Share this post


Link to post
Share on other sites
You can't 'manually code it' so I don't know what you mean by that. Try downloading and installing a good FTP programme like WS FTP Home (www.ipswitch.com), there's a 30 day trial version available.

 

Vger

I added:

 

"chmod("catalog/admin/includes", 777);

chmod("catalog/admin", 777);"

 

to the source code to no avail. I will give WS FTP a go cheers :)

Share this post


Link to post
Share on other sites

I haven't seen this error posted elsewhere on this forum, so please excuse me if it's alreay been covered.

Uploaded the files to document root and when I go to http://localhost/catalog/install, I get the error below, first a warning then this fatal with the same content. Suse 10 with Apache 2.0.54 and PHP 4.4.0

 

Fatal error: main() [function.require]: Failed opening required 'includes/functions/general.php' (include_path='/usr/share/php') in /srv/www/htdocs/catalog/install/includes/application.php on line 22

 

Any help would be appreciated and thanks for your excellent support.

Share this post


Link to post
Share on other sites

Its' also a permissions issue on your folders - in this case the 'functions' folder.

 

Vger

Share this post


Link to post
Share on other sites

I've change the permissions from 755 to 777 on each directory install/includes/functions/ and I still get the same error, any further suggestions?

 

Thanks

Share this post


Link to post
Share on other sites

Is the server your site is on running PHP in Safe Mode?

 

Vger

Share this post


Link to post
Share on other sites

Then the only other advice I can give is to go through all of your folders and check their permissions and make sure that both configure.php files are writeable by the install programme - and don't forget that you have to create a blank database BEFORE you start the install.

 

Vger

Share this post


Link to post
Share on other sites

×