Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

Hi folks

 

Iam totally new to Oscommerce, big thanks so far for this install guide, but i have hit a problem and would really like some help,

 

I have installed the catalogue no problem so far, but when i try and go to the Admin index i get this

 

p.s i have changed Admin to Neils

 

"Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) in /home/www/kirrey.freesuperhost.com/Neils/includes/functions/database.php on line 19

Unable to connect to database server!"

 

 

Can any one help!

 

Thanks

Share this post


Link to post
Share on other sites

If you can connect to the shop front but not to the backend 'admin' then check your settings in catalog/includes/configure.php against those in catalog/admin/includes/configure.php. Leave out the 'catalog/' part of that if you've installed into the root.

 

Vger

Share this post


Link to post
Share on other sites
If you can connect to the shop front but not to the backend 'admin' then check your settings in catalog/includes/configure.php against those in catalog/admin/includes/configure.php. Leave out the 'catalog/' part of that if you've installed into the root.

 

Vger

 

 

Thanks Vger, but if i go to that url catalog/includes/configure.php, it just comes up Forbidden, you dont have permission to access

 

sorry for being so crap at all this! :blush:

Share this post


Link to post
Share on other sites

You have to download the file/s via FTP to your computer and open them in a plain text editor like Notepad - not Word or Wordpad (they're not plain text editors).

 

Vger

Share this post


Link to post
Share on other sites

Hi,

 

I'm new to the forums and to osCommerce, and I'm having a weird problem.

 

I have Apache 2.0.55 with PHP 5.0.5 and MySQL installed (with PHPMyAdmin).

 

For looking at osCommerce for the first time, I'm testing it on my own computer. I've put the contents of the "catalog" folder into my Apache doc root, in the folder "oscommerce". So, when starting http://localhost/oscommerce, the installation page shows up. All's fine so far, I click on the Install button, the next page shows up "New Installation", but when I click on the Continue button on this page, nothing happens! I can't figure out why.

 

Can anyone help me with this, please?

Share this post


Link to post
Share on other sites

Plz help me ! ! ! I'm new with osCommerce

 

I did the instalation and everythig was ok but in step 7:

 

Warning: fopen(c:/domains/mydomain.com/wwwroot/oscommerce/catalog/includes/configure.php): failed to open stream: Invalid argument in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 209

 

Warning: fputs(): supplied argument is not a valid stream resource in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 210

 

Warning: fclose(): supplied argument is not a valid stream resource in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 211

 

Warning: fopen(c:/domains/mydomain.com/wwwroot/oscommerce/catalog/admin/includes/configure.php): failed to open stream: Permission denied in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 259

 

Warning: fputs(): supplied argument is not a valid stream resource in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 260

 

Warning: fclose(): supplied argument is not a valid stream resource in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 261

 

The configuration was successful!

 

Then when i pushed "Administration Tool":

Warning: mysql_connect(): Access denied for user: 'mysql@localhost' (Using password: NO) in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\admin\includes\functions\database.php on line 19

Unable to connect to database server!

 

I veryfied that my user, pass and database name were ok and they are!!

 

Can u plz help me???

Thanks

Share this post


Link to post
Share on other sites

Downgrade to php 4+. php5 and osCommerce are not compatible.

 

Vger

Hi,

 

I'm new to the forums and to osCommerce, and I'm having a weird problem.

 

I have Apache 2.0.55 with PHP 5.0.5 and MySQL installed (with PHPMyAdmin).

 

For looking at osCommerce for the first time, I'm testing it on my own computer. I've put the contents of the "catalog" folder into my Apache doc root, in the folder "oscommerce". So, when starting http://localhost/oscommerce, the installation page shows up. All's fine so far, I click on the Install button, the next page shows up "New Installation", but when I click on the Continue button on this page, nothing happens! I can't figure out why.

 

Can anyone help me with this, please?

 

 

Sometimes when the install is run, especially on Windows servers, the admin/includes/configure.php file does not get data written to it. Check that file against the contents of the includes/configure.php file and insert the data as appropriate.

 

Vger

Plz help me ! ! ! I'm new with osCommerce

 

I did the instalation and everythig was ok but in step 7:

 

Warning: fopen(c:/domains/mydomain.com/wwwroot/oscommerce/catalog/includes/configure.php): failed to open stream: Invalid argument in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 209

 

Warning: fputs(): supplied argument is not a valid stream resource in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 210

 

Warning: fclose(): supplied argument is not a valid stream resource in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 211

 

Warning: fopen(c:/domains/mydomain.com/wwwroot/oscommerce/catalog/admin/includes/configure.php): failed to open stream: Permission denied in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 259

 

Warning: fputs(): supplied argument is not a valid stream resource in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 260

 

Warning: fclose(): supplied argument is not a valid stream resource in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\install\templates\pages\install_7.php on line 261

 

The configuration was successful!

 

Then when i pushed "Administration Tool":

Warning: mysql_connect(): Access denied for user: 'mysql@localhost' (Using password: NO) in c:\domains\mydomain.com\wwwroot\oscommerce\catalog\admin\includes\functions\database.php on line 19

Unable to connect to database server!

 

I veryfied that my user, pass and database name were ok and they are!!

 

Can u plz help me???

Thanks

Share this post


Link to post
Share on other sites

All folders, including sub-folders, should be set to 755 except for the 'images' and 'graphs' folders which should be 777.

 

Vger

Share this post


Link to post
Share on other sites

You need to ask your web hosting company about that. It may be 'localhost', or '127.0.0.1' but it equally may be something entirely different.

 

Vger

Share this post


Link to post
Share on other sites

all I can say so far is that it was great of you to start this post, I did find a problem with one part of the directions that messed me up was that since I uploaded the catalog folder.......... I needed that folder in my url when I went to the install page......you left that part out, I kept trying and trying to use it the way you typed it.

Share this post


Link to post
Share on other sites

This was only meant to be a "Quick Install Guide" and not meant to replace the installation instructions in the Knowledge Base. Your first point is covered here in my guide:

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

Your second point - yes 'images' and 'graphs' remain at those permissions

 

Your final point - the reason I advise people not to enable ssl during the install is that virtually no one has a full ssl certificate before they install their domain - and if you enable ssl then your site will be set up for a full ssl cert and won't work properly without it. If you have access to a shared ssl cert then you need to input the correct information for this in the two configure.php files after you complete the install.

 

Vger

Share this post


Link to post
Share on other sites

Hello,

 

First I want to thank you soooo much for the installation guide. It's very helpful. My question is 2 part.

 

1 - I need to move a store to another domain how do I transport my store? Do I just download it and upload it to the new domain?

 

2 - how do I do an upgrade?

 

Thanks again for anyone who can help this newbie. :)

Share this post


Link to post
Share on other sites

To move a store to another domain you need to download all files and folders via FTP to your own computer. Then you need to make and download a backup of your existing database. Go to your osC admin panel --> Tools --> Download and select to Backup and to download the backup, and don't tick to use compression.

 

Then you upload all of the files/folders to your new site. Create a blank database (probably in your wb hosting control panel), and then go to your new blank database via phpMyAdmin, locate the new database, click on the SQL tab and use the Browse function to locate the backup you downloaded to your computer, then click 'Go' and this will populate the blank database with the information from your old one.

 

Then you need to edit the two configure.php files to refelect your new server setup (DIR_FS pathways in particular), and your new database details.

 

There is only one Upgrade available and that's from MS1 to MS2, and you do that by uploading the 'Install' folder to an existing website and then you go to http://www.yourdomain.com/install and choose the 'Upgrade' option. Remember to take a backup of your database first - just in case!

 

Vger

Share this post


Link to post
Share on other sites

Dear,

 

My installation have this error too. You already have a solution ?

 

thamks a lot,

 

orengo

 

 

I'm doing a new installation over server and got this error:

 

The following error has occurred:

The configuration files do not exist, or permission levels are not set.

 

Please perform the following actions:

cd /hsphere/local/home/orenji/domain.com/catalog/includes/

touch configure.php

chmod 706 configure.php

cd /hsphere/local/home/orenji/domain.com/catalog/admin/includes/

touch configure.php

chmod 706 configure.php

 

both files are set to 777 but installation still can't go thru, and anyone kindly explain what is 706? thanks.

Share this post


Link to post
Share on other sites

For the install to be able to write to the two includes/configure.php files the permissions on the folders (includes/) must also be set to 706, 755, or 777 (depends on server setup).

 

Vger

Share this post


Link to post
Share on other sites

Hey man that error i silly! :-)

 

you should modify the includes/configure.php to fit your needs..

 

 

Plz help me ! ! ! I'm new with osCommerce

Share this post


Link to post
Share on other sites
Plz help me ! ! ! I'm new with osCommerce

 

So what is it you want to know?

 

Vger

Share this post


Link to post
Share on other sites

Vger,

 

Great info in this topic too bad I didn't find it before I trudged through and figureed it out myself. Everything you said in this thread to move a site to root I had to figure out with liitle to no PHP experience. This is a great install and setup thread you have going . Thanks for being there for us newbies.

 

 

Arthur

Share this post


Link to post
Share on other sites

How do I get rid of seesion post install? I have forced cookies and for the users it works but I still get teh sessions in admin mode. Anyone?

 

Arthur

Share this post


Link to post
Share on other sites

Thanks for all your help Vger. I have some questions for you too.

 

Should I ask my host for ssl first before I install oscommerce or does it not matter what goes first?

 

Do I need ssl at all? What if I use Paypal or 2CO?

 

Lastly. Do I just get ssl from my host? I'm a little confused on how to obtain it.

 

If you can give the basic steps for getting ssl up and running that would be great.

 

Thanks again for all your help.

Share this post


Link to post
Share on other sites

×