Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

How do I do the below procedure? I use WS FTP PRO.

Sorry newbie here...

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

Share this post


Link to post
Share on other sites

Okay, if you use WS FTP Pro then FTP to your website, right click on the folder or file you wish to check/change permissions on, then select Operations, then FTP Commands, and then CHMOD (Unix), and then a box will come up entitled 'Remote File Permissions' and you can then change the numbering to whichever permission you wish to set.

 

Vger

Share this post


Link to post
Share on other sites
Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

Why "Do not enable SSL?" What if I need SSL?

 

Thanks,

Max

Share this post


Link to post
Share on other sites

If you enable ssl then the site configuration will be set up to use a full ssl certificate and not a shared ssl certificate - which is what the majority of people use for their site.

 

It is far easier not to set the configure files up for ssl when installing and adapt them later on.

 

Vger

Share this post


Link to post
Share on other sites

hi all it's probably been covered a million times before, but,

 

I've done the download, done the install, everything is hunky dory right up until I get to the part about you need to - .htaccess you admin directory - I'm totally lost

 

if I go to www.mydomain.com/admin it somes up all blue and shiny but if I click on anything it goes to a 404 error.

 

any help would be greatly appreciated ( a step by step would be a charm) B)

Share this post


Link to post
Share on other sites

If you are getting a '404 - File Not Found' error when trying to navigate from the admin landing page to the other pages then your admin/includes/configure.php file is not set up correctly. You really need to post it here (minus the database user name and password) for help but before you do that you need to password protect it.

 

Forget about writing .htaccess files yourself. Most likely you'll have a feature in your Web Hosting control panel called something like Password Protection or Directory Protection - and this will write the .htaccess files for you.

 

Vger

Share this post


Link to post
Share on other sites

this is what I get, don't get a 'log in option though' anything I click on takes me here :-

my amin/includ/configure.php is set at 644 (also tried 444)

Page not found

The page you requested was not found on this web server. This could be for a variety of reasons, including:

You followed a broken or out-of-date link.

You entered the URL for the page incorrectly.

The page no longer exists.

If you followed a broken link, please inform the owner of the referring page.

If you have any queries about this error, please e-mail webmaster@this.domain.

 

 

 

 

--------------------------------------------------------------------------------

 

Back to www.myname.org homepage

Share this post


Link to post
Share on other sites

Provided that you do get the blue landing page for 'admin' at http://www.yourdomain.com/admin or catalog/admin (wherever it is installed), and you only get the errors when you try to click to get further into 'admin' then follow my advice in my earlier post.

 

Vger

Share this post


Link to post
Share on other sites
How do I do the below procedure? I use WS FTP PRO.

Sorry newbie here...

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

Okay. I got it. :) I can't get past through the first installation stage though with the server settings, database name, etc. I created a database in my control panel but when i input the info during the initial install stage, i would get this error Access denied for user 'jwonline_justworship'@'localhost' (using password: YES). I getting confused. Help!

Share this post


Link to post
Share on other sites

Check with your hosting company what your database server address is. It is 'usually' localhost, but is not always so.

 

Don't forget also that your mysql user name and password may be different from the user name and password you use to access your web hosting control panel. With many hosting control panels you have to set up a mysql password, because one is not created for you.

 

Vger

Share this post


Link to post
Share on other sites
Okay. I got it. :) I can't get past through the first installation stage though with the server settings, database name, etc. I created a database in my control panel but when i input the info during the initial install stage, i would get this error Access denied for user 'jwonline_justworship'@'localhost' (using password: YES). I getting confused. Help!

 

Yes I did that. My database server is localhost. It was mentioned in my control panel. I also created my own database, as well as user name and password. Does the user name come with an underscore? I didn't create it that way but for some reason after it was created it came with an underscore plus the name of the database I created. And is the password supposed to be combined with the user name? I'm confused!

Share this post


Link to post
Share on other sites

Sometimes, it depends on your server, if you create a database called osCommerce then the full database name has to be entered as yourdomain_com_-_osCommerce

 

Vger

Share this post


Link to post
Share on other sites
Yes I did that. My database server is localhost. It was mentioned in my control panel. I also created my own database, as well as user name and password. Does the user name come with an underscore? I didn't create it that way but for some reason after it was created it came with an underscore plus the name of the database I created. And is the password supposed to be combined with the user name? I'm confused!

 

I am still getting an error. I am installing it from here http://www.justworshiponline.com/catalog/install.

Share this post


Link to post
Share on other sites

Yay! I was finally able to go past the initial install stage...

 

Now how do I do this?

 

Reset permissions on the two configure.php files.

Share this post


Link to post
Share on other sites

Hi,

 

I've just downloaded the stuff and am ready to install. I've created a blank database, extractedthe catalog folder and have changed the CHMOD 755 to all folders and 777 to both the configure files.

 

Now when I go to my website to continue the install, I get a 404 error. I've tried www.mysite.com/install and www.mysite.com/catalog/install, nothing works.

 

I've been trying forever to figure this out, does anyone know what I'm doing wrong?

 

Tnx

Share this post


Link to post
Share on other sites

Did you upload the osCommerce files/folders to the root of your domain, or did you upload them to somewhere outside the root of your domain?

 

FTP to your website and make sure that osCommerce is where all of your other files would be, including your default holding page (usually index.htm or html).

 

Vger

Share this post


Link to post
Share on other sites
Did you upload the osCommerce files/folders to the root of your domain, or did you upload them to somewhere outside the root of your domain?

 

FTP to your website and make sure that osCommerce is where all of your other files would be, including your default holding page (usually index.htm or html).

 

Vger

 

So if your web pages/index were in the "http://www.mydomainname.com/public_html" folder, you would want the OS Commerce catalog folder to be located in "http://www.mydomainname.com/public_html/catalog"?

Share this post


Link to post
Share on other sites

If your osCommerce 'catalog' folder is in the public_html folder then this is the root of your web, in which case the address would be http://www.yourdomain.com/catalog/install

 

Be aware that if you use a programme like FrontPage or Dreamweaver to upload to your website then unless they are set up to upload specifically to the public_html folder then they may actually upload to the first folder they come to.

 

Vger

Share this post


Link to post
Share on other sites

Hi everyone,

 

I got problems that didn't get answer, hopefully I could get helps here. Well, I have uploaded my catalog folder and database which I prebuild using XAMPP server into my hosting server.

 

As Vger pointed out, I have to reconfigure both includes\configure.php and admin\includes\configure.php. However, I am totally a newbie, and don't know what should filled in the http_server (' _____');

I saw somebody posted here saying should be my IP_Address.

 

The IP_Address is it the Server IP_Address that I found in my Hosting Control Panel?

 

:(


Wanwan -- %_%_

Share this post


Link to post
Share on other sites

Thank you Vger,

 

how about this one? HTTP_COOKIE_PATH', '/catalog/');


Wanwan -- %_%_

Share this post


Link to post
Share on other sites

That's fine, provided you installed osC in a folder called 'catalog'

 

Vger

Share this post


Link to post
Share on other sites
That's fine, provided you installed osC in a folder called 'catalog'

 

Vger

 

Do I need to change 'catalog' to anything?


Wanwan -- %_%_

Share this post


Link to post
Share on other sites

×