Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

Your web hosting company is talking complete and utter nonsense.

 

Password Protection can only be applied at a folder level - so they are either confusing your problem with Password Protection, or they've set the server up wrongly, or (as above) don't know what they're talking about.

 

Vger

Share this post


Link to post
Share on other sites

Eveybody;

 

i'm facing such Error as below...

 

"FATAL ERROR: register_globals is disabled in php.ini, please enable it!"

 

i wonder to know what is going on?

 

i write a simple php page and test it, it worked well.

 

when i write such code to test the MySQL as below...

it cannot print the msg "Database connection successfully!"...is there any problem in MySQL configuration?

 

<?php

//connect to the database server, remember to edit the username and password

$db = mysql_connect("localhost", "root", "password");

 

//report the connection failure or success

if (!$db) {

echo "There was a problem connecting to the database.";

exit;

}

if ($db) {

echo "Database connection successfully!";

exit;

}

?>

 

i'm wonder to know is it ""FATAL ERROR: register_globals is disabled in php.ini, please enable it!"", cause by MySQL or other factors?

 

Ooop...one more thing...what do you means "chmod 777 configure.php"...what should i change in

catalog/includes/configure.php and catalog/admin/includes/configure.php?

 

I'll appreciate all your help.

 

Bye :rolleyes:

 

Jimmy :blush:

Share this post


Link to post
Share on other sites

so i downloaded phpMyAdmin-2.8.0.3.zip, placed the folders in the root directory.

-created a file called 'config.inc.php' pasted the 'libraries/config.default.php' script into the new file ...

 

-inserted 'my_pwd' into config.inc.php

 

$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address

$cfg['Servers'][$i]['user'] = 'root'; // MySQL user

$cfg['Servers'][$i]['password'] = 'my_pwd'; // MySQL password (only needed with 'config' auth_type)

$cfg['Servers'][$i]['auth_type'] = 'config'; // Authentication method (config, http or cookie based)?

 

-i can now run a sql query...

 

*quote last post*

"If you did a manual setup you also need to populate the database using the oscommerce.sql file.

Go to phpmyadmin and run the file and you should be ok."

 

-result after entering oscommerce.sql in the query panel:

 

Error

SQL query:

oscommerce.sql

MySQL said: Documentation

#1064 - You have an error in your SQL syntax;

check the manual that corresponds to your MySQL server version for the right syntax to use near 'oscommerce.sql' at line 1

 

-so how should i run this 'oscommerce.sql' file/query??? huh.gif

and/or does this error mean something else is wrong?

 

 

harlo... smith are facing the same problem here...

i also cannot pass the step 2...

i have copy all the exracted file and folder from 'phpMyAdmin-2.8.0.3.zip' to my root c:\webRoot

and

i also create a 'config.inc.php' and copy the script from 'libraries/config.default.php'

and

i have inserted 'my_pwd' into config.inc.php, the others line kept the same...

 

BUT i still cannot pass the step 2 during installation....why? sad.gif

 

Somebody tell me what is going on?

 

Any idea would be appreciate! rolleyes.gif

Share this post


Link to post
Share on other sites

Ok.I've installed and are setting upp eveything and I get this error msg when connecting with my web browser (to se if everything works before starting to modify...)

 

Warning: session_start(): open(tmp/sess_074dea5488fb16b1405abbf2936d41ba, O_RDWR) failed: No such file or directory (2) in /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php on line 97

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php:97) in /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php on line 97

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php:97) in /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php on line 97
Warning Warning: The sessions directory does not exist: tmp. Sessions will not work until this directory is created.

 

How do I fix this ??? (if it has already been answered elswere...please direct me to that loction)

Tnx.

Share this post


Link to post
Share on other sites

Hi Vger,

 

Thanks for that. Iam quite new to this and I would appreciate your help on this.

 

1) I have copied the catalog folder to my webdomain and did the installtion and everything is fine

 

Now that I have done the installation I have the followign questions:

 

1) How do I integrate the oscommerce store to my own website?

 

2) And how do I integrate oscommcerce to paypal?

 

I would be very grateful for your assistance on this

 

Rgds,

Bazam

 

 

 

 

 

 

I'm posting this here so that people who need to can find a quick Installation Guide for osCommerce. It goes a bit further than the Installation Guide in the Knowledge Base.

 

---------------------------------------------------------------------

 

Here's the quick install guide.

 

1. Create a blank database via your web hosting control panel.

 

2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

 

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

5. Then go to http://www.yourdomain.com/install and begin the install procedure. Your DB Server will probably be 'localhost', your db user name and password (for mysql access) will have been provided to you by your web hosting company. The name of the database you already know - because you just set it up. Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

6. After the install create a folder called 'backups' inside the 'admin' folder (via FTP), and delete the install folder. Reset permissions on the two configure.php files.

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

Away you go!

 

Vger

Share this post


Link to post
Share on other sites

Hi,

 

My probelm at first glance would seem to be permissions however I asure you it is not. In fact I have been at this for two days trying to figure it out, and I think its related to "some" php setting, what, I have no clue. I am on a dedicated server, running Plesk 7.5.4 Fedora Core 2.

I have installed OSC manually deleted it 4-5 times (lost count) and installed it again. I have check permissiona via FTP and SSH (Telnet), I tuned on display_errors = On in php.ini to see what is going on and here is what I get

 

Warning: main(includes/functions/general.php): failed to open stream: No such file or directory in /home/httpd/vhosts/self-defense-weapons-review.com/httpdocs/catalog/install/includes/application.php on line 22

 

Warning: main(includes/functions/general.php): failed to open stream: No such file or directory in /home/httpd/vhosts/self-defense-weapons-review.com/httpdocs/catalog/install/includes/application.php on line 22

 

Warning: main(includes/functions/general.php): failed to open stream: No such file or directory in /home/httpd/vhosts/self-defense-weapons-review.com/httpdocs/catalog/install/includes/application.php on line 22

 

Fatal error: main(): Failed opening required 'includes/functions/general.php' (include_path='/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:/usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin:/usr/local/psa/admin/htdocs/domains/databases/phpPgAdmin') in /home/httpd/vhosts/self-defense-weapons-review.com/httpdocs/catalog/install/includes/application.php on line 22

 

Please note. permissions for catalog is 755 and all other directories

permissions for directory "includes" is 755 (tried 777)

Permission for configure.php is 777 in admin as well

 

No matter what I try any and all pages come up blank (not 404 errors), for what ever reason it just will not read the "required"

 

Also note I have many many PHP script running on this server with no issues

 

Thank you

 

Mike

 

ps. if you wish to see my php settings see http://www.self-defense-weapons-review.com/phpinfo.php

Share this post


Link to post
Share on other sites

I'm amazed that you have anything running on that server, with the include path that you have. It should be something like:

.:/php/includes:/usr/share/php

and not like:

'/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:/usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin:/usr/local/psa/admin/htdocs/domains/databases/phpPgAdmin'

 

Whoever set up that server made a real mess of it, and this thread is for helping people to install osCommerce on servers which have been set up correctly. I can't provide support for people on how the servers should be set up ....sorry!.

 

Vger

 

Hi,

 

My probelm at first glance would seem to be permissions however I asure you it is not. In fact I have been at this for two days trying to figure it out, and I think its related to "some" php setting, what, I have no clue. I am on a dedicated server, running Plesk 7.5.4 Fedora Core 2.

I have installed OSC manually deleted it 4-5 times (lost count) and installed it again. I have check permissiona via FTP and SSH (Telnet), I tuned on display_errors = On in php.ini to see what is going on and here is what I get

 

Warning: main(includes/functions/general.php): failed to open stream: No such file or directory in /home/httpd/vhosts/self-defense-weapons-review.com/httpdocs/catalog/install/includes/application.php on line 22

 

Warning: main(includes/functions/general.php): failed to open stream: No such file or directory in /home/httpd/vhosts/self-defense-weapons-review.com/httpdocs/catalog/install/includes/application.php on line 22

 

Warning: main(includes/functions/general.php): failed to open stream: No such file or directory in /home/httpd/vhosts/self-defense-weapons-review.com/httpdocs/catalog/install/includes/application.php on line 22

 

Fatal error: main(): Failed opening required 'includes/functions/general.php' (include_path='/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:/usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin:/usr/local/psa/admin/htdocs/domains/databases/phpPgAdmin') in /home/httpd/vhosts/self-defense-weapons-review.com/httpdocs/catalog/install/includes/application.php on line 22

 

Please note. permissions for catalog is 755 and all other directories

permissions for directory "includes" is 755 (tried 777)

Permission for configure.php is 777 in admin as well

 

No matter what I try any and all pages come up blank (not 404 errors), for what ever reason it just will not read the "required"

 

Also note I have many many PHP script running on this server with no issues

 

Thank you

 

Mike

 

ps. if you wish to see my php settings see http://www.self-defense-weapons-review.com/phpinfo.php

Share this post


Link to post
Share on other sites

Hi, I'm happy that you've managed t install osCommerce okay - but this thread doesn't go beyond the installation. You need to ask your other questions in the General Support forum.

 

Vger

Hi Vger,

 

Thanks for that. Iam quite new to this and I would appreciate your help on this.

 

1) I have copied the catalog folder to my webdomain and did the installtion and everything is fine

 

Now that I have done the installation I have the followign questions:

 

1) How do I integrate the oscommerce store to my own website?

 

2) And how do I integrate oscommcerce to paypal?

 

I would be very grateful for your assistance on this

 

Rgds,

Bazam

Share this post


Link to post
Share on other sites

The most common cause for installation getting stuck in step 2

is that most recent PHP installations have register_long_arrays = OFF

This needs to be turned to ON in the php.ini file (you will need to

stop and restart your server to get this change to take effect.)

 

Vger

so i downloaded phpMyAdmin-2.8.0.3.zip, placed the folders in the root directory.

-created a file called 'config.inc.php' pasted the 'libraries/config.default.php' script into the new file ...

 

-inserted 'my_pwd' into config.inc.php

 

$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address

$cfg['Servers'][$i]['user'] = 'root'; // MySQL user

$cfg['Servers'][$i]['password'] = 'my_pwd'; // MySQL password (only needed with 'config' auth_type)

$cfg['Servers'][$i]['auth_type'] = 'config'; // Authentication method (config, http or cookie based)?

 

-i can now run a sql query...

 

*quote last post*

"If you did a manual setup you also need to populate the database using the oscommerce.sql file.

Go to phpmyadmin and run the file and you should be ok."

 

-result after entering oscommerce.sql in the query panel:

 

Error

SQL query:

oscommerce.sql

MySQL said: Documentation

#1064 - You have an error in your SQL syntax;

check the manual that corresponds to your MySQL server version for the right syntax to use near 'oscommerce.sql' at line 1

 

-so how should i run this 'oscommerce.sql' file/query??? huh.gif

and/or does this error mean something else is wrong?

harlo... smith are facing the same problem here...

i also cannot pass the step 2...

i have copy all the exracted file and folder from 'phpMyAdmin-2.8.0.3.zip' to my root c:\webRoot

and

i also create a 'config.inc.php' and copy the script from 'libraries/config.default.php'

and

i have inserted 'my_pwd' into config.inc.php, the others line kept the same...

 

BUT i still cannot pass the step 2 during installation....why? sad.gif

 

Somebody tell me what is going on?

 

Any idea would be appreciate! rolleyes.gif

Share this post


Link to post
Share on other sites

On the last line of both configure.php files make them read 'mysql' where indicated - storing sessions in the database and not in files in a 'tmp' folder.

 

Vger

Ok.I've installed and are setting upp eveything and I get this error msg when connecting with my web browser (to se if everything works before starting to modify...)

 

Warning: session_start(): open(tmp/sess_074dea5488fb16b1405abbf2936d41ba, O_RDWR) failed: No such file or directory (2) in /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php on line 97

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php:97) in /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php on line 97

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php:97) in /hsphere/local/home/photopat/webshop.patricknaslund.com/oscommerce2/catalog/includes/functions/sessions.php on line 97
Warning Warning: The sessions directory does not exist: tmp. Sessions will not work until this directory is created.

 

How do I fix this ??? (if it has already been answered elswere...please direct me to that loction)

Tnx.

Share this post


Link to post
Share on other sites
If you look then you'll see that I've replied in this one thread four times today - and this isn't the only thread I'm subscribed to. I have answered your points, it's just that you keep asking if there's another way of doing it.

 

If you want to set up your computer as an offline web server then go to http://www.apachefriends.org/en and download XAMPP - an all in one Apache web server package. It's a 1-click install. Then install osCommerce on that and make your changes there before uploading to your online site.

 

Vger

 

I'm not asking another way of doing it...I just usually don't understand what you are saying and can't follow what your are suggesting.

 

And if I'm having this much trouble doing this with a hosting company doing the install, then I think I'd never be able to install it myself.

 

So thanks for you help and I'm not going to bother you any more. Thanks.

Share this post


Link to post
Share on other sites
I'm amazed that you have anything running on that server, with the include path that you have. It should be something like:

.:/php/includes:/usr/share/php

and not like:

'/usr/local/psa/admin/plib:/usr/local/psa/admin/javascripts:/usr/local/psa/admin/plib/locales:/usr/local/psa/admin/auto_prepend:/usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin:/usr/local/psa/admin/htdocs/domains/databases/phpPgAdmin'

 

Whoever set up that server made a real mess of it, and this thread is for helping people to install osCommerce on servers which have been set up correctly. I can't provide support for people on how the servers should be set up ....sorry!.

 

Vger

 

Hi Vger

The path that you saw is required for the Plesk Admin to run, so it is correct, what was not correct was what you pointed out ".:/php/includes:" I added that into the path and poof OSC install ran and I am now able to configure the script. Thank you for pointing out the flaw!

 

Mike

Share this post


Link to post
Share on other sites
On the last line of both configure.php files make them read 'mysql' where indicated - storing sessions in the database and not in files in a 'tmp' folder.

 

Vger

 

Thanks.....That made it... :D

Share this post


Link to post
Share on other sites

Hello,

 

My web hosting server has this an an option and all I had to do is click install and a few other things and it did it all for me.

 

Now I am trying to do a few things and I can't write to anything. I get this error

 

Error: I can not write to this file. Please set the right user permissions on: /usr/local/pem/vhosts/28285/webspace/webapps/osCommerce/httpdocs//catalog/includes/languages/english/index.php

 

I have called my host support to only get people who know nothing about os and I have not a clue can someone please help me. I don't know where to go to check my permisions or anything!

 

Thanks

Share this post


Link to post
Share on other sites

Try locating a link called File Manager in your web hosting control panel. This should enable you to change permissions on that file to 644. Then you download the file via FTP, take a backup (just in case) edit it in a plain text editor like Notepad and upload again. Any problems restore from the backup.

 

When adding text to a php page escape all apostrophies with a preceeding backslash, as in:

 

Let's = wrong

Let\'s = right

 

Vger

Share this post


Link to post
Share on other sites

I get as far as clicking on webapps part of that file and then I get this error

 

Unable to open directory: /usr/local/pem/vhosts/28285/webspace/webapps

 

Is my host missing something from this program?

Share this post


Link to post
Share on other sites
Done it thanks,

I just want a site like http://www.hepsikamera.com/index.php with my own products and colouring. is there an easier way like to copy and edit this site with ftp or any other programme?.

Hi,

I have installed teh site including the Turkish version. But the site i snot complete , do I need to go thru install steps evertime I need to go and do some work on my site or is there a shorter way to get to , so that I can edit my site.

Also please have alook at the http://www.hepsikamera.com/index.php site as you can see colour theme is orange I want my site to have red where theer i sorange on this site can you tell me what to do please.

Share this post


Link to post
Share on other sites
Looks very much like it.

 

Vger

Hi,

I have installed teh site including the Turkish version. But the site i snot complete , do I need to go thru install steps evertime I need to go and do some work on my site or is there a shorter way to get to , so that I can edit my site.

Share this post


Link to post
Share on other sites

I get a 404 error when I try to access my site. I have tried to install via Fantastico, and ended up uninstalling that. I uploaded all the files from oscommerce zip, then followed the instructions here and the ones for web install under documentation.

 

After I had trouble using Fantastico, I asked my host for help. They said you can't install OSC in an addon domain - it must be in the main domain for my hosting package. They were able to access my files using http://ipaddy/~username/domain/. I had to use that format to get to the web install, and now that addy is also the only way I can see anything on my site. I changed the website address in the install steps, but it apparently didn't work. I checked my config files and they show the correct site name. Did I do something wrong with the setup? Any way I can get it set so the website is correct (www.mydomain.com instead of using the ipaddy, etc)?

 

Thanks, I appreciate any help!

Share this post


Link to post
Share on other sites
I get a 404 error when I try to access my site. I have tried to install via Fantastico, and ended up uninstalling that. I uploaded all the files from oscommerce zip, then followed the instructions here and the ones for web install under documentation.

 

After I had trouble using Fantastico, I asked my host for help. They said you can't install OSC in an addon domain - it must be in the main domain for my hosting package. They were able to access my files using http://ipaddy/~username/domain/. I had to use that format to get to the web install, and now that addy is also the only way I can see anything on my site. I changed the website address in the install steps, but it apparently didn't work. I checked my config files and they show the correct site name. Did I do something wrong with the setup? Any way I can get it set so the website is correct (www.mydomain.com instead of using the ipaddy, etc)?

 

Thanks, I appreciate any help!

 

 

Has your domain resovled to the server yet? I would check and make sure it has, although it usually only takes a day sometimes it can take much longer.


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites

×