Jump to content

Archived

This topic is now archived and is closed to further replies.

Vger

Quick Install Guide

Recommended Posts

Your catalog is working fine, but for some reason your admin/includes/functions folder is named 'function' and not 'functions'

 

Vger

 

 

thanks Vger... like I said I uploaded everything by hand.. so I made an error there instead of making it functions I called it function.. I will try now...

Share this post


Link to post
Share on other sites
Why did you set up a new directory called 'database'? You need to go to your web hosting control panel and set up a new blank database, not a folder called 'database'.

 

Your folder permissions should be okay by default - you just need to follow the Quick Install Guids instructions at the start of this thread. If you then get permission problems then post back here.

 

Vger

 

ok,

I get the message :

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

I cannot find php.ini !.

Share this post


Link to post
Share on other sites
ok,

I get the message :

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

I cannot find php.ini !.

 

let me also add this : I have talekd to the web hosting people since and they they wont enable php.ini and suugest to use a different FTp client programme , do you know one where it wont ask for this enable?.

Share this post


Link to post
Share on other sites

Register Globals being disabled in php.ini has nothing to do with whatever FTP programme you use. These are your possible courses of action:

 

1. If your site is hosted on an Apache server then putting thise code (below) in a root level .htaccess file will turn on Register Globals just for your site:

php_flag register_globals on

2. If your site is hosted on a Windows server then you'll need to go to Contributions (link above) and download and install the latest Register Globals Patch, which will enable your site to work with Register Globals set to off in php.ini

 

Vger

Share this post


Link to post
Share on other sites
Register Globals being disabled in php.ini has nothing to do with whatever FTP programme you use. These are your possible courses of action:

 

1. If your site is hosted on an Apache server then putting thise code (below) in a root level .htaccess file will turn on Register Globals just for your site:

php_flag register_globals on

2. If your site is hosted on a Windows server then you'll need to go to Contributions (link above) and download and install the latest Register Globals Patch, which will enable your site to work with Register Globals set to off in php.ini

 

Vger

hi,

I found out that teh Linux part of my server is on Apache, but to be honest with you did not understand how to put that code in. do I use the FTP programme and write on to the root or what exactly.

sorry!!!

Share this post


Link to post
Share on other sites

Click to create a new text document on your computer desktop, and then rename it to txt.htaccess (ignore the warning about changing the file type).

 

Put the code into the file and save it.

 

Upload it to the root of your website and then click to Rename it, and rename it to just .htaccess

 

Vger

 

Vger

Share this post


Link to post
Share on other sites

hi I try to install this shop. But I get following error

 

Access denied for user 'username'@'%' to database 'db_name'

 

What should I do. Is my SP denaying to use your program or what

 

regs

Share this post


Link to post
Share on other sites
Click to create a new text document on your computer desktop, and then rename it to txt.htaccess (ignore the warning about changing the file type).

 

Put the code into the file and save it.

 

Upload it to the root of your website and then click to Rename it, and rename it to just .htaccess

 

Vger

 

Vger

My server wont allow me to put anything on the root , also when I try to log onto my new web site :

e-shop.artest.com.tr I get message "access denied" .

I think I shoul dgive this up as bad experience!.

Share this post


Link to post
Share on other sites
My server wont allow me to put anything on the root , also when I try to log onto my new web site :

e-shop.artest.com.tr I get message "access denied" .

I think I shoul dgive this up as bad experience!.

 

 

When she says root of your site she means the www or public_html folder of your site. That is where files need to be if you want someone to access them by going to www.yourdomain.com


The Knowledge Base is a wonderful thing.

Do you have a problem? Have you checked out Common Problems?

There are many very useful osC Contributions

Are you having trouble with a installed contribution? Have you checked out the support thread found Here

BACKUP BACKUP BACKUP!!! You did backup, right??

Share this post


Link to post
Share on other sites
I'm posting this here so that people who need to can find a quick Installation Guide for osCommerce. It goes a bit further than the Installation Guide in the Knowledge Base.

 

---------------------------------------------------------------------

 

Here's the quick install guide.

 

1. Create a blank database via your web hosting control panel.

 

2. Download the osCommerce 2.2 MS2 zip file from the downloads section of www.oscommerce.com, unzip it and extract the 'catalog' folder.

 

3. If you want your shop to be available at http://www.yourdomain.com/catalog then upload the whole of the catalog folder to the root directory of your website via FTP. If you want the site to be available at http://www.yourdomain.com then just upload all of the contents of the catalog folder, but not the folder itself.

 

4. Make sure that the permissions on all of the folders are set to 755, and if that does not work then set them to 777. Make sure that the includes/configure.php file and the admin/includes/configure.php file are set to 777 for the duration of the install. Once the install is complete reset to 644, 444, or 400 depending on your server setup.

 

5. Then go to http://www.yourdomain.com/install and begin the install procedure. Your DB Server will probably be 'localhost', your db user name and password (for mysql access) will have been provided to you by your web hosting company. The name of the database you already know - because you just set it up. Do not enable SSL, elect to store sessions in the database and not files (untick the box), and do not enable persistent connections.

 

6. After the install create a folder called 'backups' inside the 'admin' folder (via FTP), and delete the install folder. Reset permissions on the two configure.php files.

 

7. Password Protect your 'admin' folder using the Password Protect feature in your web hosting control panel.

 

Away you go!

 

Vger

 

in the drop down menu after the G in this forum or the documentation. For instance I was having a problem with an error on the bottom can't find page link. Searched the documentation and this forum with poor results. Then tried the Google search current site, Whala! instant success which was rather ironic as the problem turned out to be

 

241Oct 21 2004, 06:32 PM

go to your admin panel and under configuration and my store change

 

Use Search-Engine Safe URLs (still in development) to false from 42

 

I do not know what serch engine they are using with this site but it is no GOOGLE. We probably would not have 1/10 the messages on this board if GOOGLE was used to search the contents.


Talos

Share this post


Link to post
Share on other sites

The first part of the reply was cliped:

If you have the google search bar installed on your browser you will have a lot more success findung answers in this forum or the documention then with the built in search engine. Next to the google search window on the tool bar to the right of the G is a drop down box arrow, choose search current site, and you will find what you need.


Talos

Share this post


Link to post
Share on other sites

Which is exactly why I posted a thread in the Tips & Tricks Forum advising people to use exactly that method for searching this site.

 

As for your problem - well if something says 'still in evelopment' then it's a pretty safe bet that you shouldn't use it.

 

Vger

Share this post


Link to post
Share on other sites

Tere

 

I got following error on my screen maybe someone can help me. Post here or send message

 

But the error is

 

Warning: session_save_path(): SAFE MODE Restriction in effect. The script whose uid is 33 is not allowed to access owned by uid 0 in /www/02/domainname.ee/includes/functions/sessions.php on line 148

 

What should I do????

 

And also I have to fix this

 

Warning: I am able to write to the configuration file: /www/data/www.domainname.ee/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

Is someone have a good idea

 

With Best Regards

Mihkel

Share this post


Link to post
Share on other sites

Hi I foun solution for my second problem on my own. But I need also to fix firs one.

 

And now i have A question how to make this wai if I but www.domain_name.ee/admin that it now ask a passworld. right know it does not and I dont hae a premission also

Share this post


Link to post
Share on other sites
Warning: session_save_path(): SAFE MODE Restriction in effect.

 

Got to osCommerce admin --> Configuration --> Sessions and change tmp/ to just tmp

 

To password protect your admin folder go to your web hosting control panel and find the feature which allows you to password protect folders.

 

Vger

Share this post


Link to post
Share on other sites
Register Globals being disabled in php.ini has nothing to do with whatever FTP programme you use. These are your possible courses of action:

 

1. If your site is hosted on an Apache server then putting thise code (below) in a root level .htaccess file will turn on Register Globals just for your site:

php_flag register_globals on

2. If your site is hosted on a Windows server then you'll need to go to Contributions (link above) and download and install the latest Register Globals Patch, which will enable your site to work with Register Globals set to off in php.ini

 

Vger

Hi

I have found out that my server was Apache , then I tried to do what you told me in case of an apache server but the when I rty to connect to my website "shop.artest.com.tr" the message I get is:

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

when I go back and delete the .htaccess from the root it goes back to normal!.

what shall I do, please help.

Share this post


Link to post
Share on other sites

Make sure that the .htaccess file has permissions of 644. That error sounds as if you gave it permissions of 777.

 

If the permissions were 644 and you got that error then your Server Administrator has blocked the use of certain functions within .htaccess files - in which case you'll have to install the latest Register Globals Patch from Contributions.

 

Vger

Share this post


Link to post
Share on other sites
Make sure that the .htaccess file has permissions of 644. That error sounds as if you gave it permissions of 777.

 

If the permissions were 644 and you got that error then your Server Administrator has blocked the use of certain functions within .htaccess files - in which case you'll have to install the latest Register Globals Patch from Contributions.

 

Vger

It was set at 644 , as for thepatch isthere a particular one you would recommend.

And do I install this to the root of my web site?.

regards

Share this post


Link to post
Share on other sites
http://www.oscommerce.com/community/contri...r+Globals+Patch

 

Just follow the folder structure to install.

 

Vger

hello,

I have had a look at that patch and to install that i sbeyond my capabilities. Is there an alternat way , is there a contribution with the patch already installed or someonetold me that some FTP programmes assumes that register-global is set "ON" and doesnot ask fo rthis , do you know a programme of that type so that I should use that to upload.

thanks

Share this post


Link to post
Share on other sites

@ demi

 

download register_globals_v1.4 unzip or whatever

if you want to "install" this patch all you have to do is replace several files

(read the instructions in the 'patch file' folder, it's easy)

register_globals = Off in php.ini and your ok :)

Share this post


Link to post
Share on other sites
someonetold me that some FTP programmes assumes that register-global is set "ON" and doesnot ask fo rthis , do you know a programme of that type so that I should use that to upload.

 

Whoever told you that is wrong - or else you misunderstood them. Whether or not Register Globals is On in php.ini has nothing to do with your FTP programme.

 

The latest Register Globals Patch is just a set of files which has already been edited - and you just need to install them.

 

Vger

Share this post


Link to post
Share on other sites
Whoever told you that is wrong - or else you misunderstood them. Whether or not Register Globals is On in php.ini has nothing to do with your FTP programme.

 

The latest Register Globals Patch is just a set of files which has already been edited - and you just need to install them.

 

Vger

ok,

I have installed the patch ( as for who told me about the FTP programme it is teh help desk at my web host).

I have gone few steps during the install of "oscommerce" but got stuck at:

 

The following error has occurred:

 

 

The configuration files do not exist, or permission levels are not set.

 

Please perform the following actions:

cd /var/www/domains/e-shop.artest.com.tr/docs/includes/

touch configure.php

chmod 706 configure.php

cd /var/www/domains/e-shop.artest.com.tr/docs/admin/includes/

touch configure.php

chmod 706 configure.php

 

I cannot find touch configure.php in those adresses to change permissions to 777 , what shoudl I do ?.

Share this post


Link to post
Share on other sites

'touch' is a geek way of telling people to change permissions using SSH or Telnet (command line stuff). Hardly anyone uses SSH or Telnet these days - so ignore that. Use the File Manager in your web hosting control panel to change the permissions on those two files.

 

Vger

Share this post


Link to post
Share on other sites

×