Jump to content
Sign in to follow this  
airuma

Attribute Sets - MySQL error. HELP!!

Recommended Posts

After installing Attribute Sets, I get this message everytime I try to EDIT a product:

 

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/airuma/public_html/admin/includes/functions/database.php on line 45

0 -

 

select products_attributes_sets_id from products_attributes_sets_to_products where products_id=374

 

All that changes is the product ID # but all the products I tried to edit give the same error.

 

When I ADD a product it seams to work ok, no problems, but as soon as I go back and try to edit, I get the same thing over again.

 

Tha lines on the database.php files are as follows:

 

 function tep_db_query($query, $link = 'db_link') {
   global $$link, $logger;

   if (defined('STORE_DB_TRANSACTIONS') && (STORE_DB_TRANSACTIONS == 'true')) {
     if (!is_object($logger)) $logger = new logger;
     $logger->write($query, 'QUERY');
   }

   $result = mysql_query($query, $$link) or tep_db_error($query, mysql_errno(), mysql_error());

   if (defined('STORE_DB_TRANSACTIONS') && (STORE_DB_TRANSACTIONS == 'true')) {
     if (mysql_error()) $logger->write(mysql_error(), 'ERROR');
   }

   return $result;
 }

 

With line 45 being the one starting with $result = mysql_query...

I don't think the error is on the database.php file, though, because these lines look just like the original ones.

I am just lost and have no clue where to look. I've been posting in other threads for a while, but no reply.

 

Someone PLEASE help!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×