Jump to content
Sign in to follow this  
devosc

[Contribution]Paypal IPN - Devosc

Recommended Posts

i was wondering if https is needed for v3.15, i dont want https anyway, what would be good about having it, my site excludes all payment options other than paypal. Any help would be great!

Share this post


Link to post
Share on other sites

great now I have a new problem and I know it's something simple.

 

Everything works except when an email is sent it does not give the order number, so all i get for the invoice link is

 

https://www.domain.com/account_history_info.php?order_id=

 

going through the Order.class.php code I notice in the email section it is pulling it from the $item_number...

Share this post


Link to post
Share on other sites

it looks as thought the PayPal_Shopping_Cart_IPN contribution version: [18 Apr 2005 - file/folder misstaken Author: ZhenIT Software] has something wrong with the overwrite_and_run files. they did not work. but the version: [28 Mar 2005 - v3.1.5 tar.gz Author: devosc] overwrite_and_run files work good. thanks

Share this post


Link to post
Share on other sites

for testing with paypal_ipn_v3.15, can the paypal sandbox send an ipn back to the store, or do you just use the ipn test panel for the testing. Any help would be appreciated thanks!

Share this post


Link to post
Share on other sites

Got it all working. WE sell unique products of quantity 1. Ran in to an issue where 4 customer bought the same product becuase paypal ipn did not decrease the qty to 0 (status no available)

 

Is this becuase orders are listed as pending? When processed will it decrease qty and change status? any idea? Thanks


Progressive Web Design and Flash Opt-in Email Marketing Campaigns.

Arizona Web Design | obu Web Technologies, inc.

Share this post


Link to post
Share on other sites

Hi,

 

:'( I have w weird problem and I wonder if anyone can help.

 

I installes 3.1.5, and it works fine locally. When I synchronized with my host, the home page did not show, with no error displayed. I tracked it down in application_top.php to find that when I comment out the changes made to it, the home page shows ok.

 

Any suggestions?

Share this post


Link to post
Share on other sites

Not sure, but last time I saw something like that I put it down to possible whitespace errors / output.

look at the end of file in paypal/database_tables.inc.php and paypal/classes/osC.class.php and if there is a blank line (or space) after the last '?>' try removing it.


"Any fool can know. The point is to understand." -- Albert Einstein

Share this post


Link to post
Share on other sites
great now I have a new problem and I know it's something simple.

 

Everything works except when an email is sent it does not give the order number, so all i get for the invoice link is

 

https://www.domain.com/account_history_info.php?order_id=

 

going through the Order.class.php code I notice in the email section it is pulling it from the $item_number...

 

Anyone have any info on this problem?

Share this post


Link to post
Share on other sites
i was wondering if https is needed for v3.15, i dont want https anyway, what would be good about having it, my site excludes all payment options other than paypal. Any help would be great!

 

 

Just so you know, I already had someone tell me they wouldn't even sign up as a customer to my site unless I had HTTPS making sure that their private details were secure...

 

(I do have it by the way, it was a friend testing the site for me).

Share this post


Link to post
Share on other sites
Hello,

 

I just installed the paypal IPN. Everythign is working fine. I m getting emails from paypal that customer has paid. But there is a  problem... The email shows the Item Title title as my store name. It is not showing the item name in item title.

 

Can anyone tell me what is goign wrong?? Plz..

 

Thank you.

 

Hello, Since I've been beating my head against the wall like everyone else I'd thought I'd at least reply to something I know.

 

This is just how it shows when you have aggregate mode set in ADMIN, since your total is what is passed to paypal, the item title is set as your store name. Kinda wierd looking, but that's how it is designed.

 

Also, Auto-return WILL NOT work when using the CC option, I read this at paypal somewhere, it should in my opinion, but it doesn't,

 

another fact, Sales tax is passed in your total in aggregate mode, not passed at all in itemized.

 

Now my question,

 

like SamyT - Everything works fine in IPN Test Panel, order process email is even sent. But I get no IPN response from paypal either live or through sandbox. I can get the cart to reset by changing Return URL behavior to 0, or 2, but that just happens when return to merchant is pressed. I would love to get IPN working and not depend on return to merchant. Question, If I end up relying on return to merchant and auto-return, why doesn't it send a Order Process email when the customer returns?, An email is sent when paying by check and not leaving the site? Any Suggestion, help??

 

Devosc - thanks for all the hard work.

Share this post


Link to post
Share on other sites

hey guys i have installed paypal ipn v3.15 having some problems

 

1) the emails that customer receive after order is made is not showing proper subject instead it says this EMAIL_TEXT_SUBJECT

can any one please tell me how can i fix this.

 

 

2) on customer orders page. when i view the other details and click details for a paypal, a window pops up something like this. I am not getting the customers address.

 

 Transaction Details  

--------------------------------------------------------------------------------

  
Payment Received (ID # 4KA79467TA241540J)  


Name: 
john doe  (The sender of this payment is Verified) 
Email: 
johndoe@mail.com

--------------------------------------------------------------------------------



Total Amount: 
$37.94 
Fee Amount: 
$1.40 
Net Amount: 
$36.54 

--------------------------------------------------------------------------------

Date: 
Jun. 13, 2005 
Time: 
20:34:46 PDT 
Status: 
Completed 

--------------------------------------------------------------------------------



Shipping Address:



, 



--------------------------------------------------------------------------------

Payment Type: 
Instant 


--------------------------------------------------------------------------------

E-Commerce Engine Copyright ? 2000-2004 osCommerce
osCommerce provides no warranty and is redistributable under the GNU General Public License

 

 

your help is very much apprecaited

 

thankyou

Share this post


Link to post
Share on other sites

I still can not correct the issue in my order_total.php file giving me the error

 

Fatal error: Cannot redeclare class .... catalog/includes/classes/order_total.php on line 15. when returning from paypal.

 

I have tried all of the suggestions from the beginning of this forum with no change in the results. Can someone offer to help?

 

Thanks,

Rick

Share this post


Link to post
Share on other sites
great now I have a new problem and I know it's something simple.

 

Everything works except when an email is sent it does not give the order number, so all i get for the invoice link is

 

https://www.domain.com/account_history_info.php?order_id=

 

going through the Order.class.php code I notice in the email section it is pulling it from the $item_number...

I'm having the same problem. I don't at the moment have the option of testing, but I suspect this might only occur when a customer logs in and goes directly to the checkout. No way of confirming this - this is what happened now.

 

I'm getting a confirmation email about the order, and I am getting the money. However, the order doesn't appear in the database. Please help!

 

-Ethan

Share this post


Link to post
Share on other sites

I recently switched hosts, and my IPN's are no longer processing (i.e. I do not receive debug emails, all orders show as pending despite a customer truly paying for an item, and under a transaction's activity it states: No PayPal Transaction Information Available).

 

I have attempted a deinstall and reinstall of the paypal payment module, with no success. As well, I have tried to turn 'test mode' on and run a "Test IPN', however, I get a 'not found' error: The requested URL /ipn.php was not found on this server.

 

Any help would be appreciated, thank you.

Share this post


Link to post
Share on other sites

getting quite a strange one here, when i arrive at the paypal pages the total amount doesnt include the tax cost until i reach the final "Make your payment" page after entering my credit card info, i dont like this as it looks like a hidden cost. How can i display the true price the whole way through?

Share this post


Link to post
Share on other sites

No one has experienced what I'm seeing, hopefully somebody out there has?????

 

- No IPN debug emails are being sent out.

- Transactions never get updated from the original pending status, despite being paid for.

Share this post


Link to post
Share on other sites
Incidently - the addition of the checkout text

 

does not seem to be true. Unless i am missing something - with UK paypal merchant accounts you cannot take payment unless the customer has a paypal account. Is this a US only thing  - as the merchant tools in teh paypal account does not have a facility to allow this ??

 

 

I couldnt find an answer to this either. Is it only US Paypal that allows non paypal account credit card payments??

 

Im currently getting some similar issues to manic in regards to SQL errors on Customer>Orders...replaced the Orders.php for a fresh one and checked the configure.php with a fine tooth comb.......

 

Thanks for an otherwise great contribution and the peeps who's misfortunes have guided me through my own :)

Share this post


Link to post
Share on other sites
No one has experienced what I'm seeing, hopefully somebody out there has?????

 

- No IPN debug emails are being sent out.

- Transactions never get updated from the original pending status, despite being paid for.

 

 

Like many have said, make sure your Buisines id in the ADMIN/Paypal Matching exactly the primary email address at Paypal site. Also, set ADMIN/Paypal/module to debug email with your specified address.

 

I spent a week tring to figure out why I could get IPN to work, stupid me a had a password on my site so only I could enter for testing purpases. Removed Password code, IPN started working beautifully, sending email and everything.

 

Also make sure you specify notify_url as the path to yoursit/ipn.php file, I also match this exact on IPN setting at paypal

Hope this helps, email me kilbymiz@gmail.com, if you have further questions

Later,

mike

Share this post


Link to post
Share on other sites

I have solved my own problem so for manic and any one else getting the SQL 1064 errors like this,

 

Specials

1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-10, 10' at line 1

 

select p.products_id, pd.products_name, p.products_price, s.specials_id, s.specials_new_products_price, s.specials_date_added, s.specials_last_modified, s.expires_date, s.date_status_change, s.status from products p, specials s, products_description pd where p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = s.products_id order by pd.products_name limit -10, 10

 

-10, 10 or which i had was -20, 20 (it depends on the page the error appears on) then

 

In admin/includes/classes find split_page_results.php and - BACK IT UP then find the lines

 

$offset = ($max_rows_per_page * ($current_page_number - 1));

$sql_query .= " limit " . $offset . ", " . $max_rows_per_page;

 

change to

 

$offset = ($max_rows_per_page * ($current_page_number - 1));

if ($offset < 0)

{

$offset = 0 ;

}

$sql_query .= " limit " . $offset . ", " . $max_rows_per_page;

 

 

MySQL 4.1.xx handles negatives correctly (by forcing an error) in the code above unlike earlier versions of MySQL.

 

NOTE - I have NOT asked you to change catalog/includes/classes/split_page_results.php - If you have a problem on the catalog side you may want to try the same change in that file - I did and it went wrong so the change to my catalog/includes/classes/split_page_results.php file is a little more elaborate and I will share that here if it becomes an issue - but for now it seems people will mostly have a problem with empty files on the admin side.

 

 

THIS SOLUTION WAS FOUND AT http://www.websitetemplatedesign.com/forum...p=394entry394

Thanks to Jonathen for the solution.

Share this post


Link to post
Share on other sites

Also resolved my own main question. For excepting credit card payments with out the customer signing up to paypal during checkout, log in to you paypal account and to profile Website payment options>paypal account optional. You MUST have a merchant account for this. This works for UK accounts. Any problems, check your paypal email addresses in the module.

Share this post


Link to post
Share on other sites

I'm running the IPN V1.1.2 module which seems to work fine as long as people click the continue button after making their paypal payment. If they don't, the order goes through but the stock isn't subtracted :(

 

Is there a way I can change where the stock is subtracted so that it doesn't wait for people to click the continue button? I searched and found a few people ask for this, but couldn't find an answer.

thanks in advance,

James

Share this post


Link to post
Share on other sites

I've just installed PP_IPN v3.1.5

Everything went well so far. Only trhing, I can't get 'Test IPN' to work.

I always get Invalid Test no matter what I do. Tried all guides and suggestions here, copied Transaction Information to Transaction ID and Custom, set MC Gross to the same total as shopping cart - but might overseen some though....

 

Can anybody help please..?

 

My PayPal payment modul settings:

 

Enable PayPal Module

True

 

E-Mail Address

[set]

 

Business ID

[same as above]

 

Default Currency

EUR

 

Transaction Currency

Selected Currency

 

Payment Zone

--none--

 

Shopping Cart Method

Aggregate

 

Enable PayPal Shipping Address

No

 

Digest Key

Tatomusic_Cart_IPN

 

Test Mode

On

 

Cart Test

On

 

Debug Email Notifications

Yes

 

Debug Email Notification Address

[same as email]

 

PayPal Domain

www.sandbox.paypal.com

 

Return URL behavior

1

Share this post


Link to post
Share on other sites

I don't understand this.. a 'live' order didn't get an IPN (no entry in Admin 'Paypal IPN'). so after payment, the expected file download wasn't available.

I've read that there could be a delay with getting the IPN.. (?)

The 2 emails send by PayPal arrived... 2 different Transaction Codes (?)

But no transaction code with the order in shop admin:

"No PayPal Transaction Information Available (77eff36dc57edf89f3da58f9e1f20585)"

So the shop still doesn't know that the product has been paid. And therefore no download and notify message was send to the customer ...

 

I have read a lot of this forum, but going through all 80+ pages to find no real solution for my problem is a bit too much.

So, I don't know what to do.. if I can't get any help, only thing would be, I have to switch back to the default osC PayPal module :-(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×