Jump to content
Sign in to follow this  
devosc

[Contribution]Paypal IPN - Devosc

Recommended Posts

Customer already has a credit card set up with Pay-Pal, but it's

automatically taking him to the add credit card to your Pay-Pal account to complete payment, and even if he adds a credit card it says this credit card already registered to his Pay-Pal account.

 

Please advise what should be done?

Share this post


Link to post
Share on other sites

Hi guys,

 

 

I posted this a couple of days ago in the payment modules section, but I should have posted here, so I will now.

 

I just wanted to check something with you:

 

Im using the PayPal IPN contribution...

 

What I wanted to know is, is this the correct thing that should happen (it seems to work, just checking):

 

Customer goes to Paypal after confirming order and oscommerce says that the order is pending. In the Paypal section on the orders page, it says:

 

Transaction Activity

Date    Status    Details    Action    Gross    Fee    Net Amount

No PayPal Transaction Information Available (f4e185d3087f0a81d1d851696ea59e7c)

 

That seems logical.

 

BUT,

 

When the order is completed and the payment is made, the paypal section of the order says almost exactly the same thing:

 

Transaction Activity

Date    Status    Details    Action    Gross    Fee    Net Amount

No PayPal Transaction Information Available()

 

The difference is the ID is missing.

 

Now I get the debug mails ok, and the money is in paypal, and I have a new status of Processing.

 

I guess im a little concerned that there might be a problem somewhere that im missing because the paypal history isnt updated correctly.

 

Could someone clarify what exactly happens so I know?

 

Thanks for your help and time.

 

-- Raj

Share this post


Link to post
Share on other sites

When a payment is completed on my site I get something like:

 

Date Status Details Action Gross Fee Net Amount

May. 23, 2005 Completed Details $19.95 $0.88 $19.07

 

And I have my configruation setup to change the order status to processing (this is set in the paypal module configuration).

Share this post


Link to post
Share on other sites

Hello,

 

On my Transaction Details page (admin/paypal.php) I have:

 

Payment Received (ID # ........) 

 

 

Name:

..........    (The sender of this payment is Unverified)

Email:

..........

 

--------------------------------------------------------------------------------

 

 

Total Amount:

$178.75

Fee Amount:

$5.48

Net Amount:

$173.27

 

--------------------------------------------------------------------------------

 

 

Date:

May. 28, 2005

Time:

16:29:45 PDT

Status:

Completed

 

--------------------------------------------------------------------------------

 

 

Shipping Address:

 

 

 

,

 

--------------------------------------------------------------------------------

 

 

 

Payment Type:

Instant

 

 

--------------------------------------------------------------------------------

 

 

 

 

E-Commerce Engine Copyright ? 2000-2004 osCommerce

osCommerce provides no warranty and is redistributable under the GNU General Public License

 

 

Powered ByosCommerce 2.2-MS2

Instead of the Shipping Address, I have ",".

What should I modify to have a real shipping address? And how can I change oscommerce banner to mine?

 

Thanks a lot.

Irina.

Share this post


Link to post
Share on other sites

I get the same thing on the address but am not sure how to fix that.

 

Hello,

 

On my Transaction Details page (admin/paypal.php) I have:

Instead of the Shipping Address, I have ",".

What should I modify to have a real shipping address? And how can I change oscommerce banner to mine?

 

Thanks a lot.

Irina.

Share this post


Link to post
Share on other sites

Raj I am also getting the following:

 

Transaction Activity

Date    Status    Details    Action    Gross    Fee    Net Amount

No PayPal Transaction Information Available()

 

I am not sure why it is doing this as it should give the $ amounts and so forth. Anyone have any ideas?

Share this post


Link to post
Share on other sites
So, now I have a bug I can't figure out. It would seem it has to be something I changed recently, but I'm stuck on how to locate it. The problem comes when I try to delete a paypal order in the admin. Here is what I get:

 

Warning: Cannot modify header information - headers already sent by (output started at /includes/modules/payment/paypal/database_tables.inc.php:51) in /admin/includes/functions/general.php on line 86

Well, today my entire site went down with this problem during updates to RCS. It turns out the problem was quite simple, yet very odd. For unknown reasons some of my files got their line endings confused (ie, mixing up CR and LF usage). While any editor displayed the files fine it seems the PHP parsing didn't like them.

 

So, a global search and replace later it's all fixed. Just a heads up for anyone else who runs into this.

Share this post


Link to post
Share on other sites
Hello,

 

On my Transaction Details page (admin/paypal.php) I have:

Instead of the Shipping Address, I have ",".

What should I modify to have a real shipping address? And how can I change oscommerce banner to mine?

 

Thanks a lot.

Irina.

 

 

QUOTE

Payment Received (ID # ........) 

 

 

Name:

..........    (The sender of this payment is Unverified)

Email:

..........

 

--------------------------------------------------------------------------------

 

 

Total Amount:

$178.75

Fee Amount:

$5.48

Net Amount:

$173.27

 

--------------------------------------------------------------------------------

 

 

Date:

May. 28, 2005

Time:

16:29:45 PDT

Status:

Completed

 

--------------------------------------------------------------------------------

 

 

Shipping Address:

 

 

 

,

 

--------------------------------------------------------------------------------

 

 

 

Payment Type:

Instant

 

 

--------------------------------------------------------------------------------

 

 

 

 

E-Commerce Engine Copyright ? 2000-2004 osCommerce

osCommerce provides no warranty and is redistributable under the GNU General Public License

 

 

Powered ByosCommerce 2.2-MS2

 

 

iam having the same problem :(

 

any fix for it ?

 

also any one got qtp working with the new paypa ipn ? mine doesnt substract the quantity when customers pays through paypal

Edited by sinryder

Share this post


Link to post
Share on other sites

hey guys i have installed paypal ipn v3.15 overall its working great but having some some small problems

 

1) the emails that customer receive after order is made is not showing proper subject instead it says this EMAIL_TEXT_SUBJECT

 

2) on admin > orders > paypal > details

when i click on it , this is what it shows . The address field shows , instead of the address.

 

QUOTE

Payment Received (ID # ........) 

 

 

Name:

..........    (The sender of this payment is Unverified)

Email:

..........

 

--------------------------------------------------------------------------------

 

 

Total Amount:

$178.75

Fee Amount:

$5.48

Net Amount:

$173.27

 

--------------------------------------------------------------------------------

 

 

Date:

May. 28, 2005

Time:

16:29:45 PDT

Status:

Completed

 

--------------------------------------------------------------------------------

 

 

Shipping Address:

 

 

 

,

 

--------------------------------------------------------------------------------

 

 

 

Payment Type:

Instant

 

 

--------------------------------------------------------------------------------

 

 

 

 

E-Commerce Engine Copyright ? 2000-2004 osCommerce

osCommerce provides no warranty and is redistributable under the GNU General Public License

 

 

Powered ByosCommerce 2.2-MS2

 

 

3) and when i click the accept button , it says order accepted on top in green and then nothing happens. the accept button stays their and the customer receives an email like this

 

 

Date Ordered: Tuesday 31 May, 2005

EMAIL_TEXT_PRODUCTS
------------------------------------------------------
1 x Shipping Cost (shipcost) = 0

------------------------------------------------------
Sub-Total: $0.02
Free Shipping: $0.00
Total: $0.02

EMAIL_TEXT_DELIVERY_ADDRESS
------------------------------------------------------


, 


EMAIL_TEXT_BILLING_ADDRESS
------------------------------------------------------


, 


EMAIL_TEXT_PAYMENT_METHOD
------------------------------------------------------

 

 

4) also any one got qtp working with the new paypa ipn ? mine doesnt substract the quantity when customers pays through paypal

 

 

 

your help is very much appreciated

 

thankyou

Share this post


Link to post
Share on other sites
When a payment is completed on my site I get something like:

 

Date    Status    Details    Action    Gross    Fee    Net Amount

May. 23, 2005    Completed    Details        $19.95    $0.88    $19.07

 

And I have my configruation setup to change the order status to processing (this is set in the paypal module configuration).

 

 

Thats exactly what I would expect to see!

 

  Raj I am also getting the following:

 

QUOTE

Transaction Activity

Date    Status    Details    Action    Gross    Fee    Net Amount

No PayPal Transaction Information Available()

 

 

I am not sure why it is doing this as it should give the $ amounts and so forth. Anyone have any ideas?

 

I hope we can sort this out, lane's is working ok, so we must have done something wrong...

Share this post


Link to post
Share on other sites
Thats exactly what I would expect to see!

I hope we can sort this out, lane's is working ok, so we must have done something wrong...

Do you have IPN's listed when you click on the "PayPal IPN" option in the admin area under Customers? If so, what do you get when you got to one's order(s)? Mine takes me to the order that is attached to that IPN.

Share this post


Link to post
Share on other sites
Do you have IPN's listed when you click on the "PayPal IPN" option in the admin area under Customers? If so, what do you get when you got to one's order(s)? Mine takes me to the order that is attached to that IPN.

 

I have IPN's listed and if i click on them it takes me to that order that it is attached too. Is this because of CCGV? or something else i messed up?

Share this post


Link to post
Share on other sites
I have IPN's listed and if i click on them it takes me to that order that it is attached too.  Is this because of CCGV? or something else i messed up?

And the order it takes you to does not show the IPN's data? If so, something about your setup is interfering w/the process of updating orders since the IPN was received and is in the DB.

 

As for CCGV, I don't know. I am using that, but it's a very old version that pretty much works (lots of small issues I'd like fixed someday) ... but now that I think of it I can't remember it ever being tested w/this PayPal module so ...?

Share this post


Link to post
Share on other sites
And the order it takes you to does not show the IPN's data? If so, something about your setup is interfering w/the process of updating orders since the IPN was received and is in the DB.

 

As for CCGV, I don't know. I am using that, but it's a very old version that pretty much works (lots of small issues I'd like fixed someday) ... but now that I think of it I can't remember it ever being tested w/this PayPal module so ...?

 

Yes the "transaction activity" doesn't have the info just "No PayPal Transaction Information Available () " I went over my install, can't seem to find anything messed up. Would you have any idea what files to look in for mistakes?

Share this post


Link to post
Share on other sites
Yes the "transaction activity"  doesn't have the info just "No PayPal Transaction Information Available () "  I went over my install, can't seem to find anything messed up.  Would you have any idea what files to look in for mistakes?

Unfortunately no, I don't really know this contribution very well.

Share this post


Link to post
Share on other sites

is there a way to get any response here ?????????????????????????????????????????????????????? :'(

Share this post


Link to post
Share on other sites
Do you have IPN's listed when you click on the "PayPal IPN" option in the admin area under Customers? If so, what do you get when you got to one's order(s)? Mine takes me to the order that is attached to that IPN.

 

Sorry for the late reply.

 

My situation seems exactly the same as customxbox's. I can see the IPN's and they take me to the correct order.

 

Everything *seems* to work ok, its just the transaction activity is missing.

 

ill go over the installation tonight and let you know if I find anything.

 

Thanks for your suggestions so far.

Share this post


Link to post
Share on other sites
hey guys i have installed paypal ipn v3.15 overall its working great but having  some some small problems

 

1) the emails that customer receive after order is made is not showing proper subject instead it says this EMAIL_TEXT_SUBJECT

 

2) on admin > orders > paypal > details

when i click on it , this is what it shows . The address field shows , instead of the address.

3)  and when i click the accept button , it says order accepted on top in green and then nothing happens. the accept button stays their and the customer receives an email like this

Date Ordered: Tuesday 31 May, 2005

EMAIL_TEXT_PRODUCTS
------------------------------------------------------
1 x Shipping Cost (shipcost) = 0

------------------------------------------------------
Sub-Total: $0.02
Free Shipping: $0.00
Total: $0.02

EMAIL_TEXT_DELIVERY_ADDRESS
------------------------------------------------------
, 
EMAIL_TEXT_BILLING_ADDRESS
------------------------------------------------------
, 
EMAIL_TEXT_PAYMENT_METHOD
------------------------------------------------------

4) also any one got qtp working with the new paypa ipn ? mine doesnt substract the quantity when customers pays through paypal

your help is very much appreciated

 

thankyou

Share this post


Link to post
Share on other sites
Sorry for the late reply.

 

My situation seems exactly the same as customxbox's. I can see the IPN's and they take me to the correct order.

 

Everything *seems* to work ok, its just the transaction activity is missing.

 

ill go over the installation tonight and let you know if I find anything.

 

Thanks for your suggestions so far.

 

I thought i found a problem with my configre.php files and the sql db's pw. but that didn't seem to help. I have 2 other stores running IPN and this one is the ony one giving me trouble with the transaction activity. this is the only store with ccgv also, so i dunno :(

Share this post


Link to post
Share on other sites

I made a fresh install of oSc2.2 and then overwrote with v3.1.5 OverWriteAndRun and installed the SQL tables.

 

I now get a blank page on the main page of the store with this error message.

 

Warning: main(includes/modules/payment/paypal/classes/osC/osC.class.php): failed to open stream: No such file or directory in /home/******/public_html/includes/application_top.php on line 125

 

Warning: main(includes/modules/payment/paypal/classes/osC/osC.class.php): failed to open stream: No such file or directory in /home/******/public_html/includes/application_top.php on line 125

 

Fatal error: main(): Failed opening required 'includes/modules/payment/paypal/classes/osC/osC.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/******/public_html/includes/application_top.php on line 125

 

 

I was hoping to see the fresh install with the module installed.

 

 

Am I missing something?

 

 

Dan

Share this post


Link to post
Share on other sites

Hello,

 

I just installed the paypal IPN. Everythign is working fine. I m getting emails from paypal that customer has paid. But there is a problem... The email shows the Item Title title as my store name. It is not showing the item name in item title.

 

Can anyone tell me what is goign wrong?? Plz..

 

Thank you.

Share this post


Link to post
Share on other sites

I get this error when I test it.

 

2013 - Lost connection to MySQL server during query

select txn_id from paypal where txn_id = 'PAYPAL00000000000' limit 0,1

[TEP STOP]

Share this post


Link to post
Share on other sites

Could this be the problem:

 

application top I needed the following to get my SSL to work:

 

$request_type = (getenv('HTTPS') == 'on' or getenv('SERVER_PORT') == 443) ? 'SSL' : 'NONSSL';

Share this post


Link to post
Share on other sites

I HAVE THE SAME PROBLEM:

 

IT WORKED FIE BEFORE.

 

Anyone please? 

 

 

QUOTE(Maquar @ Mar 16 2005, 03:29 PM)

Hello everyone,

 

I've just installed PayPal IPN v1.1 but am kind of lost on a few things. I'm hoping one of you will help me out here. My hosting uses a shared SSL, I have read the instructions given with the PP IPN and have searched the forums but haven't had any luck. With that said heres what I'm lost on:

 

Gateway Server

Live (I'm assuming this needs to be live?)

 

Enable Encrypted Web Payments

True (I'm assuming this needs to be set to true to use the SSL?)

 

Your Private Key

(Where in My PayPal account do I obtain this if needed?)

 

Your Public Certificate

(Where in My PayPal account do I obtain this if needed?)

 

PayPals Public Certificate

(Where in My PayPal account do I obtain this if needed?)

 

Your PayPal Public Certificate ID

(Where in My PayPal account do I obtain this if needed?)

 

Working Directory

(Where in My PayPal account do I obtain this if needed?)

 

OpenSSL Location

/usr/bin/openssl (Should this be set to the shared SSL location that I used for the set up of the shop? For example..https//pathway_to_ssl)

 

Can someone please help me out?

 

Thanks,

 

Mark

 

 

 

 

 

 

   

 

AlaneinHilo  Mar 17 2005, 06:49 AM Post #1559 

Alane

 

Group: Community Member

Posts: 15

Joined: 16-February 04

Member No.: 27,254

 

 

 

Hi folks,

I just upgraded to the latest version and I am having trouble. In test mode I follow the instructions and place an order and take it all the way to paypal. In the order details:

 

 

QUOTE

Transaction Activity

Date  Status  Details  Action  Gross  Fee  Net Amount 

No PayPal Transaction Information Available (73e3d508ddc77ce5278f5fd88cc248c9) 

 

 

So I copy the number in () up there into the transaction ID and then when I click Test IPN the resulting ipn.php page gives me this error:

 

 

QUOTE

2013 - Lost connection to MySQL server during query

 

select txn_id from paypal where txn_id = '73e3d508ddc77ce52' limit 0,1

 

[TEP STOP]

 

 

Any clues as to what is going on? It sends me a debug email from my attempt:

 

 

QUOTE

------------------------------------------------------

PayPal_Shopping_Cart_IPN Debug Email Notification

------------------------------------------------------

business=***@luminousgifts.com

receiver_email=curlypinky@***.***

verify_sign=PAYPAL_SHOPPING_CART_IPN-TEST_TRANSACTION-00000000000000

payment_date=23:21:12 Mar 16, 2005 MST

digestKey=8bc62ea404f581940a1b3df742ea539a

first_name=John

last_name=Doe

payer_business_name=ACME Inc.

payer_email=alane@integrity-graphics.com

payer_id=PAYERID000000

payer_status=verified

invoice=

address_name=John Doe

address_street=1 Way Street

address_city=NeverNever

address_state=CA

address_zip=12345

address_country=United States

address_status=confirmed

payment_type=instant

txn_type=cart

custom=1

txn_id=73e3d508ddc77ce52

parent_txn_id=

num_cart_items=1

notify_version=1.6

memo=PAYPAL_SHOPPING_CART_IPN TEST

mc_currency=USD

mc_gross=43.85

mc_fee=0.01

settle_amount=0.00

settle_currency=

exchange_rate=0.00

payment_status=Completed

pending_reason=

reason_code=

submit=Test IPN

 

 

------------------------------------------------------

PayPal Response

------------------------------------------------------

INVALID

 

------------------------------------------------------

Connection Type

------------------------------------------------------

curl:  transport: tcp:// domain: www.paypal.com port: 80

 

------------------------------------------------------

Email and Business ID config

------------------------------------------------------

Store Configuration Settings

Primary PayPal Email Address: curlypinky@earthlink.net Business ID: sales@luminousgifts.com

------------------------------------------------------

PayPal Configuration Settings

Primary PayPal Email Address: curlypinky@earthlink.net Business ID: sales@luminousgifts.com

 

------------------------------------------------------

Attention!

------------------------------------------------------

This is email has NOT been sent by PayPal.

 

You have received this email via the osCommerce PayPal_Shopping_Cart_IPN Contribution

 

To discontinue receiving this notice disable 'Debug Email Notifications' in your osCommerce PayPal configuration panel.

 

 

Any clues as to why I am losing connection with my database? Thank you!

 

Alane

Share this post


Link to post
Share on other sites
I made a fresh install of oSc2.2 and then overwrote with v3.1.5 OverWriteAndRun and installed the SQL tables.

 

I now get a blank page on the main page of the store with this error message.

 

Warning: main(includes/modules/payment/paypal/classes/osC/osC.class.php): failed to open stream: No such file or directory in /home/******/public_html/includes/application_top.php on line 125

 

Warning: main(includes/modules/payment/paypal/classes/osC/osC.class.php): failed to open stream: No such file or directory in /home/******/public_html/includes/application_top.php on line 125

 

Fatal error: main(): Failed opening required 'includes/modules/payment/paypal/classes/osC/osC.class.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/******/public_html/includes/application_top.php on line 125

I was hoping to see the fresh install with the module installed.

Am I missing something?

Dan

 

 

Wiped out the OverwriteAndRun/install and redid the contrib install by hand - install went fine with no error messages at all.

 

So the OverWriteAndRun didnt work for me.....

 

Dan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×