Jump to content
Sign in to follow this  
devosc

[Contribution]Paypal IPN - Devosc

Recommended Posts

Hello every one.

I just installed the PayPal Ipn Version 2.9

It is giving me an error on checkout saying the following.

 

QUOTE

We cannot process this transaction because there is a problem with the PayPal email address supplied by the seller. Please contact the seller to resolve the problem.

 

 

 

I double checked my email addies and all is correct.

Can someone point me in the right direction to fix this error.

Thanks

Dave

 

 

Apparently there was an error in one of the files...

 

http://forums.oscommerce.com/index.php?sho...=116656&st=940#

 

"Use the file in the MS2-2.2OverWriteAndRun/includes/modules/payment directory."

 

Copy this over your existing files in that directory. Worked for me!

 

Jeff

Edited by Johnson

Share this post


Link to post
Share on other sites

Matti,

 

Cool!! Thanks, I am going check it out and do the fixing up.. Cross my figures, hope everything is okay. :lol:

 

This is my first time at tackling PHP, eventhrough I have no clue what I am doing but if I follow instruction well. There is joy in all of this!! :rolleyes:

 

Thanks~

Kel

Share this post


Link to post
Share on other sites

It work! Finally got past paypal and made a payment.

 

However another problem came up. Once I have the order in,

 

I click on the edit button on the order, (admin/orders.php) there is paypal box with an accept button. I click on that "accept" button and got these errors

 

Warning: notifycustomer(/home/eaimesh/public_html/catalog/includes/languages//checkout_process.php): failed to open stream: No such file or directory in /home/eaimesh/public_html/catalog/includes/modules/payment/paypal/classes/osC/Order.class.php on line 214

 

Warning: notifycustomer(): Failed opening '/home/eaimesh/public_html/catalog/includes/languages//checkout_process.php' for inclusion (include_path='.:/usr/local/lib/php') in /home/eaimesh/public_html/catalog/includes/modules/payment/paypal/classes/osC/Order.class.php on line 214

 

Warning: Cannot modify header information - headers already sent by (output started at /home/eaimesh/public_html/catalog/includes/modules/payment/paypal/classes/osC/Order.class.php:214) in /home/eaimesh/public_html/catalog/admin/includes/functions/general.php on line 18

 

Any clue? I through this part look odd

 

home/eaimesh/public_html/catalog/includes/languages//checkout_process.php' f

as it is missing the "english" directory. Can this be the source of the problem? A simply misroute? If so How do I fix it.

 

thanks`

Kel

Share this post


Link to post
Share on other sites

I'm successfully using the PayPal IPN, however I am having an issue with order emails. I have modified checkout_process to add a thank you message at the top.

 

When sending via another payment method (check/money order), the message is displayed just fine. When using PayPal, the message is not displayed and the default email is sent.

 

Why is my personal message missing when using PayPal as a payment option?

 

Jeff

Share this post


Link to post
Share on other sites

Hi there,

 

I have running V2.9 and anything works fine except one function. Normally a costumer does not complete payment, there should be a button in order history to complete payment. But this button will not appear!

Yes, I have set "Synchronize Invoice" to true and I did not changed the value of payment_method.

 

How is going wrong?

 

 

Nico

Share this post


Link to post
Share on other sites
Any clue? I through this part look odd

 

home/eaimesh/public_html/catalog/includes/languages//checkout_process.php' f

  as it is missing the "english" directory. Can this be the source of the problem? A simply misroute? If so How do I fix it.

 

thanks`

Kel

 

 

Yes, it appears to be for some reason - sorry I cannot tell you why at this point - check any mods you have made that touch languages - I have the module running on a live server and while it has a few non-critical issues this problem does not exist. Please post back here when you find a solution.

 

Matti


Matti Ressler

 

We were all once expert at...... nothing

_____

Share this post


Link to post
Share on other sites
Hi there,

 

I have running V2.9 and anything works fine except one function. Normally a costumer does not complete payment, there should be a button in order history to complete payment. But this button will not appear!

Yes, I have set "Synchronize Invoice" to true and I did not changed the value of payment_method.

 

How is going wrong?

Nico

 

 

... o.k. my mistake. I forgot to delete some lines in order.php from an older version...

Share this post


Link to post
Share on other sites

Hi!

 

I have also another problem. When an order was made, the order status will not be updated and I do not receive any order emails. I've got only PayPals confirmation mail and debug mail. Both show no error or failure messages.

In admin section the Transaction Activity shows "No PayPal Transaction Information Available (xxxxx...) "

 

Can anybody tell me, whats going wrong?

 

Nico

Share this post


Link to post
Share on other sites
I have also another problem. When an order was made, the order status will not be updated and I do not receive any order emails. I've got only PayPals confirmation mail and debug mail. Both show no error or failure messages.

In admin section the Transaction Activity shows "No PayPal Transaction Information Available (xxxxx...) "

 

This sounds similar to what was happening when I was using the paypal sandbox - is this with the sandbox or live? You could try using the ipn txt to see what is going on - there are instructions a bit further up the thread as to how to do it.

 

hth

 

Jax

Share this post


Link to post
Share on other sites
I'm successfully using the PayPal IPN, however I am having an issue with order emails. I have modified checkout_process to add a thank you message at the top.

 

When sending via another payment method (check/money order), the message is displayed just fine. When using PayPal, the message is not displayed and the default email is sent.

 

Why is my personal message missing when using PayPal as a payment option?

 

Jeff

 

 

Jeff,

 

Look in the catalog/includes/modules/payment/paypal directory tree - I expect that your emails originate from a different file and you will need to mirror your modifications there.

 

David

Share this post


Link to post
Share on other sites

Download link not Active after payment is made

 

Using PayPal_Shopping_Cart_IPN 2.8

 

This worked last week and there have been no changes to the site but the last order claimed the link was not active after payment was made. I get the payment IPN OK, says its complete, the order says its processing, but it is a dead link.

 

The previous order to that the link was active but did not start downloading, just decremented the download count until none were left. Do certain platforms/browsers ie mac or linux have problems with this? I use a mac and when i download from the contributions area of this site i know the filename ends up (mirror,pair). WHY?? Many other sites are this way too, sometimes I have to go to a windows machine and download the file. This seems to simple to break because of a platform issue.

 

Is there a guide on how to "get thru" problems like this?

 

How can I allow them to download wether or not PayPal_Shopping_Cart_IPN thinks they have paid?

 

Maybe a status to allow download regardless of the payment.

Even a secure method to provide a link to them directly by email.

 

I see there is a 2.9 available does it have fixes pertaining to this?

I really hate to install another one of these if it does not fix the problem because everytime I have installed I had to resort to a ground zero approach. Now I have orders/customers settings that I dont how to recover.

 

Thanks in advance for your help.

 

Note to Mac OS 9 user:

This file will have the wrong name if you unzip on Mac OS 9 (name is over 31 characters)

catalog/includes/modules/payment/paypal/images/PayPal-no-account-Click-Here.gif

This is what you get (PayPal-no-account-Cli#7B783.gif)

Share this post


Link to post
Share on other sites

Hi, I just installed PayPal_Shopping_Cart_IPN 2.9 and it completes the orders and all but when I go to view the order fro mthe admin menu, I get

 

Parse error: parse error, unexpected T_DOUBLE_ARROW in /home/jimmsdep/public_html/shop/admin/includes/classes/order.php on line 110

 

 

//begin PayPal_Shopping_Cart_IPN

'option_id' => $attributes['products_options_id'],

'value_id' => $attributes['products_options_values_id'],

//end PayPal_Shopping_Cart_IPN

 

Line 110 is the option_id line. Any ideas?

Share this post


Link to post
Share on other sites
Hi, I just installed PayPal_Shopping_Cart_IPN 2.9 and it completes the orders and all but when I go to view the order fro mthe admin menu, I get

 

Parse error: parse error, unexpected T_DOUBLE_ARROW in /home/jimmsdep/public_html/shop/admin/includes/classes/order.php on line 110

//begin PayPal_Shopping_Cart_IPN

                                  'option_id' => $attributes['products_options_id'],

                                  'value_id' => $attributes['products_options_values_id'],

//end PayPal_Shopping_Cart_IPN         

 

Line 110 is the option_id line. Any ideas?

 

 

hrm, nevermind..was one of those user to keyboard error on following directions ;) works great

Share this post


Link to post
Share on other sites

ok, new problem, heh

 

I have installed this paypal on 2 servers and I get the same error.

 

When the order is completed, the customer gets an email with a link to their account to check the status. Whenever I go to update the status it sends an email out but doesnt complete the link..

 

Order Number: 4

Detailed Invoice: /shop/account_history_info.php?order_id=4

Date Ordered: Saturday 30 October, 2004

it is missing my domain name in there..any idea? This has happened on 2 servers both linux based.

Share this post


Link to post
Share on other sites

 

Check your shop/admin/includes/configure.php file and make sure the following are correct:

 

HTTP_CATALOG_SERVER

HTTPS_CATALOG_SERVER

DIR_WS_CATALOG


"Any fool can know. The point is to understand." -- Albert Einstein

Share this post


Link to post
Share on other sites

When purchasing using Pay Pal it is important to click the continue button in the pay pal confirmation window. (This is the last window in Pay PAl) If this is not done the order will not be completed. The money is received but the order is not visible on (or tracked by) the admin. Pay pal says to have the order set to pending when the customer clicks the confirm order button prior to going to pay pal.

 

 

HOW DO I DO THIS?

Share this post


Link to post
Share on other sites
When purchasing using Pay Pal it is important to click the continue button in the pay pal confirmation window. (This is the last window in Pay PAl) If this is not done the order will not be completed.  The money is received but the order is not visible on (or tracked by) the admin.  Pay pal says to have the order set to pending when the customer clicks the confirm order button prior to going to pay pal. 

HOW DO I DO THIS?

 

Actually, this sounds to me like you are using the original paypal module, and not an IPN based module.

 

Can you clarify this?

 

David

Share this post


Link to post
Share on other sites

Please help urgently. The paypal IPN version 2.9 works fine right up to the point when you go into admin and try to edit the order. See below for error.

 

 

0 -

 

select customers_name, customers_company, customers_street_address, customers_suburb, customers_city, customers_postcode, customers_state, customers_country, customers_telephone, customers_email_address, customers_address_format_id, delivery_name, delivery_company, delivery_street_address, delivery_suburb, delivery_city, delivery_postcode, delivery_state, delivery_country, delivery_address_format_id, billing_name, billing_company, billing_street_address, billing_suburb, billing_city, billing_postcode, billing_state, billing_country, billing_address_format_id, payment_method, cc_type, cc_owner, cc_number, cc_expires, currency, currency_value, date_purchased, orders_status, last_modified, customers_id, payment_id from orders where orders_id = '2'

 

[TEP STOP]

 

2008 - MySQL client run out of memory

 

select count(*) as total from sessions where sesskey = '9f71b9e2e3cc9e86a22aa939f6d3b5e9'

 

[TEP STOP]

 

 

Warning: Unknown: A session is active. You cannot change the session module's ini settings at this time. in Unknown on line 0

 

 

 

Also, the paypal IPN link in admin throws up the following error:

 

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0" bgcolor="#FFFFFF" onload="

Fatal error: Cannot use object of type PayPal_Page as array in /home/russell/public_html/includes/modules/payment/paypal/templates/osC_Admin.tpl.php on line 27

 

 

Urgent help is needed. Thanks in advance.

Share this post


Link to post
Share on other sites

Awesome contrib, works perfectly.

 

Found an interesting thing while exploring an issue today - the problem of customers who don't click 'continue' at the Paypal confirmation page, meaning that the order doesn't get logged properly.... Paypal has an auto return option that you can switch on and bypass that page completely. Fabulous. It's in your Profile under selling tools, I believe.

 

Cheers!

Melanie

Share this post


Link to post
Share on other sites

ANYONE????

 

Download link not Active after payment is made

Using PayPal_Shopping_Cart_IPN 2.8

This worked last week and there have been no changes to the site but the last order claimed the link was not active after payment was made. I get the payment IPN OK, says its complete, the order says its processing, but it is a dead link.

The previous order to that the link was active but did not start downloading, just decremented the download count until none were left. Do certain platforms/browsers ie mac or linux have problems with this? I use a mac and when i download from the contributions area of this site i know the filename ends up (mirror,pair). WHY?? Many other sites are this way too, sometimes I have to go to a windows machine and download the file. This seems to simple to break because of a platform issue.

Is there a guide on how to "get thru" problems like this?

How can I allow them to download wether or not PayPal_Shopping_Cart_IPN thinks they have paid?

Maybe a status to allow download regardless of the payment.

Even a secure method to provide a link to them directly by email.

I see there is a 2.9 available does it have fixes pertaining to this?

I really hate to install another one of these if it does not fix the problem because everytime I have installed I had to resort to a ground zero approach. Now I have orders/customers settings that I dont how to recover.

Thanks in advance for your help.

Note to Mac OS 9 user:

This file will have the wrong name if you unzip on Mac OS 9 (name is over 31 characters)

catalog/includes/modules/payment/paypal/images/PayPal-no-account-Click-Here.gif

This is what you get (PayPal-no-account-Cli#7B783.gif)

Share this post


Link to post
Share on other sites

Hi

1. I installed the v2.9 and have the following problem in the admin/orders. I tested using paypal sandbox and all worked fine. When I went to the admin/order, I had the following message in the Transaction Actitivity:

 

No PayPal Transaction Information Available (68b649333k334l3333.....)

 

Is this correct in the test mode?

 

2. No email was sent to the buyer. Is this correct in test mode?

 

Can anyone help me??? Thanks. :'(

Share this post


Link to post
Share on other sites

Paypal IPN & special characters, anyone?

 

I have had the PayPal IPN module working for a couple months (including the recent upgrade to 2.6a). Normally, everything works great. HOWEVER, _sometimes_ we'll get a series of "INVALID"s when we try to verify the IPN.

 

I KNOW the IPN is good; the PayPal e-mail has been received, the funds are in the account, etc. However, PayPal refuses to acknowledge this.

 

The only thing I can think of at this point is that perhaps it is choking on the items which have a quote sign and/or semi-colon in them? (The current stuck order has both.) Although the code does urlencode() the incoming results before sending them back out, is it possible that PayPal isn't unencoding them before doing a compare?

 

I may just hack the module to send model #, rather than product name, to PayPal. That's more ugly in some ways, since the 'aggregated' cart is very misleading if there IS more than one item in the order - PayPal only shows the first one.

 

Thoughts or ideas? Anyone run into a similar situation? This is REALLY frustrating, and I've read the forum from end-to-end looking for ideas. (And no, before anyone asks, we're not in test mode, and our e-mail and business ids are fine -- like I said, it works MOST of the time. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×